The NetBSD Project

CVS log for pkgsrc/devel/py-flexmock/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-flexmock

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.12: download - view: text, markup, annotated - select for diffs
Tue Apr 2 18:25:03 2024 UTC (8 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, HEAD
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +5 -6 lines
py-flexmock: updated to 0.12.1

Release 0.12.1

Fixed

- Flexmock Pytest plugin entrypoint missing from `setup.py`.

Release 0.12.0

Added

- Add Python 3.12 and 3.13 support.

Changed

- Add tox.ini to sdist to make the downstream testing easier.

Removed

- Drop Python 3.6 and 3.7 support.
- Drop Pytest 5.x support.

Fixed

- Fixed the pytest integration by switching from wrapping of the test runner to
 the pytest plugin system.

Revision 1.11: download - view: text, markup, annotated - select for diffs
Tue Nov 29 21:14:10 2022 UTC (2 years ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +5 -4 lines
py-flexmock: updated to 0.11.3

Release 0.11.3

Added

- Add PEP 561 `py.typed` marker file.

Changed

- Remove documentation and test files from wheels build.
- Re-organize unit tests.

Documentation

- Add a warning about the usage of `.new_instances()` method in the documentation.

Release 0.11.2

Fixed

- Fix subunit testrunner integration is broken.
- Fix: TeamCity (PyCharm) testrunner integration is broken.

Infrastructure

- Run tests with testtools, subunit, TeamCity, and doctest testrunners using tox.

Documentation

- Test flexmock API examples using doctest.
- Re-add Sphinx support for generating man pages.
- Fix 404 page not loading CSS and Javascript resources in documentation.
- Small fixes to documentation.

Release 0.11.1

Fixed

- Fix Zope testrunner integration is broken.

Infrastructure

- Run tests with Zope testrunner using tox.

Release 0.11.0

Added

- Add Python 3.8, 3.9, 3.10, and 3.11 support.
- Add type annotations.

Changed

- **BREAKING CHANGE**: Flexmock needs to be imported explicitly using `from flexmock import flexmock`.
 The hack that allowed flexmock to be imported directly using `import flexmock` did not work well with static analysis tools.
- Many error messages have been improved.
- Undocumented methods `Expectation.reset`, `Expectation.verify`, and `Expectation.match_args` that were unintentionally left public are now private methods.
- Undocumented attributes in `Mock` and `Expectation` are now private. These attributes were never meant to be accessed directly.

Removed

- Drop Python 2.7, 3.4, 3.5 support.
- Drop Pytest 4.x support.
- Remove unittest2 and nose integrations. unittest2 and nose are not maintained anymore.
- **BREAKING CHANGE**: Removed support for calling `once`, `twice`, `never`, and `mock` methods
 without parentheses. This allows code completion and static analysis to work with these methods.

Fixed

- Fix `should_call` is broken if called on a fake object.
- Fix `and_raise` allows invalid arguments for an exception.

Infrastructure

- Run linters and tests using Github Actions.
- Add coverage reporting using Codecov.

Documentation

- Add contribution documentation.
- Use Mkdocs instead of Sphinx to build the documentation.

Revision 1.10: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:53:05 2022 UTC (2 years, 10 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -1 lines
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.9: download - view: text, markup, annotated - select for diffs
Wed Oct 6 11:07:42 2021 UTC (3 years, 1 month ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -2 lines
py-flexmock: updated to 0.10.10

Release 0.10.10
- Fix AttributeError raised when mocking a proxied object.

Revision 1.8: download - view: text, markup, annotated - select for diffs
Thu Sep 9 08:01:52 2021 UTC (3 years, 2 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -2 lines
py-flexmock: updated to 0.10.9

Release 0.10.9

Fixed
- Fix flexmock not mocking methods properly on derived classes.

Release 0.10.8

Fixed
- Fix ``with_args`` not working built-in functions.

Release 0.10.7

Fixed
- Fix ``with_args`` not working built-in methods.
- Fix previous pytest ``--durations`` fix not working.

Release 0.10.6

Fixed
- Fix flexmock broken with Pytest 4 & 5.
- Fix new_instances method not working with Python 2.7.
- Fix multiple expectations for the same classmethod are not matched.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Wed Jul 21 06:43:58 2021 UTC (3 years, 4 months ago) by adam
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -2 lines
py-flexmock: updated to 0.10.5

Release 0.10.5

Added
- Improve error message on unmatched method signature expectation.

Fixed
- Fix using ``should_call`` passes wrong ``runtime_self``.
- Fix pytest ``--durations`` flag when flexmock is installed.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Mon Jun 10 14:48:05 2019 UTC (5 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +5 -2 lines
py-flexmock: updated to 0.10.4

Release 0.10.4
- drop Python 2.6, 3.3 and Jython support
- add Python 3.6 and 3.7 support
- don't hide exception when flexmock is used as context manager
- fix expectation reset for static methods on pypy 2
- ensure original exception isn't suppressed in pytest hook

Revision 1.5: download - view: text, markup, annotated - select for diffs
Tue Jan 22 09:57:05 2019 UTC (5 years, 10 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +3 -3 lines
py-flexmock: updated to 0.10.3

Release 0.10.3
- fix compatibility with py.test 4.1
- minor documentation fixes

Revision 1.4: download - view: text, markup, annotated - select for diffs
Sat Sep 16 19:26:47 2017 UTC (7 years, 2 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2 lines
Reset maintainer

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sat Jul 22 12:40:01 2017 UTC (7 years, 4 months ago) by adam
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +4 -4 lines
Release 0.10.2
- fix recognizing whether mocked object is a method or not on Python 3

Release 0.10.1
- fix decode problem in setup.py on Python 3

Release 0.10.0
- new official upstream repository: https://github.com/bkabrda/flexmock/
- new official homepage: https://flexmock.readthedocs.org
- adopted the official BSD 2-clause license
- add support for calling flexmock module directly
- add support for mocking keyword-only args
- add support for Python 3.4 and 3.5
- drop support for Python 2.4, 2.5, 3.1 and 3.2
- add ``__version__`` attribute to flexmock module
- add various metadata to the package archive
- fix properly find out whether function is method or not
  and thanks to that don't strip first args of functions
- fix should_call to work when function returns ``None`` or ``False``
- fix various py.test issues
- fix ``CallOrderError`` with same subsequent mocking calls
- fix PyPy support issues
- various code style issues were fixed, 4-spaces indent is now used

Revision 1.2: download - view: text, markup, annotated - select for diffs
Wed Jun 8 17:43:28 2016 UTC (8 years, 5 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -2 lines
Switch to MASTER_SITES_PYPI.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Sat Jun 14 13:53:44 2014 UTC (10 years, 5 months ago) by rodent
Branches: MAIN
CVS tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Import py27-flexmock-0.9.7 as devel/py-flexmock.

flexmock is a testing library for Python that makes it easy to create mocks,
stubs and fakes.

The API is inspired by a Ruby library of the same name, but Python flexmock is
not a clone of the Ruby version. It omits a number of redundancies in the Ruby
flexmock API, alters some defaults, and introduces a number of Python-only
features.

flexmock's design focuses on simplicity and intuitiveness. This means that the
API is as lean as possible, though a few convenient short-hand methods are
provided to aid brevity and readability.

flexmock declarations are structured to read more like English sentences than
API calls, and it is possible to chain them together in any order to achieve
high degree of expressiveness in a single line of code.

In addition, flexmock integrates seamlessly with all major test runners to
reduce even more mock-related boilerplate code.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>