Up to [cvs.NetBSD.org] / pkgsrc / devel / py-flakes
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.23 / (download) - annotate - [select for diffs], Mon Jul 31 16:18:56 2023 UTC (4 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base,
pkgsrc-2023Q3,
HEAD
Changes since 1.22: +4 -4
lines
Diff to previous 1.22 (colored)
py-flakes: updated to 3.1.0 3.1.0 (2023-07-29) - Drop support for EOL python 3.6 / 3.7 - Remove ``ContinueInFinally`` check (only relevant in python < 3.8) - Fix forward annotations inside a nested scope - Produce an error when a definition shadows an unused variable - Fix accessed global annotation being redefined in a local scope - Allow redefinition of functions across ``match`` arms - Fix potential ``None`` for ``lineno`` during tokenization errors - Add support for PEP 695 and python 3.12
Revision 1.22 / (download) - annotate - [select for diffs], Sun Apr 30 17:03:57 2023 UTC (7 months, 1 week ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base,
pkgsrc-2023Q2
Changes since 1.21: +4 -3
lines
Diff to previous 1.21 (colored)
py-flakes: update to 3.0.1. 3.0.1 (2022-11-24) - Fix crash on augmented assign to ``print`` builtin 3.0.0 (2022-11-23) - Detect undefined name in variable defined by an annotated assignment - Add a new error for names which are annotated but unused - Remove handling of python 2.x ``# type:`` comments. Use annotations instead 2.5.0 (2022-07-30) - Drop support for EOL python 2.7 / 3.4 / 3.5 - Ignore ``__all__`` when not directly assigned - Handle ``TypeAlias`` annotations as aliases (PEP 613) - Assignment expressions (``:=``) target outer scope in comprehensions - Add support for new python 3.11 syntax - Unify output so it is always ``filename:lineno:col: message`` - Properly report ``SyntaxError`` from stdin in python < 3.9 - Fix offsets of ``SyntaxError``s in pypy
Revision 1.21 / (download) - annotate - [select for diffs], Wed Jan 5 15:41:04 2022 UTC (23 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1
Changes since 1.20: +4 -2
lines
Diff to previous 1.20 (colored)
python: egg.mk: add USE_PKG_RESOURCES flag This flag should be set for packages that import pkg_resources and thus need setuptools after the build step. Set this flag for packages that need it and bump PKGREVISION.
Revision 1.20 / (download) - annotate - [select for diffs], Tue Jan 4 20:53:05 2022 UTC (23 months ago) by wiz
Branch: MAIN
Changes since 1.19: +2 -1
lines
Diff to previous 1.19 (colored)
*: bump PKGREVISION for egg.mk users They now have a tool dependency on py-setuptools instead of a DEPENDS
Revision 1.19 / (download) - annotate - [select for diffs], Thu Nov 4 13:43:11 2021 UTC (2 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base,
pkgsrc-2021Q4
Changes since 1.18: +2 -2
lines
Diff to previous 1.18 (colored)
py-flakes: updated to 2.4.0 2.4.0 - Remove unused tracing code (``traceTree``) - Add support for ``match`` statement - Detect ``typing`` module attributes when imported with ``import ... as ...``
Revision 1.18 / (download) - annotate - [select for diffs], Mon Apr 5 11:17:09 2021 UTC (2 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2
Changes since 1.17: +2 -2
lines
Diff to previous 1.17 (colored)
py-flakes: updated to 2.3.1 2.3.1: - Fix regression in 2.3.0: type annotations no longer redefine imports
Revision 1.17 / (download) - annotate - [select for diffs], Mon Mar 15 07:17:15 2021 UTC (2 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base,
pkgsrc-2021Q1
Changes since 1.16: +2 -2
lines
Diff to previous 1.16 (colored)
py-flakes: updated to 2.3.0 2.3.0 (2021-03-14) - Recognize tuple concatenation in ``__all__`` export definitions - Better support use of annotation-only assignments when using ``from __future__ import annotations`` - Recognize special-case typing for ``Annotated`` - Fix undefined name ``__qualname__`` in class scope - Recognize special-cased typing for ``TypeVar`` - Errors for undefined exports in ``__all__`` are shown in a deterministic order - Fix false positives in certain typing constructs (``TypeVar``, ``NamedTuple``, ``TypedDict``, ``cast``)
Revision 1.16 / (download) - annotate - [select for diffs], Fri Apr 10 05:55:30 2020 UTC (3 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base,
pkgsrc-2020Q4,
pkgsrc-2020Q3-base,
pkgsrc-2020Q3,
pkgsrc-2020Q2-base,
pkgsrc-2020Q2
Changes since 1.15: +2 -2
lines
Diff to previous 1.15 (colored)
py-flakes: updated to 2.2.0 2.2.0: - Include column information in error messages - Fix ``@overload`` detection with other decorators and in non-global scopes - Fix return-type annotation being a class member - Fix assignment to ``_`` in doctests with existing ``_`` name - Namespace attributes which are attached to ast nodes with ``_pyflakes_`` to avoid conflicts with other libraries (notably bandit) - Add check for f-strings without placeholders - Add check for unused/extra/invalid ``'string literal'.format(...)`` - Add check for unused/extra/invalid ``'string literal % ...`` - Improve python shebang detection - Allow type ignore to be followed by a code ``# type: ignore[attr-defined]`` - Add support for assignment expressions (PEP 572) - Support ``@overload`` detection from ``typing_extensions`` as well - Fix ``@overload`` detection for async functions - Allow ``continue`` inside ``finally`` in python 3.8+ - Fix handling of annotations in positional-only arguments - Make pyflakes more resistant to future syntax additions - Fix false positives in partially quoted type annotations - Warn about ``is`` comparison to tuples - Fix ``Checker`` usage with async function subtrees - Add check for ``if`` of non-empty tuple - Switch from ``optparse`` to ``argparse`` - Fix false positives in partially quoted type annotations in unusual contexts - Be more cautious when identifying ``Literal`` type expressions
Revision 1.15 / (download) - annotate - [select for diffs], Fri Mar 1 08:49:40 2019 UTC (4 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base,
pkgsrc-2020Q1,
pkgsrc-2019Q4-base,
pkgsrc-2019Q4,
pkgsrc-2019Q3-base,
pkgsrc-2019Q3,
pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1
Changes since 1.14: +2 -2
lines
Diff to previous 1.14 (colored)
py-flakes: updated to 2.1.1 2.1.1: - Fix reported line number for type comment errors - Fix typing.overload check to only check imported names
Revision 1.14 / (download) - annotate - [select for diffs], Thu Jan 24 09:19:25 2019 UTC (4 years, 10 months ago) by adam
Branch: MAIN
Changes since 1.13: +4 -3
lines
Diff to previous 1.13 (colored)
py-flakes: updated to 2.1.0 Release 2.1.0 - Allow intentional assignment to variables named _ - Recognize __module__ as a valid name in class scope - pyflakes.checker.Checker supports checking of partial ast trees - Detect assign-before-use for local variables which shadow builtin names - Detect invalid print syntax using >> operator - Treat async for the same as a for loop for introducing variables - Add detection for list concatenation in __all__ - Exempt @typing.overload from duplicate function declaration - Importing a submodule of an as-aliased import-import is marked as used - Report undefined names from __all__ as possibly coming from a * import - Add support for changes in Python 3.8-dev - Add support for PEP 563 (from __future__ import annotations) - Include Python version and platform information in pyflakes --version - Recognize __annotations__ as a valid magic global in Python 3.6+ - Mark names used in PEP 484 # type: ... comments as used - Add check for use of is operator with str, bytes, and int literals
Revision 1.13 / (download) - annotate - [select for diffs], Mon Jun 18 11:17:15 2018 UTC (5 years, 5 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3,
pkgsrc-2018Q2-base,
pkgsrc-2018Q2
Changes since 1.12: +2 -3
lines
Diff to previous 1.12 (colored)
py-flakes: updated to 2.0.0 2.0.0 (2018-05-20) - Drop support for EOL Python <2.7 and 3.2-3.3 - Check for unused exception binding in except: block - Handle string literal type annotations - Ignore redefinitions of _, unless originally defined by import - Support __class__ without self in Python 3 - Issue an error for raise NotImplemented(...)
Revision 1.12 / (download) - annotate - [select for diffs], Wed May 23 17:26:19 2018 UTC (5 years, 6 months ago) by minskim
Branch: MAIN
Changes since 1.11: +2 -1
lines
Diff to previous 1.11 (colored)
devel/py-flakes: Add ALTERNATIVES
Revision 1.11 / (download) - annotate - [select for diffs], Fri Aug 4 05:01:57 2017 UTC (6 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base,
pkgsrc-2018Q1,
pkgsrc-2017Q4-base,
pkgsrc-2017Q4,
pkgsrc-2017Q3-base,
pkgsrc-2017Q3
Changes since 1.10: +4 -6
lines
Diff to previous 1.10 (colored)
1.6.0: - Process function scope variable annotations for used names - Find Python files without extensions by their shebang
Revision 1.10 / (download) - annotate - [select for diffs], Mon Feb 13 11:08:25 2017 UTC (6 years, 9 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base,
pkgsrc-2017Q2,
pkgsrc-2017Q1-base,
pkgsrc-2017Q1
Changes since 1.9: +2 -2
lines
Diff to previous 1.9 (colored)
Update to 1.5.0 Upstream changes: 1.5.0 (2017-01-09) - Enable support for PEP 526 annotated assignments 1.4.0 (2016-12-30): - Change formatting of ImportStarMessage to be consistent with other errors - Support PEP 498 "f-strings"
Revision 1.9 / (download) - annotate - [select for diffs], Tue Jan 3 13:23:02 2017 UTC (6 years, 11 months ago) by jperkin
Branch: MAIN
Changes since 1.8: +2 -2
lines
Diff to previous 1.8 (colored)
Use "${MV} || ${TRUE}" and "${RM} -f" consistently in post-install targets.
Revision 1.8 / (download) - annotate - [select for diffs], Sat Dec 17 11:45:18 2016 UTC (6 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base,
pkgsrc-2016Q4
Changes since 1.7: +3 -3
lines
Diff to previous 1.7 (colored)
Changes 1.3.0: - Fix PyPy2 Windows IntegrationTests - Check for duplicate dictionary keys - Fix TestMain tests on Windows - Fix "continue" and "break" checks ignoring py3.5's "async for" loop
Revision 1.7 / (download) - annotate - [select for diffs], Sun Aug 28 15:48:30 2016 UTC (7 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q3-base,
pkgsrc-2016Q3
Changes since 1.6: +1 -2
lines
Diff to previous 1.6 (colored)
Remove unnecessary PLIST_SUBST and FILES_SUBST that are now provided by the infrastructure. Mark a couple more packages as not ready for python-3.x.
Revision 1.6 / (download) - annotate - [select for diffs], Wed Jun 8 17:43:25 2016 UTC (7 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base,
pkgsrc-2016Q2
Changes since 1.5: +2 -2
lines
Diff to previous 1.5 (colored)
Switch to MASTER_SITES_PYPI.
Revision 1.5 / (download) - annotate - [select for diffs], Sun Aug 23 07:50:41 2015 UTC (8 years, 3 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base,
pkgsrc-2016Q1,
pkgsrc-2015Q4-base,
pkgsrc-2015Q4,
pkgsrc-2015Q3-base,
pkgsrc-2015Q3
Changes since 1.4: +2 -2
lines
Diff to previous 1.4 (colored)
Update to 0.9.2 Upstream changes: 0.9.2 (2015-06-17): - Fix a traceback when a global is defined in one scope, and used in another. 0.9.1 (2015-06-09): - Update NEWS.txt to include 0.9.0, which had been forgotten. 0.9.0 (2015-05-31): - Exit gracefully, not with a traceback, on SIGINT and SIGPIPE. - Fix incorrect report of undefined name when using lambda expressions in generator expressions. - Don't crash on DOS line endings on Windows and Python 2.6. - Don't report an undefined name if the 'del' which caused a name to become undefined is only conditionally executed. - Properly handle differences in list comprehension scope in Python 3. - Improve handling of edge cases around 'global' defined variables. - Report an error for 'return' outside a function.
Revision 1.4 / (download) - annotate - [select for diffs], Fri Apr 11 18:04:11 2014 UTC (9 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q2-base,
pkgsrc-2015Q2,
pkgsrc-2015Q1-base,
pkgsrc-2015Q1,
pkgsrc-2014Q4-base,
pkgsrc-2014Q4,
pkgsrc-2014Q3-base,
pkgsrc-2014Q3,
pkgsrc-2014Q2-base,
pkgsrc-2014Q2
Changes since 1.3: +2 -2
lines
Diff to previous 1.3 (colored)
Update to 0.8.1: 0.8.1 (2014-03-30): - Detect the declared encoding in Python 3. - Do not report redefinition of import in a local scope, if the global name is used elsewhere in the module. - Catch undefined variable in loop generator when it is also used as loop variable. - Report undefined name for `(a, b) = (1, 2)` but not for the general unpacking `(a, b) = func()`. - Correctly detect when an imported module is used in default arguments of a method, when the method and the module use the same name. - Distribute a universal wheel file.
Revision 1.3 / (download) - annotate - [select for diffs], Mon Mar 31 08:30:53 2014 UTC (9 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.2: +2 -2
lines
Diff to previous 1.2 (colored)
Update to 0.8: 0.8.0 (2014-03-22): - Adapt for the AST in Python 3.4. - Fix caret position on SyntaxError. - Fix crash on Python 2.x with some doctest SyntaxError. - Add tox.ini. - The `PYFLAKES_NODOCTEST` environment variable has been replaced with the `PYFLAKES_DOCTEST` environment variable (with the opposite meaning). Doctest checking is now disabled by default; set the environment variable to enable it. - Correctly parse incremental `__all__ += [...]`. - Catch return with arguments inside a generator (Python <= 3.2). - Do not complain about `_` in doctests. - Drop deprecated methods `pushFunctionScope` and `pushClassScope`.
Revision 1.2 / (download) - annotate - [select for diffs], Mon Sep 30 09:33:49 2013 UTC (10 years, 2 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base,
pkgsrc-2014Q1,
pkgsrc-2013Q4-base,
pkgsrc-2013Q4
Changes since 1.1: +5 -7
lines
Diff to previous 1.1 (colored)
Update to 0.7.3: 0.7.3 (2013-07-02): - Do not report undefined name for generator expression and dict or set comprehension at class level. - Deprecate `Checker.pushFunctionScope` and `Checker.pushClassScope`: use `Checker.pushScope` instead. - Remove dependency on Unittest2 for the tests. 0.7.2 (2013-04-24): - Fix computation of `DoctestSyntaxError.lineno` and `col`. - Add boolean attribute `Checker.withDoctest` to ignore doctests. - If environment variable `PYFLAKES_NODOCTEST` is set, skip doctests. - Environment variable `PYFLAKES_BUILTINS` accepts a comma-separated list of additional built-in names. 0.7.1 (2013-04-23): - File `bin/pyflakes` was missing in tarball generated with distribute. - Fix reporting errors in non-ASCII filenames (Python 2.x). 0.7.0 (2013-04-17): - Add --version and --help options. - Support `python -m pyflakes` (Python 2.7 and Python 3.x). - Add attribute `Message.col` to report column offset. - Do not report redefinition of variable for a variable used in a list comprehension in a conditional. - Do not report redefinition of variable for generator expressions and set or dict comprehensions. - Do not report undefined name when the code is protected with a `NameError` exception handler. - Do not report redefinition of variable when unassigning a module imported for its side-effect. - Support special locals like `__tracebackhide__` for py.test. - Support checking doctests. - Fix issue with Turkish locale where `'i'.upper() == 'i'` in Python 2. 0.6.1 (2013-01-29): - Fix detection of variables in augmented assignments. 0.6.0 (2013-01-29): - Support Python 3 up to 3.3, based on the pyflakes3k project. - Preserve compatibility with Python 2.5 and all recent versions of Python. - Support custom reporters in addition to the default Reporter. - Allow function redefinition for modern property construction via property.setter/deleter. - Fix spurious redefinition warnings in conditionals. - Do not report undefined name in __all__ if import * is used. - Add WindowsError as a known built-in name on all platforms. - Support specifying additional built-ins in the `Checker` constructor. - Don't issue Unused Variable warning when using locals() in current scope. - Handle problems with the encoding of source files. - Remove dependency on Twisted for the tests. - Support `python setup.py test` and `python setup.py develop`. - Create script using setuptools `entry_points` to support all platforms, including Windows.
Revision 1.1 / (download) - annotate - [select for diffs], Thu Jan 3 14:15:32 2013 UTC (10 years, 11 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2013Q3-base,
pkgsrc-2013Q3,
pkgsrc-2013Q2-base,
pkgsrc-2013Q2,
pkgsrc-2013Q1-base,
pkgsrc-2013Q1
Import py27-flakes-0.5.0nb1 as devel/py-flakes from wip/py-flakes Pyflakes is similar to PyChecker in scope, but differs in that it does not execute the modules to check them. This is both safer and faster, although it does not perform as many checks. Unlike PyLint, Pyflakes checks only for logical errors in programs; it does not perform any checks on style