The NetBSD Project

CVS log for pkgsrc/devel/py-dotenv/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-dotenv

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.14: download - view: text, markup, annotated - select for diffs
Sun Jan 28 08:14:02 2024 UTC (9 months, 1 week ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, HEAD
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +3 -1 lines
py-dotenv: add missing tools

Revision 1.13: download - view: text, markup, annotated - select for diffs
Tue Jan 23 13:34:09 2024 UTC (9 months, 2 weeks ago) by adam
Branches: MAIN
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +3 -9 lines
py-dotenv: updated to 1.0.1

1.0.1

**Fixed**

* Gracefully handle code which has been imported from a zipfile
* Allow modules using load_dotenv to be reloaded when launched in a separate thread
* Fix file not closed after deletion, handle error in the rewrite function

**Misc**
* Use pathlib.Path in tests
* Fix year in release date in changelog.md
* Use https in README links

Revision 1.12: download - view: text, markup, annotated - select for diffs
Mon May 22 12:25:07 2023 UTC (17 months, 2 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +10 -8 lines
py-dotenv: updated to 1.0.0

1.0.0

**Fixed**

* Drop support for python 3.7, add python 3.12-dev
* Handle situations where the cwd does not exist.

Revision 1.11: download - view: text, markup, annotated - select for diffs
Wed Jan 25 09:26:21 2023 UTC (21 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -2 lines
py-dotenv: updated to 0.21.1

0.21.1

Added
* Use Python 3.11 non-beta in CI
* Modernize variables code
* Modernize main.py and parser.py code
* Improve conciseness of cli.py and __init__.py
* Improve error message for `get` and `list` commands when env file can't be opened
* Updated Licence to align with BSD OSI template

Fixed
* Fix Out-of-scope error when "dest" variable is undefined
* Fix IPython test warning about deprecated `magic`
* Fix type hint for dotenv_path var, add StrPath alias

Revision 1.10: download - view: text, markup, annotated - select for diffs
Thu Sep 8 15:21:59 2022 UTC (2 years, 2 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -2 lines
py-dotenv: updated to 0.21.0

0.21.0

Added
* CLI: add support for invocations via 'python -m'.
* `load_dotenv` function now returns `False`.
* CLI: add --format= option to list command.

Fixed
* Drop Python 3.5 and 3.6 and upgrade GA
* Use `open` instead of `io.open`.
* Improve documentation for variables without a value
* Add `parse_it` to Related Projects by
* Update README.md by
* Improve documentation with direct use of MkDocs by

Revision 1.9: download - view: text, markup, annotated - select for diffs
Thu Jul 21 09:38:30 2022 UTC (2 years, 3 months ago) by adam
Branches: MAIN
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -3 lines
py-dotenv: updated to 0.20.0

0.20.0

Added
- Add `encoding` (`Optional[str]`) parameter to `get_key`, `set_key` and `unset_key`.

Fixed
- Use dict to specify the `entry_points` parameter of `setuptools.setup`
- Don't build universal wheels

Revision 1.8: download - view: text, markup, annotated - select for diffs
Wed Jan 5 15:41:03 2022 UTC (2 years, 10 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +4 -2 lines
python: egg.mk: add USE_PKG_RESOURCES flag

This flag should be set for packages that import pkg_resources
and thus need setuptools after the build step.

Set this flag for packages that need it and bump PKGREVISION.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:53:02 2022 UTC (2 years, 10 months ago) by wiz
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -1 lines
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.6: download - view: text, markup, annotated - select for diffs
Thu Nov 25 08:13:28 2021 UTC (2 years, 11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +4 -7 lines
py-dotenv: updated to 0.19.2

0.19.2

Fixed
- In `set_key`, add missing newline character before new entry if necessary.

0.19.1

Added
- Add support for Python 3.10.

0.19.0

Changed
- Require Python 3.5 or a later version.  Python 2 and 3.4 are no longer supported.
  by [@bbc2]).

Added
- The `dotenv_path` argument of `set_key` and `unset_key` now has a type of `Union[str,
  os.PathLike]` instead of just `os.PathLike`
- The `stream` argument of `load_dotenv` and `dotenv_values` can now be a text stream
  (`IO[str]`), which includes values like `io.StringIO("foo")` and `open("file.env",
  "r")`

0.18.0

Changed
- Raise `ValueError` if `quote_mode` isn't one of `always`, `auto` or `never` in
  `set_key`
- When writing a value to a .env file with `set_key` or `dotenv set <key> <value>`
  - Use single quotes instead of double quotes.
  - Don't strip surrounding quotes.
  - In `auto` mode, don't add quotes if the value is only made of alphanumeric characters
    (as determined by `string.isalnum`).

0.17.1

Fixed
- Fixed tests for build environments relying on `PYTHONPATH`

[0.17.0

Changed
- Make `dotenv get <key>` only show the value, not `key=value`

Added
- Add `--override`/`--no-override` option to `dotenv run`

0.16.0

Changed
- The default value of the `encoding` parameter for `load_dotenv` and `dotenv_values` is
  now `"utf-8"` instead of `None`
- Fix resolution order in variable expansion with `override=False`

Revision 1.5: download - view: text, markup, annotated - select for diffs
Mon Nov 9 12:16:14 2020 UTC (3 years, 11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines
py-dotenv: updated to 0.15.0

0.15.0:

Added
- Add `--export` option to `set` to make it prepend the binding with `export`

Changed
- Make `set` command create the `.env` file in the current directory if no `.env` file was
  found.

Fixed
- Fix potentially empty expanded value for duplicate key.
- Fix import error on Python 3.5.0 and 3.5.1.
- Fix parsing of unquoted values containing several adjacent space or tab characters

Revision 1.4: download - view: text, markup, annotated - select for diffs
Tue Aug 4 19:08:53 2020 UTC (4 years, 3 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2 lines
py-dotenv: updated to 0.14.0

0.14.0

Changed
- Privilege definition in file over the environment in variable expansion

Fixed
- Improve error message for when file isn't found
- Use HTTPS URL in package meta data

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sat May 16 17:13:40 2020 UTC (4 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +1 -2 lines
pytest from versioned deps.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Mon May 4 15:37:01 2020 UTC (4 years, 6 months ago) by adam
Branches: MAIN
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -2 lines
py-dotenv: updated to 0.13.0

0.13.0:
Add support for a Bash-like default value in variable expansion

Revision 1.1: download - view: text, markup, annotated - select for diffs
Sat Mar 21 19:41:56 2020 UTC (4 years, 7 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
py-dotenv: updated to 0.12.0

0.12.0:
Changed
- Use current working directory to find `.env` when bundled by PyInstaller

Fixed
- Fix escaping of quoted values written by `set_key`
- Fix `dotenv run` crashing on environment variables without values
- Remove warning when last line is empty

0.11.0:
Added
- Add `interpolate` argument to `load_dotenv` and `dotenv_values` to disable interpolation

Changed
- Use logging instead of warnings

Fixed
- Fix installation in non-UTF-8 environments
- Fix PyPI classifiers

0.10.5:
Fixed
- Fix handling of malformed lines and lines without a value
  - Don't print warning when key has no value.
  - Reject more malformed lines (e.g. "A: B", "a='b',c").
- Fix handling of lines with just a comment

0.10.4:
Added
- Make typing optional
- Print a warning on malformed line
- Support keys without a value

0.10.3
- Improve interactive mode detection
- Refactor parser to fix parsing inconsistencies
  - Interpret escapes as control characters only in double-quoted strings.
  - Interpret `#` as start of comment only if preceded by whitespace.

0.10.2
- Add type hints and expose them to users
- `load_dotenv` and `dotenv_values` now accept an `encoding` parameter, defaults to `None`
- Fix `str`/`unicode` inconsistency in Python 2: values are always `str` now.
- Fix Unicode error in Python 2, introduced in 0.10.0.

0.10.1
- Fix parsing of variable without a value

0.10.0
- Add support for UTF-8 in unquoted values
- Add support for trailing comments
- Add backslashes support in values
- Add support for newlines in values
- Force environment variables to str with Python2 on Windows
- Drop Python 3.3 support
- Fix stderr/-out/-in redirection

0.9.0
- Add `--version` parameter to cli
- Enable loading from current directory
- Add 'dotenv run' command for calling arbitrary shell script with .env

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>