The NetBSD Project

CVS log for pkgsrc/devel/py-distro/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-distro

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.14: download - view: text, markup, annotated - select for diffs
Mon Nov 11 07:28:06 2024 UTC (3 days, 13 hours ago) by wiz
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +1 -2 lines
py-*: remove unused tool dependency

py-setuptools includes the py-wheel functionality nowadays

Revision 1.13: download - view: text, markup, annotated - select for diffs
Sun Dec 31 21:22:57 2023 UTC (10 months, 2 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -3 lines
py-distro: update to 1.9.0.

## 1.9.0 (2023.12.19)

ENHANCEMENTS:
* Refactor distro.info() method to return an InfoDict [#360]
* Ignore the file '/etc/board-release' [#353]
* Ignore the file '/etc/ec2_version' [#359]

RELEASE:
* Run Python 3.6 on Ubuntu 20.04 for CI and bump isort [#355]

TESTS:
* Test on modern versions of CPython and PyPy and macOS [#362]
* Add support for ALT Linux Server 10.1 distribution [#354]
* Add Debian Testing to the tests [#356]
* Update archlinux resource for tests [#352]

Revision 1.12: download - view: text, markup, annotated - select for diffs
Sat Oct 28 19:56:59 2023 UTC (12 months, 2 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +3 -1 lines
python/wheel.mk: simplify a lot, and switch to 'installer' for installation

This follows the recommended bootstrap method (flit_core, build, installer).

However, installer installs different files than pip, so update PLISTs
for all packages using wheel.mk and bump their PKGREVISIONs.

Revision 1.11: download - view: text, markup, annotated - select for diffs
Tue Jun 6 12:41:12 2023 UTC (17 months, 1 week ago) by riastradh
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -2 lines
Mass-change BUILD_DEPENDS to TOOL_DEPENDS outside mk/.

Almost all uses, if not all of them, are wrong, according to the
semantics of BUILD_DEPENDS (packages built for target available for
use _by_ tools at build-time) and TOOL_DEPEPNDS (packages built for
host available for use _as_ tools at build-time).

No change to BUILD_DEPENDS as used correctly inside buildlink3.

As proposed on tech-pkg:
https://mail-index.netbsd.org/tech-pkg/2023/06/03/msg027632.html

Revision 1.10: download - view: text, markup, annotated - select for diffs
Tue Nov 1 18:29:31 2022 UTC (2 years ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -1 lines
py-distro: add missing build dependency on py-wheel

Revision 1.9: download - view: text, markup, annotated - select for diffs
Mon Oct 31 13:57:36 2022 UTC (2 years ago) by adam
Branches: MAIN
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +3 -6 lines
py-distro: updated to 1.8.0

1.8.0 (2022.10.10)

BACKWARD COMPATIBILITY:
* Replace `setup.py` with `build`

ENHANCEMENTS:
* Lowered `LinuxDistribution._distro_release_info` method complexity
* Added official support for Buildroot distribution
* Added official support for Guix distribution
* Added support for `/etc/debian_version`
* Fixed a typography in CONTRIBUTING.md
* Improved README.md "Usage" code block

RELEASE:
* Bumped black to v22.3.0 in pre-commit.ci configuration
* Enabled GitHub Dependabot to keep GitHub Actions up to date

Revision 1.8: download - view: text, markup, annotated - select for diffs
Thu Sep 29 10:08:14 2022 UTC (2 years, 1 month ago) by adam
Branches: MAIN
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +6 -5 lines
py-distro: updated to 1.7.0

1.7.0 (2022.02.15)

BACKWARD COMPATIBILITY:
* Dropped support for EOL Pythons 2.7, 3.4 and 3.5
* Dropped support for LSB and `uname` back-ends when `--root-dir` is specified
* Moved `distro.py` to `src/distro/distro.py`

ENHANCEMENTS:
* Documented that `distro.version()` can return an empty string on rolling releases
* Documented support for Python 3.10
* Added official support for Rocky Linux distribution
* Added a shebang to `distro.py` to allow standalone execution
* Added support for AIX platforms
* Added compliance for PEP-561

BUG FIXES:
* Fixed `include_uname` parameter oversight
* Fixed crash when `uname -rs` output is empty
* Fixed Amazon Linux identifier in `distro.id()` documentation
* Fixed OpenSuse >= 15 support
* Fixed encoding issues when opening distro release files
* Fixed `linux_distribution` regression

Revision 1.7: download - view: text, markup, annotated - select for diffs
Wed Jan 5 15:41:03 2022 UTC (2 years, 10 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +4 -2 lines
python: egg.mk: add USE_PKG_RESOURCES flag

This flag should be set for packages that import pkg_resources
and thus need setuptools after the build step.

Set this flag for packages that need it and bump PKGREVISION.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:53:01 2022 UTC (2 years, 10 months ago) by wiz
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -1 lines
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.5: download - view: text, markup, annotated - select for diffs
Thu Aug 5 10:09:48 2021 UTC (3 years, 3 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines
py-distro: updated to 1.6.0

1.6.0 (2021.7.30)

BACKWARDS COMPATIBILITY:
* Deprecated the `distro.linux_distribution()` function. Use
  `distro.id()`, `distro.version()` and `distro.name()` instead
* Deprecated Python 2.7, 3.4 and 3.5 support. Further releases
  will only support Python 3.6+

ENHANCEMENTS:
* Added type hints to `distro` module
* Added `__version__` for checking `distro` version
* Added support for arbitrary rootfs via the `root_dir` parameter
* Added the `--root-dir` option to CLI
* Added fallback to `/usr/lib/os-release` when `/etc/os-release` isn't available

BUG FIXES:
* Fixed `subprocess.CalledProcessError` when running `lsb_release`
* Ignore `/etc/iredmail-release` file while parsing distribution
* Use a binary file for `/dev/null` to avoid `TextIOWrapper` overhead

RELEASE:
* Moved repository from `nir0s/distro` to
  [`python-distro/distro`](https://github.com/python-distro/distro) on GitHub.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Sat May 16 09:10:42 2020 UTC (4 years, 6 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +4 -3 lines
pytest from versioned depends

Revision 1.3: download - view: text, markup, annotated - select for diffs
Mon Apr 6 09:14:03 2020 UTC (4 years, 7 months ago) by wiz
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +7 -2 lines
py-distro: update to 1.5.0.

## 1.5.0 (2020.3.30)

BACKWARD COMPATIBILITY:
* Keep output as native string so we can compatible with python2 interface [[#248](https://github.com/nir0s/distro/pull/248)]

ENHANCEMENTS:

BUG FIXES:
* Fix detection of RHEL 6 ComputeNode [[#255](https://github.com/nir0s/distro/issues/255)]
* Fix Oracle 4/5 lsb_release id and names [[#250](https://github.com/nir0s/distro/pull/250)]
* Ignore /etc/plesk-release file while parsing distribution [[#246](https://github.com/nir0s/distro/pull/246)]

TESTS:
* Test on MidnightBSD [[#254](https://github.com/nir0s/distro/issues/254)]

RELEASE:
* Remove build testing on Python 3.3 and add pypy 3.5 and Python 3.7 and 3.8 [[#244](https://github.com/nir0s/distro/pull/244)]
* Fix Windows build due to Appveyor not supporting builds on Python 2.7 anymore [[#257](https://github.com/nir0s/distro/pull/257)]

Additionally, The Python2.6 branch was fixed to support distro version 1.4.0. It is now passing all tests. Thanks [abadger](https://github.com/abadger)!

Revision 1.2.2.2: download - view: text, markup, annotated - select for diffs
Fri Oct 18 14:31:38 2019 UTC (5 years ago) by bsiegert
Branches: pkgsrc-2019Q3
Diff to: previous 1.2.2.1: preferred, colored; branchpoint 1.2: preferred, colored; next MAIN 1.3: preferred, colored
Changes since revision 1.2.2.1: +20 -0 lines
Pullup ticket #6071 - requested by taca
devel/py-distro: dependent addition
security/py-certbot: bugfix

Revisions pulled up:
- devel/Makefile                                                1.2921
- devel/py-distro/ALTERNATIVES                                  1.1
- devel/py-distro/DESCR                                         1.1
- devel/py-distro/Makefile                                      1.1-1.2
- devel/py-distro/PLIST                                         1.1
- devel/py-distro/distinfo                                      1.1
- security/py-certbot/Makefile                                  1.17-1.20

---
   Module Name:	pkgsrc
   Committed By:	triaxx
   Date:		Tue Oct  1 13:22:55 UTC 2019

   Added Files:
   	pkgsrc/devel/py-distro: DESCR Makefile PLIST distinfo

   Log Message:
   py-distro: import to version 1.4.0

   Thanks to Aleksej for importing 1.1.0 in wip.

---
   Module Name:	pkgsrc
   Committed By:	triaxx
   Date:		Tue Oct  1 13:24:35 UTC 2019

   Modified Files:
   	pkgsrc/devel: Makefile

   Log Message:
   Import py-distro to version 1.4.0

---
   Module Name:	pkgsrc
   Committed By:	triaxx
   Date:		Tue Oct  1 13:29:58 UTC 2019

   Modified Files:
   	pkgsrc/security/py-certbot: Makefile

   Log Message:
   py-certbot: fix PR pkg/54588

   pkgsrc changes:
   ---------------
   * Add devel/py-distro as a runtime dependency. Certbot claims >=3D1.0.1=
    but
     non-linux distribution are supported only from 1.2.0.

---
   Module Name:	pkgsrc
   Committed By:	adam
   Date:		Wed Oct  2 10:04:59 UTC 2019

   Modified Files:
   	pkgsrc/devel/py-distro: Makefile
   Added Files:
   	pkgsrc/devel/py-distro: ALTERNATIVES

   Log Message:
   py-distro: cleanup

---
   Module Name:	pkgsrc
   Committed By:	wiz
   Date:		Tue Oct  1 13:53:45 UTC 2019

   Modified Files:
   	pkgsrc/security/py-certbot: Makefile

   Log Message:
   py-certbot: bump PKGREVISION for added dependency

---
   Module Name:	pkgsrc
   Committed By:	wiz
   Date:		Wed Oct  2 08:38:42 UTC 2019

   Modified Files:
   	pkgsrc/security/py-certbot: Makefile

   Log Message:
   py-certbot: wip dependencies are not allowed in main pkgsrc

---
   Module Name:	pkgsrc
   Committed By:	triaxx
   Date:		Wed Oct  2 10:40:56 UTC 2019

   Modified Files:
   	pkgsrc/security/py-certbot: Makefile

   Log Message:
   py-certbot: update to 0.38nb3

   pkgsrc changes
   --------------
   * s/wip/devel/ for py-distro dependency (wip was for test only but
     committed by inattention)

Revision 1.2.2.1
Wed Oct 2 10:04:59 2019 UTC (5 years, 1 month ago) by bsiegert
Branches: pkgsrc-2019Q3
FILE REMOVED
Changes since revision 1.2: +0 -20 lines
file Makefile was added on branch pkgsrc-2019Q3 on 2019-10-18 14:31:38 +0000

Revision 1.2: download - view: text, markup, annotated - select for diffs
Wed Oct 2 10:04:59 2019 UTC (5 years, 1 month ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Branch point for: pkgsrc-2019Q3
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +6 -3 lines
py-distro: cleanup

Revision 1.1: download - view: text, markup, annotated - select for diffs
Tue Oct 1 13:22:55 2019 UTC (5 years, 1 month ago) by triaxx
Branches: MAIN
py-distro: import to version 1.4.0

Thanks to Aleksej for importing 1.1.0 in wip.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>