Up to [cvs.NetBSD.org] / pkgsrc / devel / py-decorator
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.21 / (download) - annotate - [select for diffs], Tue Aug 29 07:29:24 2023 UTC (3 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base,
pkgsrc-2023Q3,
HEAD
Changes since 1.20: +4 -3
lines
Diff to previous 1.20 (colored)
py-decorator: updated to 5.1.1 5.1.1 (2022-01-07) Sangwoo Shim contributed a fix so that cythonized functions can be decorated. Brian McFee pointed out an issue in the `decorator_apply` example and Wim Glenn pointed out that the "fix" in version 5.1 broke `decorator.contextmanager` even more. Both issues are now solved. 5.1.0 (2021-09-11) Added a function `decoratorx` using the `FunctionMaker` and thus preserving the signature of `__code__` objects. Then fixed three small bugs: - Sphinx was printing a few warnings when building the documentation, as signaled by Tomasz Koczko - functions decorated with `decorator.contextmanager` were one-shot, as discovered by Alex Pizarro. - `decorator.decorator` was not passing the kwsyntax argument. 5.0.9 (2021-05-16) Fixed a test breaking PyPy. Restored support for Sphinx. 5.0.8 (2021-05-15) Made the decorator module more robust when decorating builtin functions lacking dunder attributes, like `dict.__setitem__`. 5.0.7 (2021-04-14) The decorator module was not passing correctly the defaults inside the `*args` tuple, thanks to Dan Shult for the fix. Also fixed some mispellings in the documentation and integrated codespell in the CI, thanks to Christian Clauss. 5.0.6 (2021-04-08) The decorator module was not copying the __module__ attribute anymore. Thanks to Nikolay Markov for the notice. 5.0.5 (2021-04-04) Dropped support for Python < 3.5 with a substantial simplification of the code base (now building a decorator does not require calling "exec"). Added a way to mimic functools.wraps-generated decorators. Ported the Continuous Integration from Travis to GitHub.
Revision 1.20 / (download) - annotate - [select for diffs], Tue Jan 4 20:53:00 2022 UTC (23 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1
Changes since 1.19: +2 -1
lines
Diff to previous 1.19 (colored)
*: bump PKGREVISION for egg.mk users They now have a tool dependency on py-setuptools instead of a DEPENDS
Revision 1.19 / (download) - annotate - [select for diffs], Sat Apr 11 07:47:54 2020 UTC (3 years, 7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base,
pkgsrc-2021Q4,
pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2,
pkgsrc-2021Q1-base,
pkgsrc-2021Q1,
pkgsrc-2020Q4-base,
pkgsrc-2020Q4,
pkgsrc-2020Q3-base,
pkgsrc-2020Q3,
pkgsrc-2020Q2-base,
pkgsrc-2020Q2
Changes since 1.18: +2 -2
lines
Diff to previous 1.18 (colored)
py-decorator: updated to 4.4.2 4.4.2: Sylvan Mosberger (https://github.com/Infinisil) contributed a patch to some doctests that were breaking on NixOS. John Vandenberg (https://github.com/jayvdb) made a case for removing the usage of `__file__`, that was breaking PyOxidizer. Miro Hronok (https://github.com/hroncok) contributed some fixes for the future Python 3.9. Hugo van Kemenade (https://github.com/hugovk) contributed some fixes for the future Python 3.10.
Revision 1.18 / (download) - annotate - [select for diffs], Wed Nov 13 20:44:29 2019 UTC (4 years ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base,
pkgsrc-2020Q1,
pkgsrc-2019Q4-base,
pkgsrc-2019Q4
Changes since 1.17: +2 -2
lines
Diff to previous 1.17 (colored)
py-decorator: updated to 4.4.1 4.4.1: Changed the description to "Decorators for Humans" are requested by several users. Fixed a .rst bug in the description as seen in PyPI.
Revision 1.17 / (download) - annotate - [select for diffs], Thu Apr 4 09:51:01 2019 UTC (4 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base,
pkgsrc-2019Q3,
pkgsrc-2019Q2-base,
pkgsrc-2019Q2
Changes since 1.16: +2 -2
lines
Diff to previous 1.16 (colored)
py-decorator: updated to 4.4.0 4.4.0: Fixed a regression with decorator factories breaking the case with no arguments by going back to the syntax used in version 4.2. Accepted a small fix from Eric Larson (https://github.com/larsoner) affecting isgeneratorfunction for old Python versions. Moved the documentation from ReadTheDocs to GitHub to simplify the release process and replaced ReStructuredText with Markdown: it is an inferior solution, but it works better with GitHub and it is good enough.
Revision 1.16 / (download) - annotate - [select for diffs], Thu Feb 14 09:04:21 2019 UTC (4 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base,
pkgsrc-2019Q1
Changes since 1.15: +2 -2
lines
Diff to previous 1.15 (colored)
py-decorator: updated to 4.3.2 4.3.2: Accepted a patch from Sylvain Marie (https://github.com/smarie): now the decorator module can decorate generator functions by preserving their being generator functions. Set `python_requires='>=2.6, !=3.0.*, !=3.1.*'` in setup.py, as suggested by https://github.com/hugovk. 4.3.1: Added a section "For the impatient" to the README, addressing an issue raised by Amir Malekpour. Added support for Python 3.7. Now the path to the decorator module appears in the tracebacks, as suggested by an user at EuroPython 2018.
Revision 1.15 / (download) - annotate - [select for diffs], Sat Jun 16 12:18:12 2018 UTC (5 years, 5 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3,
pkgsrc-2018Q2-base,
pkgsrc-2018Q2
Changes since 1.14: +2 -2
lines
Diff to previous 1.14 (colored)
py-decorator: updated to 4.3.0 4.3.0: Extended the decorator family facility to work with positional arguments and updated the documentation. Removed decorator.getargspec and provided decorator.getfullargspec instead. This is convenient for users of Python 2.6/2.7, the others can just use inspect.getfullargspec.
Revision 1.14 / (download) - annotate - [select for diffs], Mon Jan 15 10:40:07 2018 UTC (5 years, 10 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base,
pkgsrc-2018Q1
Changes since 1.13: +3 -3
lines
Diff to previous 1.13 (colored)
py-decorator: updated to 4.2.1 4.2.1: Fixed a regression breaking IPython and discovered by https://github.com/spapini 4.2.0: Added a facility to define families of decorators (aka decorators with arguments) as requested by several users.
Revision 1.13 / (download) - annotate - [select for diffs], Mon Jul 24 10:20:59 2017 UTC (6 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base,
pkgsrc-2017Q4,
pkgsrc-2017Q3-base,
pkgsrc-2017Q3
Changes since 1.12: +5 -3
lines
Diff to previous 1.12 (colored)
4.1.2: Made it possible to define decorators converting coroutines into regular functions
Revision 1.12 / (download) - annotate - [select for diffs], Sun Jul 16 09:25:34 2017 UTC (6 years, 4 months ago) by adam
Branch: MAIN
Changes since 1.11: +2 -2
lines
Diff to previous 1.11 (colored)
4.1.1: Changed the documentation build system to sphinx and uploaded the docs on readthedocs.org. 4.1.0: Support for Python 3.5 coroutines defined with async def, thanks to Victor-Nicolae Savu who raised the issue of iscoroutinefunction not giving the right answer for coroutines decorated with the decorator module.
Revision 1.11 / (download) - annotate - [select for diffs], Mon Jan 16 08:04:48 2017 UTC (6 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base,
pkgsrc-2017Q2,
pkgsrc-2017Q1-base,
pkgsrc-2017Q1
Changes since 1.10: +2 -7
lines
Diff to previous 1.10 (colored)
Updated py-decorator to 4.0.11. ## 4.0.11 (2017-01-15) Small improvements to the documentation and tested with Python 3.6
Revision 1.10 / (download) - annotate - [select for diffs], Mon Jun 13 12:05:14 2016 UTC (7 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base,
pkgsrc-2016Q4,
pkgsrc-2016Q3-base,
pkgsrc-2016Q3,
pkgsrc-2016Q2-base,
pkgsrc-2016Q2
Changes since 1.9: +2 -1
lines
Diff to previous 1.9 (colored)
Add upstream bug report.
Revision 1.9 / (download) - annotate - [select for diffs], Mon Jun 13 12:03:01 2016 UTC (7 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.8: +10 -10
lines
Diff to previous 1.8 (colored)
Updated py-decorator to 4.0.10. ## 4.0.10 (2016-06-07) Improved the documentation thanks to Tony Goodchild (zearin) who also provided a much better CSS than the one I was using.
Revision 1.8 / (download) - annotate - [select for diffs], Wed Jun 8 17:43:24 2016 UTC (7 years, 6 months ago) by wiz
Branch: MAIN
Changes since 1.7: +2 -2
lines
Diff to previous 1.7 (colored)
Switch to MASTER_SITES_PYPI.
Revision 1.7 / (download) - annotate - [select for diffs], Sun Feb 14 11:02:10 2016 UTC (7 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base,
pkgsrc-2016Q1
Changes since 1.6: +6 -2
lines
Diff to previous 1.6 (colored)
Update py-decorator to 4.0.9. ## 4.0.9 (2016-02-08) Same as 4.0.7 and 4.0.8, re-uploaded due to issues on PyPI ## 4.0.7 (2016-02-06) Switched to a new changelog format (the one in http://keepachangelog.com/) since it was contributed by Alexander Artemenko. Re-added a newline to support old version of Python, as requested by [azjps](https://github.com/azjps).
Revision 1.6 / (download) - annotate - [select for diffs], Wed Dec 30 00:12:04 2015 UTC (7 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.5: +2 -2
lines
Diff to previous 1.5 (colored)
Update py-decorator to 4.0.6: 4.0.6 Removed a file x.py accidentally entered in the tarball (2015/12/11) 4.0.5 Documented a quirk signaled by David Goldstein when writing decorators for functions with keyword arguments. Avoided copying the globals, as signaled by Benjamin Peterson (2015/12/09) 4.0.4 Included a patch from Zev Benjamin: now decorated functions play well with cProfile (2015/09/25) 4.0.3 Added a warning about the memoize example, as requested by Robert Buchholz (2015/09/25)
Revision 1.5 / (download) - annotate - [select for diffs], Fri Dec 4 20:44:48 2015 UTC (8 years ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base,
pkgsrc-2015Q4
Changes since 1.4: +2 -2
lines
Diff to previous 1.4 (colored)
Update py-decorator to 4.0.2: 4.0.2 Fix: docs/README.rst was not included in MANIFEST.in by accident, thus breaking the source installation (2015/07/28) 4.0.1 Added docs directory and upload_docs command. Fixed bug with `__qualname__`, reported by Lucian Petrut (2015/07/28) 4.0.0 Removed the need for 2to3 by dropping the support for Python 2.5. Added a MANIFEST.in file and produced a proper wheel. Improved the integration with setuptools so that `python setup.py test` works. Reworked the documentation and introduced `decorator.decorated`. Removed any dependence from `inspect.getargspec`, which is deprecated in Python 3.5, as signaled by Ralf Gommers. Fixed `contextmanager` to work with Python 3.5. Copied the `__qualname__` attribute, as requested by Frazer McLean. Added a `dispatch_on` facility to implement generic functions. (2015/07/24) 3.4.2 Same as 3.4.1, re-uploaded to PyPI (2015-03-22) 3.4.1 Ported the repository from GoogleCode to GitHub and added Travis CI support. Tests are executed with the new command `python test.py -v`. setuptools is now mandatory in Python 3. The suggested installation tool is now `pip`, not `easy_install`. Supported IronPython and other Python implementations without sys._getframe, as requested by Doug Blank (2015/03/16)
Revision 1.4 / (download) - annotate - [select for diffs], Wed Dec 31 13:57:26 2014 UTC (8 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base,
pkgsrc-2015Q3,
pkgsrc-2015Q2-base,
pkgsrc-2015Q2,
pkgsrc-2015Q1-base,
pkgsrc-2015Q1
Changes since 1.3: +1 -3
lines
Diff to previous 1.3 (colored)
Improve EGG_NAME default to work for packages with '-' in their name. Remove now unnecessary overrides in various packages.
Revision 1.3 / (download) - annotate - [select for diffs], Sat Jun 14 14:27:53 2014 UTC (9 years, 5 months ago) by rodent
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base,
pkgsrc-2014Q4,
pkgsrc-2014Q3-base,
pkgsrc-2014Q3,
pkgsrc-2014Q2-base,
pkgsrc-2014Q2
Changes since 1.2: +2 -2
lines
Diff to previous 1.2 (colored)
3.4.0 Added the ability to use classes and generic callables as callers and implemented a signature-preserving contexmanager decorator. Fixed a bug with the signature f(**kw) in Python 3 and fixed a couple of doctests broken by Python 3.3. 3.3.3 Fixed a bug with kwonlyargs for Python 3
Revision 1.2 / (download) - annotate - [select for diffs], Wed Oct 31 11:19:30 2012 UTC (11 years, 1 month ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base,
pkgsrc-2014Q1,
pkgsrc-2013Q4-base,
pkgsrc-2013Q4,
pkgsrc-2013Q3-base,
pkgsrc-2013Q3,
pkgsrc-2013Q2-base,
pkgsrc-2013Q2,
pkgsrc-2013Q1-base,
pkgsrc-2013Q1,
pkgsrc-2012Q4-base,
pkgsrc-2012Q4
Changes since 1.1: +1 -4
lines
Diff to previous 1.1 (colored)
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.
Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Sun Nov 13 22:58:28 2011 UTC (12 years ago) by joerg
Branch: TNF
CVS Tags: pkgsrc-base,
pkgsrc-2012Q3-base,
pkgsrc-2012Q3,
pkgsrc-2012Q2-base,
pkgsrc-2012Q2,
pkgsrc-2012Q1-base,
pkgsrc-2012Q1,
pkgsrc-2011Q4-base,
pkgsrc-2011Q4
Changes since 1.1: +0 -0
lines
Diff to previous 1.1 (colored)
Imported py26-decorator. The ``decorator'' module aims to simplify the usage of decorators in Python code for the average programmer and to popularize decorators by showing various non-trivial examples.
Revision 1.1 / (download) - annotate - [select for diffs], Sun Nov 13 22:58:28 2011 UTC (12 years ago) by joerg
Branch: MAIN
Initial revision