The NetBSD Project

CVS log for pkgsrc/devel/py-daemon/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-daemon

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.29 / (download) - annotate - [select for diffs], Fri Jan 12 14:26:59 2024 UTC (3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, HEAD
Changes since 1.28: +3 -4 lines
Diff to previous 1.28 (colored)

py-daemon: updated to 3.0.1

Version 3.0.1
=============

:Released: 2023-03-08
:Maintainer: Ben Finney <ben+python@benfinney.id.au>

Bugs Fixed:

* Declare dependency on Setuptools >= 62.4.0.

  This is necessary for establishing the version information via Setuptools. We
  use ãàÏÔetuptools.command.buildãà `introduced in Setuptools version 62.4.0

Added:

* PyPA recommended Project URLs for the distribution.


Version 3.0.0
=============

:Released: 2023-03-04
:Maintainer: Ben Finney <ben+python@benfinney.id.au>

Bugs Fixed:

* Refactor calculation of file descriptor ranges to close.

  When the range of candidate file descriptors is very large, the code that
  computes file descriptors to close when the daemon starts attempted to
  allocate a large amount of memory and took a long time to compute.

  Thanks to Alex Pyrgiotis for the timing test case.

  This change avoids that resource-intensive computation, and significantly
  improves the performance when importing the module and when starting the
  daemon.

  Thanks to Igor Kholopov for the implementation.

Added:

* Document a `ServiceRunner` class as an example of using `DaemonContext`.

Changed:

* Raise a TypeError if any `exclude` values are not valid file descriptors.

  Formerly, an invalid value might be silently ignored.

  Thanks to Igor Kholopov for the suggestion.

* Migrate package version handling to use Setuptools API.

  The Distutils library is deprecated for direct use; see

Removed:

* Remove redundant ãàÏØheelãàfrom the requirements specification.

  As described by the Python Packaging Authority:

      This [ãàÏØheelãàѾ dependency is exposed automatically by setuptools and the
      users do not need to declare it explicitly ãàit will be installed by PEP
      517 front-ends automatically, when building wheels.

  Thanks to Micha Górny for the implementation.

* Remove Setuptools ÏÕestãàcommand support.

  The ãàÏÕestãàcommand is formally deprecated, in favour of dedicated test
  runners.

* Remove Setuptools ãàÏÓegisterãàand ãàÏÖploadãàcommand support.

  The commands to publish a distribution to PyPI are removed, in favour of the
  Twine tool.

* Remove the obsolete `runner` module.

  This module was deprecated starting in `python-daemon` version 2.1.2, and is
  now removed as unmaintained.

Revision 1.28 / (download) - annotate - [select for diffs], Tue Nov 7 22:37:59 2023 UTC (5 months, 1 week ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4
Changes since 1.27: +2 -2 lines
Diff to previous 1.27 (colored)

*: latest py-sphinx only support Python 3.9+

Revision 1.27 / (download) - annotate - [select for diffs], Sat Oct 28 19:56:58 2023 UTC (5 months, 3 weeks ago) by wiz
Branch: MAIN
Changes since 1.26: +2 -1 lines
Diff to previous 1.26 (colored)

python/wheel.mk: simplify a lot, and switch to 'installer' for installation

This follows the recommended bootstrap method (flit_core, build, installer).

However, installer installs different files than pip, so update PLISTs
for all packages using wheel.mk and bump their PKGREVISIONs.

Revision 1.26 / (download) - annotate - [select for diffs], Sun Oct 23 10:44:26 2022 UTC (17 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4
Changes since 1.25: +3 -5 lines
Diff to previous 1.25 (colored)

py-daemon: updated to 2.3.2

Version 2.3.2
=============

Bugs Fixed:

* Declare Twine as a development dependency (not a build dependency).
* Specify to build a wheel distribution for only Python 3 or later.
* Specify the built package requires Python 3 or later.

Removed:

* The earlier version 2.3.1 is now ãà×Úankedãàfrom PyPI (unlisted and not an
  installation candidate), because that version incorrectly permitted
  installation on Python 2. Thanks to Nick M. for the report.

Revision 1.25 / (download) - annotate - [select for diffs], Sun Sep 11 16:01:23 2022 UTC (19 months, 1 week ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3
Changes since 1.24: +5 -3 lines
Diff to previous 1.24 (colored)

py-daemon: Convert to wheel.mk to fix build.

Bump PKGREVISION.

Revision 1.24 / (download) - annotate - [select for diffs], Mon Sep 5 09:49:36 2022 UTC (19 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.23: +3 -4 lines
Diff to previous 1.23 (colored)

py-daemon: updated to 2.3.1

Version 2.3.1
=============

Bugs Fixed:

* Avoid operations on a closed stream file when detecting a socket.
* Correct use of names to allow `from daemon import *`.

Changed:

* Speed daemon start time by computing candidate file descriptors once.
* Remove incorrect double-patch of objects in test cases.
* Deprecate helper function `is_socket`.

  The function incorrectly causes `ValueError` when the file object is already
  closed. Migrate to the new `is_socket_file` helper function instead.

Removed:

* Drop backward-compatible helpers that provided Python 2 support.

  * declaration of source encoding ãàÏÖtf-8ãà  * absolute_import
  * unicode_literals
  * module-level metaclass `type`
  * unification of str with unicode type
  * renamed standard library exceptions and modules
  * raise exception from context exception

  All these are default behaviour in Python 3 and need no special
  handling.

Revision 1.23 / (download) - annotate - [select for diffs], Tue Jan 4 20:52:59 2022 UTC (2 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.22: +2 -1 lines
Diff to previous 1.22 (colored)

*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.22 / (download) - annotate - [select for diffs], Mon Sep 20 09:20:17 2021 UTC (2 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3
Changes since 1.21: +1 -2 lines
Diff to previous 1.21 (colored)

py-daemon: remove py-pygments dependency

It belongs into py-docutils and was just added there.

Revision 1.21 / (download) - annotate - [select for diffs], Mon Sep 20 08:55:30 2021 UTC (2 years, 6 months ago) by nia
Branch: MAIN
Changes since 1.20: +4 -3 lines
Diff to previous 1.20 (colored)

py-daemon: Add missing build-time dependency.

I have no idea where this dependency comes from (it's not in setup.py),
but adding it fixes the build.

Revision 1.20 / (download) - annotate - [select for diffs], Mon Jun 21 13:59:56 2021 UTC (2 years, 9 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.19: +2 -1 lines
Diff to previous 1.19 (colored)

py-daemon: needs py-docutils

Revision 1.19 / (download) - annotate - [select for diffs], Wed Jun 2 11:42:17 2021 UTC (2 years, 10 months ago) by adam
Branch: MAIN
Changes since 1.18: +2 -3 lines
Diff to previous 1.18 (colored)

py-daemon: fix BUILD_DEPENDS

Revision 1.18 / (download) - annotate - [select for diffs], Sat May 22 09:55:25 2021 UTC (2 years, 10 months ago) by nia
Branch: MAIN
Changes since 1.17: +2 -1 lines
Diff to previous 1.17 (colored)

py-daemon: add missing dependency

Revision 1.17 / (download) - annotate - [select for diffs], Sat May 8 09:16:15 2021 UTC (2 years, 11 months ago) by adam
Branch: MAIN
Changes since 1.16: +7 -10 lines
Diff to previous 1.16 (colored)

py-daemon: updated to 2.3.0

Version 2.3.0
=============
Removed:

* Remove support for Python versions older than Python 3.

  Python 2 has been unsupported by the Python project since 2020.

* Remove dependency on back-ported `unittest2` and `mock`.
  Depend instead on standard library `unittest` and `unittest.mock`.

Revision 1.16 / (download) - annotate - [select for diffs], Mon Aug 31 23:07:01 2020 UTC (3 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.15: +3 -2 lines
Diff to previous 1.15 (colored)

*: switch to versioned_dependencies.mk for py-setuptools

Revision 1.15 / (download) - annotate - [select for diffs], Thu May 14 19:39:03 2020 UTC (3 years, 11 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2
Changes since 1.14: +3 -1 lines
Diff to previous 1.14 (colored)

No longer supports Python 2.7

Revision 1.14 / (download) - annotate - [select for diffs], Thu Dec 5 14:51:01 2019 UTC (4 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.13: +3 -2 lines
Diff to previous 1.13 (colored)

py-daemon: updated to 2.2.4

Version 2.2.4

Bugs Fixed:
* Run the Setuptools `egg-info` command as part of the `build`
  command.
* Create the socket and catch ãà×Ïon-socketãàerrors.
* Only deal with a range of file descriptors if the range is not empty.
* Declare Twine as a build dependency.
* Reformat the change log entries with keepachangelog.com sub-sections.

Changed:
* Upgrade Tox dependency to version ãà.7.0ãà
* Significant speed-up to discovery of file descriptors to close.
* Refactor the build system to use Makefile modules for each topic.

Revision 1.13 / (download) - annotate - [select for diffs], Mon Jan 21 09:23:51 2019 UTC (5 years, 2 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

py-daemon: updated to 2.2.3

Version 2.2.3

Bug Fixes:
* Use custom fake file type for testing fileno behaviour.

  This works around an incompatibility in Python 2.7 file type that
  caused test cases to fail.

Changes:
* Promote the warning for runner module to a DeprecationWarning.
  This has been an unofficial example module from the beginning, and
  it will be removed in a future version.


Version 2.2.2

Bug Fixes:
* Remove from the build system specification a white space character
  not permitted in TOML format.

Additions:
* Implement test suite automation in virtualenvs, using Tox.


Version 2.2.1

Additions:
* Add a :PEP:518 conformant build system specification (the
  pyproject.toml file).

Revision 1.12 / (download) - annotate - [select for diffs], Tue Nov 27 16:36:28 2018 UTC (5 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4
Changes since 1.11: +10 -10 lines
Diff to previous 1.11 (colored)

py-daemon: updated to 2.2.0

Version 2.2.0

Bug Fixes:
* Correct the description of the return value for
  daemon.is_detach_process_context_required.
* Set a sensible default for Distribution.script_name.
  This works around a bug in Setuptools which calls commands before
  the Distribution is initialised.

Changes:
* The test suite now relies on the test discovery feature in
  ãàÏÖnittestãà This feature is in Python version 2.7 and later.
* Improve performance of daemon.close_all_open_files.

Revision 1.11 / (download) - annotate - [select for diffs], Mon Sep 4 18:08:20 2017 UTC (6 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.10: +2 -2 lines
Diff to previous 1.10 (colored)

Follow some redirects.

Revision 1.10 / (download) - annotate - [select for diffs], Sun Jul 30 05:53:52 2017 UTC (6 years, 8 months ago) by adam
Branch: MAIN
Changes since 1.9: +10 -14 lines
Diff to previous 1.9 (colored)

Version 2.1.2
Additions:
* Add a README document for the code base.
Changes:
* Migrate code project hosting to Pagure.
  Record the change of homepage URL in PyPI metadata.
* Raise a warning that the ãàÏÓunnerãàmodule is pending deprecation.
  This has been an unofficial example module from the beginning, and
  it will be removed in a future version.
Bug Fixes:
* Ensure custom types are part of the Python type hierarchy.
* Avoid a circular dependency for the version string at install time.

Revision 1.9 / (download) - annotate - [select for diffs], Sun Jan 1 14:43:32 2017 UTC (7 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.8: +2 -2 lines
Diff to previous 1.8 (colored)

Add python-3.6 to incompatible versions.

Revision 1.8 / (download) - annotate - [select for diffs], Sat Jul 9 13:03:40 2016 UTC (7 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.7: +2 -2 lines
Diff to previous 1.7 (colored)

Remove python33: adapt all packages that refer to it.

Revision 1.7 / (download) - annotate - [select for diffs], Wed Jun 8 17:43:24 2016 UTC (7 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

Switch to MASTER_SITES_PYPI.

Revision 1.6 / (download) - annotate - [select for diffs], Sat Dec 5 21:25:36 2015 UTC (8 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

Extend PYTHON_VERSIONS_INCOMPATIBLE to 35

Revision 1.5 / (download) - annotate - [select for diffs], Wed Dec 31 13:57:26 2014 UTC (9 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.4: +1 -2 lines
Diff to previous 1.4 (colored)

Improve EGG_NAME default to work for packages with '-' in their name.
Remove now unnecessary overrides in various packages.

Revision 1.4 / (download) - annotate - [select for diffs], Fri May 9 07:37:00 2014 UTC (9 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

Mark packages that are not ready for python-3.3 also not ready for 3.4,
until proven otherwise.

Revision 1.3 / (download) - annotate - [select for diffs], Sun Jan 19 09:09:13 2014 UTC (10 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.2: +5 -5 lines
Diff to previous 1.2 (colored)

Update to 1.6:

    Version 1.6 released.

    * Use absolute imports to disambiguate provenance of names.
    * setup.py: Require ãàÏÍockfile >=0.9ãà
    * daemon/pidfile.py: Renamed from ãàÏÅaemon/pidlockfile.pyãà Change
      references elsewhere to use this new name.
    * test/test_pidfile.py: Renamed from ãàÏÕest/test_pidlockfile.pyãà
      Change references elsewhere to use this new name.
    * daemon/pidfile.py: Remove functionality now migrated to ãàÏÍockfileãà      library.

Revision 1.2 / (download) - annotate - [select for diffs], Wed Oct 31 11:19:29 2012 UTC (11 years, 5 months ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.1: +1 -3 lines
Diff to previous 1.1 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.1 / (download) - annotate - [select for diffs], Tue Aug 14 12:29:50 2012 UTC (11 years, 8 months ago) by imil
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3

Initial import of py-daemon, version 1.5.5, into the NetBSD Packages Collection.

A well-behaved Unix daemon process is tricky to get right, but the required
steps are much the same for every daemon program. A DaemonContext instance
holds the behaviour and configured process environment for the program; use
the instance as a context manager to enter a daemon state.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>