File:
[cvs.NetBSD.org] /
pkgsrc /
devel /
py-cython /
distinfo
Revision
1.71:
download - view:
text,
annotated -
select for diffs
Wed May 18 11:37:44 2022 UTC (2 years, 6 months ago) by
adam
Branches:
MAIN
CVS tags:
pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
HEAD
py-cython: updated to 0.29.30
0.29.30 (2022-05-16)
====================
Bugs fixed
----------
* The GIL handling changes in 0.29.29 introduced a regression where
objects could be deallocated without holding the GIL.
0.29.29 (2022-05-16)
====================
Features added
--------------
* Avoid acquiring the GIL at the end of nogil functions.
This change was backported in order to avoid generating wrong C code
that would trigger C compiler warnings with tracing support enabled.
Bugs fixed
----------
* Function definitions in ``finally:`` clauses were not correctly generated.
* A case where C-API functions could be called with a live exception set was fixed.
* Pickles can now be exchanged again with those generated from Cython 3.0 modules.
* Cython now correctly generates Python methods for both the provided regular and
reversed special numeric methods of extension types.
* Calling unbound extension type methods without arguments could raise an
``IndexError`` instead of a ``TypeError``.
* Calling unbound ``.__contains__()`` super class methods on some builtin base
types could trigger an infinite recursion.
* The C union type in pure Python mode mishandled some field names.
* Allow users to overwrite the C macro ``_USE_MATH_DEFINES``.
* Improved compatibility with CPython 3.10/11.
* Docstrings of descriptors are now provided in PyPy 7.3.9.