The NetBSD Project

CVS log for pkgsrc/devel/py-cython/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-cython

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2013Q1


Revision 1.7 / (download) - annotate - [select for diffs], Sun Feb 3 16:35:51 2013 UTC (11 years, 1 month ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.6: +4 -4 lines
Diff to previous 1.6 (colored)

Update to 0.18:

0.18 (2013-01-28)
=================

Features added
--------------

* Named Unicode escapes ("\N{...}") are supported.

* Python functions/classes provide the special attribute "__qualname__"
  as defined by PEP 3155.

* Added a directive ``overflowcheck`` which raises an OverflowException when
  arithmetic with C ints overflow.  This has a modest performance penalty, but
  is much faster than using Python ints.

* Calls to nested Python functions are resolved at compile time.

* Type inference works across nested functions.

* ``py_bytes_string.decode(...)`` is optimised.

* C ``const`` declarations are supported in the language.

Bugs fixed
----------

* Automatic C++ exception mapping didn't work in nogil functions (only in
  "with nogil" blocks).

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>