CVS log for pkgsrc/devel/py-cachetools/Makefile
Up to [cvs.NetBSD.org] / pkgsrc / devel / py-cachetools
Request diff between arbitrary revisions
Keyword substitution: kv
Default branch: MAIN
Revision 1.23: download - view: text, markup, annotated - select for diffs
Sat Apr 12 10:02:37 2025 UTC (2 weeks, 3 days ago) by adam
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.22: preferred, colored
Changes since revision 1.22: +3 -2
lines
Fix PLIST after py-setuptools update; bump depends and revision
Revision 1.22: download - view: text, markup, annotated - select for diffs
Fri Feb 21 08:47:04 2025 UTC (2 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2025Q1-base,
pkgsrc-2025Q1
Diff to: previous 1.21: preferred, colored
Changes since revision 1.21: +2 -2
lines
py-cachetools: updated to 5.5.2
v5.5.2 (2025-02-20)
- Reduce number of ``@cached`` lock/unlock operations.
- Improve documentation.
- Update CI environment.
Revision 1.21: download - view: text, markup, annotated - select for diffs
Thu Jan 30 08:25:49 2025 UTC (2 months, 4 weeks ago) by adam
Branches: MAIN
Diff to: previous 1.20: preferred, colored
Changes since revision 1.20: +2 -4
lines
py-cachetools: updated to 5.5.1
v5.5.1 (2025-01-21)
- Add documentation regarding caching of exceptions.
- Officially support Python 3.13.
- Update CI environment.
Revision 1.20: download - view: text, markup, annotated - select for diffs
Mon Nov 11 07:28:02 2024 UTC (5 months, 2 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base,
pkgsrc-2024Q4
Diff to: previous 1.19: preferred, colored
Changes since revision 1.19: +1 -2
lines
py-*: remove unused tool dependency
py-setuptools includes the py-wheel functionality nowadays
Revision 1.19: download - view: text, markup, annotated - select for diffs
Mon Aug 19 09:21:53 2024 UTC (8 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base,
pkgsrc-2024Q3
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +2 -2
lines
py-cachetools: updated to 5.5.0
v5.5.0 (2024-08-18)
- ``TTLCache.expire()`` returns iterable of expired ``(key, value)``
pairs.
- ``TLRUCache.expire()`` returns iterable of expired ``(key, value)``
pairs.
- Documentation improvements.
- Update CI environment.
Revision 1.18: download - view: text, markup, annotated - select for diffs
Wed Jul 17 04:05:53 2024 UTC (9 months, 1 week ago) by adam
Branches: MAIN
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +2 -2
lines
py-cachetools: updated to 5.4.0
v5.4.0 (2024-07-15)
- Add the ``keys.typedmethodkey`` decorator.
- Deprecate ``MRUCache`` class.
- Deprecate ``@func.mru_cache`` decorator.
- Update CI environment.
Revision 1.17: download - view: text, markup, annotated - select for diffs
Tue Feb 27 08:35:32 2024 UTC (14 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q2-base,
pkgsrc-2024Q2,
pkgsrc-2024Q1-base,
pkgsrc-2024Q1
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +6 -3
lines
py-cachetools: updated to 5.3.3
v5.3.3 (2024-02-26)
- Documentation improvements.
- Update CI environment.
Revision 1.16: download - view: text, markup, annotated - select for diffs
Fri Oct 27 09:33:34 2023 UTC (18 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base,
pkgsrc-2023Q4
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +2 -2
lines
py-cachetools: updated to 5.3.2
v5.3.2 (2023-10-24)
- Add support for Python 3.12.
- Various documentation improvements.
Revision 1.15: download - view: text, markup, annotated - select for diffs
Sun May 28 10:51:31 2023 UTC (23 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base,
pkgsrc-2023Q3,
pkgsrc-2023Q2-base,
pkgsrc-2023Q2
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +2 -2
lines
py-cachetools: updated to 5.3.1
v5.3.1 (2023-05-27)
- Depend on Python >= 3.7.
Revision 1.14: download - view: text, markup, annotated - select for diffs
Sun Apr 30 15:15:20 2023 UTC (2 years ago) by wiz
Branches: MAIN
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +2 -3
lines
py-cachetools: update to 5.3.0.
v5.3.0 (2023-01-22)
===================
- Add ``cache_info()`` function to ``@cached`` decorator.
v5.2.1 (2023-01-08)
===================
- Add support for Python 3.11.
- Correct version information in RTD documentation.
- ``badges/shields``: Change to GitHub workflow badge routes.
v5.2.0 (2022-05-29)
===================
- Add ``cachetools.keys.methodkey()``.
- Add ``cache_clear()`` function to decorators.
- Add ``src`` directory to ``sys.path`` for Sphinx autodoc.
- Modernize ``func`` wrappers.
v5.1.0 (2022-05-15)
===================
- Add cache decorator parameters as wrapper function attributes.
v5.0.0 (2021-12-21)
===================
- Require Python 3.7 or later (breaking change).
- Remove deprecated submodules (breaking change).
The ``cache``, ``fifo``, ``lfu``, ``lru``, ``mru``, ``rr`` and
``ttl`` submodules have been deleted. Therefore, statements like
``from cachetools.ttl import TTLCache``
will no longer work. Use
``from cachetools import TTLCache``
instead.
- Pass ``self`` to ``@cachedmethod`` key function (breaking change).
The ``key`` function passed to the ``@cachedmethod`` decorator is
now called as ``key(self, *args, **kwargs)``.
The default key function has been changed to ignore its first
argument, so this should only affect applications using custom key
functions with the ``@cachedmethod`` decorator.
- Change exact time of expiration in ``TTLCache`` (breaking change).
``TTLCache`` items now get expired if their expiration time is less
than *or equal to* ``timer()``. For applications using the default
``timer()``, this should be barely noticable, but it may affect the
use of custom timers with larger tick intervals. Note that this
also implies that a ``TTLCache`` with ``ttl=0`` can no longer hold
any items, since they will expire immediately.
- Change ``Cache.__repr__()`` format (breaking change).
String representations of cache instances now use a more compact and
efficient format, e.g.
``LRUCache({1: 1, 2: 2}, maxsize=10, currsize=2)``
- Add TLRU cache implementation.
- Documentation improvements.
Revision 1.13: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:52:55 2022 UTC (3 years, 3 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -1
lines
*: bump PKGREVISION for egg.mk users
They now have a tool dependency on py-setuptools instead of a DEPENDS
Revision 1.12: download - view: text, markup, annotated - select for diffs
Thu Sep 30 19:02:27 2021 UTC (3 years, 6 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base,
pkgsrc-2021Q4
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -2
lines
py-cachetools: updated to 4.2.4
v4.2.4 (2021-09-30)
- Add submodule shims for backward compatibility.
v4.2.3 (2021-09-29)
- Add documentation and tests for using ``TTLCache`` with
``datetime``.
- Link to typeshed typing stubs.
- Flatten package file hierarchy.
Revision 1.11: download - view: text, markup, annotated - select for diffs
Fri May 7 18:18:11 2021 UTC (3 years, 11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -2
lines
py-cachetools: updated to 4.2.2
v4.2.2 (2021-04-27)
===================
- Update build environment.
- Remove Python 2 remnants.
- Format code with Black.
Revision 1.10: download - view: text, markup, annotated - select for diffs
Sat Mar 20 19:24:23 2021 UTC (4 years, 1 month ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base,
pkgsrc-2021Q1
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -2
lines
py-cachetools: updated to 4.2.1
v4.2.1 (2021-01-24)
===================
- Handle ``__missing__()`` not storing cache items.
- Clean up ``__missing__()`` example.
v4.2.0 (2020-12-10)
===================
- Add FIFO cache implementation.
- Add MRU cache implementation.
- Improve behavior of decorators in case of race conditions.
- Improve documentation regarding mutability of caches values and use
of key functions with decorators.
- Officially support Python 3.9.
Revision 1.9: download - view: text, markup, annotated - select for diffs
Tue Jul 7 07:04:47 2020 UTC (4 years, 9 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q4-base,
pkgsrc-2020Q4,
pkgsrc-2020Q3-base,
pkgsrc-2020Q3
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -2
lines
py-cachetools: updated to 4.1.1
v4.1.1
Improve popitem() exception context handling.
Replace float('inf') with math.inf.
Improve "envkey" documentation example.
Revision 1.8: download - view: text, markup, annotated - select for diffs
Sun Apr 12 21:13:14 2020 UTC (5 years ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2020Q2-base,
pkgsrc-2020Q2
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -2
lines
py-cachetools: update to 4.1.0.
v4.1.0 (2020-04-08)
===================
- Support ``user_function`` with ``cachetools.func`` decorators
(Python 3.8 compatibility).
- Support ``cache_parameters()`` with ``cachetools.func`` decorators
(Python 3.9 compatibility).
Revision 1.7: download - view: text, markup, annotated - select for diffs
Thu Jan 9 14:20:28 2020 UTC (5 years, 3 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base,
pkgsrc-2020Q1
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +4 -2
lines
py-cachetools: update to 4.0.0.
v4.0.0 (2019-12-15)
===================
- Require Python 3.5 or later.
Revision 1.6: download - view: text, markup, annotated - select for diffs
Tue Jul 2 10:19:10 2019 UTC (5 years, 9 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q4-base,
pkgsrc-2019Q4,
pkgsrc-2019Q3-base,
pkgsrc-2019Q3
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -2
lines
py-cachetools: updated to 3.1.1
v3.1.1:
- Document how to use shared caches with @cachedmethod.
- Fix pickling/unpickling of cache keys
Revision 1.5: download - view: text, markup, annotated - select for diffs
Thu Jan 31 10:01:05 2019 UTC (6 years, 2 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2
lines
py-cachetools: updated to 3.1.0
v3.1.0:
- Fix Python 3.8 compatibility issue.
- Use time.monotonic as default timer if available.
- Improve documentation regarding thread safety.
Revision 1.4: download - view: text, markup, annotated - select for diffs
Fri Jan 4 22:48:43 2019 UTC (6 years, 3 months ago) by adam
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2
lines
py-cachetools: updated to 3.0.0
v3.0.0:
Officially support Python 3.7.
Drop Python 3.3 support (breaking change).
Remove missing cache constructor parameter (breaking change).
Remove self from @cachedmethod key arguments (breaking change).
Add support for maxsize=None in cachetools.func decorators.
Revision 1.3: download - view: text, markup, annotated - select for diffs
Tue May 15 06:49:45 2018 UTC (6 years, 11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3,
pkgsrc-2018Q2-base,
pkgsrc-2018Q2
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +3 -3
lines
py-cachetools: updated to 2.1.0
2.1.0:
- Deprecate missing cache constructor parameter.
- Handle overridden getsizeof() method in subclasses.
- Fix Python 2.7 RRCache pickling issues.
- Various documentation improvements.
Revision 1.2: download - view: text, markup, annotated - select for diffs
Tue Aug 22 08:18:20 2017 UTC (7 years, 8 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q1-base,
pkgsrc-2018Q1,
pkgsrc-2017Q4-base,
pkgsrc-2017Q4,
pkgsrc-2017Q3-base,
pkgsrc-2017Q3
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -2
lines
v2.0.1:
- Officially support Python 3.6.
- Move documentation to RTD.
- Documentation: Update import paths for key functions
Revision 1.1: download - view: text, markup, annotated - select for diffs
Mon Mar 20 19:56:55 2017 UTC (8 years, 1 month ago) by minskim
Branches: MAIN
CVS tags: pkgsrc-2017Q2-base,
pkgsrc-2017Q2,
pkgsrc-2017Q1-base,
pkgsrc-2017Q1
Import py-cachetools-2.0.0
cachetools is Extensible memoizing collections and decorators.
CVSweb <webmaster@jp.NetBSD.org>