[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-buildbot-console-view

File: [cvs.NetBSD.org] / pkgsrc / devel / py-buildbot-console-view / Makefile (download)

Revision 1.6, Thu Nov 15 14:14:14 2018 UTC (5 years, 5 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4
Changes since 1.5: +2 -2 lines

py-buildbot: updated to 1.5.0

v1.5.0:
Bug fixes
Fix the umask parameter example to make it work with both Python 2.x and 3.x.
Fix build-change association for multi-codebase builds in the console view..
Fixed builders page doesn't list workers in multi-master configuration
Restricted groups added by :py:class:~buildbot.www.oauth2.GitHubAuth's
getTeamsMembership option to only those teams to which the user belongs.
Previously, groups were added for all teams for all organizations to which
the user belongs.
Fix 'Show old workers' combo behavior.

Features
GitHub teams added to a user's groups by
:py:class:~buildbot.www.oauth2.GitHubAuth's getTeamsMembership option
are now added by slug as well as by name. This means a team named "Bot
Builders" in the organization "buildbot" will be added as both buildbot/Bot Builders and buildbot/bot-builders.
Make urlText renderable for the
:py:class:~buildbot.steps.transfer.FileUpload build step.
Added noticeOnChannel option to :bb:reporter:IRC to send notices
instead of messages to channels. This was an option in v0.8.x and removed in
v0.9.0, which defaulted to sending notices. The v0.8.x default of sending
messages is now restored.

Reverts
Reverted: Fix git submodule support when using sshPrivateKey and sshHostKey because it broke other use cases
In order to have this feature to work, you need to keep your master in 1.4.0, and make sure your worker buildbot.tac are installed in the same path as your master.


v1.4.0:
Bug fixes
Fix Build.getUrl() to not ignore virtual builders.
Fix git submodule support when using sshPrivateKey and sshHostKey
settings by passing ssh data as absolute, not relative paths.
Fixed :bb:step:P4 for change in latest version of p4 login -p.
:py:class:buildbot.reporters.irc.IrcStatusBot no longer encodes messages
before passing them on to methods of its Twisted base class to avoid posting
the repr() of a bytes object when running on Python 3.

Features
Added new :bb:step:GitPush step to perform git push operations.
Objects returned by :ref:renderer now are able to pass extra arguments to
the rendered function via withArgs method.

Test Suite
Test suite has been improved for readability by adding a lot of inlineCallbacks
Fixed tests which didn't wait for assertFailure's returned deferred.
The test suite now runs on Python 3.7 (mostly deprecation warnings from dependencies shut down)

# $NetBSD: Makefile,v 1.6 2018/11/15 14:14:14 adam Exp $

DISTNAME=	buildbot-console-view-1.5.0
PKGNAME=	${PYPKGPREFIX}-${DISTNAME}
CATEGORIES=	devel net python
MASTER_SITES=	${MASTER_SITE_PYPI:=b/buildbot-console-view/}

MAINTAINER=	joerg@NetBSD.org
HOMEPAGE=	https://buildbot.net/
COMMENT=	Waterfall Plugin for the buildbot CI system
LICENSE=	gnu-gpl-v2

DEPENDS+=	${PYPKGPREFIX}-buildbot-[0-9]*:../../devel/py-buildbot
BUILD_DEPENDS+=	${PYPKGPREFIX}-buildbot-pkg-[0-9]*:../../devel/py-buildbot-pkg

USE_LANGUAGES=	# none

.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"