The NetBSD Project

CVS log for pkgsrc/devel/py-babel/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-babel

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.33 / (download) - annotate - [select for diffs], Thu May 12 08:20:36 2022 UTC (10 months, 1 week ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, HEAD
Changes since 1.32: +2 -2 lines
Diff to previous 1.32 (colored)

*: fix == vs. != confusion

Reported by adam

Revision 1.32 / (download) - annotate - [select for diffs], Thu May 12 08:05:28 2022 UTC (10 months, 1 week ago) by wiz
Branch: MAIN
Changes since 1.31: +8 -2 lines
Diff to previous 1.31 (colored)

*: do not use py-freezegun with python 2.7

Revision 1.31 / (download) - annotate - [select for diffs], Wed Jan 5 15:41:01 2022 UTC (14 months, 2 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.30: +4 -2 lines
Diff to previous 1.30 (colored)

python: egg.mk: add USE_PKG_RESOURCES flag

This flag should be set for packages that import pkg_resources
and thus need setuptools after the build step.

Set this flag for packages that need it and bump PKGREVISION.

Revision 1.30 / (download) - annotate - [select for diffs], Tue Jan 4 20:52:51 2022 UTC (14 months, 2 weeks ago) by wiz
Branch: MAIN
Changes since 1.29: +2 -1 lines
Diff to previous 1.29 (colored)

*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.29 / (download) - annotate - [select for diffs], Thu Apr 29 07:43:02 2021 UTC (22 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.28: +7 -2 lines
Diff to previous 1.28 (colored)

py-babel: updated to 2.9.1

Version 2.9.1

Bugfixes
* The internal locale-data loading functions now validate the name of the locale file to be loaded and only
  allow files within Babel's data directory.

Revision 1.28 / (download) - annotate - [select for diffs], Thu Nov 26 11:43:33 2020 UTC (2 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.27: +2 -2 lines
Diff to previous 1.27 (colored)

py-babel: updated to 2.9.0

Version 2.9.0

Upcoming version support changes
* This version, Babel 2.9, is the last version of Babel to support Python 2.7, Python 3.4, and Python 3.5.

Improvements
* CLDR: Use CLDR 37
* Dates: Handle ZoneInfo objects in get_timezone_location, get_timezone_name
* Numbers: Add group_separator feature in number formatting

Bugfixes
* Dates: Correct default Format().timedelta format to 'long' to mute deprecation warnings
* Import: Simplify iteration code in "import_cldr.py"
* Import: Stop using deprecated ElementTree methods "getchildren()" and "getiterator()"
* Messages: Fix unicode printing error on Python 2 without TTY.
* Messages: Introduce invariant that _invalid_pofile() takes unicode line.
* Tests: fix tests when using Python 3.9
* Tests: Remove deprecated 'sudo: false' from Travis configuration
* Tests: Support Py.test 6.x
* Utilities: LazyProxy: Handle AttributeError in specified func
* Utilities: Replace usage of parser.suite with ast.parse

Documentation
* Update parse_number comments
* Add __iter__ to Catalog documentation

Revision 1.27 / (download) - annotate - [select for diffs], Wed Jan 22 21:16:36 2020 UTC (3 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.26: +2 -2 lines
Diff to previous 1.26 (colored)

py-babel: updated to 2.8.0

Version 2.8.0

Improvements
* CLDR: Upgrade to CLDR 36.0
* Messages: Don't even open files with the "ignore" extraction method

Bugfixes
* Numbers: Fix formatting very small decimals when quantization is disabled
* Messages: Attempt to sort all messages

Docs
* Add years to changelog
* Note that installation requires pytz

Revision 1.26 / (download) - annotate - [select for diffs], Wed May 29 21:02:29 2019 UTC (3 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2
Changes since 1.25: +5 -4 lines
Diff to previous 1.25 (colored)

py-babel: updated to 2.7.0

Version 2.7.0

Possibly incompatible changes
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
These may be backward incompatible in some cases, as some more-or-less internal
APIs have changed. Please feel free to file issues if you bump into anything
strange and we'll try to help!

* General: Internal uses of babel.util.odict have been replaced with
  collections.OrderedDict from The Python standard library.

Improvements
~~~~~~~~~~~~
* CLDR: Upgrade to CLDR 35.1
* General: allow anchoring path patterns to the start of a string
* General: Bumped version requirement on pytz
* Messages: pybabel compile: exit with code 1 if errors were encountered
* Messages: Add omit-header to update_catalog
* Messages: Catalog update: keep user comments from destination by default
* Messages: Skip empty message when writing mo file
* Messages: Small fixes to avoid crashes on badly formatted .po files
* Numbers: parse_decimal() strict argument and suggestions
* Numbers: don't repeat suggestions in parse_decimal strict
* Numbers: implement currency formatting with long display names
* Numbers: parse_decimal(): assume spaces are equivalent to non-breaking spaces when not in strict mode
* Performance: Cache locale_identifiers()

Bugfixes
~~~~~~~~
* CLDR: Skip alt=... for week data (minDays, firstDay, weekendStart, weekendEnd)
* Dates: Fix wrong weeknumber for 31.12.2018
* Locale: Avoid KeyError trying to get data on WindowsXP
* Locale: get_display_name(): Don't attempt to concatenate variant information to None
* Messages: pofile: Add comparison operators to _NormalizedString
* Messages: pofile: don't crash when message.locations can't be sorted

Tooling & docs
~~~~~~~~~~~~~~
* Docs: Remove all references to deprecated easy_install
* Docs: Switch print statement in docs to print function - NotAFile
* Docs: Update all pypi.python.org URLs to pypi.org
* Docs: Use https URLs throughout project where available
* Support: Add testing and document support for Python 3.7
* Support: Test on Python 3.8-dev
* Support: Using ABCs from collections instead of collections.abc is deprecated.
* Tests: Fix conftest.py compatibility with pytest 4.3
* Tests: Update pytest and pytest-cov

Revision 1.25 / (download) - annotate - [select for diffs], Sun Jun 24 11:43:49 2018 UTC (4 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2
Changes since 1.24: +2 -5 lines
Diff to previous 1.24 (colored)

py-babel: updated to 2.6.0

Version 2.6.0

Possibly incompatible changes
These may be backward incompatible in some cases, as some more-or-less internal APIs have changed.
Please feel free to file issues if you bump into anything strange and we'll try to help!
* Numbers: Refactor decimal handling code and allow bypass of decimal quantization.
* Messages: allow processing files that are in locales unknown to Babel
* General: Drop support for EOL Python 2.6 and 3.3

Other changes
* CLDR: Use CLDR 33
* Lists: Add support for various list styles other than the default
* Messages: Add new PoFileError exception
* Times: Simplify Linux distro specific explicit timezone setting search

Bugfixes
* CLDR: avoid importing alt=narrow currency symbols
* CLDR: ignore non-Latin numbering systems
* Docs: Fix improper example for date formatting
* Tooling: Fix some deprecation warnings

Tooling & docs
* Add explicit signatures to some date autofunctions
* Include license file in the generated wheel package
* Python 3.6 invalid escape sequence deprecation fixes
* Test and document all supported Python versions
* Update copyright header years and authors file

Revision 1.24 / (download) - annotate - [select for diffs], Wed Apr 4 11:00:56 2018 UTC (4 years, 11 months ago) by fhajny
Branch: MAIN
Changes since 1.23: +4 -1 lines
Diff to previous 1.23 (colored)

devel/py-babel: Remove silly write perms on distfile contents.

Revision 1.23 / (download) - annotate - [select for diffs], Thu Jan 18 12:41:41 2018 UTC (5 years, 2 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1
Changes since 1.22: +2 -2 lines
Diff to previous 1.22 (colored)

py-babel: updated to 2.5.3

Version 2.5.3:
This is a maintenance release that reverts undesired API-breaking changes that slipped into 2.5.2

Version 2.5.2:
Bugfixes
* Revert the unnecessary PyInstaller fixes from 2.5.0 and 2.5.1

Revision 1.22 / (download) - annotate - [select for diffs], Fri Sep 15 11:25:26 2017 UTC (5 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

py-babel: update to 2.5.1

Version 2.5.1

Minor Improvements and bugfixes
* Use a fixed datetime to avoid test failures
* Parse multi-line __future__ imports better
* Fix validate_currency docstring
* Allow normalize_locale and exists to handle various unexpected inputs
* Make PyInstaller support more robust

Revision 1.21 / (download) - annotate - [select for diffs], Tue Aug 22 08:16:44 2017 UTC (5 years, 7 months ago) by adam
Branch: MAIN
Changes since 1.20: +3 -4 lines
Diff to previous 1.20 (colored)

Version 2.5.0

New Features
* Numbers: Add currency utilities and helpers
* Support PyInstaller

Minor Improvements and bugfixes
* Dates: Add __str__ to DateTimePattern
* Dates: Fix an invalid string to bytes comparison when parsing TZ files on Py3
* Dates: Formatting zero-padded components of dates is faster
* Documentation: Fix "Good Commits" link in CONTRIBUTING.md
* Documentation: Fix link to Python gettext module
* Messages: Allow both dash and underscore separated locale identifiers in pofiles
* Messages: Extract Python messages in nested gettext calls
* Messages: Fix in-place editing of dir list while iterating
* Messages: Stabilize sort order
* Time zones: Honor the no-inherit marker for metazone names

Revision 1.20 / (download) - annotate - [select for diffs], Thu Apr 6 06:49:18 2017 UTC (5 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.19: +3 -3 lines
Diff to previous 1.19 (colored)

Version 2.4.0

New Features
~~~~~~~~~~~~
Some of these changes might break your current code and/or tests.

* CLDR: CLDR 29 is now used instead of CLDR 28
* Messages: Add option 'add_location' for location line formatting
* Numbers: Allow full control of decimal behavior

Minor Improvements and bugfixes
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
* Documentation: Improve Date Fields descriptions
* Documentation: Typo fixes and documentation improvementscs10)
* Messages: Default to UTF-8 source encoding instead of ISO-8859-1
* Messages: Ensure messages are extracted in the order they were passed in
* Messages: Message extraction for JSX files is improved
* Messages: PO file reading supports multi-line obsolete units
* Messages: Python message extractor respects unicode_literals in __future__
* Messages: Roundtrip Language headers
* Messages: units before obsolete units are no longer erroneously marked obsolete
* Numbers: `parse_pattern` now preserves the full original pattern
* Numbers: Fix float conversion in `extract_operands`
* Plurals: Fix plural forms for Czech and Slovak locales
* Plurals: More plural form fixes based on Mozilla and CLDR references

Internal improvements
~~~~~~~~~~~~~~~~~~~~~
* Local times are constructed correctly in tests
* Miscellaneous small improvements
* Regex flags are extracted from the regex strings
* The PO file reader is now a class and has seen some refactoring

Revision 1.19 / (download) - annotate - [select for diffs], Tue Jan 3 13:23:01 2017 UTC (6 years, 2 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.18: +2 -2 lines
Diff to previous 1.18 (colored)

Use "${MV} || ${TRUE}" and "${RM} -f" consistently in post-install targets.

Revision 1.18 / (download) - annotate - [select for diffs], Thu Dec 15 10:41:20 2016 UTC (6 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4
Changes since 1.17: +2 -3 lines
Diff to previous 1.17 (colored)

Version 2.3.4
-------------
(Bugfix release, released on April 22th)

Bugfixes
~~~~~~~~
* CLDR: The lxml library is no longer used for CLDR importing, so it should not cause strange failures either.
* CLI: Every last single CLI usage regression should now be gone, and both distutils and stand-alone CLIs should work as they have in the past.

Revision 1.17 / (download) - annotate - [select for diffs], Sun Aug 28 15:48:29 2016 UTC (6 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.16: +1 -4 lines
Diff to previous 1.16 (colored)

Remove unnecessary PLIST_SUBST and FILES_SUBST that are now provided
by the infrastructure.

Mark a couple more packages as not ready for python-3.x.

Revision 1.16 / (download) - annotate - [select for diffs], Wed Jun 8 17:43:24 2016 UTC (6 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.15: +2 -2 lines
Diff to previous 1.15 (colored)

Switch to MASTER_SITES_PYPI.

Revision 1.15 / (download) - annotate - [select for diffs], Sun Mar 15 19:31:45 2015 UTC (8 years ago) by hiramatsu
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.14: +2 -2 lines
Diff to previous 1.14 (colored)

Set MAINTAINER to pkgsrc-users.

Revision 1.14 / (download) - annotate - [select for diffs], Fri Apr 18 13:15:36 2014 UTC (8 years, 11 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.13: +2 -1 lines
Diff to previous 1.13 (colored)

Add ALTERNATIVES to prepare renamed `pybabel' tool.

Revision 1.13 / (download) - annotate - [select for diffs], Thu Apr 17 12:29:48 2014 UTC (8 years, 11 months ago) by rodent
Branch: MAIN
Changes since 1.12: +9 -2 lines
Diff to previous 1.12 (colored)

Move pybabel to pybabel-${PYVERSSUFFIX} in post-install to allow
installation with multiple python versions. Bump PKGREVISION.

Revision 1.12 / (download) - annotate - [select for diffs], Sat Jan 25 10:30:02 2014 UTC (9 years, 1 month ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.11: +1 -3 lines
Diff to previous 1.11 (colored)

Mark packages as not ready for python-3.x where applicable;
either because they themselves are not ready or because a
dependency isn't. This is annotated by
PYTHON_VERSIONS_INCOMPATIBLE=  33 # not yet ported as of x.y.z
or
PYTHON_VERSIONS_INCOMPATIBLE=  33 # py-foo, py-bar
respectively, please use the same style for other packages,
and check during updates.

Use versioned_dependencies.mk where applicable.
Use REPLACE_PYTHON instead of handcoded alternatives, where applicable.
Reorder Makefile sections into standard order, where applicable.

Remove PYTHON_VERSIONS_INCLUDE_3X lines since that will be default
with the next commit.

Whitespace cleanups and other nits corrected, where necessary.

Revision 1.11 / (download) - annotate - [select for diffs], Sun Jan 12 09:45:24 2014 UTC (9 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.10: +1 -3 lines
Diff to previous 1.10 (colored)

PYTHON_VERSIONS_INCOMPATIBLE cleanup.

Revision 1.10 / (download) - annotate - [select for diffs], Fri Oct 11 14:25:24 2013 UTC (9 years, 5 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4
Changes since 1.9: +2 -1 lines
Diff to previous 1.9 (colored)

some failure with Python32

Revision 1.9 / (download) - annotate - [select for diffs], Fri Oct 11 12:09:59 2013 UTC (9 years, 5 months ago) by obache
Branch: MAIN
Changes since 1.8: +6 -4 lines
Diff to previous 1.8 (colored)

Update Babel to 1.3.

Babel Changelog
===============

Version 1.3
-----------

(bugfix release, released on July 29th 2013)

- Fixed a bug in likely-subtag resolving for some common locales.
  This primarily makes ``zh_CN`` work again which was broken
  due to how it was defined in the likely subtags combined with
  our broken resolving.  This fixes #37.
- Fixed a bug that caused pybabel to break when writing to stdout
  on Python 3.
- Removed a stray print that was causing issues when writing to
  stdout for message catalogs.

Version 1.2
-----------

(bugfix release, released on July 27th 2013)

- Included all tests in the tarball.  Previously the include
  skipped past recursive folders.
- Changed how tests are invoked and added separate standalone
  test command.  This simplifies testing of the package for
  linux distributors.

Version 1.1
-----------

(bugfix release, released on July 27th 2013)

- added dummy version requirements for pytz so that it installs
  on pip 1.4.
- Included tests in the tarball.

Version 1.0
-----------

(Released on July 26th 2013, codename Revival)

- support python 2.6, 2.7, 3.3+ and pypy - drop all other versions
- use tox for testing on different pythons
- Added support for the locale plural rules defined by the CLDR.
- Added `format_timedelta` function to support localized formatting of
  relative times with strings such as "2 days" or "1 month" (ticket #126).
- Fixed negative offset handling of Catalog._set_mime_headers (ticket #165).
- Fixed the case where messages containing square brackets would break with
  an unpack error.
- updated to CLDR 23
- Make the CLDR import script work with Python 2.7.
- Fix various typos.
- Sort output of list-locales.
- Make the POT-Creation-Date of the catalog being updated equal to
  POT-Creation-Date of the template used to update (ticket #148).
- Use a more explicit error message if no option or argument (command) is
  passed to pybabel (ticket #81).
- Keep the PO-Revision-Date if it is not the default value (ticket #148).
- Make --no-wrap work by reworking --width's default and mimic xgettext's
  behaviour of always wrapping comments (ticket #145).
- Add --project and --version options for commandline (ticket #173).
- Add a __ne__() method to the Local class.
- Explicitly sort instead of using sorted() and don't assume ordering
  (Jython compatibility).
- Removed ValueError raising for string formatting message checkers if the
  string does not contain any string formattings (ticket #150).
- Fix Serbian plural forms (ticket #213).
- Small speed improvement in format_date() (ticket #216).
- Fix so frontend.CommandLineInterface.run does not accumulate logging
  handlers (#227, reported with initial patch by dfraser)
- Fix exception if environment contains an invalid locale setting (#200)
- use cPickle instead of pickle for better performance (#225)
- Only use bankers round algorithm as a tie breaker if there are two nearest
  numbers, round as usual if there is only one nearest number (#267, patch by
  Martin)
- Allow disabling cache behaviour in LazyProxy (#208, initial patch from Pedro
  Algarvio)
- Support for context-aware methods during message extraction (#229, patch
  from David Rios)
- "init" and "update" commands support "--no-wrap" option (#289)
- fix formatting of fraction in format_decimal() if the input value is a float
  with more than 7 significant digits (#183)
- fix format_date() with datetime parameter (#282, patch from Xavier Morel)
- fix format_decimal() with small Decimal values (#214, patch from George Lund)
- fix handling of messages containing '\\n' (#198)
- handle irregular multi-line msgstr (no "" as first line) gracefully (#171)
- parse_decimal() now returns Decimals not floats, API change (#178)
- no warnings when running setup.py without installed setuptools (#262)
- modified Locale.__eq__ method so Locales are only equal if all of their
  attributes (language, territory, script, variant) are equal
- resort to hard-coded message extractors/checkers if pkg_resources is
  installed but no egg-info was found (#230)
- format_time() and format_datetime() now accept also floats (#242)
- add babel.support.NullTranslations class similar to gettext.NullTranslations
  but with all of Babel's new gettext methods (#277)
- "init" and "update" commands support "--width" option (#284)
- fix 'input_dirs' option for setuptools integration (#232, initial patch by
  tienne Bersac)
- ensure .mo file header contains the same information as the source .po file
  (#199)
- added support for get_language_name() on the locale objects.
- added support for get_territory_name() on the locale objects.
- added support for get_script_name() on the locale objects.
- added pluralization support for currency names and added a '¤¤¤'
  pattern for currencies that includes the full name.
- depend on pytz now and wrap it nicer.  This gives us improved support
  for things like timezone transitions and an overall nicer API.
- Added support for explicit charset to PO file reading.
- Added experimental Python 3 support.
- Added better support for returning timezone names.
- Don't throw away a Catalog's obsolete messages when updating it.
- Added basic likelySubtag resolving when doing locale parsing and no
  match can be found.

Revision 1.8 / (download) - annotate - [select for diffs], Wed Oct 31 11:19:28 2012 UTC (10 years, 4 months ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.7: +1 -3 lines
Diff to previous 1.7 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.7 / (download) - annotate - [select for diffs], Fri Oct 7 10:59:02 2011 UTC (11 years, 5 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

Update py-babel to 0.9.6.

Version 0.9.6
http://svn.edgewall.org/repos/babel/tags/0.9.6/
(Mar 17 2011, from branches/stable/0.9.x)

 * Backport r493-494: documentation typo fixes.
 * Make the CLDR import script work with Python 2.7.
 * Fix various typos.
 * Fixed Python 2.3 compatibility (ticket #146, #233).
 * Sort output of list-locales.
 * Make the POT-Creation-Date of the catalog being updated equal to
   POT-Creation-Date of the template used to update (ticket #148).
 * Use a more explicit error message if no option or argument (command) is
   passed to pybabel (ticket #81).
 * Keep the PO-Revision-Date if it is not the default value (ticket #148).
 * Make --no-wrap work by reworking --width's default and mimic xgettext's
   behaviour of always wrapping comments (ticket #145).
 * Fixed negative offset handling of Catalog._set_mime_headers (ticket #165).
 * Add --project and --version options for commandline (ticket #173).
 * Add a __ne__() method to the Local class.
 * Explicitly sort instead of using sorted() and don't assume ordering
   (Python 2.3 and Jython compatibility).
 * Removed ValueError raising for string formatting message checkers if the
   string does not contain any string formattings (ticket #150).
 * Fix Serbian plural forms (ticket #213).
 * Small speed improvement in format_date() (ticket #216).
 * Fix number formatting for locales where CLDR specifies alt or draft
   items (ticket #217)
 * Fix bad check in format_time (ticket #257, reported with patch and tests by
   jomae)
 * Fix so frontend.CommandLineInterface.run does not accumulate logging
   handlers (#227, reported with initial patch by dfraser)
 * Fix exception if environment contains an invalid locale setting (#200)

Revision 1.6 / (download) - annotate - [select for diffs], Wed Apr 21 06:01:51 2010 UTC (12 years, 11 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

Update py-babel to 0.9.5.

Version 0.9.5
http://svn.edgewall.org/repos/babel/tags/0.9.5/
(Apr 6 2010, from branches/stable/0.9.x)

 * Fixed the case where messages containing square brackets would break with
   an unpack error.
 * Backport of r467: Fuzzy matching regarding plurals should *NOT* be checked
   against len(message.id)  because this is always 2, instead, it's should be
   checked against catalog.num_plurals (ticket #212).

Revision 1.5 / (download) - annotate - [select for diffs], Tue May 19 08:59:11 2009 UTC (13 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2
Changes since 1.4: +1 -2 lines
Diff to previous 1.4 (colored)

Use standard location for LICENSE line (in MAINTAINER/HOMEPAGE/COMMENT
block). Uncomment some commented out LICENSE lines while here.

Revision 1.4 / (download) - annotate - [select for diffs], Tue May 12 13:27:55 2009 UTC (13 years, 10 months ago) by obache
Branch: MAIN
Changes since 1.3: +3 -1 lines
Diff to previous 1.3 (colored)

set LICENSE.

Revision 1.3 / (download) - annotate - [select for diffs], Thu Oct 23 06:10:30 2008 UTC (14 years, 5 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

Update Babel to 0.9.4.

Version 0.9.4
http://svn.edgewall.org/repos/babel/tags/0.9.4/
(Aug 25 2008, from branches/stable/0.9.x)

 * Currency symbol definitions that is defined with choice patterns in the
   CLDR data are no longer imported, so the symbol code will be used instead.
 * Fixed quarter support in date formatting.
 * Fixed a serious memory leak that was introduces by the support for CLDR
   aliases in 0.9.3 (ticket #128).
 * Locale modifiers such as "@euro" are now stripped from locale identifiers
   when parsing (ticket #136).
 * The system locales "C" and "POSIX" are now treated as aliases for
   "en_US_POSIX", for which the CLDR provides the appropriate data. Thanks to
   Manlio Perillo for the suggestion.
 * Fixed JavaScript extraction for regular expression literals (ticket #138)
   and concatenated strings.
 * The `Translation` class in `babel.support` can now manage catalogs with
   different message domains, and exposes the family of `d*gettext` functions
   (ticket #137).

Revision 1.2 / (download) - annotate - [select for diffs], Fri Sep 12 05:32:37 2008 UTC (14 years, 6 months ago) by epg
Branch: MAIN
CVS Tags: pkgsrc-2008Q3-base, pkgsrc-2008Q3, cube-native-xorg-base, cube-native-xorg
Changes since 1.1: +1 -2 lines
Diff to previous 1.1 (colored)

Default EGG_NAME to ${DISTNAME} in egg.mk and drop EGG_NAME from packages that
set it to ${DISTNAME}.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Fri Aug 1 08:35:40 2008 UTC (14 years, 7 months ago) by obache
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Import Babel-0.9.3 as devel/py-babel.

Babel is a Python library that provides an integrated collection of
utilities that assist with internationalizing and localizing Python
applications (in particular web-based applications.)

Revision 1.1 / (download) - annotate - [select for diffs], Fri Aug 1 08:35:40 2008 UTC (14 years, 7 months ago) by obache
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>