The NetBSD Project

CVS log for pkgsrc/devel/py-attrs/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-attrs

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.28: download - view: text, markup, annotated - select for diffs
Wed Aug 7 20:12:10 2024 UTC (3 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, HEAD
Diff to: previous 1.27: preferred, colored
Changes since revision 1.27: +2 -2 lines
py-attrs: updated to 24.2.0

24.2.0

Deprecations

- Given the amount of warnings raised in the broader ecosystem, we've decided to only soft-deprecate the *hash* argument to `@define` / `@attr.s`.
 Please don't use it in new code, but we don't intend to remove it anymore.

Changes

- `attrs.converters.pipe()` (and its syntactic sugar of passing a list for `attrs.field()`'s / `attr.ib()`'s *converter* argument) works again when passing `attrs.setters.convert` to *on_setattr* (which is default for `attrs.define`).
- Restored support for PEP [649](https://peps.python.org/pep-0649/) / [749](https://peps.python.org/pep-0749/)-implementing Pythons -- currently 3.14-dev.

Revision 1.27: download - view: text, markup, annotated - select for diffs
Sun Aug 4 06:40:25 2024 UTC (3 months, 1 week ago) by adam
Branches: MAIN
Diff to: previous 1.26: preferred, colored
Changes since revision 1.26: +7 -7 lines
py-attrs: updated to 24.1.0

24.1.0

Backwards-incompatible Changes

- `attrs.evolve()` doesn't accept the *inst* argument as a keyword argument anymore.
  Pass it as the first positional argument instead.
- `attrs.validators.provides()` has been removed.
  The removed code is available as a [gist](https://gist.github.com/hynek/9eaaaeb659808f3519870dfa16d2b6b2) for convenient copy and pasting.
- All packaging metadata except from `__version__` and `__version_info__` has been removed from the `attr` and `attrs` modules (for example, `attrs.__url__`).

  Please use [`importlib.metadata`](https://docs.python.org/3/library/importlib.metadata.html) or [*importlib_metadata*](https://pypi.org/project/importlib-metadata/) instead.
- Speed up the generated `__eq__` methods significantly by generating a chain of attribute comparisons instead of constructing and comparing tuples.
  This change arguably makes the behavior more correct,
  but changes it if an attribute compares equal by identity but not value, like `float('nan')`.

Deprecations

- The *repr_ns* argument to `attr.s` is now deprecated.
  It was a workaround for nested classes in Python 2 and is pointless in Python 3.
- The *hash* argument to `@attr.s`, `@attrs.define`, and `make_class()` is now deprecated in favor of *unsafe_hash*, as defined by PEP 681.

Changes

- Allow original slotted `functools.cached_property` classes to be cleaned by garbage collection.
  Allow `super()` calls in slotted cached properties.
- Our type stubs now use modern type notation and are organized such that VS Code's quick-fix prefers the `attrs` namespace.
- Preserve `AttributeError` raised by properties of slotted classes with `functools.cached_properties`.
- It is now possible to wrap a converter into an `attrs.Converter` and get the current instance and/or the current field definition passed into the converter callable.

  Note that this is not supported by any type checker, yet.
- `attrs.make_class()` now populates the `__annotations__` dict of the generated class, so that `attrs.resolve_types()` can resolve them.
- Added the `attrs.validators.or_()` validator.
- The combination of a `__attrs_pre_init__` that takes arguments, a kw-only field, and a default on that field does not crash anymore.
- `attrs.validators.in_()` now transforms certain unhashable options to tuples to keep the field hashable.

  This allows fields that use this validator to be used with, for example, `attrs.filters.include()`.
- If a class has an *inherited* method called `__attrs_init_subclass__`, it is now called once the class is done assembling.

  This is a replacement for Python's `__init_subclass__` and useful for registering classes, and similar.

Revision 1.26: download - view: text, markup, annotated - select for diffs
Sun Dec 31 08:01:32 2023 UTC (10 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1
Diff to: previous 1.25: preferred, colored
Changes since revision 1.25: +5 -10 lines
py-attrs: updated to 23.2.0

23.2.0

Changes

- The type annotation for `attrs.resolve_types()` is now correct.
- Type stubs now use `typing.dataclass_transform` to decorate dataclass-like decorators, instead of the non-standard `__dataclass_transform__` special form, which is only supported by Pyright.
- Fixed serialization of namedtuple fields using `attrs.asdict/astuple()` with `retain_collection_types=True`.
- `attrs.AttrsInstance` is now a `typing.Protocol` in both type hints and code.
  This allows you to subclass it along with another `Protocol`.
- If *attrs* detects that `__attrs_pre_init__` accepts more than just `self`, it will call it with the same arguments as `__init__` was called.
  This allows you to, for example, pass arguments to `super().__init__()`.
- Slotted classes now transform `functools.cached_property` decorated methods to support equivalent semantics.
- Added *class_body* argument to `attrs.make_class()` to provide additional attributes for newly created classes.
  It is, for example, now possible to attach methods.

Revision 1.25: download - view: text, markup, annotated - select for diffs
Sat Oct 28 19:56:57 2023 UTC (12 months, 2 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.24: preferred, colored
Changes since revision 1.24: +2 -1 lines
python/wheel.mk: simplify a lot, and switch to 'installer' for installation

This follows the recommended bootstrap method (flit_core, build, installer).

However, installer installs different files than pip, so update PLISTs
for all packages using wheel.mk and bump their PKGREVISIONs.

Revision 1.24: download - view: text, markup, annotated - select for diffs
Sun Jul 30 15:32:48 2023 UTC (15 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3
Diff to: previous 1.23: preferred, colored
Changes since revision 1.23: +1 -6 lines
Remove dependencies for Python 3.7

Revision 1.23: download - view: text, markup, annotated - select for diffs
Sun Jun 18 05:39:37 2023 UTC (16 months, 3 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.22: preferred, colored
Changes since revision 1.22: +2 -2 lines
py-ZopeInterface: moved to py-zope.interface

Revision 1.22: download - view: text, markup, annotated - select for diffs
Sun Apr 30 13:14:49 2023 UTC (18 months, 1 week ago) by wiz
Branches: MAIN
Diff to: previous 1.21: preferred, colored
Changes since revision 1.21: +26 -15 lines
py-attrs: update to 23.1.0.

##  - 2023-04-16

### Backwards-incompatible Changes

- Python 3.6 has been dropped and packaging switched to static package data using .



### Deprecations

- The support for *zope-interface* via the `attrs.validators.provides` validator is now deprecated and will be removed in, or after, April 2024.

  The presence of a C-based package in our developement dependencies has caused headaches and we're not under the impression it's used a lot.

  Let us know if you're using it and we might publish it as a separate package.



### Changes

- `attrs.filters.exclude()` and `attrs.filters.include()` now support the passing of attribute names as strings.

- `attrs.has()` and `attrs.fields()` now handle generic classes correctly.

- Fix frozen exception classes when raised within e.g. `contextlib.contextmanager`, which mutates their `__traceback__` attributes.

- `@frozen` now works with type checkers that implement .

- Restored ability to unpickle instances pickled before 22.2.0.

- `attrs.asdict()`'s and `attrs.astuple()`'s type stubs now accept the `attrs.AttrsInstance` protocol.

- Fix slots class cellvar updating closure in CPython 3.8+ even when `__code__` introspection is unavailable.

- `attrs.resolve_types()` can now pass `include_extras` to `typing.get_type_hints()` on Python 3.9+, and does so by default.

- Added instructions for pull request workflow to `CONTRIBUTING.md`.

- Added *type* parameter to `attrs.field()` function for use with `attrs.make_class()`.

  Please note that type checkers ignore type metadata passed into `make_class()`, but it can be useful if you're wrapping _attrs_.

- It is now possible for `attrs.evolve()` (and `attr.evolve()`) to change fields named `inst` if the instance is passed as a positional argument.

  Passing the instance using the `inst` keyword argument is now deprecated and will be removed in, or after, April 2024.

- `attrs.validators.optional()` now also accepts a tuple of validators (in addition to lists of validators).



##  - 2022-12-21

### Backwards-incompatible Changes

- Python 3.5 is not supported anymore.



### Deprecations

- Python 3.6 is now deprecated and support will be removed in the next release.



### Changes

- `attrs.field()` now supports an *alias* option for explicit `__init__` argument names.

  Get `__init__` signatures matching any taste, peculiar or plain!
  The  *alias* option can be use to override private attribute name mangling, or add other arbitrary field argument name overrides.

- `attrs.NOTHING` is now an enum value, making it possible to use with e.g. .

- Added missing re-import of `attr.AttrsInstance` to the `attrs` namespace.

- Fix slight performance regression in classes with custom `__setattr__` and speedup even more.

- Class-creation performance improvements by switching performance-sensitive templating operations to f-strings.

  You can expect an improvement of about 5% -- even for very simple classes.

- `attrs.has()` is now a  for `AttrsInstance`.
  That means that type checkers know a class is an instance of an `attrs` class if you check it using `attrs.has()` (or `attr.has()`) first.

- Made `attrs.AttrsInstance` stub available at runtime and fixed type errors related to the usage of `attrs.AttrsInstance` in *Pyright*.

- On Python 3.10 and later, call  on dict classes after creation.
  This improves the detection of abstractness.

- *attrs*'s pickling methods now use dicts instead of tuples.
  That is safer and more robust across different versions of a class.

- Added `attrs.validators.not_(wrapped_validator)` to logically invert *wrapped_validator* by accepting only values where *wrapped_validator* rejects the value with a `ValueError` or `TypeError` (by default, exception types configurable).

- The type stubs for `attrs.cmp_using()` now have default values.

- To conform with ` now accept *unsafe_hash* in addition to *hash*.



##  - 2022-07-28

### Backwards-incompatible Changes

- Python 2.7 is not supported anymore.

  Dealing with Python 2.7 tooling has become too difficult for a volunteer-run project.

  We have supported Python 2 more than 2 years after it was officially discontinued and feel that we have paid our dues.
  All version up to 21.4.0 from December 2021 remain fully functional, of course.


- The deprecated `cmp` attribute of `attrs.Attribute` has been removed.
  This does not affect the *cmp* argument to `attr.s` that can be used as a shortcut to set *eq* and *order* at the same time.



### Changes

- Instantiation of frozen slotted classes is now faster.

- If an `eq` key is defined, it is also used before hashing the attribute.

- Added `attrs.validators.min_len()`.

- `attrs.validators.deep_iterable()`'s *member_validator* argument now also accepts a list of validators and wraps them in an `attrs.validators.and_()`.

- Added missing type stub re-imports for `attrs.converters` and `attrs.filters`.

- Added missing stub for `attr(s).cmp_using()`.

- `attrs.validators._in()`'s `ValueError` is not missing the attribute, expected options, and the value it got anymore.

- Python 3.11 is now officially supported.

Revision 1.21: download - view: text, markup, annotated - select for diffs
Sun Apr 30 12:12:52 2023 UTC (18 months, 1 week ago) by wiz
Branches: MAIN
Diff to: previous 1.20: preferred, colored
Changes since revision 1.20: +6 -2 lines
py-attrs: add test status, comment out test dependency

py-ZopeInterface will shortly stop supporting python 2.x, and it's an
optional here.

Revision 1.20: download - view: text, markup, annotated - select for diffs
Wed Aug 24 09:25:55 2022 UTC (2 years, 2 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3
Diff to: previous 1.19: preferred, colored
Changes since revision 1.19: +3 -3 lines
*: use coverage from versioned_dependencies.mk

Revision 1.19: download - view: text, markup, annotated - select for diffs
Wed Feb 23 11:43:41 2022 UTC (2 years, 8 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +3 -4 lines
py-attrs: updated to 21.4.0

21.4.0 (2021-12-29)
-------------------

Changes
^^^^^^^

- Fixed the test suite on PyPy3.8 where ``cloudpickle`` does not work.
- Fixed ``coverage report`` for projects that use ``attrs`` and don't set a ``--source``.


----


21.3.0 (2021-12-28)
-------------------

Backward-incompatible Changes
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

- When using ``@define``, converters are now run by default when setting an attribute on an instance -- additionally to validators.
  I.e. the new default is ``on_setattr=[attrs.setters.convert, attrs.setters.validate]``.

  This is unfortunately a breaking change, but it was an oversight, impossible to raise a ``DeprecationWarning`` about, and it's better to fix it now while the APIs are very fresh with few users.
- ``import attrs`` has finally landed!
  As of this release, you can finally import ``attrs`` using its proper name.

  Not all names from the ``attr`` namespace have been transferred; most notably ``attr.s`` and ``attr.ib`` are missing.
  See ``attrs.define`` and ``attrs.field`` if you haven't seen our next-generation APIs yet.
  A more elaborate explanation can be found `On The Core API Names <https://www.attrs.org/en/latest/names.html>`_

  This feature is at least for one release **provisional**.
  We don't *plan* on changing anything, but such a big change is unlikely to go perfectly on the first strike.

  The API docs have been mostly updated, but it will be an ongoing effort to change everything to the new APIs.
  Please note that we have **not** moved -- or even removed -- anything from ``attr``!

  Please do report any bugs or documentation inconsistencies!


Changes
^^^^^^^

- ``attr.asdict(retain_collection_types=False)`` (default) dumps collection-esque keys as tuples.
- ``__match_args__`` are now generated to support Python 3.10's
  `Structural Pattern Matching <https://docs.python.org/3.10/whatsnew/3.10.html#pep-634-structural-pattern-matching>`_.
  This can be controlled by the ``match_args`` argument to the class decorators on Python 3.10 and later.
  On older versions, it is never added and the argument is ignored.
- If the class-level *on_setattr* is set to ``attrs.setters.validate`` (default in ``@define`` and ``@mutable``) but no field defines a validator, pretend that it's not set.
- The generated ``__repr__`` is significantly faster on Pythons with f-strings.
- Attributes transformed via ``field_transformer`` are wrapped with ``AttrsClass`` again.
- Generated source code is now cached more efficiently for identical classes.
- Added ``attrs.converters.to_bool()``.
- ``attrs.resolve_types()`` now resolves types of subclasses after the parents are resolved.
- Added new validators: ``lt(val)`` (< val), ``le(va)`` (≤ val), ``ge(val)`` (≥ val), ``gt(val)`` (> val), and ``maxlen(n)``.
- ``attrs`` classes are now fully compatible with `cloudpickle <https://github.com/cloudpipe/cloudpickle>`_ (no need to disable ``repr`` anymore).
- Added new context manager ``attrs.validators.disabled()`` and functions ``attrs.validators.(set|get)_disabled()``.
  They deprecate ``attrs.(set|get)_run_validators()``.
  All functions are interoperable and modify the same internal state.
  They are not – and never were – thread-safe, though.
- ``attrs.validators.matches_re()`` now accepts pre-compiled regular expressions in addition to pattern strings.



21.2.0 (2021-05-07)
-------------------

Backward-incompatible Changes
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

- We had to revert the recursive feature for ``attr.evolve()`` because it broke some use-cases -- sorry!
- Python 3.4 is now blocked using packaging metadata because ``attrs`` can't be imported on it anymore.
  To ensure that 3.4 users can keep installing  ``attrs`` easily, we will `yank <https://pypi.org/help/#yanked>`_ 21.1.0 from PyPI.
  This has **no** consequences if you pin ``attrs`` to 21.1.0.



21.1.0 (2021-05-06)
-------------------

Deprecations
^^^^^^^^^^^^

- The long-awaited, much-talked-about, little-delivered ``import attrs`` is finally upon us!

  Since the NG APIs have now been proclaimed stable, the **next** release of ``attrs`` will allow you to actually ``import attrs``.
  We're taking this opportunity to replace some defaults in our APIs that made sense in 2015, but don't in 2021.

  So please, if you have any pet peeves about defaults in ``attrs``'s APIs, *now* is the time to air your grievances in 487!
  We're not gonna get such a chance for a second time, without breaking our backward-compatibility guarantees, or long deprecation cycles.
  Therefore, speak now or forever hold you peace!
- The *cmp* argument to ``attr.s()`` and `attr.ib()` has been **undeprecated**
  It will continue to be supported as syntactic sugar to set *eq* and *order* in one go.

  I'm terribly sorry for the hassle around this argument!
  The reason we're bringing it back is it's usefulness regarding customization of equality/ordering.

  The ``cmp`` attribute and argument on ``attr.Attribute`` remains deprecated and will be removed later this year.


Changes
^^^^^^^

- It's now possible to customize the behavior of ``eq`` and ``order`` by passing in a callable.
- The instant favorite next-generation APIs are not provisional anymore!

  They are also officially supported by Mypy as of their `0.800 release <https://mypy-lang.blogspot.com/2021/01/mypy-0800-released.html>`_.

  We hope the next release will already contain an (additional) importable package called ``attrs``.
- If an attribute defines a converter, the type of its parameter is used as type annotation for its corresponding ``__init__`` parameter.

  If an ``attr.converters.pipe`` is used, the first one's is used.
- Fixed the creation of an extra slot for an ``attr.ib`` when the parent class already has a slot with the same name.
- ``__attrs__init__()`` will now be injected if ``init=False``, or if ``auto_detect=True`` and a user-defined ``__init__()`` exists.

  This enables users to do "pre-init" work in their ``__init__()`` (such as ``super().__init__()``).

  ``__init__()`` can then delegate constructor argument processing to ``self.__attrs_init__(*args, **kwargs)``.
- ``bool(attr.NOTHING)`` is now ``False``.
- It's now possible to use ``super()`` inside of properties of slotted classes.
- Allow for a ``__attrs_pre_init__()`` method that -- if defined -- will get called at the beginning of the ``attrs``-generated ``__init__()`` method.
- Added forgotten ``attr.Attribute.evolve()`` to type stubs.
- ``attrs.evolve()`` now works recursively with nested ``attrs`` classes.
- Python 3.10 is now officially supported.
- ``attr.resolve_types()`` now takes an optional *attrib* argument to work inside a ``field_transformer``.
- ``ClassVar``\ s are now also detected if they come from `typing-extensions <https://pypi.org/project/typing-extensions/>`_.
- To make it easier to customize attribute comparison, we have added the ``attr.cmp_with()`` helper.

  See the `new docs on comparison <https://www.attrs.org/en/stable/comparison.html>`_ for more details.
- Added **provisional** support for static typing in ``pyright`` via the `dataclass_transforms specification <https://github.com/microsoft/pyright/blob/main/specs/dataclass_transforms.md>`_.
  Both the ``pyright`` specification and ``attrs`` implementation may change in future versions of both projects.

Revision 1.18: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:52:51 2022 UTC (2 years, 10 months ago) by wiz
Branches: MAIN
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +2 -1 lines
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.17: download - view: text, markup, annotated - select for diffs
Tue Oct 6 10:51:21 2020 UTC (4 years, 1 month ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +2 -2 lines
*: use py-hypothesis via versioned_dependencies.mk

Revision 1.16: download - view: text, markup, annotated - select for diffs
Sat May 16 09:03:22 2020 UTC (4 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +2 -2 lines
fix pytest versioned dep.

Revision 1.15: download - view: text, markup, annotated - select for diffs
Sat May 16 08:51:29 2020 UTC (4 years, 5 months ago) by adam
Branches: MAIN
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +4 -2 lines
py-attrs: pytest from versioned depends

Revision 1.14: download - view: text, markup, annotated - select for diffs
Tue Oct 15 07:53:35 2019 UTC (5 years ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +2 -2 lines
py-attrs: updated to 19.3.0

19.3.0:
Changes
- Fixed ``auto_attribs`` usage when default values cannot be compared directly with ``==``, such as ``numpy`` arrays.

Revision 1.13: download - view: text, markup, annotated - select for diffs
Mon Oct 7 20:25:01 2019 UTC (5 years, 1 month ago) by adam
Branches: MAIN
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -2 lines
py-attrs: updated to 19.2.0

19.2.0:

Backward-incompatible Changes
- Removed deprecated ``Attribute`` attribute ``convert`` per scheduled removal on 2019/1.
- ``__lt__``, ``__le__``, ``__gt__``, and ``__ge__`` do not consider subclasses comparable anymore.

  This has been deprecated since 18.2.0 and was raising a ``DeprecationWarning`` for over a year.


Deprecations
- The ``cmp`` argument to ``attr.s()`` and ``attr.ib()`` is now deprecated.

  Please use ``eq`` to add equality methods (``__eq__`` and ``__ne__``) and ``order`` to add ordering methods (``__lt__``, ``__le__``, ``__gt__``, and ``__ge__``) instead – just like with `dataclasses <https://docs.python.org/3/library/dataclasses.html>`_.

  Both are effectively ``True`` by default but it's enough to set ``eq=False`` to disable both at once.
  Passing ``eq=False, order=True`` explicitly will raise a ``ValueError`` though.

  Since this is arguably a deeper backward-compatibility break, it will have an extended deprecation period until 2021-06-01.
  After that day, the ``cmp`` argument will be removed.

  ``attr.Attribute`` also isn't orderable anymore.

Changes
- Updated ``attr.validators.__all__`` to include new validators.
- Slotted classes now use a pure Python mechanism to rewrite the ``__class__`` cell when rebuilding the class, so ``super()`` works even on environments where ``ctypes`` is not installed.
- When collecting attributes using ``@attr.s(auto_attribs=True)``, attributes with a default of ``None`` are now deleted too.
- Fixed ``attr.validators.deep_iterable()`` and ``attr.validators.deep_mapping()`` type stubs.
- ``attr.validators.is_callable()`` validator now raises an exception ``attr.exceptions.NotCallableError``, a subclass of ``TypeError``, informing the received value.
- ``@attr.s(auto_exc=True)`` now generates classes that are hashable by ID, as the documentation always claimed it would.
- Added ``attr.validators.matches_re()`` that checks string attributes whether they match a regular expression.
- Keyword-only attributes (``kw_only=True``) and attributes that are excluded from the ``attrs``'s ``__init__`` (``init=False``) now can appear before mandatory attributes.
- The fake filename for generated methods is now more stable.
  It won't change when you restart the process.
- The value passed to ``@attr.ib(repr=…)`` can now be either a boolean (as before) or a callable.
  That callable must return a string and is then used for formatting the attribute by the generated ``__repr__()`` method.
- Added ``attr.__version_info__`` that can be used to reliably check the version of ``attrs`` and write forward- and backward-compatible code.

Revision 1.12: download - view: text, markup, annotated - select for diffs
Sun Mar 3 12:17:05 2019 UTC (5 years, 8 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -2 lines
py-attrs: updated to 19.1.0

19.1.0:
Backward-incompatible Changes
- Fixed a bug where deserialized objects with cache_hash=True could have incorrect hash code values.
  This change breaks classes with cache_hash=True when a custom __setstate__ is present.
  An exception will be thrown when applying the attrs annotation to such a class.

Changes
- Add is_callable, deep_iterable, and deep_mapping validators.
  * is_callable: validates that a value is callable
  * deep_iterable: Allows recursion down into an iterable,
    applying another validator to every member in the iterable
    as well as applying an optional validator to the iterable itself.
  * deep_mapping: Allows recursion down into the items in a mapping object,
    applying a key validator and a value validator to the key and value in every item.
    Also applies an optional validator to the mapping object itself.
  You can find them in the attr.validators package.
- Fixed stub files to prevent errors raised by mypy's disallow_any_generics = True option.
- Attributes with init=False now can follow after kw_only=True attributes.
- attrs now has first class support for defining exception classes.

  If you define a class using @attr.s(auto_exc=True) and subclass an exception, the class will behave like a well-behaved exception class including an appropriate __str__ method, and all attributes additionally available in an args attribute.
- Clarified documentation for hashing to warn that hashable objects should be deeply immutable (in their usage, even if this is not enforced).

Revision 1.11: download - view: text, markup, annotated - select for diffs
Mon Sep 3 07:40:18 2018 UTC (6 years, 2 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -2 lines
py-attrs: updated to 18.2.0

18.2.0:
Deprecations
Comparing subclasses using <, >, <=, and >= is now deprecated. The docs always claimed that instances are only compared if the types are identical, so this is a first step to conform to the docs.
Equality operators (== and !=) were always strict in this regard.

Changes
attrs now ships its own PEP 484 type hints. Together with mypy’s attrs plugin, you’ve got all you need for writing statically typed code in both Python 2 and 3!
At that occasion, we’ve also added narrative docs about type annotations in attrs.
Added kw_only arguments to attr.ib and attr.s, and a corresponding kw_only attribute to attr.Attribute. This change makes it possible to have a generated __init__ with keyword-only arguments on Python 3, relaxing the required ordering of default and non-default valued attributes.
The test suite now runs with hypothesis.HealthCheck.too_slow disabled to prevent CI breakage on slower computers.
attr.validators.in_() now raises a ValueError with a useful message even if the options are a string and the value is not a string.
attr.asdict() now properly handles deeply nested lists and dictionaries.
Added attr.converters.default_if_none() that allows to replace None values in attributes. For example attr.ib(converter=default_if_none("")) replaces None by empty strings.
Fixed a reference leak where the original class would remain live after being replaced when slots=True is set.
Slotted classes can now be made weakly referenceable by passing @attr.s(weakref_slot=True).
Added cache_hash option to @attr.s which causes the hash code to be computed once and stored on the object.
Attributes can be named property and itemgetter now.
It is now possible to override a base class’ class variable using only class annotations.

Revision 1.10: download - view: text, markup, annotated - select for diffs
Thu May 10 08:24:40 2018 UTC (6 years, 6 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +11 -4 lines
py-attrs: updated to 18.1.0

18.1.0:
- x=X(); x.cycle = x; repr(x) will no longer raise a RecursionError, and will instead show as X(x=...).
- attr.ib(factory=f) is now syntactic sugar for the common case of attr.ib(default=attr.Factory(f)).
- Added attr.field_dict() to return an ordered dictionary of attrs attributes for a class, whose keys are the attribute names.
- The order of attributes that are passed into attr.make_class() or the these argument of @attr.s() is now retained if the dictionary is ordered (i.e. dict on Python 3.6 and later, collections.OrderedDict otherwise).
  Before, the order was always determined by the order in which the attributes have been defined which may not be desirable when creating classes programatically.
- In slotted classes, __getstate__ and __setstate__ now ignore the __weakref__ attribute.
- Setting the cell type is now completely best effort.
  This fixes attrs on Jython.
  We cannot make any guarantees regarding Jython though, because our test suite cannot run due to dependency incompatabilities.
- If attr.s is passed a *these* argument, it will not attempt to remove attributes with the same name from the class body anymore.
- The hash of attr.NOTHING is now vegan and faster on 32bit Python builds.
- The overhead of instantiating frozen dict classes is virtually eliminated.
- Generated __init__ methods now have an __annotations__ attribute derived from the types of the fields.
- We have restructured the documentation a bit to account for attrs' growth in scope.

Revision 1.9: download - view: text, markup, annotated - select for diffs
Mon Jan 1 21:08:46 2018 UTC (6 years, 10 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +4 -4 lines
py-attrs: updated to 17.4.0

17.4.0:

Backward-incompatible Changes
- The traversal of MROs when using multiple inheritance was backward:
  If you defined a class C that subclasses A and B like C(A, B), attrs would have collected the attributes from B *before* those of A.
  This is now fixed and means that in classes that employ multiple inheritance, the output of __repr__ and the order of positional arguments in __init__ changes.
  Due to the nature of this bug, a proper deprecation cycle was unfortunately impossible.
  Generally speaking, it's advisable to prefer kwargs-based initialization anyways – *especially* if you employ multiple inheritance and diamond-shaped hierarchies.
- The __repr__ set by attrs
  no longer produces an AttributeError
  when the instance is missing some of the specified attributes
  (either through deleting
  or after using init=False on some attributes).

  This can break code
  that relied on repr(attr_cls_instance) raising AttributeError
  to check if any attr-specified members were unset.

  If you were using this,
  you can implement a custom method for checking this::

      def has_unset_members(self):
          for field in attr.fields(type(self)):
              try:
                  getattr(self, field.name)
              except AttributeError:
                  return True
          return False

Deprecations
- The attr.ib(convert=callable) option is now deprecated in favor of attr.ib(converter=callable).
  This is done to achieve consistency with other noun-based arguments like *validator*.
  *convert* will keep working until at least January 2019 while raising a DeprecationWarning.

Changes
- Generated __hash__ methods now hash the class type along with the attribute values.
  Until now the hashes of two classes with the same values were identical which was a bug.
  The generated method is also *much* faster now.
- attr.ib\ ’s metadata argument now defaults to a unique empty dict instance instead of sharing a common empty dict for all.
  The singleton empty dict is still enforced.
- ctypes is optional now however if it's missing, a bare super() will not work in slots classes.
  This should only happen in special environments like Google App Engine.
- The attribute redefinition feature introduced in 17.3.0 now takes into account if an attribute is redefined via multiple inheritance.
  In that case, the definition that is closer to the base of the class hierarchy wins.
- Subclasses of auto_attribs=True can be empty now.
- Equality tests are *much* faster now.
- All generated methods now have correct __module__, __name__, and (on Python 3) __qualname__ attributes.

Revision 1.8: download - view: text, markup, annotated - select for diffs
Thu Nov 16 07:57:53 2017 UTC (6 years, 11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -2 lines
py-attrs: updated to 17.3.0

17.3.0:

Backward-incompatible Changes
- Attributes are not defined on the class body anymore.
  This means that if you define a class C with an attribute x, the class will *not* have an attribute x for introspe
ction anymore.
  Instead of C.x, use attr.fields(C).x or look at C.__attrs_attrs__.
  The old behavior has been deprecated since version 16.1.

Changes
- super() and __class__ now work on Python 3 when slots=True.
- Added type argument to attr.ib() and corresponding type attribute to attr.Attribute.

  This change paves the way for automatic type checking and serialization (though as of this release attrs does not make use of it).
  In Python 3.6 or higher, the value of attr.Attribute.type can alternately be set using variable type annotations
- The combination of str=True and slots=True now works on Python 2.
- attr.Factory is hashable again.
- Subclasses now can overwrite attribute definitions of their superclass.

  That means that you can -- for example -- change the default value for an attribute by redefining it.
- Added new option auto_attribs to @attr.s that allows to collect annotated fields without setting them to attr.ib().

  Setting a field to an attr.ib() is still possible to supply options like validators.
  Setting it to any other value is treated like it was passed as attr.ib(default=value) -- passing an instance of attr.Factory also works as expected.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Thu Oct 5 06:49:16 2017 UTC (7 years, 1 month ago) by adam
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +4 -3 lines
Disabled BUILD_DEPENDS: hypothesis now requires attrs

Revision 1.6: download - view: text, markup, annotated - select for diffs
Sun Sep 3 08:36:53 2017 UTC (7 years, 2 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -2 lines
Comment out dead MASTER_SITES/HOMEPAGEs.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Wed May 24 19:41:34 2017 UTC (7 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +5 -3 lines
Changes 17.2.0:
Validators are hashable again. Note that validators may become frozen in the future, pending availability of no-overhead frozen classes.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Sat May 20 06:01:46 2017 UTC (7 years, 5 months ago) by adam
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +3 -3 lines
Changes 17.1.0:
Backward-incompatible changes:
* attrs will set the __hash__() method to None by default now. The way hashes were handled before was in conflict with Python’s specification. This may break some software although this breakage is most likely just surfacing of latent bugs. You can always make attrs create the __hash__() method using @attr.s(hash=True).
* Correspondingly, attr.ib‘s hash argument is None by default too and mirrors the cmp argument as it should.

Deprecations:
* attr.assoc() is now deprecated in favor of attr.evolve() and will stop working in 2018.

Changes:
Fix default hashing behavior. Now hash mirrors the value of cmp and classes are unhashable by default.
Added attr.evolve() that, given an instance of an attrs class and field changes as keyword arguments, will instantiate a copy of the given instance with the changes applied. evolve() replaces assoc(), which is now deprecated. evolve() is significantly faster than assoc(), and requires the class have an initializer that can take the field values as keyword arguments (like attrs itself can generate).
FrozenInstanceError is now raised when trying to delete an attribute from a frozen class.
Frozen-ness of classes is now inherited.
__attrs_post_init__() is now run if validation is disabled.
Added attr.validators.in_(options) that, given the allowed options, checks whether the attribute value is in it. This can be used to check constants, enums, mappings, etc.
Added attr.validators.and_() that composes multiple validators into one.
For convenience, the validator argument of @attr.s now can take a list of validators that are wrapped using and_().
Accordingly, attr.validators.optional() now can take a list of validators too.
Validators can now be defined conveniently inline by using the attribute as a decorator. Check out the examples to see it in action!
attr.Factory() now has a takes_self argument that makes the initializer to pass the partially initialized instance into the factory. In other words you can define attribute defaults based on other attributes.
Default factories can now also be defined inline using decorators. They are always passed the partially initialized instance.
Conversion can now be made optional using attr.converters.optional().
attr.make_class() now accepts the keyword argument bases which allows for subclassing.
Metaclasses are now preserved with slots=True.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Mon Feb 13 18:57:05 2017 UTC (7 years, 8 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -2 lines
Changes 16.3.0:
* Attributes now can have user-defined metadata which greatly improves attrs‘s extensibility.

* Allow for a __attrs_post_init__ method that – if defined – will get called at the end of the attrs-generated __init__ method.

* Add @attr.s(str=True) that will optionally create a __str__ method that is identical to __repr__. This is mainly useful with Exceptions and other classes that rely on a useful __str__ implementation but overwrite the default one through a poor own one. Default Python class behavior is to use __repr__ as __str__ anyways.

If you tried using attrs with Exceptions and were puzzled by the tracebacks: this option is for you.

* Don’t overwrite __name__ with __qualname__ for attr.s(slots=True) classes.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Wed Jun 1 12:30:45 2016 UTC (8 years, 5 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -2 lines
Fix MASTER_SITES.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Thu Apr 14 11:06:27 2016 UTC (8 years, 7 months ago) by leot
Branches: MAIN
Import py-attrs-15.2.0 as devel/py-attrs

attrs is an MIT-licensed Python package with class decorators that ease the
chores of implementing the most common attribute-related object protocols.

You just specify the attributes to work with and attrs gives you:

 * a nice human-readable __repr__,
 * a complete set of comparison methods,
 * an initializer,
 * and much more

without writing dull boilerplate code again and again.

This gives you the power to use actual classes with actual types in your code
instead of confusing tuples or confusingly behaving namedtuples.

So put down that type-less data structures and welcome some class into your
life!

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>