[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-astroid

File: [cvs.NetBSD.org] / pkgsrc / devel / py-astroid / Makefile (download)

Revision 1.41, Fri Apr 16 05:44:05 2021 UTC (2 years, 11 months ago) by adam
Branch: MAIN
Changes since 1.40: +2 -2 lines

py-astroid: updated to 2.5.3

What's New in astroid 2.5.3?
============================
* Takes into account the fact that subscript inferring for a ClassDef may involve __class_getitem__ method
* Reworks the `collections` and `typing` brain so that `pylint`s acceptance tests are fine.
* Use ``inference_tip`` for ``typing.TypedDict`` brain.
* Fix mro for classes that inherit from typing.Generic
* Add inference tip for typing.Generic and typing.Annotated with ``__class_getitem__``

# $NetBSD: Makefile,v 1.41 2021/04/16 05:44:05 adam Exp $

DISTNAME=	astroid-2.5.3
PKGNAME=	${PYPKGPREFIX}-${DISTNAME}
CATEGORIES=	devel python
MASTER_SITES=	${MASTER_SITE_PYPI:=a/astroid/}

MAINTAINER=	kamel.derouiche@gmail.com
HOMEPAGE=	https://github.com/pycqa/astroid
COMMENT=	Rebuild a new abstract syntax tree from Python's ast
LICENSE=	gnu-lgpl-v3

DEPENDS+=	${PYPKGPREFIX}-lazy-object-proxy>=1.4.0:../../devel/py-lazy-object-proxy
DEPENDS+=	${PYPKGPREFIX}-wrapt>=1.11:../../devel/py-wrapt
BUILD_DEPENDS+=	${PYPKGPREFIX}-test-runner-[0-9]*:../../devel/py-test-runner
TEST_DEPENDS+=	${PYPKGPREFIX}-test-[0-9]*:../../devel/py-test

PYTHON_VERSIONS_INCOMPATIBLE=	27

.include "../../lang/python/pyversion.mk"
.if ${_PYTHON_VERSION} < 38
DEPENDS+=	${PYPKGPREFIX}-typed-ast>=1.4.0:../../devel/py-typed-ast
.endif

USE_LANGUAGES=	# none

.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"