The NetBSD Project

CVS log for pkgsrc/devel/py-astor/PLIST

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-astor

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.5 / (download) - annotate - [select for diffs], Mon Dec 16 10:18:54 2019 UTC (3 years, 5 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, HEAD
Changes since 1.4: +2 -1 lines
Diff to previous 1.4 (colored)

py-astor: updated to 0.8.1

0.8.1:
Create sdist before making a test release too

Revision 1.4 / (download) - annotate - [select for diffs], Fri Jul 6 08:09:50 2018 UTC (4 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.3: +2 -4 lines
Diff to previous 1.3 (colored)

py-astor: updated to 0.7.1

0.7.1:
Fix installation error introduced in 0.7.0

0.7:
Add Python 3.7 to classifiers

Revision 1.3 / (download) - annotate - [select for diffs], Thu Nov 23 10:29:03 2017 UTC (5 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4
Changes since 1.2: +4 -1 lines
Diff to previous 1.2 (colored)

py-astor: updated to 0.6.2

0.6.2:
Fix 'make clean' command

Revision 1.2 / (download) - annotate - [select for diffs], Tue Oct 31 12:51:23 2017 UTC (5 years, 7 months ago) by adam
Branch: MAIN
Changes since 1.1: +25 -10 lines
Diff to previous 1.1 (colored)

py-astor: updated to 0.6

0.6:

New features
* New astor.rtrip command-line tool to test round-tripping of Python source to AST and back to source. (Contributed by Patrick Maupin.)
* New pretty printer outputs much better looking code:
  . Remove parentheses where not necessary
  . Use triple-quoted strings where it makes sense
  . Add placeholder for function to do nice line wrapping on output
* Additional Python 3.5 support: - Additional unpacking generalizations (PEP 448)
  .  Async and await (PEP 492)
* Added Python 3.6 feature support:
  . f-strings (PEP 498)
  . async comprehensions (PEP 530)
  . variable annotations (PEP 526)
* Code cleanup, including renaming for PEP8 and deprecation of old names. See :ref:`deprecations` for more information.

Bug fixes
* Don't put trailing comma-spaces in dictionaries. astor will now create {'three': 3} instead of {'three': 3, }.
* Fixed several bugs in code generation.

Revision 1.1 / (download) - annotate - [select for diffs], Sun May 18 03:22:03 2014 UTC (9 years ago) by rodent
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2

Import py27-astor-0.3 as devel/py-astor.

astor is designed to allow easy manipulation of Python source via the AST. There
are some other similar libraries, but astor focuses on the following areas:

 * Round-trip back to Python via Armin Ronacher's codegen.py module:
   ** Modified AST doesn't need linenumbers, ctx, etc. or otherwise be directly
      compileable
   ** Easy to read generated code as, well, code
 * Dump pretty-printing of AST
   ** Harder to read than round-tripped code, but more accurate to figure out
      what is going on.
   ** Easier to read than dump from built-in AST module
 * Non-recursive treewalk
   ** Sometimes you want a recursive treewalk (and astor supports that, starting
      at any node on the tree), but sometimes you don't need to do that. astor
      doesn't require you to explicitly visit sub-nodes unless you want to:
   ** You can add code that executes before a node's children are visited,
      and/or
   ** You can add code that executes after a node's children are visited, and/or
   ** You can add code that executes and keeps the node's children from being
      visited (and optionally visit them yourself via a recursive call)
   ** Write functions to access the tree based on object names and/or attribute
      names
   ** Enjoy easy access to parent node(s) for tree rewriting

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>