The NetBSD Project

CVS log for pkgsrc/devel/py-Pyro/PLIST

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-Pyro

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.8 / (download) - annotate - [select for diffs], Sun Dec 16 14:33:24 2018 UTC (5 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, HEAD
Changes since 1.7: +10 -7 lines
Diff to previous 1.7 (colored)

py-Pyro: updated to 4.74

Pyro 4.74

- serpent 1.27 required to avoid regression in previous version
- fixed marshal serializer problem that prevented it to even call register() in the name server.
  Its dumpsCall is now able to use the class_to_dict conversion for unmarshallable types
  (in simple situations, not recursively).  Previously, you would get a ValueError: unmarshallable object.
- msgpack, json and marshal serializers now understand how to serialize array.array the same way serpent already did


Pyro 4.73

- include LICENSE file in distribution
- avoid decode error when dealing with memoryview annotations


Pyro 4.72

- (source files: normalized line endings to LF)
- the -k command line option to supply a HMAC encryption key on the command line for the name server, nsc,
  echoserver, flameserver and httpgateway tools is now deprecated (and will print a warning if used).
  It is a security issue because the key used is plainly visible.
  If you require proper security, use Pyro's 2-way SSL feature. Alternatively, set the HMAC key in the (new) environment
  variable PYRO_HMAC_KEY if you still have to use it before launching the aforementioned tools.


Pyro 4.71

- updated msgpack dependency (was msgpack-python but that name is now deprecated)
- fixed restart and force reload commands of the contrib/init.d/pyro4-nsd script, and changed its port binding
  from 9999 back to 9090 which is Pyro's default.
- serpent 1.24 library now required to fix some api deprecation warnings when using Python 3.7 or newer.
- updated sphinx documentation theme


Pyro 4.70

- bump to version 4.70 to emphasize the following change:
- incompatible API change for python 3.7 compatibility: renaming of async function and keyword arguments in the API:
  Renamed Pyro4.core.async to Pyro4.core.asyncproxy (and its occurrence in Pyro4)
  and the async keyword argument in some methods to asynchronous.
  This had to be done because async (and await) are now parsed as keywords in Python 3.7 and using them otherwise will result
  in a SyntaxError when loading the module.
  It is suggested you stop using the asyncproxy function and instead create asynchronous proxies using the _pyroAsync
  method on the regular proxy.
- For existing code running on Python *older than 3.7*, a backwards compatibility feature is present to still provide the
  async function and keyword arguments as they were supported on previous Pyro versions.
  But also for that older environments, it's advised to migrate away from them and start using the new names.
- Proxy and Daemon have a new 'connected_socket' parameter. You can set it to a user-supplied connected socket that must
  be used by them instead of creating a new socket for you. Connected sockets can be created using the socket.socketpair()
  function for instance, and allow for easy and efficient communication over an internal socket between
  parent-child processes or threads, using Pyro.  Also see the new 'socketpair' example.
- dropped support for Python 3.3 (which has reached end-of-life status). Supported Python versions are now 2.7, and 3.4 or newer.

Revision 1.7 / (download) - annotate - [select for diffs], Sun Oct 8 10:21:57 2017 UTC (6 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4
Changes since 1.6: +17 -7 lines
Diff to previous 1.6 (colored)

py-Pyro: update to 4.62

Pyro 4.62:
major new feature: SSL/TLS support added - a handful of new config items (ãàÏ´SLãàprefixed), supports server-only certificate and also 2-way-ssl (server+client certificates). For testing purposes, self-signed server and client certificates are available in the ãàÏÄertsãàdirectory. SSL/TLS in Pyro is supported on Python 2.7.11+ or Python 3.4.4+ (these versions have various important security related changes such as disabling vulnerable cyphers or protocols by default)
added SSL example that shows how to configure 2-way-SSL in Pyro and how to do certificate verification on both sides.
added cloudpickle serialization support (https://github.com/cloudpipe/cloudpickle/)
added a small extended-pickle example that shows what dill and cloudpickle can do (send actual functions)
daemon is now more resilient to exceptions occurring with socket communications (it logs them but is otherwise not interrupted) (this was required to avoid errors occurring in the SSL layer stopping the server)
some small bugs fixed (crash when logging certain errors in thread server, invalid protected members showing up on pypy3)
the raise data line in a traceback coming from Pyro now has a comment after it, telling you that you probably should inspect the remote traceback as well.
note: if youãàÑÓe using Python 3 only and are interested in a modernized version of Pyro, have a look at Pyro5: https://github.com/irmen/Pyro5 ItãàÑÔ experimental work in progress, but it works pretty well.
note: Pyro4 is reaching a state where I consider it ãà×Çeature completeãà IãàÑÎ considering not adding more new features but only doing bug-fixes. New features (if any) will then appear only in Pyro5.

Revision 1.6 / (download) - annotate - [select for diffs], Wed Dec 4 16:41:01 2013 UTC (10 years, 4 months ago) by drochner
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4
Changes since 1.5: +10 -3 lines
Diff to previous 1.5 (colored)

update to 4.22
changes:
-added IPv6 support
-added Python3 support
-bugfixes

Revision 1.5 / (download) - annotate - [select for diffs], Fri Feb 17 18:32:57 2012 UTC (12 years, 2 months ago) by drochner
Branch: MAIN
CVS Tags: pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4, pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1
Changes since 1.4: +61 -83 lines
Diff to previous 1.4 (colored)

update to 4.12
This is a complete rewrite.

Revision 1.4 / (download) - annotate - [select for diffs], Sat Oct 15 12:08:38 2011 UTC (12 years, 6 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2011Q4-base, pkgsrc-2011Q4
Changes since 1.3: +2 -1 lines
Diff to previous 1.3 (colored)

* convert PYDISTUTILPKG to regist egg-info.

Bump PKGREVISION.

Revision 1.3 / (download) - annotate - [select for diffs], Sun Jun 14 17:49:04 2009 UTC (14 years, 10 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2
Changes since 1.2: +1 -4 lines
Diff to previous 1.2 (colored)

Remove @dirrm entries from PLISTs

Revision 1.2 / (download) - annotate - [select for diffs], Fri Jan 7 16:17:42 2005 UTC (19 years, 3 months ago) by darcy
Branch: MAIN
CVS Tags: pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, pkgsrc-2008Q1-base, pkgsrc-2008Q1, pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3, pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1, pkgsrc-2006Q4-base, pkgsrc-2006Q4, pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1, pkgsrc-2005Q4-base, pkgsrc-2005Q4, pkgsrc-2005Q3-base, pkgsrc-2005Q3, pkgsrc-2005Q2-base, pkgsrc-2005Q2, pkgsrc-2005Q1-base, pkgsrc-2005Q1, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.1: +11 -11 lines
Diff to previous 1.1 (colored)

Use PYVERSSUFFIX to differentiate between versions built for different
versions of Python and to resolve conflicts with other packages.

Bump PKGREVISION.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Fri Dec 31 10:13:56 2004 UTC (19 years, 3 months ago) by darcy
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Initial import of Pyro from pkgsrc-wip.

Pyro is an acronym for PYthon Remote Objects. It is an advanced and powerful
Distributed Object Technology system written entirely in Python, that is
designed to be very easy to use. It resembles Java's Remote Method
Invocation (RMI). It is less similar to CORBA - which is a system- and
language independent Distributed Object Technology and has much more to
offer than Pyro or RMI. But Pyro is small, simple and free (MIT software
license).

Get the manual from

	http://pyro.sourceforge.net/pyro-manual/PyroManual.html

Check quite impressive success stories on

	http://pyro.sourceforge.net/projects.html

Revision 1.1 / (download) - annotate - [select for diffs], Fri Dec 31 10:13:56 2004 UTC (19 years, 3 months ago) by darcy
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>