The NetBSD Project

CVS log for pkgsrc/devel/protobuf/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / protobuf

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2020Q3


Revision 1.33 / (download) - annotate - [select for diffs], Fri Aug 21 11:29:18 2020 UTC (3 years, 7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.32: +2 -2 lines
Diff to previous 1.32 (colored)

protobuf py-protobuf: updated to 3.13.0

Protocol Buffers v3.13.0

C++

Removed deprecated unsafe arena string accessors
Enabled heterogeneous lookup for std::string keys in maps.
Removed implicit conversion from StringPiece to std::string
Fix use-after-destroy bug when the Map is allocated in the arena.
Improved the randomness of map ordering
Added stack overflow protection for text format with unknown fields
Use std::hash for proto maps to help with portability.
Added more Windows macros to proto whitelist.
Arena constructors for map entry messages are now marked "explicit"
(for regular messages they were already explicit).
Fix subtle aliasing bug in RepeatedField::Add
Fix mismatch between MapEntry ByteSize and Serialize with respect to unset
fields.

Python

JSON format conformance fixes:
Reject lowercase t for Timestamp json format.
Print full_name directly for extensions (no camelCase).
Reject boolean values for integer fields.
Reject NaN, Infinity, -Infinity that is not quoted.
Base64 fixes for bytes fields: accept URL-safe base64 and missing padding.
Bugfix for fields/files named "async" or "await".
Improved the error message when AttributeError is returned from getattr
in EnumTypeWrapper.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>