[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / php-gettext

File: [cvs.NetBSD.org] / pkgsrc / devel / php-gettext / Makefile (download)

Revision 1.12, Sun Sep 2 14:09:56 2012 UTC (11 years, 3 months ago) by marino
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3
Changes since 1.11: +2 -2 lines

devel/php-gettext: Fix break caused by gettext-lib change

php-gettext previously searched the $PREFIX/include, /usr/local/include
and /usr/include for the libintl.h header.  The recent change to
gettext-lib moved the header to $PREFIX/include/gettext broke the
build on platforms that don't have native libintl.

Fix this by changing the search path from $PREFIX/include to
$BUILDLINK_DIR/include and let the buildlink system provide the
header.  The core issue is how the configuration script determines if
gettext is available on the system.

No revbump needed; the same gettext-lib is used as before.

# $NetBSD: Makefile,v 1.12 2012/09/02 14:09:56 marino Exp $

MODNAME=		gettext
CATEGORIES+=		devel
COMMENT=		PHP extension for gettext support

PKG_DESTDIR_SUPPORT=	user-destdir

CONFLICTS=	php-gettext-[0-9]*

CONFIGURE_ARGS+=	--with-gettext=shared,${BUILDLINK_DIR}

.include "../../lang/php/ext.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"