File:  [cvs.NetBSD.org] / pkgsrc / devel / pcre / Makefile
Revision 1.82: download - view: text, annotated - select for diffs
Thu Jan 19 18:52:07 2017 UTC (8 years, 2 months ago) by agc
Branches: MAIN
CVS tags: HEAD
Convert all occurrences (353 by my count) of

	MASTER_SITES= 	site1 \
			site2

style continuation lines to be simple repeated

	MASTER_SITES+= site1
	MASTER_SITES+= site2

lines. As previewed on tech-pkg. With thanks to rillig for fixing pkglint
accordingly.

# $NetBSD: Makefile,v 1.82 2017/01/19 18:52:07 agc Exp $

DISTNAME=	pcre-8.40
CATEGORIES=	devel
MASTER_SITES=	ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/
MASTER_SITES+=	${MASTER_SITE_SOURCEFORGE:=pcre/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.pcre.org/
COMMENT=	Perl Compatible Regular Expressions library
LICENSE=	modified-bsd

USE_LANGUAGES=		c c++
USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--enable-pcre16
CONFIGURE_ARGS+=	--enable-unicode-properties
CONFIGURE_ARGS+=	--enable-utf8

SUBST_CLASSES+=		rpath
SUBST_STAGE.rpath=	pre-configure
SUBST_MESSAGE.rpath=	Fixing rpath output in pcre-config
SUBST_FILES.rpath=	pcre-config.in
SUBST_VARS.rpath=	COMPILER_RPATH_FLAG

PKGCONFIG_OVERRIDE=	libpcre.pc.in libpcrecpp.pc.in libpcreposix.pc.in
PKGCONFIG_OVERRIDE+=	libpcre16.pc.in

# needs a stacksize of 5.5mb, default is 2mb
TEST_TARGET=		test

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>