[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / p5-Test-Inline

File: [cvs.NetBSD.org] / pkgsrc / devel / p5-Test-Inline / Makefile (download)

Revision 1.9, Fri Jun 24 20:31:04 2005 UTC (18 years, 9 months ago) by wiz
Branch: MAIN
Changes since 1.8: +11 -5 lines

Update to 2.002 (replacing old branch that ended with 0.16):

2.002   Sat Jun 11 2005
	- The Test::Builder interface changes, breaking the test counts.
	- This change makes them work again

2.001   Sat Jun 11 2005
	- After determining Test::Inline 1 doesn't actually USE
	  the Test::Inline namespace, decided Schwern can just sod off
	  and I'm moving to production now.
	- Old users should not be effected if they specifically install
	  the module 'Pod::Test'

2.00_10 Sat Jun 11 2005
	- Making sure =begin testing SETUP behaves completely like the
	  previous =begin test setup sections

2.00_09 Fri Jun 10 2005
	- Adding Test::Inline::Handler::File::VCS to support automatically
	  adding output scripts to version control system, if they have one.
	- Added a --vcs flag to inline2test to use Test::Inline::Handler::File::VCS
	- Converted testing from =begin test setup to =begin testing SETUP

2.00_08 Fri May 21 2005
	- Adding a no_index to prevent bad things being indexed

2.00_07 Fri May 21 2005
	- Set inline2test to actually install
	- Remove pod2test, since I'm leaving it as is.

2.00_06 Thu May 20 2005
	- Added a few more bug fixes, and made the warning only a print,
	  and not a "true" warning.

2.00_05 Sat Mar 26 2005
	- Added support for =for example begin -> =for example end blocks

2.00_04	Fri Mar 25 2005
	- Resolved rt.cpan.org #557 (Catch and thow error for badly nested POD)

2.00_03 Mon Mar 21 2005
	- Forgot to update Changes in 2.00_02
	- Added automatic inclusion of 99_pod.t to my build script,
	  as recommended by CPANTS
	- Fixed a POD bug in Inline.pm

2.00_02 Mon Mar 21 2005
	- Moving some things around to make Test::Inline less
	  oriented around classes, and made adding things a bit
	  smarter.

2.00_01 Fri Mar 18 2005
	- Moved from PCPP (Phase N private CPAN repository) to Open Source
	  repository.
	- Inlined File::DirUtils as Test::Inline::Util
	- Renamed Test::Inline::TestFile as Test::Inline::Script
	- Completed POD docs for what methods exist
	- Partially completed main module DESCRIPTION

---------------------------------------------------------------------
Formerly known as Test::Inline2, a private Phase N Australia module

2.12 Tue Mar 15 2005
	- Fixed a bug in the generation of the manifest resulting from
	  other fixes in 2.11

2.11 Tue Mar 15 2005
	- Added 06_multifile to test a basic multi-file generation
	- Fixed so the we do actuall prepend the output path

2.10 Thu Mar 10 2005
	- Added support for the check_count flag, which allows the number
	  of tests run to be checked section-by-section, rather than
	  file-by-file only.

2.01 Mon Mar  7 2005
	- Tweaked some error messages

2.00 Thu Nov 18 2004
	- Mixed one final bug that was causing the manifest not to come out
	  in dependency order.

1.99 Thu Oct 28 2004
	- Doing error messages a slightly different way

1.98 Thu Oct 28 2004
	- Adding yet more error messages

1.97 Thu Oct 28 2004
	- Added more error messages (when in verbose mode)

1.96 Sun Sep  5 2004
	- Cleaned up Makefile.PL and dependencies

1.95 Sat Sep  4 2004
	- Fix in add_class

1.94 Fri Sep  3 2004
	- Fix a bug when generating manifests with relative paths

1.93 Fri Sep  3 2004
	- Save in sorted order for consistency

1.92 Fri Sep  3 2004
	- Fixed the bool and "" overloads for ::TestFile
	- Fixed manifest generation
	- Changed the meaning of the 'output' option slightly to make it more useful

1.91 Thu Sep  2 2004
	- Added the ability to supply a custom file content generator

1.90 Thu Sep  2 2004
	- More bugs that slipped through in ->save

1.64 Thu Sep  3 2004
	- Fixed a number of calls to ->_write
	- ->add and ->add_class both return the number of files added now

1.63 Thu Sep  2 2004
	- Made a small correction to the Test::Inline2::Handler::File API

1.62 Wed Sep  1 2004
	- Added a special hack to prevent one particular warning during a
	 unit test script in which we don't want to see it.

1.61 Web Sep  1 2004
	- Fixed some bugs in Test::Inline2::Handler::File

1.60 Wed Sep  1 2004
	- Changed to using Handler classes for the features we want to overload

1.50 Tue Aug 31 2004
	- Converted from Test::Inline::Heavy to Test::Inline2
	- Removed Test::Inline2::Config
	- Added class-level dependencies to a test section

1.02 Mon Aug 30 2004
	- Removed an erroneous $DB::single = 1

1.01 Fri Aug 20 2004
	- Updated Algorithm::Dependency to 1.02

1.00 Fri Aug 20 2004
	- Updating Algorithm::Dependency to 1.01 to fix critical ignore_orphans failure
	- Added a warning when there is a missing dependency

0.9  missing

0.8  missing

0.7
	- Using File::Slurp to read files

0.6  missing

0.5  missing

0.4  Sat Apr 17 2004
	- No changes to Test::Inline::Heavy itself
	  Updated to match the changes from 0.3 to 0.4 of Test::ClassAPI

0.3  Sat Apr 17 2004
	- No changes to Test::Inline::Heavy itself
	  Updated to use the more stable 0.3 version of Test::ClassAPI

0.2  Wed Apr 14 2004
	- Changed namespace to Test::Inline::Heavy

0.1  Mon May 12 2003
	- original version

# $NetBSD: Makefile,v 1.9 2005/06/24 20:31:04 wiz Exp $

DISTNAME=		Test-Inline-2.002
PKGNAME=		p5-${DISTNAME}
SVR4_PKGNAME=		p5tin
CATEGORIES=		devel perl5
MASTER_SITES=		${MASTER_SITE_PERL_CPAN:=Test/}

MAINTAINER=		tech-pkg@NetBSD.org
HOMEPAGE=		http://search.cpan.org/dist/Test-Inline/
COMMENT=		Inlining your tests next to the code being tested

BUILD_DEPENDS+=		p5-ExtUtils-AutoInstall>=0.49:../../devel/p5-ExtUtils-AutoInstall
DEPENDS+=		p5-Algorithm-Dependency>=1.02:../../devel/p5-Algorithm-Dependency
DEPENDS+=		p5-Class-Autouse>=1.15:../../devel/p5-Class-Autouse
DEPENDS+=		p5-File-Find-Rule>=0.26:../../devel/p5-File-Find-Rule
DEPENDS+=		p5-File-Flat>=0.95:../../devel/p5-File-Flat
DEPENDS+=		p5-File-Slurp>=9999.04:../../devel/p5-File-Slurp
DEPENDS+=		p5-Test-Simple>=0.33:../../devel/p5-Test-Simple

PERL5_PACKLIST=		${PERL5_SITEARCH}/auto/Test/Inline/.packlist

.include "../../devel/p5-Test-Harness/depends.mk"
.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"