The NetBSD Project

CVS log for pkgsrc/devel/p5-Perl-Critic/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / p5-Perl-Critic

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.50 / (download) - annotate - [select for diffs], Thu Jul 6 09:39:52 2023 UTC (2 months, 4 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, HEAD
Changes since 1.49: +2 -1 lines
Diff to previous 1.49 (colored)

*: recursive bump for perl 5.38

Revision 1.49 / (download) - annotate - [select for diffs], Sat Apr 29 22:39:05 2023 UTC (5 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2
Changes since 1.48: +3 -3 lines
Diff to previous 1.48 (colored)

Update to 1.150
Update DEPENDS

Upstream changes:
1.150 Sat Mar  4 21:17:45 CST 2023

    [Enhancements]
    Added Test::Builder and Text::Wrap to the list of default exceptions in
    Variables::ProhibitPackageVars. Thanks, Graham Knop. (GH #1025)

    [Internals]
    We now use PPIx::Utils instead of PPIx::Utilities, which is more recently
    maintained.

Revision 1.48 / (download) - annotate - [select for diffs], Sun Jan 8 00:22:27 2023 UTC (8 months, 3 weeks ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1
Changes since 1.47: +3 -9 lines
Diff to previous 1.47 (colored)

Update to 1.148
Update DEPENDS

Upstream changes:
1.148 Sat Jan  7 15:20:07 CST 2023

    [Possible breakage]
    Removed Perl::Critic::Utils::DataConversion. Any add-on policies that used
    it will need to copy the functions from there into their own code.

    [Documentation]
    ProhibitCascadingIfElse no longer suggests using given/when.

    [Internals]
    We no longer require Test::Deep for testing.

    Test::Kwalitee is now only recommended, not required.

    Random microoptimizations, like using hashes for array contents checking,
    and using any() instead of calling grep as a boolean.


1.146 Wed Dec 21 21:05:20 CST 2022

    [New features]
    ProhibitBarewordDirHandles now checks for sysopen as well as open. Thanks,
    Tadeusz Sonierz. (GH #732)

    Added a Dockerfile in the extras/ directory for those who want to run P::C
    in a container. Thanks, Isaac Gittins. (GH #832)

    Subroutines::ProhibitBuiltinHomonyms now can take an "allows" parameter to
    specify subroutines that won't violate the policy. Thanks, UTAGAWA Kiki.
    (GH #14, #932)

    ProhibitStringyEval now allows package declarations in evals when
    allow_includes = true. This is a common way packages are declared.
    Thanks, Chris Novakovic. (GH #908)

    [Bug Fixes]
    Fixed some problems with how Perl::Critic determined scope. Thanks, Tom
    Wyant. (GH #793)

    Fixed improper violation for lexical subroutines in
    Subroutines::ProhibitBuiltinHomonyms. Thanks, TOYAMA Nao. (GH #973, #955,
    #546)

    ValuesAndExpressions::RequireNumberSeparators no longer complains if your
    version numbers do not have number separators in them. Thanks, Tom Wyant.
    (GH #856, #904)

    Fixed a false positive with split() in ProhibitUnusedCapture. Thanks, Tom
    Wyant. (GH #888)

    [Internals]
    We no longer use or need IO::String. Thanks, Graham Knop. (GH #997)

    Removed requirements and mentions of modules no longer used:
    * Fatal
    * IO::String
    * IPC::Open2
    * Pod::Parser
    * Task::Weaken


1.144 Mon Dec  5 09:44:04 PM CST 2022

    Perl::Critic now requires Perl 5.10.1.

    [New features]
    The ProhibitAugmentedAssignmentInDeclaration policy now allows augmented
    assignments to "our" variables, if the allow_our option is enabled.
    Thanks, Graham Knop. (GH #993)

    ProhibitExplicitISA now recommends "use parent" instead of "use base".
    (GH #987)

    RequireUseWarnings now recognizes that "use v5.36" implies warnings.
    Thanks, Andrew Grechkin. (GH #984)

    Subroutines::ProhibitNestedSubs now allows lexical subroutines can
    now be inside of other subroutines. Thanks, TOYAMA Nao. (GH #946,
    #971, #972)

    RequireUseStrict now knows that Test::Spec enables it. (GH #906)

    ProhibitUnusedCapture now understands @{^CAPTURE} and %{^CAPTURE_ALL} that
    were added in Perl 5.26.0. Thanks, Tom Wyant. (GH #778)

    Allow numeric operators on special number strings 'NaN' and 'inf'. Thanks,
    Omer Gazit. (GH #803)

    [Fixes]
    Miscellanea::ProhibitUselessNoCritic no longer filters out errors about
    itself, just as Miscellanea::ProhibitUnrestrictedNoCritic cannot. Thanks,
    Bernhard Schmalhofer. (GH #939)

    Fixed GH #878: bareword filehandle dies on `open(CHECK, '/foo');`. Thanks,
    Tom Wyant.

    [Internals]
    Updated to using Perl 5.10.1. Starting migrating to Perl 5.10-isms like
    defined-or. Thanks, James Raspass.

    [Documentation]
    Updated some outdated docs in Perl::Critic::Utils. Thanks, Slaven Rezi.
    (GH #951)


1.142 Mon Nov 28 08:12:14 PM CST 2022

    This is the last version of Perl::Critic that will run on Perl 5.6.1.  The
    next release will require Perl 5.10.1.

    [New Features]
    Add new policy InputOutput::ProhibitBarewordDirHandles, comparable to
    ProhibitBarewordFilehanles.  Thanks, raf. (GH #912)

    References::ProhibitDoubleSigils policy now allows for Perl's
    postfix dereference syntax and does not report a policy violation.
    Thanks to Ilya Rassadin (GH #578)

    Added Test::Class::Moose and MooseX::MethodAttributes::Role to the
    list of modules that are equivalent to "use strict".  (GH #808, GH #886)

    Subroutines::RequireArgUnpacking now detects anonymous subroutines with
    attributes, prototypes or signatures.  Thanks, Tom Wyant. (GH #684)

    ProhibitVoidMap and ProhibitVoidGrep now detect void context inside subs,
    such as:

        sub { map { foo($_) } @list; return }

    Thanks, James Raspass. (GH #905)

    RequireArgUnpacking now allows a closure to be recognized as a way that
    subroutine arguments can be unpacked.  This is specified with an optional
    allow_closures configuration option.  Thanks, Tom Wyant. (GH #737)

    ProhibitTwoArgOpen now disallows one-arg opens as well. Also, it
    no longer allows two-arg opening of STDIN/STDOUT/STDERR.  Thanks,
    Dan Book. (GH #652, #653)

    [Fixes]
    ProhibitLeadingZeros would not handle sysopen and lexical variables
    correctly. This has been fixed. Thanks, Tom Wyant. (GH #789)

    [Documentation]
    We note that the any() function is available in both List::MoreUtils and
    List::SomeUtils.

    Added instructions to perlcritic on how to integrate with Visual Studio
    Code.  Thanks, sigzero.

    [Internals]
    Switch to using List::SomeUtils instead of List::MoreUtils.

Revision 1.47 / (download) - annotate - [select for diffs], Tue Jun 28 11:33:05 2022 UTC (15 months, 1 week ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3
Changes since 1.46: +2 -1 lines
Diff to previous 1.46 (colored)

*: recursive bump for perl 5.36

Revision 1.46 / (download) - annotate - [select for diffs], Wed Jul 28 07:13:32 2021 UTC (2 years, 2 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3
Changes since 1.45: +2 -3 lines
Diff to previous 1.45 (colored)

Update to 1.140

Upstream changes:
1.140 Tue Mar 23 21:42:19 CDT 2021

    [New Features]
    Subroutines::RequireFinalReturn now lets you specify a
    terminal_methods parameter to specify methods that should been as
    terminal.  This is like the terminal_funcs parameter, but for methods.
    Thanks, Robin Smidsrød and Mike Bruins. (GH #920)


1.139_01 Tue Sep  1 23:52:18 CDT 2020

    [Fixes]
    Removed an extra /x in RequireInterpolationOfMetachars.pm that caused
    deprecation warnings in Perl 5.22 and higher.  (GH #822)

    Documentation::RequirePackageMatchesPodName now recognizes the package
    name if it's in C<< I<> >> or C<< B<> >> markup.  Thanks, Renée Bäcker.
    (GH #913)

Revision 1.45 / (download) - annotate - [select for diffs], Mon May 24 19:51:23 2021 UTC (2 years, 4 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.44: +2 -2 lines
Diff to previous 1.44 (colored)

*: recursive bump for perl 5.34

Revision 1.44 / (download) - annotate - [select for diffs], Wed Dec 2 11:06:55 2020 UTC (2 years, 10 months ago) by ast
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.43: +3 -2 lines
Diff to previous 1.43 (colored)

devel/p5-Perl-Critic: Version 1.138 requires Pod::TextPlain which is part of Pod::Parser

Revision 1.43 / (download) - annotate - [select for diffs], Mon Aug 31 18:08:41 2020 UTC (3 years, 1 month ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.42: +2 -1 lines
Diff to previous 1.42 (colored)

*: bump PKGREVISION for perl-5.32.

Revision 1.42 / (download) - annotate - [select for diffs], Thu Apr 16 13:50:59 2020 UTC (3 years, 5 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2
Changes since 1.41: +2 -2 lines
Diff to previous 1.41 (colored)

(devel/p5-Perl-Critic) Updated to 1.138

1.138 Fri Jan 24 15:50:34 CST 2020

    Stable release.  No changes since 1.137_01.


1.137_01 Thu Jan 23 16:44:57 CST 2020

    [Fixes]
    RequireCheckingReturnValueOfEval didn't count returning the result of an
    eval as checking it.  Now it does.  However, it's only if you "return eval
    { ... }".  It still doesn't handle the case of "return ( eval {} )".
    Thanks, Tom Wyant. (GH #324)

    ProhibitPunctuationVars would get confused and think that the expression
    qr/SOME$/ was using the $/ special variable.  Thanks, Tom Wyan. (GH #843)

Revision 1.41 / (download) - annotate - [select for diffs], Wed Jan 1 05:39:06 2020 UTC (3 years, 9 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.40: +4 -5 lines
Diff to previous 1.40 (colored)

(devel/p5-Perl-Critic) Updated to 1.136

1.136 Wed Nov 27 09:51:09 CST 2019
    Stable release.  No changes since 1.135_01.


1.135_01 Tue Nov 26 14:50:11 CST 2019
    [New Features]
    The ProhibitNoWarnings pollicy now handles warnings in the experimental::
    group.  Thanks, Ren辿 B辰ker. (GH #892)

    [Documentation]
    Prevented some example code from showing up in `perldoc`.  Thanks, Tom
    Hukins.  (GH #799)

Revision 1.40 / (download) - annotate - [select for diffs], Sun Nov 3 10:16:02 2019 UTC (3 years, 11 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.39: +3 -3 lines
Diff to previous 1.39 (colored)

devel/p5-*: align variable assignments

pkglint -Wall -F --only aligned --only indent p5-*

No manual corrections.

Revision 1.39 / (download) - annotate - [select for diffs], Sun Aug 11 13:20:10 2019 UTC (4 years, 1 month ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.38: +2 -1 lines
Diff to previous 1.38 (colored)

Bump PKGREVISIONs for perl 5.30.0

Revision 1.38 / (download) - annotate - [select for diffs], Sun Jun 30 20:15:36 2019 UTC (4 years, 3 months ago) by nia
Branch: MAIN
Changes since 1.37: +2 -2 lines
Diff to previous 1.37 (colored)

Update packages using a search.cpan.org HOMEPAGE to metacpan.org.

The former now redirects to the latter.

This covers the most simple cases where http://search.cpan.org/dist/name
can be changed to https://metacpan.org/release/name.

Reviewed by hand to hopefully make sure no unwanted changes sneak in.

Revision 1.37 / (download) - annotate - [select for diffs], Sat Jun 1 07:10:42 2019 UTC (4 years, 4 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2
Changes since 1.36: +3 -5 lines
Diff to previous 1.36 (colored)

Update to 1.134

Upstream changes:
1.134 Wed May 22 21:17:21 CDT 2019
    Stable release.  No changes since 1.133_02.


1.133_02 Mon May 20 10:48:16 CDT 2019
    [New Features]
    Support indented heredocs.  Thanks, Gregory Oschwald. (GH#861)

    In Subroutines::ProhibitManyArgs, you can now omit the object
    variable (C<$self> or C<$class>) from the argument count.  Thanks,
    Szymon Nieznaski. (GH#815)

    [Dependencies]
    Removed use of File::HomeDir. Thanks, Karen Etheridge.
    Upgrade to PPI 1.265.  By Will Braswell.  (GH#860)

    Fix failed tests caused by new PPI.  Thanks, Szymon Nieznaski.
    (GH #858)

    [Internals]
    Updated the Appveyor convig.  Thanks, Roy Ivy III. (GH#851)


1.133_01 Thu Oct 25 23:21:31 CDT 2018
    [New Features]
    Added new policy BuiltinFunctions::ProhibitShiftRef.  It disallows
    this construct that causes a memory leak in Perl 5.21.4 and above:

        my $ref = \shift;

    The documentation for the policy contains details on when this can
    happen. Thanks, Todd Rinaldo. (GH#837)

    [Policy Changes]
    The policy Documentation::RequirePodLinksIncludeText is obsolete and
    has been removed. Thanks, Salvatore Bonaccorso. (GH#494)

Revision 1.36 / (download) - annotate - [select for diffs], Wed Aug 22 09:44:31 2018 UTC (5 years, 1 month ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.35: +2 -1 lines
Diff to previous 1.35 (colored)

Recursive bump for perl5-5.28.0

Revision 1.35 / (download) - annotate - [select for diffs], Tue Jun 19 06:44:31 2018 UTC (5 years, 3 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2
Changes since 1.34: +4 -3 lines
Diff to previous 1.34 (colored)

Update to 1.132
Update DEPENDS

Upstream changes:
1.132    Thu May 31 21:48:48 CDT 2018
    [New Features]
    Added the ability to specify a regex to tell what unused private
    subroutines are OK in Subroutines::ProhibitUnusedPrivateSubroutines.
    This is handy for Moose classes where there could be many false
    positives on _build_xxxx() subroutines.
    Thanks, Dave Cross.  (GH #811, #812)

    [Dependencies]
    Perl::Critic now no longer relies on the deprecated Email::Address.
    (GH #816)

1.131_02 Tue Feb 20 17:18:03 CST 2018
    [New Features]
    Perl::Critic now assumes that .psgi files are Perl, too.  Thanks, Tom
    Hukins. (GH#805)

    Variables::ProhibitUnusedVariables no longer gives a false positive for
    variables used in interpolation.  Thanks, Omer Gazit. (GH#801)

    [Bug Fixes]
    Added missing requirement for Fatal.pm.


1.131_01 Tue Nov 21 17:28:06 CST 2017
    [New Features]
    In the ProhibitLeadingZeros policy, added an exception for mkfifo.
    Thanks, Evan Zacks. (GH#786)

    Add color support for Windows platforms.  Thanks, Roy Ivy III. (GH#700)

    [Bug Fixes]
    Recode Perl::Critic::Utils::all_perl_files() to use File::Find instead
    of opendir/readdir.  This solves endless directory traversals if
    the directories contain circular symbolic references.  Thanks, Tom Wyant.

    [Documentation]
    Added CONTRIBUTING.md.  Thanks, Jonas B. Nielsen.

Revision 1.34 / (download) - annotate - [select for diffs], Sun Sep 17 12:51:02 2017 UTC (6 years ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.33: +2 -2 lines
Diff to previous 1.33 (colored)

p5-Perl-Critic: update to 1.130.

1.130   Thu Jul 20 23:16:34 CDT 2017
    [New Features]
    * Policies which ensure that system calls are checked such as
      RequireCheckedSystemCalls now have an "autodie_modules" setting which
      allows you to tell the policy about other modules which export
      autodie. Fixes #699. PR #747. Thanks to Dave Rolsky.

Revision 1.33 / (download) - annotate - [select for diffs], Sat Jun 17 13:04:16 2017 UTC (6 years, 3 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.32: +3 -4 lines
Diff to previous 1.32 (colored)

Updated devel/p5-Perl-Critic to 1.128
-------------------------------------
1.128    Sat Jun 10 22:31:28 CDT 2017

    Official release.  No changes since 1.127_02.

1.127_02 Tue May 23 18:31:59 CDT 2017

Developer release leading up to 1.128.

    [Bug Fixes]
    * PPI misparsing a module caused an incorrect "Must end with a
      recognizable true value."  This is fixed by upgrading to PPI
      1.224. (GH #696, GH #607)
    * A test would fail under the upcoming Perl 5.26 that omits the current
      directory from @INC.  Thanks, Kent Fredric.
    * Fixed an invalid test in the RequireBarewordsIncludes test.  Thanks,
      Christian Walde. (GH #751)
    * If an element contained blank lines then the source "%r" displayed
      for a violation was wrong. Thanks, Sawyer X. (GH #702, #734)

    [Dependencies]
    Perl::Critic now requires PPI 1.224.  PPI is the underlying Perl parser
    on which Perl::Critic is built, and 1.224 introduces many parsing fixes
    such as:
    * Fixes for dot-in-@INC.
    * Parse left side of => as bareword even if it looks like a keyword or op.
    * $::x now works.
    * Higher accuracy when deciding whether certain characters are operators or
      variable type casts (*&% etc.).
    * Subroutine attributes parsed correctly.

    [Performance Enhancements]
    * Sped up BuiltinFunctions::ProhibitUselessTopic ~7%.  Thanks, James
      Raspass. (GH #656)

    [Documentation]
    * Fixed incorrect explanation of capture variables in
      ProhibitCaptureWithoutTest.  Thanks, Felipe Gasper.
    * Fixed incorrect links. Thanks, Glenn Fowler.
    * Fixed incorrect example for returning a sorted list.  Thanks, @daviding58.
    * Fixed invalid POD.  Thanks, Jakub Wilk. (GH #735)
    * Updated docs on ProhibitYadaOperator.  Thanks, Stuart A Johnston. (GH #662)
    * Removed all the references to the old mailing list and code repository
      at tigris.org.  (GH #757)


1.127_01 Sun May 21 21:57:16 CDT 2017

    Removed from CPAN because it did not get indexed correctly.

Revision 1.32 / (download) - annotate - [select for diffs], Mon Jun 5 14:23:28 2017 UTC (6 years, 4 months ago) by ryoon
Branch: MAIN
Changes since 1.31: +2 -2 lines
Diff to previous 1.31 (colored)

Recursive revbump from lang/perl5 5.26.0

Revision 1.31 / (download) - annotate - [select for diffs], Wed Jun 8 19:23:24 2016 UTC (7 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.30: +2 -1 lines
Diff to previous 1.30 (colored)

Bump PKGREVISION for perl-5.24.

Revision 1.30 / (download) - annotate - [select for diffs], Sun Sep 6 03:58:35 2015 UTC (8 years, 1 month ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3
Changes since 1.29: +3 -3 lines
Diff to previous 1.29 (colored)

(pkgsrc)
 - Add following line for make test
  BUILD_DEPENDS+=        p5-Module-Pluggable-[0-9]*:../../devel/p5-Module-Pluggable
(upstream)
 - Update 1.125 to 1.126
------------------------
1.126 2015-08-10
    [New Policies]
    * Added a policy: ControlStructures::ProhibitYadaOperator - Never use ...
      in production code.

    [Bug Fixes]
    * Fixed problems arising from having -b in your .perltidyrc file. Thanks
      @hjkatz.
    * Removed extra newline from policy names returned by P::C::Config->policies.
      Thanks @ratsbane.
    * `fc` and `say` are now covered by ProhibitUselessTopic. Thanks @JRaspass.

    [Miscellanea]
    * Add more strict/warnings importer modules. Thanks @oalders.
    * Path::Tiny is now recommended over File::Slurp
    * Micro-optimize by calling ->content() directly instead of going
      through the overloads. Thanks @JRaspass.
    * Square brackets are now allowed around your `## no critic` policy
      list. Thanks @zdm.

Revision 1.29 / (download) - annotate - [select for diffs], Fri Jun 12 10:49:38 2015 UTC (8 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2
Changes since 1.28: +2 -1 lines
Diff to previous 1.28 (colored)

Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.

Revision 1.28 / (download) - annotate - [select for diffs], Sun Mar 15 23:57:30 2015 UTC (8 years, 6 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.27: +2 -2 lines
Diff to previous 1.27 (colored)

Update 1.123 to 1.125
---------------------
1.125 2015-03-02
    [Bug Fixes]
    * Corrected dependency on List::Util::any() to List::MoreUtils::any()

    [Miscellanea]
    * Revised and updated documentation.

1.124 2015-02-27
    [Policy Changes]
    * The ProhibitUnusedPrivateSubroutines policy can now ignore files that
      use particular modules with 'skip_when_using' option allows of, for
      example, skipping the policy for roles.  Thanks to Mark Fowler.

    * The RequireUseStrict and RequireUseWarnings policies now regard Moose,
      Moo, Mouse, Dancer, Mojolicious, and several other modules as equivalent
      to the strict and warnings pragma.

    [Bug Fixes]
    * The RequireChecked* family of policies has been fixed to accommodate
      version numbers when use-ing the autodie pragma. GH #612. Thanks citrin.

Revision 1.27 / (download) - annotate - [select for diffs], Tue Jan 6 14:39:10 2015 UTC (8 years, 8 months ago) by wen
Branch: MAIN
Changes since 1.26: +6 -7 lines
Diff to previous 1.26 (colored)

Update to 1.123
Update DEPENDS

Upstream changes:
1.123 2014-11-11

    [Dependencies]
    * Now requires PPI-1.220 which has numerous bug fixes. This may
      eliminate the need for some "## no critic" markers you inserted to
      work around those bugs. The "ProhibitUselessNoCritic" policy should
      help you find them.

    [Miscellanea]
    * Fixed a typo in the Variables::ProhibitPerl4PackageNames message.

1.122 2014-08-25

    [Dependencies]
    * Now requires PPI-1.218 which has numerous enahncements and bug fixes.
      Also now requires Readonly-2.00, which obviates the need for Readonly::XS
      to get fast constants.

    * File::HomeDir, File::Which, and Term::ANSIColor are all required now
      instead of being optional or recommended. This simplifies our test code
      and ensures consistent optimal behavior for all users.

    [New Policies]
    * Added two new policies: BuiltinFunctions::ProhibitUselessTopic and
      RegularExpressions::ProhibitUselessTopic.

    [Miscellanea]
    * Updated the perlcritic.el script to use modern Emacs hooks.
      Thanks to @intrigeri and the Debian team for the patch.  Fixes GH #556.

    * Removed all the internal RCS keyword boilerplate blocks that were never
      getting expanded.

Revision 1.26 / (download) - annotate - [select for diffs], Thu May 29 23:36:12 2014 UTC (9 years, 4 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.25: +2 -1 lines
Diff to previous 1.25 (colored)

Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.

Revision 1.25 / (download) - annotate - [select for diffs], Sat Apr 26 13:44:40 2014 UTC (9 years, 5 months ago) by wen
Branch: MAIN
Changes since 1.24: +2 -2 lines
Diff to previous 1.24 (colored)

Update to 1.121

Upstream changes:
1.121 2013-11-02

    [New Features]
    * Added new themes based on CERT guidelines. Thanks Kirk Kimmel.

    [Administrative Changes]
    * The source code repository for Perl-Critic has been moved to GitHub
      at http://github.com/Perl-Critc/Perl-Critic.  All ticekts from the
      RT queue have also been moved there.  Please use GitHub for submitting
      any new bugs or corresponding about existing ones.  Huge thanks to
      Tim Bunce, Andreas Marienborg, fREW Schmidt, and Graham Knop for
      making this happen.

    [Miscellanea]
    * This change log was reformatted to comply with CPAN::Changes::Spec,
      courtesy of Neil Bowers as part of a quest on http://questhub.io.
      Does your change log comply?

Revision 1.24 / (download) - annotate - [select for diffs], Thu Oct 31 03:04:33 2013 UTC (9 years, 11 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4
Changes since 1.23: +2 -4 lines
Diff to previous 1.23 (colored)

Update to 1.120

Upstream changes:
[1.119] Released on 2013-09-25

     Bug Fixes:
     * Tests were failing with Config::Tiny 2.17 or later, due to a
       change in the error messages produced by that module.
       This fixes #16 on Github,  #88679 & #88889 on RT.


     Policy Changes:
     * BuiltinFunctions::ProhibitVoidGrep and ::ProhibitVoidMap: grep
       and map called as functions are now allowed in slice operations.
       RT #79289
       Thanks to Wade at Anomaly dot org for the patch.
     * Subroutines::RequireArgUnpacking: Most tests of the size of @_
       are now allowed.  RT #79138

     Other Changes:
     * Modernized our usage of Exporter.  See RT #75300.
       Thanks to Olivier Mengu. for the patch.

[1.118] Released on 2012-07-10

    Policy Changes:
    * CodeLayout::RequireTidyCode: Revise to work with incompatible
      changes in Perl::Tidy 20120619. RT #77977.
    * TestingAndDebugging::ProhibitNoWarnings: Correct the parse of the
      'no warnings' statement, so that 'no warnings "qw"' is recognized
      as supressing just 'qw' warnings. RT #74647.
    * Miscellanea::RequireRcsKeywords has been moved to the Perl-Critic-More
      distribution,  RT #69546

    Other Changes:
    * Make all unescaped literal "{" characters in regexps into
      character classes. These are deprecated, and became noisy with
      Perl 5.17.0.  RT #77510.

Revision 1.23 / (download) - annotate - [select for diffs], Fri May 31 12:40:39 2013 UTC (10 years, 4 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.22: +2 -2 lines
Diff to previous 1.22 (colored)

Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.

Revision 1.22 / (download) - annotate - [select for diffs], Wed Oct 31 11:18:48 2012 UTC (10 years, 11 months ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.21: +1 -3 lines
Diff to previous 1.21 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.21 / (download) - annotate - [select for diffs], Wed Oct 3 21:55:29 2012 UTC (11 years ago) by wiz
Branch: MAIN
Changes since 1.20: +2 -1 lines
Diff to previous 1.20 (colored)

Bump all packages that use perl, or depend on a p5-* package, or
are called p5-*.

I hope that's all of them.

Revision 1.20 / (download) - annotate - [select for diffs], Thu Sep 13 16:10:47 2012 UTC (11 years ago) by sno
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3
Changes since 1.19: +9 -9 lines
Diff to previous 1.19 (colored)

Updating package for CPAN module Perl::Critic in devel/p5-Perl-Critic
from 1.117 to 1.118.

pkgsrc changes:
- adjust dependencies

upstream changes:
[1.118] Released on 2012-07-10

    Policy Changes:
    * CodeLayout::RequireTidyCode: Revise to work with incompatible
      changes in Perl::Tidy 20120619. RT #77977.
    * TestingAndDebugging::ProhibitNoWarnings: Correct the parse of the
      'no warnings' statement, so that 'no warnings "qw"' is recognized
      as supressing just 'qw' warnings. RT #74647.
    * Miscellanea::RequireRcsKeywords has been moved to the Perl-Critic-More
      distribution,  RT #69546

    Other Changes:
    * Make all unescaped literal "{" characters in regexps into
      character classes. These are deprecated, and became noisy with
      Perl 5.17.0.  RT #77510.

Revision 1.19 / (download) - annotate - [select for diffs], Fri May 11 13:26:14 2012 UTC (11 years, 4 months ago) by sno
Branch: MAIN
CVS Tags: pkgsrc-2012Q2-base, pkgsrc-2012Q2
Changes since 1.18: +3 -3 lines
Diff to previous 1.18 (colored)

Update package for CPAN distribution Perl::Critic in devel/p5-Perl-Critic
from 1.116 to 1.117.

pkgsrc changes:
- mark requirement update of p5-PPIx-Regexp to 0.022

Upstream changes:
[1.117] Released on 2011-12-21

    HAPPY HOLIDAYS!

    New Policies:
    * Variables::ProhibitAugmentedAssignmentInDeclaration reports
      constructs like 'my $x += 1'. Contributed by Mike O'Regan

    Policy Changes:
    * BuiltinFunctions::ProhibitLvalueSubstr: Add explicit 'use version'.
      RT #68498.
    * CodeLayout::ProhibitHardTabs: Add 'pbp' to the default_themes list.
      RT #71093.
    * ControlStructures::ProhibitMutatingListFunctions now understands that
      tr///r (introduced in 5.13.7) does not change its operand.
    * ControlStructures::ProhibitMutatingListFunctions now understands that
      '//=', '<<=', and '>>=' are assignment operators. RT #70901.
    * ErrorHandling::RequireCheckingReturnValueOfEval now allows things
      like grep { eval $_ }. RT #69489.
    * Modules::RequireExplicitPackage now has configuraion option
      allow_import_of, to allow the import of specified modules before
      the package statement. RT #72660.
    * RegularExpressions::ProhibitEnumeratedClasses no longer thinks
      that [A-Za-z_] matches \w. RT #69322.
    * RegularExpressions::ProhibitUnusedCaptures now skips the first
      block of an 'if' or 'elsif' if the regular expression is bound to
      its operand with the '!~' operator. RT #69867.
    * RegularExpressions::ProhibitUnusedCaptures now looks into lists
      and blocks in the replacement portion of the regular expression if
      /e is asserted. RT #72086.
    * RegularExpressions::RequireDotMatchAnything,
      RegularExpressions::RequireExtendedFormatting and
      RegularExpressions::RequireLineBoundaryMatching now honor defaults
      set with 'use re "/modifiers"'. RT #72151.
    * Subroutines::ProhibitManyArgs now recognizes '+' as a prototype
      character.
    * Variables::ProhibitPunctuationVars now recognizes bracketed
      variables embedded in interpolated strings (e.g. "${$}"). For the
      purpose of the 'allow' configuration, these are considered
      equivalent to the unbracketed form. RT #72910.
    Other Changes:
    * Corrected POD in Perl::Critic::PPI::Utils. RT #68898.
    * Perl::Critic::Violation source() method now returns the line
      containing the violation (not the first line) when the statement
      containing the violation spans multiple lines.

Revision 1.18 / (download) - annotate - [select for diffs], Tue Aug 16 23:01:57 2011 UTC (12 years, 1 month ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3
Changes since 1.17: +6 -5 lines
Diff to previous 1.17 (colored)

Update to 1.116:

[1.116] Released on 2011-05-15

    Policy Changes:
    * BuiltInFunctions::ProhibitLvalueSubstr does not report violations
      if the document contains an explicit 'use n.nnn;' where the
      version is before 5.005.  RT #59112
    * Documentation::RequirePodSections no longer blows up on code
      having POD but no =head1. This problem was introduced with RT
      #59268. RT #67231
    * RegularExpressions::ProhibitUnusedCapture should more reliably
      find things like s/(a)/${1}2/.  RT #67273.
    * ValuesAndExpressions::ProhibitMagicNumbers and
      Module::RequireVersionVar now treat versions passed as the second
      argument of a 'package' statement the same as versions declared as
      'our $VERSION ...'.  RT #67159
    * Variables::RequireLexicalLoopIterators does not report violations
      if the document contains an explicit 'use n.nnn;' where the
      version is before 5.004.  RT #67760

[1.115] Released on 2011-03-31

    Minor bits:
    * Fatal error in RegularExpressions::ProhibitUnusedCapture here
      document check.  RT #67116.
    * Internal POD error in Documentation::RequirePodLinksIncludeText.  Patch
      by Salvatore Bonaccorso.  RT #67012

[1.114] Released on 2011-03-26

    Policy Changes:
    * Documentation::RequirePodLinksIncludeText now handles nested POD
      formatting. RT #65569
    * Clarified relation of severity numbers to names in Perl::Critic
      POD. RT #66017
    * Removed caveats from Variables::RequireLocalizedPunctuationVars,
      no longer necessary with PPI 1.208. RT #65514
    * Have InputOutput::RequireBriefOpen attempt to expand scope as
      necessary to deal with the case where the open() and the
      corresponding close() are not in the same scope. RT #64437
    * RegularExpressions::ProhibitUnusedCapture now looks inside
      double-quotish things. RT #38942.
    * RegularExpressions::ProhibitUnusedCapture now takes logical
      alternation into account, so that (e.g.)
          if ( /(a)/ || /(b)/ ) {
              say $1;
          }
      is not a violation. RT #38942.
    * ValuesAndExpressions::ProhibitCommaSeparatedStatements now
      recognizes 'return { foo => 1, bar => 2 }' as containing a hash
      constructor, not a block. This was fixed by PPI 1.215. RT #61301.
    * ValuesAndExpressions::ProhibitCommaSeparatedStatements now
      recognizes 'bless { foo => 1, bar => 2 }' as containing a hash
      constructor, not a block. This was fixed by PPI 1.215. RT #64132.

[1.113] Released on 2011-02-14

    New Policies:
    * InputOutput::RequireEncodingWithUTF8Layer recommends
      ':encoding(utf8)' over ':utf8' in open() and binmode(). It is severity 5
      because of the bad things that can happen if invalid UTF8 gets loose in
      your code.
    * Modules::ProhibitConditionalUseStatements prohibits
      'use module' inside a conditional, since the statement is executed
      unconditionally at compile time.  Thanks to Peter Guzis for submitting
      the policy and tests in RT #59065.

    Policy Changes:
    * CodeLayout::RequireConsistentNewlines produces multiple undefined
      value errors when a violation is found. RT #65663
    * ControlStructures::ProhibitMutatingListFunctions allows s///r,
      which was introduced in 5.13.2.
    * ControlStructures::ProhibitPostfixControls now looks for "when".  It is
      treated in the same way as "if".
    * Documentation::RequirePodSections now honors '## no critic'
      annotation anywhere before the '__END__', '__DATA__', or first
      '=head1', whichever comes first.  The line number of the offending
      '=head1 NAME' was added to the violation description.  RT #59268.
    * RegularExpressions::ProhibitUnusedCapture now takes account of the
      use of $- and $+ (and their English equivalents under 'use
      English') provided the subscripts are literal integers.
    * RegularExpressions::ProhibitUnusedCapture now takes account of the
      use of capture variables in the replacement portion of
      s/.../.../e.
    * Subroutines::ProhibitUnusedPrivateSubroutines now looks inside
      regular expressions.
    * ValuesAndExpressions::ProhibitMagicNumbers now supports Const::Fast.
    * ValuesAndExpressions::ProhibitMagicNumbers now has a
      constant_creator_subroutines parameter to allow the user to
      configure the names of subroutines that create constants. RT #62562.
    * ValuesAndExpressions::ProhibitMismatchedOperators didn't handle file
      test operators properly.  Patch by H.Merijn Brand.  RT #58751
    * Variables::ProhibitUnusedVariables now looks inside regular
      expressions.
    * ValuesAndExpressions::RequireInterpolationOfMetachars now detects
      and complains about "\b" and "\l" as documented in perlop, and
      "\1" through "\7", which are not documented there, but were found
      in toke.c.

    New Developer Features:
    * uses_module(), namespaces(), and subdocuments_for_namespace() methods on
      Perl::Critic::Document.
    * Perl::Critic::Document->new() now accepts a -filename-override argument
      for setting the filename when the source code comes from something
      other than an actual file.

    Other Changes:
    * Test::Perl::Critic::Policy no longer exports by default.
    * Build phase now requires Test::Deep.
    * Added example using Try::Tiny to documentation of
      ErrorHandling::RequireCheckingReturnValueOfEval. Suggested by Andy
      Lester on the developers mailing list.
    * In order to get more consistent behavior across all installations of
      Perl::Critic, IPC::Open2 (which actually is part of core), PPIx::Regexp,
      Perl::Tidy, Pod::Spell, and Text::ParseWords are no longer optional
      prerequisites.
    * Now depends upon PPIx::Utilities v1.1.0.

    Bug Fixes:
    * Build.PL/Makefile.PL didn't specify a minimum version of version.pm, but
      TestingAndDebugging::RequireUseStrict did.  RT #58952
    * Perl::Critic::Annotation needs to look inside the __END__ statement to
      find the true end of the document, otherwise POD policies may give false
      positives.  RT #59176
    * BuiltinFunctions::ProhibitStringyEval no longer dies on eval
      "#...".  RT #60179
    * RegularExpressions::ProhibitUnusedCapture now takes account of the
      %LAST_PAREN_MATCH as well as %+ if English has been loaded.  RT #60002
    * Subroutines::ProhibitManyArgs now interprets prototype groups (e.g.
      \[$@%]) as representing a single argument.
    * Require Exporter version 5.63 (versus version 0) to get sane handling of
      export tags.  RT# 61071
    * Prevent Subroutines::ProhibitUnusedPrivateSubroutines from failing
      on &_subroutine().  RT #61311
    * Subroutines::ProhibitAmpersandSigils now allows references of the
      form \( &sub1, &sub2 ).  RT #49609

[1.112_002] Released on 2011-02-09
[1.112_001] Released on 2010-12-14

    Changes summarized into 1.113 above.  For exact details, see Changes on
    BackPAN.

[1.111] Released on 2010-12-14

    Bug Fixes:
    * TestingAndDebugging::ProhibitNoStrict and ProhibitNoWarnings no longer
      rely on the behavior of all() when the list is empty due to change in
      List::MoreUtils 0.28.  RT #63816

[1.110_001] Released on 2010-11-30

    Changes summarized into 1.113 above.  For exact details, see Changes on
    BackPAN.  (Yes, all of this stuff was not in 1.111.)

Revision 1.17 / (download) - annotate - [select for diffs], Sun Aug 14 12:26:30 2011 UTC (12 years, 1 month ago) by obache
Branch: MAIN
Changes since 1.16: +2 -2 lines
Diff to previous 1.16 (colored)

Revision bump after updating perl5 to 5.14.1.

Revision 1.16 / (download) - annotate - [select for diffs], Wed Sep 1 06:03:55 2010 UTC (13 years, 1 month ago) by sno
Branch: MAIN
CVS Tags: pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3
Changes since 1.15: +5 -3 lines
Diff to previous 1.15 (colored)

Updating devel/p5-Perl-Critic from 1.108nb1 to 1.109

Upstream changes:
[1.109] Released on 2010-08-29
    Bug Fixes:
    * ValuesAndExpressions::RequireInterpolationOfMetachars fix due to
      changes in Email::Address 1.890.  Note that this may find problems
      in code that it didn't before, e.g. q<'@foo'>.

Revision 1.15 / (download) - annotate - [select for diffs], Sat Aug 21 16:34:17 2010 UTC (13 years, 1 month ago) by seb
Branch: MAIN
Changes since 1.14: +2 -1 lines
Diff to previous 1.14 (colored)

Bump the PKGREVISION for all packages which depend directly on perl,
to trigger/signal a rebuild for the transition 5.10.1 -> 5.12.1.

The list of packages is computed by finding all packages which end
up having either of PERL5_USE_PACKLIST, BUILDLINK_API_DEPENDS.perl,
or PERL5_PACKLIST defined in their make setup (tested via
"make show-vars VARNAMES=..."), minus the packages updated after
the perl package update.

sno@ was right after all, obache@ kindly asked and he@ led the
way. Thanks!

Revision 1.14 / (download) - annotate - [select for diffs], Sat Jul 31 10:58:07 2010 UTC (13 years, 2 months ago) by sno
Branch: MAIN
Changes since 1.13: +7 -4 lines
Diff to previous 1.13 (colored)

Updating devel/p5-Perl-Critic from 1.106 to 1.108

pkgsrc changes:
- adjust dependencies

Upstream changes:
[1.108] Released on 2010-06-22
    This is the "Give Shawn Moore what we promised him a year ago and hurry up
    and get this out before Brad Oaks gives his YAPC::NA talk" release.

    New Policies:
    * Documentation::RequirePodLinksIncludeText
    * Subroutines::ProhibitUnusedPrivateSubroutines

    New Features:
    * There is a new global configuration item, 'program-extensions', which
      configures Perl::Critic's idea of which file name extensions represent
      programs.  The desired extensions are specified as a space-separated list,
      with leading '.' on each if that is desired.  Files whose names end in
      '.PL' will always be considered programs.  This can be overridden by
      command option --programs-extensions, which can be specified multiple
      times.
    * There is now a perlcritic --allow-unsafe switch.  Without this switch,
      Perl::Critic will silently refuse to load any Policy that is marked
      unsafe.  Unsafe Policies are usually ones that may compile or execute
      untrusted code (see Perl::Critic::DynamicPolicy for an example); Policy
      authors can mark their policies as unsafe by overriding the is_safe()
      method.
    * The framework that we use to test Perl::Critic Policies has been
      packaged into a convenient module that you can use to test your own
      Policies.  See Test::Perl::Critic::Policy and Perl::Critic::TestUtils
      for details.

    Policy Changes
    * BuiltInFunctions::ProhibitLvalueSubstr no longer complains when there
      is a low-precedence operator between the substr() and the assignment
      operator.
    * CodeLayout::ProhibitParensWithBuiltins now allows 'state ($foo)'.  RT
      #52029
    * ErrorHandling::RequireCarping now has an
      allow_in_main_if_not_in_subroutine option to allow "die" directly in
      the default namespace.
    * InputOutput::RequireBriefOpen now recognizes CORE::open(),
      CORE::close(), CORE::GLOBAL::open(), and CORE::GLOBAL::close().  RT
      #52391
    * Modules::ProhibitEvilModules now complains by default about the modules
      deprecated by the Perl 5 Porters in 5.12.
    * Modules::RequireVersionVar documentation updated to make clear that "my
      $VERSION" does not work as a module version declaration.  RT #56667
    * The RegularExpressions::* policies have been converted from using
      Regexp::Parser to using PPIx::Regexp for their heavy lifting.
    * RegularExpressions::ProhibitCaptureWithoutTest now allows capture
      variables inside when() {}.  RT #36081.
    * RegularExpressions::ProhibitUnusedCapture now checks for unused named
      captures.
    * Subroutines::ProhibitManyArgs revised to count only characters in the
      prototype that represent arguments.  RT #56627
    * Subroutines::ProhibitNestedSubs no longer complains about scheduled
      blocks (BEGIN, etc.) inside subroutines and vice versa.
    * Subroutines::RequireFinalReturn should now understand a final given/when
      statement, and declare an error if there is no 'default' block or if any
      branch does not return.
    * TestingAndDebugging::RequireUseStrict now accepts 'use 5.011' or greater
      as equivalent to 'use strict'.
    * ValuesAndExpressions::ProhibitMismatchedOperators false positive with
      "'foo' x 15 . 'bar'".  RT #54524
    * Variables::ProhibitPunctuationVars gave false positives on qr// regexp's
      ending in '$'.  RT #55604

    Bug Fixes:
    * The "## no critic" annotations now respect #line directives.
    * Annotations on statements spanning more than one line (e.g.
            my $foo =
                '$bar'; ## no critic (RequireInterpolationOfMetachars)
      ) are now handled as single-line annotations, not block annotations.
    * All instances of L<Foo> in the POD have been changed to L<Foo|Foo>.
      L</bar> and L<Foo/bar> were allowed to stand.  RT #37485
    * Spaces are now allowed immediately inside the enclosing parentheses in
      "## no critic ( Foo )".  RT #52038
    * With the introduction of PPIx::Regexp, Perl::Critic no longer dies
      when it encounters a Perl 5.010 regexp.  RT #49442.
    * DEVELOPER.pod typo in link to
      ValuesAndExpressions::ProhibitConstantPragma policy. RT #57818
    * Spelling errors in documentation.  RT #57375
    * "die" used instead of "croak".  RT #56619
    * Fixed regex test that caused test failures on every Perl 5.11
      (credit Tom Wyant).
    * t/20_policy_pod_spelling.t now works (or at least no longer fails)
      in non-English locales (again).  RT #43291 and RT #48986.
    * Perldoc hae broken link for McCabe score definition.  RT #53219
    * RT #33935 and #49679 were fixed by upgrading to PPI 1.208

    Other Changes:
    * Perl::Critic::Utils::is_unchecked_call() updated to include chmod in the
      set of things covered by autodie (this happened in autodie v2.08).  The
      primary effect of this is on InputOutput::RequireCheckedSyscalls.
    * Now depends upon Task::Weaken to ensure that we only install with perls
      where Scalar::Util::weaken() works.
    * Email::Address was optional, but is now required.  So everyone
      gets the optimal behavior from RequireInterpolationOfMetachars.
    * Some infrastructure has been extracted to the new PPIx-Utilities
      distro.  It is also a required dependency here.  Over time a good
      portion of Perl::Critic::Utils* will be migrated to this distribution.
    * Perl::Critic::Utils::PPI::get_constant_name_element_from_declaring_statement()
      is deprecated because it doesn't handle multiple constants being
      declared within a single "use constant" statement.  Use
      PPIx::Utilities::Statement::get_constant_name_elements_from_declaring_statement()
      instead.
    * Removed all uses of Perl::Critic::Utils::PPIRegep.  Since the
      PPIx::Regexp update, Perl::Critic only used get_match_string() and
      friends, which were superseded by the corresponding PPI methods.
      Perl::Critic now depends on PPI-1.208 or newer.
    * Moved Perl::Critic::Utils::PPIRegexp to the Perl-Critic-Deprecated.
    * The PolicySummary.pod file is now generated when the distribution
      is created, rather than when you install it.  This ensures the file
      will be available on http://search.cpan.org.  Thanks to Bear Longyear
      for bringing this to our attention.

[1.107_001] Released on 2010-06-20
    Changes summarized into 1.108 above.  For exact details, see Changes on
    BackPAN.

Revision 1.13 / (download) - annotate - [select for diffs], Sun Jun 13 21:38:38 2010 UTC (13 years, 3 months ago) by seb
Branch: MAIN
CVS Tags: pkgsrc-2010Q2-base, pkgsrc-2010Q2
Changes since 1.12: +2 -6 lines
Diff to previous 1.12 (colored)

Update p5-Perl-Critic from version 1.105 to version 1.106.

Pkgsrc changes:
- adjust dependencies wrt to minimum required perl package version

Upstream changes:
[1.106] Released on 2010-05-10

    Bug Fixes:
    * NamingConventions::Capitalization fix for PPI 1.212.  RT #57348

Revision 1.12 / (download) - annotate - [select for diffs], Sat Sep 12 18:43:35 2009 UTC (14 years ago) by sno
Branch: MAIN
CVS Tags: pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)

Updating devel/p5-Perl-Critic from 1.104 to 1.105

Upstream changes:
[1.105] Released on 2009-09-07
    Bug Fixes:
    * Variables::ProhibitPunctuationVars would complain about "%-" appearing
      anywhere in a string.  RT #49016

    Policy Changes:
    * InputOutput::RequireCheckedSyscalls now complains about unchecked "say"
      by default.  RT #37487

Revision 1.11 / (download) - annotate - [select for diffs], Sat Aug 29 23:27:50 2009 UTC (14 years, 1 month ago) by seb
Branch: MAIN
Changes since 1.10: +4 -3 lines
Diff to previous 1.10 (colored)

Update p5-Perl-Critic from version 1.103 to version 1.104.

Pkgsrc changes:
- Adjust/fix dependencies

Upstream changes:
[1.104] Released 2009-08-23

    This release is dedicated to Tom Wyant in appreciation of the amount of
    effort he put into the enhancements and bug fixes in this release, for
    having the patience to wait for the amount of time that it took to get
    them out, and for overall awesomeness.  Thank you, Tom.

    New Policies:
      Objects::ProhibitIndirectSyntax
      ValuesAndExpressions::ProhibitComplexVersion
      ValuesAndExpressions::RequireConstantVersion

    New Optional Requirement:
    * Email::Address, if you want
      ValuesAndExpressions::ProhibitInterpolationOfLiterals to properly ignore
      emaila addresses.

    New Features:
    * Perlcritic will list the names of files with violations if given the
      --files-with-violations option, or the names of files without
      violations if given the --files-without-violations options. These
      have synonyms -l and -L respectively.
    * Perlcritic has a new --list-enabled option, which lists the Policies
      that will be enforced, given the current configuration.  This is
      useful if you've written a complex command-line or modified your
      .perlcriticrc file and you want to see which Policies *would*
      be used with the current configuration, if you were actually going
      to critque a file with it.
    * Perl::Critic::Violation now takes #line directives into account in the
      %F, %f, and %l formats.  You can get the old values via the new %G, %g,
      and %L formats.

    Policy Changes:
    * CodeLayout::ProhibitParensWithBuiltins was complaining in certain cases
      where parentheses are required due to operator precedence.  RT #46862.
    * ControlStructures::ProhibitMutatingListFunctions no longer complains
      about uses of tr/// that don't modify the operand.  Reported by EDAVIS,
      RT #44515.
    * Miscellanea::RequireRcsKeywords now accepts "qw$Keyword: ...$".  RT
      #45196.
    * Modules::RequireFilenameMatchesPackage now respects logical filenames
      defined by the "#line" directives.  This allows the Policy to work
      properly with IDEs and code generators.
    * NamingConventions::Capitalization now allows fully qualified subroutine
      declarations ( e.g. "sub Foo::Bar::baz {...}" ).  However, the
      non-package part of the subroutine name must still conform to whatever
      capitalization rule you have chosen.
    * RegularExpressions::ProhibitCaptureWithoutTest no longer complains if
      the regex is followed by an "or die" or similar.  Reported by EDAVIS,
      RT #36081.
    * RegularExpressions::ProhibitComplexRegexes no longer counts variable
      substitutions in the length.   Reported by EDAVIS, RT #36098.
    * RegularExpressions::ProhibitUnusedCapture now considers the body of
      while loops and not just their condition.  Reported by EDAVIS, RT
      #38942.
    * ValuesAndExpressions::ProhibitInterpolationOfLiterals can now properly
      ignore email addresses if you have Email::Address installed.
    * ValuesAndExpressions::ProhibitVersionStrings was getting confused by
      comments.  Reported by Kevin Ryde,  RT #44986.
    * ValuesAndExpressions::RequireInterpolationOfMetachars now allows sigils
      in the arguments to "use vars".  Contributed by Kevin Ryde, RT #47318.
    * ValuesAndExpressions::RequireInterpolationOfMetachars now properly
      ignores email addesses, if you have Email::Address installed.  Inspired
      by the Kevin Ryde contribution in RT #47318.
    * Variables::ProhibitPunctuationVars gained the ability to look inside
      interpolated strings.  Doing this correctly is challenging and things
      may not work out right; how the policy does this can be controlled via
      the new "string_mode" option.  Contributed by Edgar Whipple
      <perlmonk at misterwhipple dot com>.
    * Variables::ProhibitPunctuationVars now ignores $] by default since there
      is no English.pm equivalent.

    Other Bug Fixes:
    * Perl::Critic::Utils::parse_arg_list() was slurping up the "or die ..."
      portion of "open my $foo, 'somefile' or die ...", causing
      InputOutput::ProhibitTwoArgOpen to not complain about this example.
      Reported by Alexandr Ciornii,  RT #44554.

    Minor Changes
    * The line count emitted by the --statistics option is further broken down
      by line content.

    Minor Documentation Fixes:
    * ValuesAndExpressions::ProhibitInterpolationOfLiterals.  Reported by
      Debian in http://bugs.debian.org/542814,  RT #48936

    Build Fixes:
    * There wasn't a specific version given for the List::MoreUtils dependency
      and we're using features that weren't avialable until 0.19.  So, we now
      require version 0.19.  Noticed by John J. Trammell,  RT #48917.
    * Some tests were tied to the specific "true" and "false" values that some
      functions were returning.  Reported by Michael Schwern,  RT #43910.

    Other News:
    * Komodo version 5.1.1 now has built-in support for Perl-Critic,
      if you have the Perl::Critic and criticism modules installed.
      Both should be available through the ActiveState Perl Package
      Manager ppm(1).

Revision 1.10 / (download) - annotate - [select for diffs], Sun Aug 9 12:50:15 2009 UTC (14 years, 1 month ago) by sno
Branch: MAIN
Changes since 1.9: +5 -3 lines
Diff to previous 1.9 (colored)

Updating package for p5 module Perl::Critic from 1.100 to 1.103

pkgsrc changes:
  - Adjusting dependency information according to META.yml

Upstream changes:
[1.103] Released on 2009-08-03

    Fix configure_require prerequisite on Module::Build 0.34_02.

[1.102] Released on 2009-08-03

    Bug fixes:
    * Works with PPI 1.205.  Yay for 5.10 support!
    * Variables::RequireLexicalLoopIterators didn't work correctly on foreach
      loops with labels.

[1.101_003] Released on 2009-07-22
[1.101_002] Released on 2009-07-21
[1.101_001] Released on 2009-07-21

    Changes summarized into 1.102 above.  For exact details, see Changes on
    BackPAN.

Revision 1.9 / (download) - annotate - [select for diffs], Mon Jul 20 09:49:42 2009 UTC (14 years, 2 months ago) by sno
Branch: MAIN
Changes since 1.8: +11 -4 lines
Diff to previous 1.8 (colored)

pkgsrc changes:
  - Updating package for p5 module Perl::Critic from 1.098 to 1.100
  - removing options for recommended dependencies - require them all
  - Adding license (perl license)

Upstream changes:
[1.100] Released on 2009-07-17

    This is a POD fix release to deal with issues identified by Test::POD
    1.40.  There is no functional difference between this release and 1.098.
    This is the last release of Perl::Critic that will be compatible with PPI
    1.203.  PPI's parsing of for(each)? loops is changing in its next release
    in an incompatible manner and there will be a release in the near future
    to make Perl::Critic compatible with that change.

Revision 1.8 / (download) - annotate - [select for diffs], Tue Mar 10 17:59:46 2009 UTC (14 years, 6 months ago) by sno
Branch: MAIN
CVS Tags: pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1
Changes since 1.7: +6 -3 lines
Diff to previous 1.7 (colored)

PkgSrc changes:

- Updating module to 1.098
- Allow to select recommended dependencies using options framework

Upstream changes:

[1.098] Released on 2009-03-07

    Some Exciting News:
    The Perl Development Kit (PDK 8.0) from ActiveState now includes a
    very slick graphical interface to Perl-Critic.  I highly recommend
    that you check it out.  Here's a link to screenshots and docs:

    http://docs.activestate.com/pdk/8.0/PerlCritic_gui.html

    New Features:
    * Violation coloring is now configurable via command line or profile. The
      profile entries are color-severity-highest, -high, -medium, -low, or
      -lowest. Numbers are accepted in lieu of named severities (e.g.
      'color-severity-5' for 'color-severity-highest'), and 'colour' is
      accepted in lieu of 'color'.
    * Handling of unrecognized policy configuration items is now controlled by
      the profile_strictness. The default is to warn about them. The previous
      default was that they were fatal.
    * -p is now a synonym for --profile.
    * The --verbose option for perlcritic now supports a %C format that will
      displays the class of PPI::Element that caused the violation.

    Policy Changes:
    * ControlStructures::ProhibitNegativeExpressionsInUnlessAndUntilConditions
      didn't include "pbp" in its default themes even though it is derived
      from the book.  Now it does.  :]
    * ErrorHandling::RequireCarping now allows a here document as the last
      element if the "allow_messages_ending_with_newlines" option is true.
    * Fix Subroutines::ProhibitAmpersandSigils so it allows "defined(&x)" as
      well as "defined &x".  Patch from Kevin Ryde, RT #38855.
    * Subroutines::ProtectPrivateSubs now has an "allow" option to specify
      subroutines which are exempt from this policy.  RT #38678.
      Additionally, a "private_name_regex" option has been added that allows
      you to specify what a private subrouting name looks like.
    * Subroutines::RequireArgUnpacking now has an "allow_subscripts" option
      to allow array slices and elements.  RT #34009.
    * Subroutines::RequireArgUnpacking now has an "allow_delegation_to" option
      to allow the usual delegation idiom. Delegation to 'SUPER::' and
      'NEXT::' are allowed by default.  RT #33839.
    * Subroutines::RequireArgUnpacking no longer generates a false positive
      for '$$_[]', which is an obfuscated way of saying '$_->[]'.  RT #37713.
    * ValuesAndExpressions::ProhibitMagicNumbers now has an
      allow_to_the_right_of_a_fat_comma option, which defaults to true.  Note
      that it currently only works /directly/ to the right of a fat comma.
    * Variables::ProhibitMatchVars had its default themes changed to "core
      performance pbp", instead of "core bugs pbp" because, while the match
      variables make regular expressions slow, it doesn't cause them to not
      work correctly.
    * Variables::ProhibitPackageVars has had FindBin and Log::Log4perl added
      to the default exemptions.
    * Variables::ProhibitReusedNames now has an "allow" option to specify
      names that can be reused.  It defaults to enabling $self and $class.  RT
      #42767.
    * Variables::RequireLocalizedPunctuationVars has a customizable set of
      exemptions via the "allow" option.

    New Developer Features:
    * The guts of perlcritic have been moved to Perl::Critic::Command.  You
      can invoke Perl::Critic::Command::run() to get the equivalent of running
      the command.  (Note, however, this interface WILL change, so don't count
      on the current one.)
    * Modules have had a "INTERFACE SUPPORT" section added which states
      whether the Perl::Critic developers consider the particular module is
      public or not.  Any removal of functionality from a public module will
      go through a deprecation cycle.  Non-public modules may have their
      interfaces changed without notice.
    * P::C::Policy now has an is_enabled() method.
    * P::C::Violation now has an element_class() method.

    Bug Fixes:
    * CodeLayout::ProhibitTrailingWhitespace didn't notice cases where PPI
      would produce instances of PPI::Token::Whitespace that contained
      multiple lines.
    * Subroutines::ProtectPrivateSubs no longer regards the exportable POSIX
      subroutines whose names begin with underscore as private.  RT #38678.
    * Subroutines::RequireArgUnpacking mishandled a complicated sitation with
      $_ being an array reference.  RT #39601.
    * Variables::RequireLocalizedPunctuationVars now applies to subscripted
      names.  RT #29384.

    Internals:
    * The guts of Build.PL and Makefile.PL have been rearranged.

[1.097_002] Released on 2009-03-01
[1.097_001] Released on 2009-03-01

    Changes summarized into 1.098 above.  For exact details, see Changes on
    BackPAN.

[1.096] Released on 2009-02-01

    New Policies:
    * ValuesAndExpressions::ProhibitSpecialLiteralHeredocTerminator

    Policy Changes:
    * Documentation::PodSpelling now has a stop_words_file option.
    * Modules::ProhibitEvilModules now has a modules_file option.

    Bug Fixes:
    * ErrorHandling::RequireCarping will now allow a literal newline
      as well as "\n".  Fixed by Kyle Hasselbacher, RT #25046
    * Fix InputOutput::ProhibitTwoArgOpen so it allows '-|' or '|-' as the
      second of two arguments.  Patches from Kyle Hasselbacher and Leland
      Johnson, RT #42384.
    * InputOutput::RequireBracedFileHandleWithPrint applies to printf as well
      as print.  Fixed by Kyle Hasselbacher, RT #42537.
    * TestingAndDebugging::RequireUseStrict and
      TestingAndDebugging::RequireUseWarnings are no longer fooled by a
      block-scoped pragma.  RT #42310.
    * ValuesAndExpressions::RequireInterpolationOfMetachars allows for escaped
      backslashes.  Fixed by Tom Wyant, RT #38530.
    * Fix for problem in P::C::Document in dealing with underscores in
      expressions like "use 5.009_001".  Patch by Kevin Ryde, RT #36570 and
      #42089.
    * Fix in extras/perlcritic.el for a radio button.  Patch by Kevin Ryde, RT
      #42190.
    * Fix distclean target in Makefile.PL.  Patch by Richard Soderberg,
      RT #42088.
    * Fix temporary files not being cleaned up after tests.  Patch by Kyle
      Hasselbacher, RT #41443.
    * Deal with changes in Pod::Parser v1.36 in test in t/05_utils_pod.t.

    Documentation improvements contributed by Mark Grimes in response to RT
    #41942.

[1.095_001] Released on 2009-01-18

    Changes summarized into 1.096 above.  For exact details, see Changes on
    BackPAN.

Oked by rhaen@

Revision 1.7 / (download) - annotate - [select for diffs], Sun Jan 4 23:06:29 2009 UTC (14 years, 9 months ago) by he
Branch: MAIN
Changes since 1.6: +4 -3 lines
Diff to previous 1.6 (colored)

Update from version 1.092 to 1.094.001 (upstream 1.094001).

Pkgsrc changes:
 o Change to Module::Build

Upstream changes:

[1.094001] Released on 2009-01-01

    Bug Fixes:
    * Tests would fail on systems without Regexp::Parser installed.

[1.094] Released on 2009-01-01

    Incompatible Changes:
    * The way that "## no critic" markers was refactored.  As
      a result, we discovered that the syntax for the markers was pretty
      vague.  If you didn't do it just right, it would disable all policies,
      and not just the specific ones that you wanted.  So we've tightened this
      up a bit.  If you followed the examples that have been in the docs for
      the last couple years, then you should be fine.  But if you've been
      using certain other variations in your "## no critic" markers, then you
      might suddenly find yourself violating the new
      ProhibtUnrestrictedNoCritic policy.  To fix this, just make sure your
      Policy names appear in parentheses:

        ## no critic Foo, Bar, Baz     # wrong!
        ## no critic Foo Bar Baz       # wrong!


        ## no critic (Foo, Bar, Baz)   # ok!
        ## no critic qw(Foo Bar Baz)   # also ok!

    * The deprecated $FORMAT variables for Perl::Critic::Policy and
      Perl::Critic::Violation no longer exist.  Use the corresponding
      get_format() and set_format() functions instead.

    New Policies:
    * Miscellanea::ProhibitUnrestrictedNoCritic
    * Miscellanea::ProhibitUselessNoCritic
    * NamingConventions::Capitalization
    * Subroutines::ProhibitReturnSort
    * Variables::ProhibitReusedNames

    Removed Policies:
    * NamingConventions::ProhibitMixedCaseSubs and
      NamingConventions::ProhibitMixedCaseVars have been moved to a separate
      Perl-Critic-Deprecated distribution.  The
      NamingConventions::Capitalization policy does everything they do, plus
      more.

    Policy Changes:
    * BuiltinFunctions::ProhibitStringyEval now has an allow_includes option
      that makes it behave (mostly) like Ricardo SIGNES'
      Perl::Critic::Policy::Lax::ProhibitStringyEval::ExceptForRequire.
    * InputOutput::RequireCheckedClose, InputOutput::RequireCheckedOpen, and
      InputOutput::RequireCheckedSyscalls now all support autodie.
      Unfortunately, autodie is currently treated like a module and not a
      pragma, which means that the lexical scoping is not taken into account.
    * InputOutput::RequireCheckedSyscalls now has an exclude_functions
      parameter.
    * Modules::ProhibitEvilModules now allows you to specify what the
      description of a use of a bad module should be, to, say, suggest that
      people use autodie instead of Fatal.
    * Subroutine::ProhibitExcessComplexity violation descriptions now include
      the name of the subroutine, thanks to Andreas Koenig, RT #40070.
    * TestingAndDebugging::RequireUseStrict and
      TestingAndDebugging::RequireUseWarnings now have equivalent_modules
      parameters that allow you to designate other modules as being equivalent
      to the strict and warnings pragmata.  This one is for all you Moose fans
      out there.  :]

    Bug Fixes:
    * ControlStructures::ProhibitUnreachableCode would treat package
      statements as unreachable.  Fixed by Kevin Ryde.  RT #41734
    * Fix warning from InputOutput::ProhibitOneArgSelect when select was
      called with no arguments.  RT #41926
    * Miscellanea::RequireRcsKeywords couldn't find keywords after __END__
      that didn't look like part of POD.
    * Modules::RequireFilenameMatchesPackage would incorrectly complain about
      programs.  Yet more greatness contributed by Schwern.  RT #39024.
    * If a perlcriticrc file referred to a policy that wasn't installed and
      the profile-strictness option was set to "fatal",
      Perl::Critic::PolicyFactory fell over instead of reporting the
      problematic policy name.

    Miscellanea:
    * Perl::Critic::Violation will automatically strip trailing periods
      from your Policy description and explanation strings.  This ensures that
      the punctuation is consistent with the format specified by the user via
      the -verbose formatting options.

    New Developer Features:
    * Perl::Critic::Policy::prepare_to_scan_document() is now checked and a
      Policy can disable itself for just a single document, which can speed
      things up.

[1.093_03] Released on 2008-12-11
[1.093_02] Released on 2008-10-30
[1.093_01] Released on 2008-09-07

    Changes summarized into 1.094 above.  For exact details, see Changes in
    1.093_003 on BackPAN.

Revision 1.6 / (download) - annotate - [select for diffs], Mon Nov 17 04:49:00 2008 UTC (14 years, 10 months ago) by he
Branch: MAIN
CVS Tags: pkgsrc-2008Q4-base, pkgsrc-2008Q4
Changes since 1.5: +5 -6 lines
Diff to previous 1.5 (colored)

Update from version 1.090nb1 to 1.092.

Pkgsrc changes:
 o Re-order DEPENDS to match META.yml from package

Upstream changes:

[1.092] Released on 2008-09-02

    Bug Fixes:
    * Fixed POD errors that were causing build failures.  Sorry
      about that.

[1.091] Released on 2008-09-01

    New Policies:
    * RegularExpressions::RequireDotMatchAnything

    New Features:
    * perlcritic now supports a -pager option, so you can more easily
      send the output to your favorite pager.  You can set this option
      on the command-line or in your .perlcriticrc file.  See the
      perlcritic perldoc for more details.  Credit to Michael Schwern.
    * The output from "perlcritic -doc PATTERN" will be automatically
      sent to your pager if you have set the -pager option.

    Policy Changes:
    * CodeLayout::ProhibitQuotedWordLists no longer applies if the list
      contains any non-words, by default.  A non-word is anything that does
      not match /[\w-]+/.  You can restore the former behavior by setting the
      "strict" option.  RT #37886.
    * CodeLayout::ProhibitQuotedWordLists also now applies to the import
      arguments of a C<use> statement.  RT #24467.
    * ErrorHandling::RequireCheckingReturnValueOfEval now recognizes ternary
      left-sides as valid checks.
    * RegularExpressions::RequireExtendedFormatting gains a
      minimum_regex_length_to_complain_about option.  Also, regexes that
      contain only word and whitespace characters are now exempt from this
      policy, by default; you can make it complain about them by turning on
      the new strict option.  Contributed by Michael Schwern.  RT #38531.
    * TestingAndDebugging::ProhibitNoWarnings now supports a
      allow_with_category_restriction option, thanks to Michael Schwern.
      RT #38514.
    * CodeLayout::ProhibitHardTabs now allows leading tabs in qw() word lists
      and regexes with the /x modifier.  You can still configure this
      policy to forbid all hard tabs, if you like.  RT #32440

    Bug Fixes:
    * perlcritic should now work under PAR.  RT #38380.
    * URL for our repository in META.yml now works for anonymous
      checkout.  The password is "" (empty).  RT #38628.
    * color for high-severity violations is now magenta because
      it is more redable than yellow on white backgrounds.  RT #38511.

Revision 1.5 / (download) - annotate - [select for diffs], Sun Oct 19 19:17:58 2008 UTC (14 years, 11 months ago) by he
Branch: MAIN
Changes since 1.4: +2 -1 lines
Diff to previous 1.4 (colored)

Bump the PKGREVISION for all packages which depend directly on perl,
to trigger/signal a rebuild for the transition 5.8.8 -> 5.10.0.

The list of packages is computed by finding all packages which end
up having either of PERL5_USE_PACKLIST, BUILDLINK_API_DEPENDS.perl,
or PERL5_PACKLIST defined in their make setup (tested via
"make show-vars VARNAMES=...").

Revision 1.4 / (download) - annotate - [select for diffs], Fri Aug 15 16:57:07 2008 UTC (15 years, 1 month ago) by seb
Branch: MAIN
CVS Tags: pkgsrc-2008Q3-base, pkgsrc-2008Q3, cube-native-xorg-base, cube-native-xorg
Changes since 1.3: +2 -1 lines
Diff to previous 1.3 (colored)

The Perl 5 module 'version' is required by the current version
this package hence add a dependency on the p5-version package.

Revision 1.3 / (download) - annotate - [select for diffs], Mon Aug 11 14:46:24 2008 UTC (15 years, 1 month ago) by he
Branch: MAIN
Changes since 1.2: +5 -3 lines
Diff to previous 1.2 (colored)

Update from version 1.051 to 1.090.

Pkgsrc changes:
 o Adjust dependencies to match new requirements

Upstream changes:

[1.090] Released on 2008-07-22

    Bug Fixes:
    * Test was incorrectly failing when Regexp::Parser wasn't installed.

[1.089] Released on 2008-07-21

    Minor Enhancements:
    * -s is now a synonym for --single-policy.

    Policy Changes:
    * Subroutines::ProhibitBuiltinHomonyms now also prohibits subroutines
      with the same name as a Perl keyword (e.g. if, foreach, while).
      Inspired by RT #37632.
    * Subroutines::ProtectPrivateSubs now allows expressions like
      "shift->_some_private_method();".  Note that this *only* applies
      to the "shift" function -- a private method call on the right of any
      other bareword still causes a violation.  RT #34713.
    * Subroutines::RequireFinalReturn now includes exec in the set of things
      that mark a successful return.  RT #37672
    * ValuesAndExpressions::ProhibitInterpolationOfLiterals now takes a
      allow_if_string_contains_single_quote option.  Contributed by Ed
      Avis <ed@membled.com>.  RT #36125.
    * ValuesAndExpressions::RequireInterpolationOfMetachars now supports a
      rcs_keywords option to allow for the common case where those require
      dollar signs.

    Bug Fixes:
    * BuiltinFunctions::ProhibitSleepViaSelect would complain if there were
      three undefs as arguments to select(), but one of them was the timeout.
      RT #37416.
    * Reduced false positives in
      RegularExpressions::ProhibitSingleCharAlternation.  Thanks to
      Andy Lester and Elliot Shank test cases.
    * RegularExpressions::ProhibitUnusedCapture would complain if there were
      multiple captures used in a substitution, e.g. s/(.)(.)/$2$1/.
    * Subroutines::ProhibitAmpersandSigils no longer complains about
      "sort &foo(...)".
    * Makefile.PL, Build.PL and other ".PL" scripts which typically do not
      have a shebang are no longer mistaken as modules.  This prevents
      spurious warnings from Modules::RequireEndWithOne.  RT #20481.

    Internals:
    * Tests are now self compliant.

[1.088] Released on 2008-07-04

    New Policies
    * ErrorHandling::RequireCheckingReturnValueOfEval

    Policy Changes:
    * ValuesAndExpressions::ProhibitLeadingZeros now accepts octal numbers
      for the Unix permissions argument to chmod, dbmopen, mkdir, sysopen, or
      umask, by default.  Use the "strict" option to get the old behavior.
      RT #31977.
    * Due to the consensus at YAPC::NA 2008,
      Variables::ProhibitUnusedVariables default severity has been raised to
      medium/3.

    Minor Changes:
    * The perlcritic "--Version" option is now "--version" in order to act
      like the rest of the world.

[1.087] Released on 2008-06-21

    Policy Changes:
    * CodeLayout::ProhibitParensWithBuiltins no longer complains about
      sort(foo(@x)).
    * TestingAndDebugging::RequireUseWarnings will not complain about files
      that contain a "use 5.005" statement or similar for perls prior to 5.6.
      Lesson of the day: computer conferences where you can meet in the real
      world can clarify conversations greatly.  Good to finally meet you Adam.
    * InputOutput::ProhibitTwoArgOpen similarly will not complain if there's
      a "use/require 5.005" statement in the file.  RT #34385.

    Bug fixes:
    * Perl::Critic can now critique a file named "0".  However, PPI will give
      a parse error until the next version comes out.  Fixes RT #36127.
    * Moved detection of the lack of any enabled Policies from P::C::Config
      to Perl::Critic.  This was causing the perlcritic.t in Parrot to fail.
      Note, however, there are plans afoot to change how Perl::Critic is
      configured and things that depend upon that may break.  Please contact
      users@perlcritic.tigris.org and tell us how you're using P::C::Config
      directly so that we can take your needs into account.

[1.086] Released on 2008-06-12

    Policy Changes:
    * NamingConventions::ProhibitAmbiguousNames now specifies the name that
      it had problems with in its violation descriptions.

    Bug fixes:
    * The color option wasn't being correctly set from a .perlcriticrc.
      RT #36569.

    Minor changes:
    * --colour is now a synonym for --color.

[1.085] Released on 2008-06-07

    New Policies:
    * Documentation::RequirePackageMatchesPodName

    Policy Changes:
    * Variables::ProhibitUnusedVariables detects a few more cases.  It's
      still very limited, though.

    Bug fixes:
    * ControlStructures::ProhibitUnreachableCode didn't notice "until" was an
      conditional expression.

    Minor documentation updates.

[1.084] Released on 2008-05-24

    New Features:
    * perlcritic now supports a --list-themes option.
    * You can specify the maximum number of violations you want per Policy
      per document.  Developers can give a default value for this for a
      Policy by overriding default_maximum_violations_per_document().
      See RequireUseStrict and ProhibitMagicNumbers for examples.

    Policy Moved:
    * The ValuesAndExpressions::ProhibitMagicNumbers policy has been moved
      from Perl::Critic::More into the primary Perl::Critic distribution.

    New Policies:
    * Variables::ProhibitUnusedVariables (very dumb, limited initial
      implementation.)
    * ControlStructures::ProhibitLabelsWithSpecialBlockNames
      Contributed by Mike O'Regan.  Kickin' ass, Mike.

    Policy Changes:
    * ControlStructures::ProhibitUnreachableCode now handles the perl 5.10
      "//" and "err" operators.  RT #36080
    * InputOutput::RequireBriefOpen now ignores opens of STDIN, STDOUT,
      and STDERR.  You're generally trying to make long-lasting global
      effects when manipulating these.  (RT #35774)
    * RegularExpressions::ProhibitUnusualDelimiters now supports an
      "allow_all_brackets" option.
    * RegularExpressions::RequireBracesForMultiline now supports an
      "allow_all_brackets" option.
    * TestingAndDebugging::RequireUseStrict now accepts "use Moose::Role"
      as equivalent to "use strict".  (RT #34838)
    * TestingAndDebugging::RequireUseWarnings now accepts "use Moose::Role"
      as equivalent to "use warnings".  (RT #34838)
    * ValuesAndExpressions::ProhibitMagicNumbers now accepts constant
      subroutines.
    * Variables::ProhibitMatchVars no longer detects "use English;".
      This problem is detected in a more clear way by
      Modules::RequireNoMatchVarsWithUseEnglish.
    * Variables::ProhibitPerl4PackageNames no longer complains about
      $'/$POSTMATCH.  RT #36059
    * Variables::RequireLocalizedPunctuationVars now allows the use of "my".
      RT #33937

    Bug Fixes:
    * No longer falls over if a single file has a parse error.

    New Developer Features:
    * If a document specifies a minimum perl version, e.g. "use 5.008003",
      P::C::Document::highest_explicit_perl_version() will tell you what it
      is.
    * The parameter to P::C::Policy::initialize_if_enabled is now a
      P::C::PolicyConfig object instead of a hash reference.

    Minor Changes:
    * LOTS of documentation updates.
    * A few more statistics are emitted by perlcritic with the --statistics
      option.
    * perlcritic --profile-proto now includes policy abstracts in its
      output.

    Prerequisites:
    * Now depends upon PPI 1.203.
    * New dependency upon version.

[1.083_006] Released on 2008-05-20
[1.083_005] Released on 2008-05-19
[1.083_004] Released on 2008-05-18
[1.083_003] Released on 2008-05-17
[1.083_002] Released on 2008-05-17
[1.083_001] Released on 2008-04-13

    Changes summarized into 1.084 above.  For exact details, see Changes in
    1.083_006 on BackPAN.

[1.082] Released on 2008-03-08

    New Features:
    * A new metadata system for defining policy parameters/options has been
      added.  This makes the life of policy authors easier because
      configuration validation and parsing can be taken care of
      automatically, in most cases.  This allows greater integration with
      IDEs and allows the perlcritic "--profile-proto" option to produce
      better output.

      Note: This change does NOT REQUIRE ANY CHANGES to policies outside of
      this distribution; they should continue to work as is.  However, use
      of this facility can reduce the size of your code and provide the
      means for tools to discover more about your policy.  If this change
      does break any of your policies, please let us know.

      To learn how to take advantage of this facility, read
      Perl::Critic::DEVELOPER and look at the source of any of the
      configurable policies included in this distribution.

      There is a discussion of the design considerations for this facility in
      the source repository under doc/PolicyParameter_Notes.pod.

    * Added support for "criticism-fatal" option in your perlcriticrc
      file.  This will be used by the criticism pragma to cause execution
      to abort if the file contains any violations.

    New Policy:
    * Module::RequireNoMatchVarsWithUseEnglish

    Policy Changes:
    * Added an allow_last_statement_to_be_comma_separated_in_map_and_grep
      option to ValuesAndExpressions::ProhibitCommaSeparatedStatements.
      Partial response to http://rt.cpan.org/Public/Bug/Display.html?id=27654.
    * ControlStructures::ProhibitPostfixControls gains the ability to have
      the flow control statements allowed to be modified.  This in response
      to RT #29540.
    * TestingAndDebugging::RequireUseStrict now accepts "use Moose" as
      equivalent to "use strict".
    * TestingAndDebugging::RequireUseWarnings now accepts "use Moose" as
      equivalent to "use warnings".

    Bug Fixes:
    * RT #31281 perlcritic doesn't recognize "#!/bin/env perl" shebang
    * Replace usage of Unicode property escapes with POSIX character classes
      order to restore 5.6 compatability.
    * RT #30388 ValuesAndExpressions::ProhibitVersionStrings complained
      about numbered directories in "use lib".
    * Fixed handling of badly behaved spelling programs in PodSpelling.

[1.081_006] Released on 2008-03-02
[1.081_005] Released on 2007-12-29
[1.081_004] Released on 2007-12-20
[1.081_003] Released on 2007-12-16
[1.081_002] Released on 2007-12-16
[1.081_001] Released on 2007-12-15

    Changes summarized into 1.082 above.  For exact details, see Changes in
    1.081_006 on BackPAN.

[1.080] Released on 2007-11-11

    New Features:
    * Allow a "## no critic" statement after a shebang on line 1 of a
      file.  This allows users to block violations that apply to
      whole files and still allow shebangs.

    New Policies: (funded by a Perl Foundation grant)
    * InputOutput::ProhibitExplicitStdin
    * RegularExpressions::ProhibitFixedStringMatches
    * RegularExpressions::RequireBracesForMultiline
    * RegularExpressions::ProhibitUnusualDelimiters
    * RegularExpressions::ProhibitUnusedCapture
    * RegularExpressions::ProhibitComplexRegexes
    * RegularExpressions::ProhibitSingleCharAlternation
    * RegularExpressions::ProhibitEscapedMetacharacters
    * RegularExpressions::ProhibitEnumeratedClasses
    * InputOutput::RequireBriefOpen
    * InputOutput::RequireCheckedSyscalls

    Other New Policies
    * ControlStructures::ProhibitNegativeExpressionsInUnlessAndUntilConditions

    Policy Changes:
    * Variables::ProhibitConditionalDeclarations now permits you to local-ize
      variables in conditional declarations.  This makes sense, since
      C<local> is actually a variable modifier, rather than a declaration.
      Thanks to David Golden for reporting this.

    New Developer Features:
    * Perl::Critic::Utils::PPIRegexp encapsulates interaction with
      the PPI Regexp token classes.  Those classes have very sparse
      APIs, so this package hides away the ugly fiddling with PPI
      internals.
    * Added a new optional_modules parameter for the .run syntax.

    Bug fixes:
    * PPI::Structure::List can now contain multiple children,
      so P::C::Utils::parse_arg_list() needs to handle it.

      This was done in the process of fixing
      http://rt.cpan.org/Ticket/Display.html?id=24924, which was a problem
      with TestingAndDebugging::RequireTestLabels.

    * ValuesAndExpressions::ProhibitLongChainsOfMethodCalls wasn't resetting
      chain length when it ran into the end of a sub-expression.

      http://rt.cpan.org/Public/Bug/Display.html?id=30040

    * ValuesAndExpressions::ProhibitCommaSeparatedStatements was reporting
      false positives when builtins which accept both no and multiple
      arguments were involved.

      http://rt.cpan.org/Public/Bug/Display.html?id=27654

    Internals:
    * Removed all use of Carp in favor of exceptions.

    Prerequisites:
    * Now requires PPI 1.201.  A number of workarounds for PPI bugs have been
      removed.
    * New dependency upon Exception::Class.

    Installation:
    * Use Devel::CheckOS to see whether Perl::Critic is being installed on
      a Solaris system and warn about tar(1) chopping file names off if it
      is.

[1.079_003]  Released on 2007-10-22
[1.079_002]  Released on 2007-10-21
[1.079_001]  Released on 2007-10-09

    Changes summarized into 1.080 above.  For exact details, see Changes in
    1.079_003 on BackPAN.

[1.078]  Released on 2007-09-19

    Restore Perl::Critic::TestUtils::should_skip_author_tests() and
    get_author_test_skip_message().  Some Perl::Critic add-on distributions
    are using them.

[1.077]  Released on 2007-09-15

    Note: if you don't have any problems installing Perl::Critic 1.076, there
    is no need to upgrade to this version.  There are no functionality
    changes.  This release only contains changes related to installation that
    a few people were experiencing.

    Minor changes:
    * Removed build-time use of Readonly, again, due to problems some people
      were having when trying to compile the code by hand, rather than using
      CPAN(PLUS)?.
    * Don't run author tests if there's a .svn directory present because
      users who grabbed the code from the source repository were executing
      them and getting failures.
    * Don't generate optional, module-hiding test wrappers if author tests
      are not enabled.


[1.076]  Released on 2007-09-07

    It appears from reports on the 1.075_001 release that the subroutine
    sigils were indeed the problem.  Release to the general populace.


[1.075_001]  Released on 2007-09-06

    Bug Fixes:
    Undo the changes in 1.073 and 1.074.  Instead, stop using the subroutine
    sigil in import and export lists.  It is suspected that the problem lies
    with Exporter stripping off ampersands.

[1.074]  Released on 2007-09-04

    Bug Fixes:
    Repeat the Makefile.PL change on
    t/generate_without_optional_dependencies_wrappers.PL.
    I love CPAN Testers.

[1.073]  Released on 2007-09-04

    Bug Fixes:
    Work around problems with the combination of Exporter & Readonly in
    Makefile.PL on some machines.

[1.072]  Released on 2007-09-03

    Bug Fixes:
    * The Makefile generated by Makefile.PL was not syntactically correct
      according to some versions of Solaris.  Thanks to Diab Jerius
      (DJERIUS) for discovery and testing.
    * Fixed mis-definition of "quiet" value for the "--profile-strictness"
      option.
    * Enhanced testing with the absence of optional modules.

[1.071]  Released on 2007-08-24

    The "Brown Paper Bag" Release

    Bug Fixes:
    * Tests would not pass in environments that did not have all optional
      dependencies installed.

Revision 1.2 / (download) - annotate - [select for diffs], Thu Jun 12 02:14:25 2008 UTC (15 years, 3 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper
Changes since 1.1: +3 -1 lines
Diff to previous 1.1 (colored)

Add DESTDIR support.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Sun Apr 22 21:04:36 2007 UTC (16 years, 5 months ago) by seb
Branch: TNF
CVS Tags: pkgsrc-base, pkgsrc-2008Q1-base, pkgsrc-2008Q1, pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3, pkgsrc-2007Q2-base, pkgsrc-2007Q2
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Initial import of p5-Perl-Critic version 1.051 into The NetBSD
Packages Collection.

The Perl 5 module Perl::Critic is an extensible framework for
creating and applying coding standards to Perl source code.

Essentially, it is a static source code analysis engine. Perl::Critic
is distributed with a number of Perl::Critic::Policy modules that
attempt to enforce various coding guidelines. Most Policy modules
are based on Damian Conway's book Perl Best Practices. However,
Perl::Critic is not limited to PBP and will even support Policies
that contradict Conway. You can enable, disable, and customize
those Polices through the Perl::Critic interface. You can also
create new Policy modules that suit your own tastes.
A front-end script, perlcritic, is provided.

Revision 1.1 / (download) - annotate - [select for diffs], Sun Apr 22 21:04:36 2007 UTC (16 years, 5 months ago) by seb
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>