[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / p5-Moose

File: [cvs.NetBSD.org] / pkgsrc / devel / p5-Moose / Makefile (download)

Revision 1.34, Thu Nov 19 21:21:53 2009 UTC (14 years, 4 months ago) by seb
Branch: MAIN
CVS Tags: pkgsrc-2009Q4-base, pkgsrc-2009Q4
Changes since 1.33: +2 -2 lines

Update p5-Moose from version 0.92 to version 0.93.

Upstream changes:
0.93 Thu, Nov 19, 2009
    * Moose::Object
      - Calling $object->new() is no longer deprecated, and no longer
        warns. (doy)

    * Moose::Meta::Role
      - The get_attribute_map method is now deprecated. (Dave Rolsky)

    * Moose::Meta::Method::Delegation
      - Preserve variable aliasing in @_ for delegated methods, so that
        altering @_ affects the passed value. (doy)

    * Moose::Util::TypeConstraints
      - Allow array refs for non-anonymous form of enum and duck_type, not
        just anonymous. The non-arrayref forms may be removed in the
        future. (doy)
      - Changed Str constraint to not accept globs (*STDIN or *FOO). (chansen)
      - Properly document Int being a subtype of Str. (doy)

    * Moose::Exporter
      - Moose::Exporter using modules can now export their functions to the
        main package. This applied to Moose and Moose::Role, among
        others. (nothingmuch)

    * Moose::Meta::Attribute
      - Don't remove attribute accessors we never installed, during
        remove_accessors. (doy)

    * Moose::Meta::Attribute::Native::Trait::Array
      - Don't bypass prototype checking when calling List::Util::first, to
        avoid a segfault when it is called with a non-code argument. (doy)

    * Moose::Meta::Attribute::Native::Trait::Code
      - Fix passing arguments to code execute helpers. (doy)

# $NetBSD: Makefile,v 1.34 2009/11/19 21:21:53 seb Exp $
#

DISTNAME=	Moose-0.93
PKGNAME=	p5-${DISTNAME}
CATEGORIES=	devel perl5
MASTER_SITES=	${MASTER_SITE_PERL_CPAN:=Test/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://moose.perl.org/
COMMENT=	Postmodern object system for Perl 5
LICENSE=	${PERL5_LICENSE}

DEPENDS+=	p5-Class-MOP>=0.94:../../devel/p5-Class-MOP
DEPENDS+=	p5-Data-OptList-[0-9]*:../../devel/p5-Data-OptList
DEPENDS+=	p5-List-MoreUtils>=0.12:../../devel/p5-List-MoreUtils
DEPENDS+=	p5-Sub-Exporter>=0.980:../../devel/p5-Sub-Exporter
DEPENDS+=	p5-Sub-Name-[0-9]*:../../devel/p5-Sub-Name
DEPENDS+=	p5-Task-Weaken-[0-9]*:../../devel/p5-Task-Weaken
DEPENDS+=	p5-Try-Tiny>=0.02:../../devel/p5-Try-Tiny

BUILD_DEPENDS+=	p5-DBM-Deep-[0-9]*:../../databases/p5-DBM-Deep
BUILD_DEPENDS+=	p5-DateTime-Calendar-Mayan-[0-9]*:../../time/p5-DateTime-Calendar-Mayan
BUILD_DEPENDS+=	p5-DateTime-Format-MySQL-[0-9]*:../../time/p5-DateTime-Format-MySQL
BUILD_DEPENDS+=	p5-Declare-Constraints-Simple-[0-9]*:../../devel/p5-Declare-Constraints-Simple
BUILD_DEPENDS+=	p5-IO-String-[0-9]*:../../devel/p5-IO-String
BUILD_DEPENDS+=	p5-Locale-US-[0-9]*:../../misc/p5-Locale-US
BUILD_DEPENDS+=	p5-Module-Refresh-[0-9]*:../../devel/p5-Module-Refresh
BUILD_DEPENDS+=	p5-Params-Coerce-[0-9]*:../../devel/p5-Params-Coerce
BUILD_DEPENDS+=	p5-Regexp-Common-[0-9]*:../../textproc/p5-Regexp-Common
BUILD_DEPENDS+=	p5-Test-Deep-[0-9]*:../../devel/p5-Test-Deep
BUILD_DEPENDS+=	p5-Test-Exception>=0.27:../../devel/p5-Test-Exception
BUILD_DEPENDS+=	p5-Test-Output-[0-9]*:../../devel/p5-Test-Output
BUILD_DEPENDS+=	p5-Test-Pod-Coverage-[0-9]*:../../devel/p5-Test-Pod-Coverage
BUILD_DEPENDS+=	p5-Test-Pod-[0-9]*:../../devel/p5-Test-Pod
BUILD_DEPENDS+=	p5-Test-Simple>=0.88:../../devel/p5-Test-Simple
BUILD_DEPENDS+=	p5-URI-[0-9]*:../../www/p5-URI
BUILD_DEPENDS+=	p5-libwww-[0-9]*:../../www/p5-libwww

PKG_DESTDIR_SUPPORT=	user-destdir

USE_LANGUAGES=	# empty
PERL5_PACKLIST=	auto/Moose/.packlist

# keep bundled Module::Install - it's modified
MAKE_PARAMS+=		--skipdeps
#PERL5_MODULE_TYPE=	Module::Install

.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"