[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / p5-Moose

File: [cvs.NetBSD.org] / pkgsrc / devel / p5-Moose / Makefile (download)

Revision 1.21, Sat May 2 21:33:17 2009 UTC (14 years, 11 months ago) by seb
Branch: MAIN
Changes since 1.20: +2 -2 lines

Update p5-Moose from version 0.76 to version 0.77.

Pkgsrc changes:
- Adjust dependency on p5-Class-MOP

Upstream changes:
0.77 Sat, May 2, 2009
    * Moose::Meta::Role
      - Add explicit use of Devel::GlobalDestruction and Sub::Name
        (perigrin)

    * Moose::Object
      - Pass a boolean to DEMOLISHALL and DEMOLISH indicating whether
        or not we are currently in global destruction (doy)
      - Add explicit use of Devel::GlobalDestruction and Sub::Name
        (perigrin)

    * Moose::Cookbook::FAQ
      - Reworked much of the existing content to be more useful to
        modern Moose hackers (Sartak)

    * Makefile.PL
      - Depend on Class::MOP 0.83 instead of 0.82_01. It seems that if
        we use a dev version number there CPAN.pm will not follow the
        dependency.

# $NetBSD: Makefile,v 1.21 2009/05/02 21:33:17 seb Exp $
#

DISTNAME=	Moose-0.77
PKGNAME=	p5-${DISTNAME}
CATEGORIES=	devel perl5
MASTER_SITES=	${MASTER_SITE_PERL_CPAN:=Test/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://moose.perl.org/
COMMENT=	Postmodern object system for Perl 5
LICENSE=	artistic-2.0

DEPENDS+=	p5-Class-MOP>=0.82:../../devel/p5-Class-MOP
DEPENDS+=	p5-Data-OptList-[0-9]*:../../devel/p5-Data-OptList
DEPENDS+=	p5-List-MoreUtils>=0.12:../../devel/p5-List-MoreUtils
DEPENDS+=	p5-Sub-Exporter>=0.972:../../devel/p5-Sub-Exporter
DEPENDS+=	p5-Task-Weaken-[0-9]*:../../devel/p5-Task-Weaken

BUILD_DEPENDS+=	p5-DBM-Deep-[0-9]*:../../databases/p5-DBM-Deep
BUILD_DEPENDS+=	p5-DateTime-Format-MySQL-[0-9]*:../../time/p5-DateTime-Format-MySQL
BUILD_DEPENDS+=	p5-Declare-Constraints-Simple-[0-9]*:../../devel/p5-Declare-Constraints-Simple
BUILD_DEPENDS+=	p5-IO-String-[0-9]*:../../devel/p5-IO-String
BUILD_DEPENDS+=	p5-Locale-US-[0-9]*:../../misc/p5-Locale-US
BUILD_DEPENDS+=	p5-Module-Refresh-[0-9]*:../../devel/p5-Module-Refresh
BUILD_DEPENDS+=	p5-Params-Coerce-[0-9]*:../../devel/p5-Params-Coerce
BUILD_DEPENDS+=	p5-Regexp-Common-[0-9]*:../../textproc/p5-Regexp-Common
BUILD_DEPENDS+=	p5-Test-Deep-[0-9]*:../../devel/p5-Test-Deep
BUILD_DEPENDS+=	p5-Test-Exception>=0.21:../../devel/p5-Test-Exception
BUILD_DEPENDS+=	p5-Test-Output-[0-9]*:../../devel/p5-Test-Output
BUILD_DEPENDS+=	p5-Test-Pod-Coverage-[0-9]*:../../devel/p5-Test-Pod-Coverage
BUILD_DEPENDS+=	p5-Test-Pod-[0-9]*:../../devel/p5-Test-Pod
BUILD_DEPENDS+=	p5-Test-Warn-[0-9]*:../../devel/p5-Test-Warn
BUILD_DEPENDS+=	p5-URI-[0-9]*:../../www/p5-URI
BUILD_DEPENDS+=	p5-libwww-[0-9]*:../../www/p5-libwww

PKG_DESTDIR_SUPPORT=	user-destdir

USE_LANGUAGES=	# empty
PERL5_PACKLIST=	auto/Moose/.packlist

.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"