The NetBSD Project

CVS log for pkgsrc/devel/p5-MooX-StrictConstructor/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / p5-MooX-StrictConstructor

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.4 / (download) - annotate - [select for diffs], Thu Apr 16 11:37:20 2020 UTC (7 weeks, 2 days ago) by mef
Branch: MAIN
CVS Tags: HEAD
Changes since 1.3: +5 -5 lines
Diff to previous 1.3 (colored)

(devel/p5-MooX-StrictConstructor)  Updated to 0.011

(pkgsrc)
 - BUILD_DEPENDS converted to TEST_DEPENDS

(upstream)
0.011     2020-03-10 09:38:39-07:00 America/Los_Angeles

        - Switched from Carp::confess to die in order to avoid leaking
          sensitive data via stack traces. The previous behavior can be
          enabled in an application by using Carp::Always.  Thanks
          @jrubinator!

Revision 1.3 / (download) - annotate - [select for diffs], Sat Apr 7 08:44:52 2018 UTC (2 years, 2 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2
Changes since 1.2: +5 -5 lines
Diff to previous 1.2 (colored)

Update to 0.010

Upstream changes:
0.010     2018-03-25 10:15:40-07:00 America/Los_Angeles

        - Undo the previous "fix" for the minimum perl version.
          The basic requirement is for 5.004 but the tests require
          5.006.

Revision 1.2 / (download) - annotate - [select for diffs], Sun Mar 25 12:03:38 2018 UTC (2 years, 2 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1
Changes since 1.1: +5 -5 lines
Diff to previous 1.1 (colored)

Update to 0.009

Upstream changes:
0.009     2018-03-24 14:12:47-07:00 America/Los_Angeles

        - Built using current Dist::Zilla, so various things
          are better, e.g. includes a LICENSE.
        - A couple of things that are only used in xt tests
          used to be test requirements, now their develop
          requirements.
        - No longer includes explicit dependencies on a handful
          of modules (e.g. indirect) that Moo's use of strictures
          used to require.
        - Now only includes a Makefile.PL.
        - The build now includes a cpanfile in the repo.
        - The minimum perl version is now consistent between the
          Makefile.PL and the META.{yml,json} files.

Revision 1.1 / (download) - annotate - [select for diffs], Fri Apr 15 11:38:07 2016 UTC (4 years, 1 month ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2

Import p5-MooX-StrictConstructor-0.008 as devel/p5-MooX-StrictConstructor.

Simply loading this module makes your constructors "strict". If
your constructor is called with an attribute init argument that
your class does not declare, then it dies. This is a great way to
catch small typos.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>