[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / p5-MooX-StrictConstructor

File: [cvs.NetBSD.org] / pkgsrc / devel / p5-MooX-StrictConstructor / Makefile (download)

Revision 1.5, Sat Apr 7 08:44:52 2018 UTC (2 years, 5 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2
Changes since 1.4: +2 -2 lines

Update to 0.010

Upstream changes:
0.010     2018-03-25 10:15:40-07:00 America/Los_Angeles

        - Undo the previous "fix" for the minimum perl version.
          The basic requirement is for 5.004 but the tests require
          5.006.

# $NetBSD: Makefile,v 1.5 2018/04/07 08:44:52 wen Exp $

DISTNAME=	MooX-StrictConstructor-0.010
PKGNAME=	p5-${DISTNAME}
CATEGORIES=	devel perl5
MASTER_SITES=	${MASTER_SITE_PERL_CPAN:=../../authors/id/H/HA/HARTZELL/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://search.cpan.org/~hartzell/MooX-StrictConstructor/
COMMENT=	Make your Moo-based object constructors blow up on unknown attributes
LICENSE=	${PERL5_LICENSE}

DEPENDS+=	p5-Class-Method-Modifiers-[0-9]*:../../devel/p5-Class-Method-Modifiers
DEPENDS+=	p5-Moo-[0-9]*:../../devel/p5-Moo
DEPENDS+=	p5-indirect-[0-9]*:../../devel/p5-indirect
DEPENDS+=	p5-bareword-filehandles-[0-9]*:../../devel/p5-bareword-filehandles
DEPENDS+=	p5-multidimensional-[0-9]*:../../devel/p5-multidimensional
DEPENDS+=	p5-strictures-[0-9]*:../../devel/p5-strictures
BUILD_DEPENDS+=	p5-Test-CPAN-Meta-[0-9]*:../../devel/p5-Test-CPAN-Meta
BUILD_DEPENDS+=	p5-Test-Fatal-[0-9]*:../../devel/p5-Test-Fatal
BUILD_DEPENDS+=	p5-Test-Pod-[0-9]*:../../devel/p5-Test-Pod
BUILD_DEPENDS+=	p5-Test-Pod-Coverage-[0-9]*:../../devel/p5-Test-Pod-Coverage
BUILD_DEPENDS+=	p5-Pod-Coverage-[0-9]*:../../textproc/p5-Pod-Coverage
BUILD_DEPENDS+=	p5-Pod-Coverage-TrustPod-[0-9]*:../../textproc/p5-Pod-Coverage-TrustPod

PERL5_PACKLIST=		auto/MooX/StrictConstructor/.packlist

.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"