The NetBSD Project

CVS log for pkgsrc/devel/p5-Module-ScanDeps/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / p5-Module-ScanDeps

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.49 / (download) - annotate - [select for diffs], Sun Aug 11 13:19:52 2019 UTC (5 months, 1 week ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, HEAD
Changes since 1.48: +2 -1 lines
Diff to previous 1.48 (colored)

Bump PKGREVISIONs for perl 5.30.0

Revision 1.48 / (download) - annotate - [select for diffs], Sun Jun 30 20:15:21 2019 UTC (6 months, 3 weeks ago) by nia
Branch: MAIN
Changes since 1.47: +2 -2 lines
Diff to previous 1.47 (colored)

Update packages using a search.cpan.org HOMEPAGE to metacpan.org.

The former now redirects to the latter.

This covers the most simple cases where http://search.cpan.org/dist/name
can be changed to https://metacpan.org/release/name.

Reviewed by hand to hopefully make sure no unwanted changes sneak in.

Revision 1.47 / (download) - annotate - [select for diffs], Sat Jan 26 07:48:24 2019 UTC (11 months, 3 weeks ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1
Changes since 1.46: +2 -3 lines
Diff to previous 1.46 (colored)

Update to 1.27

Upstream changes:
1.27  2019-01-15

- fixes by Shawn Laffan <shawnlaffan@gmail.com>
  - Process lines like "{ package foo; use if 1, "warnings"; } (#8)
  - Also handle 'do {use module; ...}'

- some clean ups
  - scandeps.pl: sort output by module name
  - add_deps(): use _gettype() instead of inline code
  - _compile_or_execute(): require DynaLoader _before_ accessing
    its variables
  - t/7-check-dynaloader.t: improve diagnostics

- drop Cwd from the list of potential XS modules

- suppress warnings in some ancient Perls

1.26  2018-12-12

- Glue DLLs of XS modules should have type "shared" rather than "data"

  Detection broke on Windows where nowadays $Config{dlext} = "xs.dll"
  (i.e. it's not a simple suffix)

- Mention some other modules: Module::ExtractUse and Perl::PrereqScanner::* family

- Add %Preload rules for:
  - JSON::MaybeXS
  - HTTP::Entity::Parser
  - FFI::Platypus

Revision 1.46 / (download) - annotate - [select for diffs], Wed Aug 22 09:44:19 2018 UTC (17 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.45: +2 -1 lines
Diff to previous 1.45 (colored)

Recursive bump for perl5-5.28.0

Revision 1.45 / (download) - annotate - [select for diffs], Tue Aug 21 11:02:33 2018 UTC (17 months ago) by wiz
Branch: MAIN
Changes since 1.44: +2 -2 lines
Diff to previous 1.44 (colored)

p5-Module-ScanDeps: update to 1.25.

1.25  2018-08-18

- Merge pull request #2 from shawnlaffan/master, thanx Shawn!

  continue scanning one-liners when use if, autouse or >5.010 found

- Fix how data obtained from compiling or executing a file
  is incorporated (_info2rv).

  Sanitize all pathnames to use slash (instead of backslash):
  - members of @INC
  - keys and values of %INC
  - members of @dl_shared_objects
  This should make stripping @INC prefixes finally work.

- Add %Preload rule for FFI::Platypus

- Add bugtracker to META.yml

Revision 1.44 / (download) - annotate - [select for diffs], Sun Sep 17 11:14:11 2017 UTC (2 years, 4 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.43: +5 -4 lines
Diff to previous 1.43 (colored)

p5-Module-ScanDeps: update to 1.24.

1.24  2017-06-28

- Merge pull request from Salvador FandiƱo (salva), thx!
  Specio::PartialDump uses unicore

- Fix RT#119737: Problems with detecting DateTime::Format::Natural dependencies
  ... by adding a %Preload rule

Revision 1.43 / (download) - annotate - [select for diffs], Mon Jun 5 14:23:16 2017 UTC (2 years, 7 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.42: +2 -1 lines
Diff to previous 1.42 (colored)

Recursive revbump from lang/perl5 5.26.0

Revision 1.42 / (download) - annotate - [select for diffs], Mon Jan 2 13:46:46 2017 UTC (3 years ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.41: +2 -3 lines
Diff to previous 1.41 (colored)

Update to 1.23

Upstream changes:
1.23  2016-11-16

- add %Preload rules for List::SomeUtils and Pod::Simple::Transcode

- get rid of Module::Install, use ExtUtils::MakeMaker

Revision 1.41 / (download) - annotate - [select for diffs], Mon Sep 19 09:44:07 2016 UTC (3 years, 4 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.40: +2 -3 lines
Diff to previous 1.40 (colored)

Updated devel/p5-Module-ScanDeps to 1.22
----------------------------------------
1.22  2016-09-17
- Fix RT#117887: Not parsing new release of Net::DNS::Resolver
  add %Preload rule for Net/DNS/Resolver.pm

Revision 1.40 / (download) - annotate - [select for diffs], Wed Jun 8 19:23:12 2016 UTC (3 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.39: +2 -1 lines
Diff to previous 1.39 (colored)

Bump PKGREVISION for perl-5.24.

Revision 1.39 / (download) - annotate - [select for diffs], Tue May 3 15:05:19 2016 UTC (3 years, 8 months ago) by mef
Branch: MAIN
Changes since 1.38: +2 -2 lines
Diff to previous 1.38 (colored)

Updated devel/p5-Module-ScanDeps to 1.21
----------------------------------------
1.21  2016-04-05
- %Preload: add rules for List::MoreUtils and Log::Dispatch
- %Preload: make the following modules require the unicore stuff:
  charnames.pm
  Unicode/Normalize.pm
  Unicode/UCD.pm
- add helper _glob_in_inc_1()
- remove all references to http://par.perl.org/, doesn't exist anymore

Revision 1.38 / (download) - annotate - [select for diffs], Sun Apr 17 09:34:43 2016 UTC (3 years, 9 months ago) by wiz
Branch: MAIN
Changes since 1.37: +2 -3 lines
Diff to previous 1.37 (colored)

Update p5-Module-ScanDeps to 1.20:

1.20  2015-10-04

- Fix RT #107304: Newer versions of File::Path cause warning "_Inline for _Inline: No such file or directory at Module/ScanDeps.pm line 1339."
  - drop the dubious call to rmtree()

- Fix RT106142: Preload dependencies for PDL and PDL::NiceSlice
  - adopted from a patch by Shawn Laffan, thanks Shawn!

- Fix RT#106144: Preload dependencies for File::BOM)
  - adopted from a patch by Shawn Laffan, thanks Shawn!

- Revise our stance on utf8.pm:

  - A line of "use utf8;" just means "this file is encoded in UTF-8"
    and should _not_ result in scanning utf8.pm which will pull in
    the whole Unicode shebang (propery tables and what not).
    Yes, utf8.pm _doesn contain "require utf8_heavy.pl", but only inside
    an AUTOLOAD() that is _not_ triggered by calling functions
    like utf8::is_utf8().

  - OTOH the innocently looking one-liner

      perl -ne 'print if /\pN/'

    implicitly loads utf8.pm and triggers the AUTOLAD().

  - So prevent utf8.pm from being scanned and make utf8_heavy.pl
    the indicator for "I need the Unicode stuff" instead.

  - Cache the results of _get_preload('utf8_heavy.pl').

- Make %Preload "transitive" so that given

    my %Preload = (
      'Foo.pm' => [ 'Bar.pm' ],
      'Bar.pm' => [ 'Quux.pm' ],
      ...
    );

  scan_deps_static() register a dependency on Bar.pm _and_
  Quux.pm when it saw "use Foo;"

- Minor changes:
  - drop dubious %Preload of utf8.pm for SOAP::Lite and XML::Parser::Expat
  - drop code for Perl < 5.008 as we require 5.8.1 already
  - rework the implementation of -x/-c
  - add add_preload_rule() to dynamically add a %Preload rule
  - recognize constructs like "open FH, '<:via(Foo)', ..."
  - upgrade to Module::Install 1.16

Revision 1.37 / (download) - annotate - [select for diffs], Fri Sep 4 11:36:12 2015 UTC (4 years, 4 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3
Changes since 1.36: +5 -3 lines
Diff to previous 1.36 (colored)

(pkgsrc)
 - Add following line for make test
  BUILD_DEPENDS+=        p5-Test-Requires-[0-9]*:../../devel/p5-Test-Requires
(upstream)
 - Update 1.18 to 1.19
----------------------
1.19  2015-05-27
  - add %Preload rule for LWP::MediaTypes: data file LWP/media.types
  - add %Preload entry for MIME::Types: data file MIME/types.db
  - add %Preload rule for AnyEvent
  - always add Encode.pm when fix encountering constructs like
      decode("klingon", ...)
            open FH, "<:encoding(klingon)", ..
  - add license
  - update OpenFoundry repository URL

Revision 1.36 / (download) - annotate - [select for diffs], Fri Jun 12 10:49:28 2015 UTC (4 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2
Changes since 1.35: +2 -1 lines
Diff to previous 1.35 (colored)

Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.

Revision 1.35 / (download) - annotate - [select for diffs], Thu Feb 12 07:02:48 2015 UTC (4 years, 11 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.34: +2 -2 lines
Diff to previous 1.34 (colored)

Update to 1.18
--------------
1.18  2015-01-19
  - Fix RT #101569: Incorrect module parsing if Moose is included

Revision 1.34 / (download) - annotate - [select for diffs], Sun Jan 4 06:06:36 2015 UTC (5 years ago) by schmonz
Branch: MAIN
Changes since 1.33: +2 -3 lines
Diff to previous 1.33 (colored)

Update to 1.17. From the changelog:

- scandeps.pl: die if an option is not recognized
- Reformat Changes file according to CPAN::Changes::Spec
- Modify %Preload rule: let Unicode::UCD explicitly imply utf8.pm.
  This fixes PAR::Packer's self test.
  Previously Unicode::UCD implied utf8.pm implicitly because
  it contains calls to some utf8::foo() functions.
- Add %Preload rule: Mozilla::CA requires its cacert.pem file
- Recognize "do filename" constructs even if "do" isn't at the start
  of a chunk.
- Upgrade to Module::Install 1.14
- Fix RT#98938: recognize Module::Runtime module-loading functions
- Fix a nasty typo that broke scandeps.pl option -E
    $ scandeps -E "some string"
    Unknown option: E
    Can't open some string: No such file or directory at scandeps.pl line 49.
  - also scandeps.pl: die if an option is not recognized
- Remove some overzealous heuristics from scan_chunk()
  - they were looking for
    Foo::Bar->something
    Foo::Bar::whatever(...)
  _anywhere_ in programs to infer a dependency on Foo/Bar.pm.
  BEWARE: This might break some use cases, i.e. missing some dependencies.
  On the other hand,  this causes hard to investigate problems like the one
  starting at http://www.mail-archive.com/par@perl.org/msg05531.html.
  While the former can easily be worked around by the user itself (just
  add a missing dependecy explicitly, e.g. using "pp -M ...") and
  typically can be solved in general by adding a %Preload rule,
  the latter just wastes people's times.
- Recognize Test::More require_ok() and use_ok()
  - makes 3-static_oo_interface_real.t pass again (fallout from the above)
- Upgrade to Module::Install 1.12
- Add option -T to request information from CPAN
  - don't access CPAN behind the user's back just because they have
    CPANPLUS installed (it was in the Perl core from 5.10 to 5.18) -
    it might not even have been configured (e.g. in a corporate internet)
  - only do this when explicitly requested
- Fix RT #98203: Migrate from deprecated Module::Build::ModuleInfo to Module::Metadata
  - thanx Petr Pisar (ppisar@redhat.com) for the hint
- add long option names to scandeps.pl
- implement option --xargs for scandeps.pl
- fix wrong version numbers in Changes
- Fix RT #92860 (t/7-check-dynaloader.t doesn't handle systems with mod2fname),
  also RT #97519 (Fix for t/7-check-dynaloader.t on systems with DynaLoader::mod2fname)
  - applied patch from Brian Fraser (fraserbn@gmail.com), thanks!
  - lib/Module/ScanDeps/DataFeed.pm: apply here, too
- Fix recognition of (open() arguments) "<:encoding(klingon)",
  implies modules PerlIO and PerlIO::encoding.
- Fix RT #90869: Use of uninitialized value $module in substitution (s///)
- Fix RT #87775: typo fixes, thanks dsteinbrunner@pobox.com
- new %Preload rule for B::Hooks::EndOfScope
- new %Preload rule for Pod::Usage
- add a fake %Preload rule that warns if use of Module::Implementation
  or Module::Runtime is detected (coz' they're doing runtime loading)
- change some tests to use Test::Requires instead of homegrown stuff;
  hence add it to "test_requires"
- clean up some uses of Test::More
- Fix RT #89000: test broken by indirect base.pm disuse
  - delete base.pm from list of expected deps,
    patch by Andrew Main (zefram@fysh.org)
- new %Preload rule for Net::HTTPS (e.g. used by LWP::Protocol::https)
  - look for IO::Socket::SSL or Net::SSL
- new %Preload rule for YAML::Any
  - try to figure out what YAML::Any would have used
    (using YAML::Any->implementation)
  - as fallback, include anything below YAML
- add %Preload rule for Params::Validate to detect
  its PP and XS implementations
- Fix RT #80276 Module DateTime::Format::ISO8601 generates error
  after being packaged
  - caused by failing to pack DateTime::Format::Builder::Parser::XXX modules
    needed by DateTime::Format::Builder::Parser
  - add a corresponding %Preload rule
- update to Module::Install 1.06

Revision 1.33 / (download) - annotate - [select for diffs], Thu Oct 9 13:44:43 2014 UTC (5 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4
Changes since 1.32: +1 -2 lines
Diff to previous 1.32 (colored)

Remove SVR4_PKGNAME, per discussion on tech-pkg.

Revision 1.32 / (download) - annotate - [select for diffs], Thu May 29 23:36:05 2014 UTC (5 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.31: +2 -2 lines
Diff to previous 1.31 (colored)

Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.

Revision 1.31 / (download) - annotate - [select for diffs], Fri May 31 12:40:31 2013 UTC (6 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.30: +2 -2 lines
Diff to previous 1.30 (colored)

Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.

Revision 1.30 / (download) - annotate - [select for diffs], Wed Oct 31 11:18:32 2012 UTC (7 years, 2 months ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.29: +1 -3 lines
Diff to previous 1.29 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.29 / (download) - annotate - [select for diffs], Wed Oct 3 21:55:17 2012 UTC (7 years, 3 months ago) by wiz
Branch: MAIN
Changes since 1.28: +2 -1 lines
Diff to previous 1.28 (colored)

Bump all packages that use perl, or depend on a p5-* package, or
are called p5-*.

I hope that's all of them.

Revision 1.28 / (download) - annotate - [select for diffs], Thu Sep 13 15:53:22 2012 UTC (7 years, 4 months ago) by sno
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3
Changes since 1.27: +2 -2 lines
Diff to previous 1.27 (colored)

Updating package for CPAN module Module::ScanDeps in devel/p5-Module-ScanDeps
from 1.08 to 1.09

upstream changes:
[Changes for 1.09 - 2012-09-09]
* teach Module::ScanDeps about "use if ..." constructs
  - fixes CPAN Testers failures for PAR::Packer with perl 5.17.1 and up
    (Roderich Schupp)

* RT #79003: t/7-check-dynaloader.t failing when /usr/lib != /usr/lib64
  - scrap the test for "$entry{file} starts with $expected_prefix" as
    its assumptions are flawed (Roderich Schupp)

* Mojo::Base is a loader (Alexandr Ciornii)
* Special case for Class::Load (Alexandr Ciornii)

Revision 1.27 / (download) - annotate - [select for diffs], Fri Jul 6 11:23:28 2012 UTC (7 years, 6 months ago) by sno
Branch: MAIN
Changes since 1.26: +3 -4 lines
Diff to previous 1.26 (colored)

Updating package for Perl 5 module Module::ScanDeps in
devel/p5-Module-ScanDeps from 1.04 to 1.08.

pkgsrc changes:
- remark using of bundled Module::Install in addition to ExtUtils::MakeMaker

Upstream changes:
[Changes for 1.08 - 2012-02-21]
* RT #73785: scandeps -c fails on modules that depend on Getopt::Euclid
  - for "scandeps -c ..." switch from an INIT block to a CHECK block
    and call the augmented script with "perl -c"  instaed of "perl"

* RT#72954 ":encoding(UTF-8)" doesn't imply a dependency on Encode.pm
  - if scan_chunk sees ":encoding(FOO)" or similar, it goes to some
    length to find the "external" Encode module to handle FOO; but it
    forgets that Encode.pm itself is needed at runtime (esp. if FOO
    is an encoding "internally" handled by Encode.pm, e.g. "UTF-8")

* %Preload: add rules for Gtk2.pm and Pango.pm
* %Preload: fix a problem with Image::ExifTool

[Changes for 1.07 - 2011-11-29]
* RT #72796: dynaloader test fails when the .so files are in the
  system lib dirs and local::lib is involved?
  Relax a check in t/7-check-dynaloader.t
* Update Module::Install to 1.04

[Changes for 1.06 - 2011-11-28]
* RT #72211: pp includes way too much modules (when using 'use strict;')?
  Rework regexes to detect "use MODULE ...":
  the following line from unicore/mktables

    my $unihan = 'Unihan properties are by default not enabled in the Perl core.  Instead use CPAN: Unicode::Unihan';

  would erroneously detect a dependency on CPAN.pm (which will in turn
  pull in a lot of modules)
* Bump Perl version requirement to 5.8.1 (Schwern: The End Of 5.6 Is Nigh!)
* Rewrite t/7-check-dynaloader.t to look for more candidates of dynamic modules
  that might be used as test cases

[Changes for 1.05 - 2011-11-02]
* RT #72082: $FindBin::Bin issue on Moudel::ScanDeps 1.04
  Make FindBin work (at least with option -c or -x) by spoofing $0
  in the temp script generated for M:SD::DataFeed
* RT #70134: patch suggestions for Module::ScanDeps 1.04: additional preload
  rules, used_via_preload attribute
  Add suggested %Preload rules from the attached patch (thanks, Markus Jansen)
* Add %Preload rules for MozRepl
* Special case for Package::Stash (Alexandr Ciornii)
* Special case for Moose (Alexandr Ciornii)

Revision 1.26 / (download) - annotate - [select for diffs], Sat Oct 29 20:26:37 2011 UTC (8 years, 2 months ago) by hiramatsu
Branch: MAIN
CVS Tags: pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4
Changes since 1.25: +2 -3 lines
Diff to previous 1.25 (colored)

Update p5-Module-ScanDpes to 1.04.

Changes from previous:
[Changes for 1.04 - 2011-07-21]
* Brown paper bag bug: fix option -x (execute) (broken by changes for -c)
* While we're at it: honor option -I with -c

[Changes for 1.03 - 2011-07-18]

* RT #69213: ScanDeps incompatible with AnyEvent (Perl 5.14, AnyEvent 5.34, PAR 1.00.2)
  For option -c (compile) M:SD used to wrap the file in one big sub and
  appended an END block where it dumps %INC etc; the outer sub causes problems
  with certain contructs. Instead we now use an INIT block prepended
  to the file.

* RT #69471: Problem with "eval { require SomeModule }" constructions
  Module::ScanDeps::DataFeed now omits %INC pairs with an undefined value
  (these may be created by an unsuccessful "require" under certain conditions).
  Also omit CODE refs from @INC.

* Fix for failing CPAN Testers report
  http://www.cpantesters.org/cpan/report/4208fa16-a5d1-11e0-a0bc-c71a7862a918:
  Perl 5.15.0 got rid of Shell.pm

* Fix for failing CPAN Testers report
  http://www.cpantesters.org/cpan/report/772147dc-6c1f-1014-baf2-318eb63ba09a:
  - regex meta characters in filenames break consistency check

* Simplify Module::ScanDeps::DataFeed somewhat by localizing %INC
  around "require Module::ScanDeps::DataFeed" and by using Data::Dumper
  for the actual dump.

* Don't create the tempfiles for DataFeed in the working directory.

* Purge all pod from Module::ScanDeps::DataFeed, advise the  CPAN
  indexer not to bother with it; same for Module::ScanDeps::Cache.

[Changes for 1.02 - 2011-04-03]
* %Preload: add _all_ *.pl file below .../unicore for utf8.pm

[Changes for 1.01 - 2011-03-26]
* %Preload: add "unicore/version" for Unicode/UCD.pm
  (because it contains a call openunicode(..., "version"))

[Changes for 1.00 - 2011-02-19]
* RT #65855: Special handling for POSIX requested (Roderich Schupp)
* RT #65252: Temp files left when execute fails (Roderich Schupp)
* add a %Preload rule for Log::Report::Dispatcher (Roderich Schupp)
  cf. http://www.nntp.perl.org/group/perl.par/2011/01/msg4871.html
* add %Preload rule for Date::Manip (Roderich Schupp)
* speed up scanning *significantly* by not re-constructing regexen
  for every line of input and reducing the no. of sub calls (Steffen Mueller)
* add Eric Roode to AUTHORS (Steffen Mueller)
* RT #61027: "use lib" does not work (Roderich Schupp)
  scan_line(): When handling "use lib '/some/dir'" we add "/some/dir/ARCHNAME",
  "/some/dir/VER" and "/some/dir/VER/ARCHNAME", but forgot
  to add "/some/dir" itself.
  While we're at it, improve parsing the argument list of "use lib".
  Simply eval the string, this should at least make all forms of
  quoted strings work correctly.
* fix URI special case (clkao)
* fix a regression reported by CPAN Testers (Roderich Schupp)
* finally: bump version to 1.00

Revision 1.25 / (download) - annotate - [select for diffs], Sun Aug 14 12:26:19 2011 UTC (8 years, 5 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2011Q3-base, pkgsrc-2011Q3
Changes since 1.24: +2 -2 lines
Diff to previous 1.24 (colored)

Revision bump after updating perl5 to 5.14.1.

Revision 1.24 / (download) - annotate - [select for diffs], Sat Aug 21 16:34:03 2010 UTC (9 years, 5 months ago) by seb
Branch: MAIN
CVS Tags: pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3
Changes since 1.23: +2 -1 lines
Diff to previous 1.23 (colored)

Bump the PKGREVISION for all packages which depend directly on perl,
to trigger/signal a rebuild for the transition 5.10.1 -> 5.12.1.

The list of packages is computed by finding all packages which end
up having either of PERL5_USE_PACKLIST, BUILDLINK_API_DEPENDS.perl,
or PERL5_PACKLIST defined in their make setup (tested via
"make show-vars VARNAMES=..."), minus the packages updated after
the perl package update.

sno@ was right after all, obache@ kindly asked and he@ led the
way. Thanks!

Revision 1.23 / (download) - annotate - [select for diffs], Tue Aug 3 22:09:28 2010 UTC (9 years, 5 months ago) by seb
Branch: MAIN
Changes since 1.22: +2 -2 lines
Diff to previous 1.22 (colored)

Update from version 0.97 to version 0.98.

Upstream changes:
[Changes for 0.98 - 2010-07-26]
* Make %Preload entry for "utf8.pm" lazy (Roderich Schupp)
* Upgrade to Module::Install 1.00 (Roderich Schupp)
* RT #58093: Par-Packer not including all dependencies (unicore/Heavy.pl) (Roderich Schupp)
* Add %Preload rule for RPC::XML (Roderich Schupp)
* RT #57494: add %Preload rule for JSON.pm (Roderich Schupp)

Revision 1.22 / (download) - annotate - [select for diffs], Sun Apr 11 23:31:58 2010 UTC (9 years, 9 months ago) by seb
Branch: MAIN
CVS Tags: pkgsrc-2010Q2-base, pkgsrc-2010Q2
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

Update from version 0.96 to version 0.97.

Upstream changes:
[Changes for 0.97 - 2010-04-10]
* Pack the content of module/distribution sharedirs is automatically. (kmx)
* RT #56020 - add data files used by Unicode::UCD (Roderich Schupp)
* RT #55746 - remove bogus "... if %Config::Config" condition (Roderich Schupp)
* Add special case for CGI::Application::Plugin::AutoRunmode (Alexandr Ciornii)
* Add special case for CGI::Application::Plugin::Authentication (Alexandr Ciornii)
* Add special case for DBIx::Perlish (Alexandr Ciornii)

Revision 1.21 / (download) - annotate - [select for diffs], Tue Dec 15 13:26:29 2009 UTC (10 years, 1 month ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4
Changes since 1.20: +2 -2 lines
Diff to previous 1.20 (colored)

Update to 0.96:

[Changes for 0.96 - 2009-11-13]
* perl 5.6.1 compatibility (Alexandr Ciornii)
* Test for "use module version;" (Alexandr Ciornii)

Revision 1.20 / (download) - annotate - [select for diffs], Sat Sep 19 16:32:27 2009 UTC (10 years, 4 months ago) by sno
Branch: MAIN
CVS Tags: pkgsrc-2009Q3-base, pkgsrc-2009Q3
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

Updating devel/p5-Module-ScanDeps from 0.94 to 0.95

Upstream changes:
[Changes for 0.95 - 2009-10-16]
* Fix "uninitialized value" warnings (Dave Rolsky)
* Add special case for Perl::Critic (Alexandr Ciornii)
* Add special case for Event (Alexandr Ciornii)
* Add special case for Wx.pm (Alexandr Ciornii)
* Add special case for Log::Any

Revision 1.19 / (download) - annotate - [select for diffs], Wed Aug 19 19:16:20 2009 UTC (10 years, 5 months ago) by sno
Branch: MAIN
Changes since 1.18: +2 -2 lines
Diff to previous 1.18 (colored)

Updating package devel/p5-Module-ScanDeps from 0.93 to 0.94

Upstream changes:
[Changes for 0.94 - 2009-08-10]
* Add tests for scan_line (Alexandr Ciornii)
* RT#48151 fixed, "require __PACKAGE__" should not die (Alexandr Ciornii)
* OS/2 fixes (Ilya Zakharevich)

Revision 1.18 / (download) - annotate - [select for diffs], Sun Aug 9 22:36:10 2009 UTC (10 years, 5 months ago) by sno
Branch: MAIN
Changes since 1.17: +3 -2 lines
Diff to previous 1.17 (colored)

Fix dependency cycle to Module::Install

Revision 1.17 / (download) - annotate - [select for diffs], Sun Aug 9 11:53:34 2009 UTC (10 years, 5 months ago) by sno
Branch: MAIN
Changes since 1.16: +5 -4 lines
Diff to previous 1.16 (colored)

Updating package for p5 module Module::ScanDeps from 0.91 to 0.93

pkgsrc changes:
  - Use Module::Install as module type

Upstream changes:
[Changes for 0.93 - 2009-07-19]
* Implement caching of dependencies (Christoph Lamprecht)

[Changes for 0.92 - 2009-07-19]
* Fix bug with {type} being set to unexpected values in some cases (Christoph Lamprecht)
* Add tests for scan_chunk (Alexandr Ciornii)
* Add special case for parent.pm (Alexandr Ciornii)
* Fix for "use parent::something" (Alexandr Ciornii)
* Add special case for Catalyst.pm (Alexandr Ciornii)

Revision 1.16 / (download) - annotate - [select for diffs], Wed Jul 8 08:21:28 2009 UTC (10 years, 6 months ago) by sno
Branch: MAIN
Changes since 1.15: +5 -2 lines
Diff to previous 1.15 (colored)

Updating package for p5 module Module::ScanDeps from 0.90 to 0.91
Setting license

Upstream changes:
[Changes for 0.91 - 2009-06-22]
* Add special case for Tk's setPalette call (Christoph Lamprecht)

Revision 1.15 / (download) - annotate - [select for diffs], Sun May 10 00:01:55 2009 UTC (10 years, 8 months ago) by seb
Branch: MAIN
CVS Tags: pkgsrc-2009Q2-base, pkgsrc-2009Q2
Changes since 1.14: +2 -2 lines
Diff to previous 1.14 (colored)

Update from version 0.89 to version 0.90.

Upstream changes:
[Changes for 0.90 - 2009-05-09]
* Add special case for DateTime::Locale
* Add special case for PAR::Repository and PAR::Repository::Client

Revision 1.14 / (download) - annotate - [select for diffs], Fri Nov 7 20:58:07 2008 UTC (11 years, 2 months ago) by seb
Branch: MAIN
CVS Tags: pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4
Changes since 1.13: +2 -6 lines
Diff to previous 1.13 (colored)

Update from version 0.84 to version 0.89.

Pkgsrc changes:
* Drop dependencies on Perl 5 modules provided by the minimum
required perl5 package (5.10)

Upstream changes:
[Changes for 0.89 - 2008-11-03]
* Distribution fixes.
* Do not use base Exporter.
* Detection of 'asa' and 'only::matching'.

[Changes for 0.88 - 2008-10-28]
* Add special case for File::HomeDir.

[Changes for 0.87 - 2008-10-28]
* Add special case for PPI.

[Changes for 0.86 - 2008-10-23]
* Fix the 'use prefork "Foo"' static detection.
* Fix the detection of any of the module-loader modules such as
  prefork, autouse, etc. if invoked as 'use prefork"Foo"' (note
  the lack of a space).
* Slightly refactor the loader-module scanning. (see above)
* Support for "use maybe 'foo';"
* Use (arch|priv)libexp instead of (arch|priv)lib
  in scandeps.pl (Mark Stosberg)
* Update to Module::Install 0.77

[Changes for 0.85 - 2008-08-01]
* Add special case for Net::Server.

Revision 1.13 / (download) - annotate - [select for diffs], Sun Oct 19 19:17:57 2008 UTC (11 years, 3 months ago) by he
Branch: MAIN
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

Bump the PKGREVISION for all packages which depend directly on perl,
to trigger/signal a rebuild for the transition 5.8.8 -> 5.10.0.

The list of packages is computed by finding all packages which end
up having either of PERL5_USE_PACKLIST, BUILDLINK_API_DEPENDS.perl,
or PERL5_PACKLIST defined in their make setup (tested via
"make show-vars VARNAMES=...").

Revision 1.12 / (download) - annotate - [select for diffs], Tue Jun 3 11:53:11 2008 UTC (11 years, 7 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.11: +5 -1 lines
Diff to previous 1.11 (colored)

Add missing dependency:
 p5-version        (since versin 0.82)
 p5-Module-Builder (since versin 0.75)
Should fix PR 38842.

Bump PKGREVISION.

Revision 1.11 / (download) - annotate - [select for diffs], Wed May 28 21:49:26 2008 UTC (11 years, 7 months ago) by abs
Branch: MAIN
Changes since 1.10: +4 -2 lines
Diff to previous 1.10 (colored)

Updated devel/p5-Module-ScanDeps to 0.84

[Changes for 0.84 - 2008-05-13]
* Add special case for Class::MethodMaker.

[Changes for 0.83 - 2008-03-23]
* Add special case for Image::ExifTool.

[Changes for 0.82 - 2008-01-08]
* Add Test::More to build requirements (Alexandr Ciornii)
* Add dependency on version.pm
* Now correctly identifies feature.pm as a dependency if
  "use 5.10.0;" (and up) is found.

[Changes for 0.81 - 2007-12-07]
* Fix for the case-insensitive-file-system-test.

[Changes for 0.80 - 2007-11-30]
* Fix to avoid duplicated entries arising from used_by references with
  case differences.
* Do not report input files themselves as dependencies.
  (Regression from 0.74 onwards)
* Remove warning from ScanFileRE tests.

[Changes for 0.78 - 2007-11-17]
* Fix ScanFileRE heuristics to allow for scanning files without
  suffixes.

[Changes for 0.77 - 2007-09-20]
* Add support for prefork.pm (similar to how base.pm is detected).
* Added uses field to hash descriptions returned by scan_deps +
  tests (Adrian Issott)
* Added ScanFileRE to restrict the files scanned to .pl, .pm, .al and
  .t but allow the user to override + tests (Adrian Issott)

[Changes for 0.76 - 2007-07-21]
* Fix special case for Term::ReadLine (should not rope in Tk)
* New special case for Tcl::Tk (should not rope in Tk either!)
* New special case for threads::shared ==> rope in attributes.pm
* Fix to avoid duplicated entries that can arise due to case
  differences that don't actually matter on case-tolerant
  systems (Adrian Issott)
* M::SD warnings now go to STDERR not STDOUT (Adrian Issott)
* Fixed bug #24162: scandeps.(bat|pl) doesn't correctly identify Core
  Modules on Windows (Adrian Issott)
* Now finds shared libraries for modules specified as input files.
* Tests for finding shared libraries.

[Changes for 0.75 - 2007-06-24]
* Fix special cases for POE. (Roderich Schupp)
* Added exported path_to_inc_name subroutine (Adrian Issott)
* Added Module::Build::ModuleInfo dependency (Adrian Issott)
* Fixed bug where input files weren't scoped properly
* Add new "check-for-dynaloader" test. (Eric Wilhelm)

Revision 1.10 / (download) - annotate - [select for diffs], Sat Jun 9 23:37:46 2007 UTC (12 years, 7 months ago) by abs
Branch: MAIN
CVS Tags: pkgsrc-2008Q1-base, pkgsrc-2008Q1, pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3, pkgsrc-2007Q2-base, pkgsrc-2007Q2
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

Updated devel/p5-Module-ScanDeps 0.68 -> 0.74

[Changes for 0.74 - 2007-04-26]
* Same as 0.73_01, but not a developer release.

[Changes for 0.73_01 - 2007-03-28]
* Fixed bug "scan_deps doesn't show ALL the dependencies"
* Ensured all file entries are given by absolute paths
* Added a number of test artificial dependency trees as test data mainly for
  "scan_deps doesn't show ALL the dependencies" bug
* Added tests for scandeps recurse option (all pass)
* Added tests for scandeps skip option (all pass)
* Added tests to show a duplicated dependency is in fact only shown once (all pass)
* Added Utils.pm test module containing generic_scandeps_rv_test and
  compare_scandeps_rvs subroutines (Adrian Issott)

[Changes for 0.73 - 2007-03-25]
* Now being a little cleverer for detecting globs in diamond operators.
  (Requiring a meta character within the <>.)

[Changes for 0.72 - 2007-02-03]
* Case-insensitive @INC removal for case-insensitive
  filesystems (Eric Wilhelm)

[Changes for 0.71 - 2007-01-04]
* Added special cases for
  Catalyst
  Class::MakeMethods
  Config::Any
  DBIx::Class
  Email::Send
  Log::Log4perl
  SQL::Translator
* print() the "# Legend..." line instead of warn()ing it.

[Changes for 0.70 - 2006-11-21]
* Added special case for Image::Info.

[Changes for 0.69 - 2006-11-07]
* Additional corner cases for LWP::UserAgent and LWP::Parallel::UserAgent and
  friends.

Revision 1.9 / (download) - annotate - [select for diffs], Tue Oct 31 15:10:05 2006 UTC (13 years, 2 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2007Q1-base, pkgsrc-2007Q1, pkgsrc-2006Q4-base, pkgsrc-2006Q4
Changes since 1.8: +2 -3 lines
Diff to previous 1.8 (colored)

Update p5-Module-ScanDeps to 0.68.

Changes:
[Changes for 0.68 - 2006-10-25]
* Added special case for PerlIO.pm. If PerlIO.pm is needed, require
  PerlIO::scalar, too, because it can be used "under the hood".
  (Roderich Schupp)
* Added some File::Spec'ness. (Steffen Mueller)
* Refactored the %Preload mapping code into _get_preload so that
  the PAR -M %Preload fix would work. (Steffen Mueller)

[Changes for 0.67 - 2006-10-24]
* Added @IncludeLibs which is used alongside @INC for searching modules.
  (David Romano)
* Won't pick up Tk as a dependency for Term::ReadLine any more.
  You can stop laughing now!

[Changes for 0.66 - 2006-09-24]
* Fixed another bug in Module::ScanDeps::Datafeed which would break
  run- and compile-time dependency scanners if $ENV{PERL5LIB} entries
  had trailing backslashes. Thanks to Steven Mackenzie for pointing
  this out.
* Added some documentation and comments to M::SD::Datafeed for the sake of
  future maintainers.

[Changes for 0.65 - 2006-09-24]
* Fixed bug in Module::ScanDeps::Datafeed which would die() in 0.64.

[Changes for 0.64 - 2006-09-22]
* Upgraded to Module::Install 0.64
* Added warning of missing modules when -V is in effect (scandeps.pl).
* Added warning of missing modules if "warn_missing=>1" specified as
  an option to scan_deps.

[Changes for 0.63 - 2006-08-27]
* Upgraded to Module::Install 0.63

[Changes for 0.62 - 2006-07-16]

* Better diagnostics.pm support for searching the related
  .pod file.

[Changes for 0.61 - 2006-06-30]

* Now presenting more helpful (and correct) error messages when
  multiple versions of a module (files) are found.
* Corrected a POD error.
* Added test for POD correctness.

[Changes for 0.60 - 2006-05-23]

* Fixed bug that prevented "use encoding 'utf-8';" from being
  picked up. This was because the -8 was stripped and thus, the
  encoding wasn't recognized.

[Changes for 0.59 - 2006-05-03]

* Recovering 5.005 compatibility. (Hopefully!)
* Using Module::Install 0.62
* Added a dependency on File::Temp for pre 5.6 perls.
* Fixed broken Module::Pluggable support.

[Changes for 0.58 - 2006-04-16]

* Added dependency for Test::Deep
* Added dependency for Math::Symbolic

[Changes for 0.57 - 2006-03-03]

* Applied Stephen Schulze's patch which fixes the problem that modules are
  reported as depended upon only once.

[Changes for 0.56 - 2006-02-20]

* Added special dependency for Tk::Getopt. Suggested by Slaven Rezic.

[Changes for 0.55 - 2006-02-17]

* Applied Roderich Schupp's patch to fix a problem with 'autouse'.
* Now using Module::Install 0.56

[Changes for 0.54 - 2006-01-11]

* Switch to File::Temp::tempfile() for more robust temporary file creation.
  Contributed by: Jesse Vincent

* Update to latest Module::Install _again_ to fix Cygwin installation.
  Reported by: Matt S Trout

[Changes for 0.53 - 2006-01-10]

* Update to latest Module::Install; no functional changes.

[Changes for 0.52 - 2005-12-12]

* Support for autouse.pm.

* Support for Tk::DragDrop.  Reported by: Renee Baecker.

Revision 1.8 / (download) - annotate - [select for diffs], Sat Mar 4 21:29:23 2006 UTC (13 years, 10 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.7: +2 -2 lines
Diff to previous 1.7 (colored)

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

Revision 1.7 / (download) - annotate - [select for diffs], Tue Dec 27 13:54:57 2005 UTC (14 years ago) by seb
Branch: MAIN
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

Lower expectations, both others' and mine: relinquish stewardship

Revision 1.6 / (download) - annotate - [select for diffs], Sat Aug 6 06:19:12 2005 UTC (14 years, 5 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base, pkgsrc-2005Q4, pkgsrc-2005Q3-base, pkgsrc-2005Q3
Changes since 1.5: +2 -1 lines
Diff to previous 1.5 (colored)

Bump the PKGREVISIONs of all (638) packages that hardcode the locations
of Perl files to deal with the perl-5.8.7 update that moved all
pkgsrc-installed Perl files into the "vendor" directories.

Revision 1.5 / (download) - annotate - [select for diffs], Wed Jul 13 18:01:27 2005 UTC (14 years, 6 months ago) by jlam
Branch: MAIN
Changes since 1.4: +2 -2 lines
Diff to previous 1.4 (colored)

Turn PERL5_PACKLIST into a relative path instead of an absolute path.
These paths are now relative to PERL5_PACKLIST_DIR, which currently
defaults to ${PERL5_SITEARCH}.  There is no change to the binary
packages.

Revision 1.4 / (download) - annotate - [select for diffs], Mon Apr 11 21:45:33 2005 UTC (14 years, 9 months ago) by tv
Branch: MAIN
CVS Tags: pkgsrc-2005Q2-base, pkgsrc-2005Q2
Changes since 1.3: +1 -2 lines
Diff to previous 1.3 (colored)

Remove USE_BUILDLINK3 and NO_BUILDLINK; these are no longer used.

Revision 1.3 / (download) - annotate - [select for diffs], Thu Mar 31 22:42:31 2005 UTC (14 years, 9 months ago) by seb
Branch: MAIN
Changes since 1.2: +2 -3 lines
Diff to previous 1.2 (colored)

Update to version 0.51

Changes since last packaged version (0.50):
[Changes for 0.51 - 2005-01-08]
* scandeps.pl is now usable without CPANPLUS.pm installed.
  Reported by: Rafael Garcia-Suarez

Revision 1.2 / (download) - annotate - [select for diffs], Mon Dec 20 11:31:01 2004 UTC (15 years, 1 month ago) by grant
Branch: MAIN
CVS Tags: pkgsrc-2005Q1-base, pkgsrc-2005Q1, pkgsrc-2004Q4-base, pkgsrc-2004Q4
Changes since 1.1: +2 -1 lines
Diff to previous 1.1 (colored)

since perl is now built with threads on most platforms, the perl archlib
module directory has changed (eg. "darwin-2level" vs.
"darwin-thread-multi-2level").

binary packages of perl modules need to be distinguishable between
being built against threaded perl and unthreaded perl, so bump the
PKGREVISION of all perl module packages and introduce
BUILDLINK_RECOMMENDED for perl as perl>=5.8.5nb5 so the correct
dependencies are registered and the binary packages are distinct.

addresses PR pkg/28619 from H. Todd Fujinaka.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Thu Nov 11 19:05:26 2004 UTC (15 years, 2 months ago) by seb
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Initial addition of p5-Module-ScanDeps version 0.50 in the NetBSD
Packages Collection.

The Perl 5 module Module::ScanDeps allows to recursively scan Perl
code for dependencies.

Revision 1.1 / (download) - annotate - [select for diffs], Thu Nov 11 19:05:26 2004 UTC (15 years, 2 months ago) by seb
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>