The NetBSD Project

CVS log for pkgsrc/devel/p5-Module-Install-XSUtil/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / p5-Module-Install-XSUtil

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.19 / (download) - annotate - [select for diffs], Sun Nov 3 10:15:57 2019 UTC (11 days, 1 hour ago) by rillig
Branch: MAIN
CVS Tags: HEAD
Changes since 1.18: +2 -2 lines
Diff to previous 1.18 (colored)

devel/p5-*: align variable assignments

pkglint -Wall -F --only aligned --only indent p5-*

No manual corrections.

Revision 1.18 / (download) - annotate - [select for diffs], Sun Aug 11 13:19:51 2019 UTC (3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.17: +2 -2 lines
Diff to previous 1.17 (colored)

Bump PKGREVISIONs for perl 5.30.0

Revision 1.17 / (download) - annotate - [select for diffs], Sun Jun 30 20:15:20 2019 UTC (4 months, 2 weeks ago) by nia
Branch: MAIN
Changes since 1.16: +2 -2 lines
Diff to previous 1.16 (colored)

Update packages using a search.cpan.org HOMEPAGE to metacpan.org.

The former now redirects to the latter.

This covers the most simple cases where http://search.cpan.org/dist/name
can be changed to https://metacpan.org/release/name.

Reviewed by hand to hopefully make sure no unwanted changes sneak in.

Revision 1.16 / (download) - annotate - [select for diffs], Wed Aug 22 09:44:18 2018 UTC (14 months, 3 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.15: +2 -2 lines
Diff to previous 1.15 (colored)

Recursive bump for perl5-5.28.0

Revision 1.15 / (download) - annotate - [select for diffs], Mon Jun 5 14:23:16 2017 UTC (2 years, 5 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-
Changes since 1.14: +2 -2 lines
Diff to previous 1.14 (colored)

Recursive revbump from lang/perl5 5.26.0

Revision 1.14 / (download) - annotate - [select for diffs], Wed Jun 8 19:23:12 2016 UTC (3 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

Bump PKGREVISION for perl-5.24.

Revision 1.13 / (download) - annotate - [select for diffs], Sun Jul 12 18:56:15 2015 UTC (4 years, 4 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3
Changes since 1.12: +4 -4 lines
Diff to previous 1.12 (colored)

Comment out dependencies of the style
{perl>=5.16.6,p5-ExtUtils-ParseXS>=3.15}:../../devel/p5-ExtUtils-ParseXS
since pkgsrc enforces the newest perl version anyway, so they
should always pick perl, but sometimes (pkg_add) don't due to the
design of the {,} syntax.

No effective change for the above reason.

Ok joerg

Revision 1.12 / (download) - annotate - [select for diffs], Fri Jun 12 10:49:27 2015 UTC (4 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2
Changes since 1.11: +2 -1 lines
Diff to previous 1.11 (colored)

Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.

Revision 1.11 / (download) - annotate - [select for diffs], Sun Jan 4 06:11:43 2015 UTC (4 years, 10 months ago) by schmonz
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.10: +3 -4 lines
Diff to previous 1.10 (colored)

Update to 0.45. From the changelog:

- Requires ExtUtils::ParseXS 3.18 because of 2.21 issues
  (https://github.com/xslate/p5-Text-Xslate/issues/104)
- Support PUREPERL_ONLY=1
- Remove experimental requires_xs() because Module::Install
  provides another requires_xs()
- Move t/01_example.t to xt/

Revision 1.10 / (download) - annotate - [select for diffs], Thu May 29 23:36:04 2014 UTC (5 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.

Revision 1.9 / (download) - annotate - [select for diffs], Fri May 31 12:40:31 2013 UTC (6 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.8: +2 -2 lines
Diff to previous 1.8 (colored)

Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.

Revision 1.8 / (download) - annotate - [select for diffs], Wed Oct 31 11:18:32 2012 UTC (7 years ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.7: +1 -2 lines
Diff to previous 1.7 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.7 / (download) - annotate - [select for diffs], Wed Oct 3 21:55:16 2012 UTC (7 years, 1 month ago) by wiz
Branch: MAIN
Changes since 1.6: +2 -1 lines
Diff to previous 1.6 (colored)

Bump all packages that use perl, or depend on a p5-* package, or
are called p5-*.

I hope that's all of them.

Revision 1.6 / (download) - annotate - [select for diffs], Thu Nov 10 04:39:59 2011 UTC (8 years ago) by hiramatsu
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4
Changes since 1.5: +2 -3 lines
Diff to previous 1.5 (colored)

Update p5-Module-Install-XSUtil to 0.42.

Changes from previous:
0.42 2011-10-19 20:00:07
    - Remove cc_inc_paths, which is already defined in M::I
      (thanks to @shohex)

0.41 2011-10-04 12:05:54
    - Complete support for requires_cplusplus()

0.40 2011-09-24 00:56:33
    - ExtUtils::ParseXS is now configure_requires, instead of
      build_requires (xaicron++)

0.39 2011-08-22 11:28:15
    - Add cc_inc_paths() as an alias to cc_include_paths()
    - Add requires_cplusplus() as an experimental feature;
      currently it chnages only warnings flags

0.38 2011-06-22 15:15:37
    - Workaround MacOSX's system perl failure caused by multiple -arch
      for gcc (thanks to @kazuho)

0.37 2011-05-16 23:33:49
    - Makefile.PL -g implices "-g -ggdb -g3" for gcc (EXPERIMENTAL)
    - PERL_ONLY=1 means --pp for modules with XS/PP dual backends

0.36 Thu Oct  7 16:49:04 2010
    - Resolve RT #61660 (SREZIC): Support for ccache missing
    - Resolve RT #61770 (bokutin): A typo in SYNOPSIS

0.35 Wed Sep 29 23:46:17 2010
    - Checks C99 specification more strictly
    - Add some macros to xshelper.h

0.34 Sun Sep 26 12:18:18 2010
    - Oops! The change in 0.33 did not work.

Revision 1.5 / (download) - annotate - [select for diffs], Sun Aug 14 12:26:18 2011 UTC (8 years, 3 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2011Q3-base, pkgsrc-2011Q3
Changes since 1.4: +2 -1 lines
Diff to previous 1.4 (colored)

Revision bump after updating perl5 to 5.14.1.

Revision 1.4 / (download) - annotate - [select for diffs], Thu Sep 23 22:43:21 2010 UTC (9 years, 1 month ago) by sno
Branch: MAIN
CVS Tags: pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

Updating devel/p5-Module-Install-XSUtil from 0.27 to 0.33

Upstream changes:
0.33 Sun Sep 19 22:15:10 2010
    - Disable -Wdeclaration-after-statement by requires_c99()

0.32 Mon Sep 13 14:18:33 2010
    - Don't clean xshelper.h by default.
      Use use_xshelper -clean (or -realclean) to clean the file.

0.31 Mon Sep 13 13:09:16 2010
    - Fix a check for STATIC_INLINE (s/__cplusplus__/__cplusplus/)

0.30 Sat Sep 11 14:17:06 2010
    - Add use_xshelper() command to create xshelper.h

Revision 1.3 / (download) - annotate - [select for diffs], Wed Sep 8 20:29:16 2010 UTC (9 years, 2 months ago) by sno
Branch: MAIN
Changes since 1.2: +6 -6 lines
Diff to previous 1.2 (colored)

Updating devel/p5-Module-Install-XSUtil from 0.22nb1 to 0.27

pkgsrc changes:
- adjust dependencies

Upstream changes:
0.27 Sun Sep  5 11:47:03 2010
    - c99_available() should not have any side effects (reported by makamaka)

0.26 Sat Aug  7 17:47:37 2010
    - Use the version of installed gcc, not $Config{gccversion} (xaicron)

0.25 Tue Jul 13 19:43:34 2010
    - Add requires_c99() to assert that the compiler supports C99
    - Fix Win32 problems, hopefully

0.24 Sun May 16 13:24:58 2010
    - Compliant with Module::Install 0.97

0.23_02 Fri May 14 11:42:09 2010
    - Don't exit if include dirs don't exist (lestrrat)
    - Add cc_assert_lib() as an interface to Devel::CheckLib (lestrrat)
    - Add want_xs() (lestrrat)
    - Separate out detection of "-" and stuff to cc_libs(), and let
      cc_append_to_lib()s just be a simple function (lestrrat)

0.23_01 Mon May 10 12:10:59 2010
    - Clarify docs (lestrrat)
    - Add want_xs() command (lestrrat)

0.23 Sun May  9 11:15:41 2010
    - Setup clean_files for gcov output files (*.gcov, *.gcno, *.gcda)
    - Add cc_libs() for MakeMaker's LIBS option (currently, it is just an
      ailas to cc_append_libs())
    - cc_append_libs (and then cc_libs) accepts raw arguments as
      "cc_libs qw(-L/path/to/libs -lfoo)" (lestrrat++)

Revision 1.2 / (download) - annotate - [select for diffs], Sat Aug 21 16:34:02 2010 UTC (9 years, 2 months ago) by seb
Branch: MAIN
Changes since 1.1: +2 -1 lines
Diff to previous 1.1 (colored)

Bump the PKGREVISION for all packages which depend directly on perl,
to trigger/signal a rebuild for the transition 5.10.1 -> 5.12.1.

The list of packages is computed by finding all packages which end
up having either of PERL5_USE_PACKLIST, BUILDLINK_API_DEPENDS.perl,
or PERL5_PACKLIST defined in their make setup (tested via
"make show-vars VARNAMES=..."), minus the packages updated after
the perl package update.

sno@ was right after all, obache@ kindly asked and he@ led the
way. Thanks!

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Sat Apr 10 14:20:21 2010 UTC (9 years, 7 months ago) by seb
Branch: TNF
CVS Tags: pkgsrc-base, pkgsrc-2010Q2-base, pkgsrc-2010Q2
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Initial import of p5-Module-Install-XSUtil version 0.22 in the
NetBSD Packages Collection.

The Perl 5 module Module::Install::XSUtil provides a set of utilities
to setup distributions which include or depend on XS module.

Revision 1.1 / (download) - annotate - [select for diffs], Sat Apr 10 14:20:21 2010 UTC (9 years, 7 months ago) by seb
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>