[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / p5-Hash-Util-FieldHash-Compat

File: [cvs.NetBSD.org] / pkgsrc / devel / p5-Hash-Util-FieldHash-Compat / Makefile (download)

Revision 1.19, Sun Nov 3 10:15:55 2019 UTC (4 years, 1 month ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.18: +3 -3 lines

devel/p5-*: align variable assignments

pkglint -Wall -F --only aligned --only indent p5-*

No manual corrections.

# $NetBSD: Makefile,v 1.19 2019/11/03 10:15:55 rillig Exp $
#

DISTNAME=	Hash-Util-FieldHash-Compat-0.11
PKGNAME=	p5-${DISTNAME}
PKGREVISION=	3
CATEGORIES=	devel perl5
MASTER_SITES=	${MASTER_SITE_PERL_CPAN:=Hash/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://metacpan.org/release/Hash-Util-FieldHash-Compat
COMMENT=	Perl 5 module to user Hash::Util::FieldHash or ties
LICENSE=	${PERL5_LICENSE}

USE_LANGUAGES=	# empty
PERL5_PACKLIST=	auto/Hash/Util/FieldHash/Compat/.packlist

# This package was added after Perl 5.10 became the minimal required
# version for pkgsrc. The module Hash::Util::FieldHash is a core
# module since version 5.9.4. Thus this module/package does not need
# any of the two dependencies below.
#DEPENDS+=	p5-Tie-RefHash>=1.38:../../devel/p5-Tie-RefHash
# ---------------------
# Data for 2015-06-01
# Tie::RefHash::Weak was not in CORE (or so I think)
DEPENDS+=	p5-Tie-RefHash-Weak>=0.08:../../devel/p5-Tie-RefHash-Weak

BUILD_DEPENDS+=	p5-Test-Simple>=1.001010:../../devel/p5-Test-Simple

.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"