Up to [cvs.NetBSD.org] / pkgsrc / devel / p5-Function-Parameters
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.7 / (download) - annotate - [select for diffs], Tue Oct 26 10:16:40 2021 UTC (23 months, 1 week ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base,
pkgsrc-2023Q3,
pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1,
pkgsrc-2021Q4-base,
pkgsrc-2021Q4,
HEAD
Changes since 1.6: +2 -2
lines
Diff to previous 1.6 (colored)
archivers: Replace RMD160 checksums with BLAKE2s checksums All checksums have been double-checked against existing RMD160 and SHA512 hashes Could not be committed due to merge conflict: devel/py-traitlets/distinfo The following distfiles were unfetchable (note: some may be only fetched conditionally): ./devel/pvs/distinfo pvs-3.2-solaris.tgz ./devel/eclipse/distinfo eclipse-sourceBuild-srcIncluded-3.0.1.zip
Revision 1.6 / (download) - annotate - [select for diffs], Thu Oct 7 13:41:33 2021 UTC (23 months, 3 weeks ago) by nia
Branch: MAIN
Changes since 1.5: +1 -2
lines
Diff to previous 1.5 (colored)
devel: Remove SHA1 hashes for distfiles
Revision 1.5 / (download) - annotate - [select for diffs], Mon Nov 13 15:10:33 2017 UTC (5 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2,
pkgsrc-2021Q1-base,
pkgsrc-2021Q1,
pkgsrc-2020Q4-base,
pkgsrc-2020Q4,
pkgsrc-2020Q3-base,
pkgsrc-2020Q3,
pkgsrc-2020Q2-base,
pkgsrc-2020Q2,
pkgsrc-2020Q1-base,
pkgsrc-2020Q1,
pkgsrc-2019Q4-base,
pkgsrc-2019Q4,
pkgsrc-2019Q3-base,
pkgsrc-2019Q3,
pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1,
pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3,
pkgsrc-2018Q2-base,
pkgsrc-2018Q2,
pkgsrc-2018Q1-base,
pkgsrc-2018Q1,
pkgsrc-2017Q4-base,
pkgsrc-2017Q4
Changes since 1.4: +5 -5
lines
Diff to previous 1.4 (colored)
p5-Function-Parameters: update to 2.001003. 2.001003 2017-11-11 - Fix threaded initialization issue better. This is the same issue that was fixed in 2.001002, but now we use PL_op_mutex instead of PL_check_mutex. This has the advantage of also being thread-safe on v5.14. 2.001002 2017-11-09 - Fix crash when Function::Parameters is loaded at runtime by multiple threads (a stack overflow due to infinite recursion). This is arguably a core bug (#132413). The current workaround employed by Function::Parameters slightly abuses an internal perl mutex meant for something else (protecting op checkers), but it fixes the issue on perls v5.16 .. v5.26. v5.14 doesn't have this API yet, so the workaround is not thread safe there. It is technically possible to still run into this issue if two threads initialize Function::Parameters at the exact same moment (I haven't managed to reproduce this yet, so hopefully it's unlikely in practice). It is possible to completely avoid the problem on all versions of perl and Function::Parameters by making sure the module is loaded before the first thread is created.
Revision 1.4 / (download) - annotate - [select for diffs], Sun Sep 17 10:35:15 2017 UTC (6 years ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base,
pkgsrc-2017Q3
Changes since 1.3: +5 -5
lines
Diff to previous 1.3 (colored)
p5-Function-Parameters: update to 2.001001. 2.001001 2017-07-12 - fix duplicate type check on invocant: method foo(T $self: $x) { ... } # every call to foo() performs T->check($self) twice - clean up how type errors refer to parameters (now it's "parameter $N" for non-invocant parameters and "invocant $N" for invocants (or just "invocant" if there is exactly one)) - rewrite pragma implementation and the way %^H is used - remove several internal package variables 2.000007 2017-05-15 - no real code changes - extend bug #129090 workaround to perl 5.25.5 - try to detect broken Moose installs earlier - fix declaration of developer dependencies
Revision 1.3 / (download) - annotate - [select for diffs], Wed Apr 19 12:01:43 2017 UTC (6 years, 5 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base,
pkgsrc-2017Q2
Changes since 1.2: +5 -5
lines
Diff to previous 1.2 (colored)
Updated devel/p5-Function-Parameters to 2.000006 ------------------------------------------------ 2.000006 2017-04-16 - work around core bug #129090 / #131146 in perl 5.22 and 5.24: perl -e 'use Function::Parameters; \&f; fun f() { eval "" }' hangs in the compiler (also happens with perl -d or Devel::Cover instead of eval) (gh #29) 2.000003 2017-03-31 - fix a bug where method modifiers would inadvertently declare subs (e.g. 'before foo() {}' acting like 'sub foo; BEGIN { &before('foo', sub {}) }'), breaking Pkg->can($method) and thus Class::Method::Modifiers (RT #120804) - make method modifiers take effect at runtime because otherwise you'd have to wrap every with()/extends() in a BEGIN block to make consumed/inherited methods visible to modifiers (RT #120804) - make method modifiers require a name (what would an anonymous modifier modify?) - (hopefully) improve the error message you get for trying to add any parameters after a slurpy 2.000002 2017-03-27 - default to strict mode - allow types with multiple arguments (e.g. 'Tuple[Int, String]') - implement new 'auto' type reifier and use it by default - allow multiple invocants - support custom installers - implement Moo/Moose-style method modifiers - rework and extend import syntax - make implicit $self available in default arguments - call type reifiers from correct package and remove 2nd arg workaround - remove :(...) prototype syntax - remove undocumented 'attrs' option - drop internal Moo dependency
Revision 1.2 / (download) - annotate - [select for diffs], Mon Mar 20 09:12:26 2017 UTC (6 years, 6 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base,
pkgsrc-2017Q1
Changes since 1.1: +5 -5
lines
Diff to previous 1.1 (colored)
Update devel/p5-Function-Parameters to 1.0706 --------------------------------------------- 1.0706 2017-03-17 - don't require . in @INC during install - improve internal code generation functions used on perls before 5.22 (pkgsrc note) make test fails at t/foreign/Fun/name.t, but the previous version also fails at the same point, thus update, thank you.
Revision 1.1 / (download) - annotate - [select for diffs], Sat Jun 11 12:44:27 2016 UTC (7 years, 3 months ago) by kamil
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base,
pkgsrc-2016Q4,
pkgsrc-2016Q3-base,
pkgsrc-2016Q3,
pkgsrc-2016Q2-base,
pkgsrc-2016Q2
Import p5-Function-Parameters-1.0705 as devel/p5-Function-Parameters This module extends Perl with keywords that let you define functions with parameter lists. It uses Perl's perlapi/PL_keyword_plugin API, so it works reliably and doesn't require a source filter. Originally packaged in pkgsrc-wip by myself. Reviewed by <leot>.