[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / p5-Dist-Zooky

File: [cvs.NetBSD.org] / pkgsrc / devel / p5-Dist-Zooky / Makefile (download)

Revision 1.6, Thu May 29 23:35:51 2014 UTC (4 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.5: +2 -2 lines

Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.

# $NetBSD: Makefile,v 1.6 2014/05/29 23:35:51 wiz Exp $

DISTNAME=	Dist-Zooky-0.10
PKGNAME=	p5-${DISTNAME}
PKGREVISION=	4
CATEGORIES=	devel perl5
MASTER_SITES=	${MASTER_SITE_PERL_CPAN:=Dist/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://search.cpan.org/dist/Dist-Zooky/
COMMENT=	Perl 5 module to convert a distribution to Dist::Zilla
LICENSE=	${PERL5_LICENSE}

DEPENDS+=	p5-App-Cmd>=0.307:../../devel/p5-App-Cmd
DEPENDS+=	{perl>=5.16.0,p5-CPAN-Meta>=2.101610}:../../devel/p5-CPAN-Meta
DEPENDS+=	p5-Dist-Zilla>=4.102342:../../devel/p5-Dist-Zilla
DEPENDS+=	{perl>=5.11.3,p5-ExtUtils-MakeMaker>=6.56}:../../devel/p5-ExtUtils-MakeMaker
DEPENDS+=	{perl>=5.13.3,p5-Module-Build>=0.36070}:../../devel/p5-Module-Build
DEPENDS+=	p5-Moose>=1.07:../../devel/p5-Moose
DEPENDS+=	p5-MooseX-Types>=0.22:../../devel/p5-MooseX-Types
DEPENDS+=	p5-MooseX-Types-Perl>=0.101340:../../devel/p5-MooseX-Types-Perl
DEPENDS+=	p5-Software-License>=0.101.620:../../devel/p5-Software-License

# for implicit depdendencies like File::Temp, IPC::Cmd,
#     Module::Load::Conditional, Params::Check
PERL5_REQD+=	5.14.1

PERL5_PACKLIST=		auto/Dist/Zooky/.packlist

.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"