[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / p5-Curses

File: [cvs.NetBSD.org] / pkgsrc / devel / p5-Curses / Makefile (download)

Revision 1.52, Tue Aug 18 07:31:05 2015 UTC (8 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3
Changes since 1.51: +2 -2 lines

Bump all packages that depend on curses.bui* or terminfo.bui* since they
might incur ncurses dependencies on some platforms, and ncurses just bumped
its shlib.
Some packages were bumped twice now, sorry for that.

# $NetBSD: Makefile,v 1.52 2015/08/18 07:31:05 wiz Exp $

DISTNAME=	Curses-1.32
PKGNAME=	p5-${DISTNAME}
PKGREVISION=	2
CATEGORIES=	devel perl5
MASTER_SITES=	${MASTER_SITE_PERL_CPAN:=Curses/}
EXTRACT_SUFX=	.tgz

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://search.cpan.org/dist/Curses/
COMMENT=	Perl5 module for terminal screen handling and optimization
# really it's gnu-gpl-v1+ OR artistic-1.0, but currently we don't have gplv1
LICENSE=	${PERL5_LICENSE}

PERL5_PACKLIST=		auto/Curses/.packlist

# We should really work out the location of the system forms.h
SUBST_STAGE.h_form	= post-configure
SUBST_MESSAGE.h_form	= Hard wiring form.h
SUBST_FILES.h_form	= c-config.h
SUBST_SED.h_form	= -e 's,<form.h>,"/usr/include/form.h",g'

MAKE_PARAMS+=	FORMS MENUS

.include "../../lang/perl5/module.mk"
.include "../../mk/curses.buildlink3.mk"

.if ${CURSES_TYPE} == "curses"
SUBST_CLASSES+=		h_form
.elif ${CURSES_TYPE} == "ncurses" || ${CURSES_TYPE} == "ncursesw"
MAKE_PARAMS+=		PANELS
# Don't link to system termcap as we're using ncurses
BUILDLINK_TRANSFORM+=	rm:-ltermcap

# Use the FreeBSD ncurses config as that works fine for pkgsrc
pre-configure:
	${LN} -sf ${WRKSRC}/hints/c-freebsd.ncurses.h ${WRKSRC}/c-config.h
.endif

# Pass appropriate CURSES_LIBTYPE so Curses will link to the matching panel/menu/form library
.if ${CURSES_TYPE} == "curses"
.  if ${OPSYS} == "Linux"
CURSES_LIBTYPE=		ncurses
.  else
CURSES_LIBTYPE=		bsd
.  endif
.elif ${CURSES_TYPE} == "ncurses"
CURSES_LIBTYPE=		ncurses
.elif ${CURSES_TYPE} == "ncursesw"
CURSES_LIBTYPE=		ncursesw
.endif

.if defined(CURSES_LIBTYPE)
MAKE_ENV+=		CURSES_LIBTYPE=${CURSES_LIBTYPE}
MAKE_ENV+=		CURSES_CFLAGS=${BUILDLINK_INCDIRS.${CURSES_TYPE}:S/^/-I/}
MAKE_ENV+=		CURSES_LDFLAGS=${BUILDLINK_LDADD.${CURSES_TYPE}}
.endif

.include "../../mk/bsd.pkg.mk"