Up to [cvs.NetBSD.org] / pkgsrc / devel / ogre
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.12 / (download) - annotate - [select for diffs], Tue Oct 26 10:15:58 2021 UTC (23 months, 1 week ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base,
pkgsrc-2023Q3,
pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1,
pkgsrc-2021Q4-base,
pkgsrc-2021Q4,
HEAD
Changes since 1.11: +2 -2
lines
Diff to previous 1.11 (colored)
archivers: Replace RMD160 checksums with BLAKE2s checksums All checksums have been double-checked against existing RMD160 and SHA512 hashes Could not be committed due to merge conflict: devel/py-traitlets/distinfo The following distfiles were unfetchable (note: some may be only fetched conditionally): ./devel/pvs/distinfo pvs-3.2-solaris.tgz ./devel/eclipse/distinfo eclipse-sourceBuild-srcIncluded-3.0.1.zip
Revision 1.11 / (download) - annotate - [select for diffs], Thu Oct 7 13:40:51 2021 UTC (23 months, 3 weeks ago) by nia
Branch: MAIN
Changes since 1.10: +1 -2
lines
Diff to previous 1.10 (colored)
devel: Remove SHA1 hashes for distfiles
Revision 1.10 / (download) - annotate - [select for diffs], Mon Mar 1 12:12:14 2021 UTC (2 years, 7 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2,
pkgsrc-2021Q1-base,
pkgsrc-2021Q1
Changes since 1.9: +6 -8
lines
Diff to previous 1.9 (colored)
ogre: Update to 1.12.11 The main change is that it builds again. # New and Noteworthy in OGRE 1.12 This is only a high level overview. For a detailed changes, see the git changelog. ## Core changes ### Component Media files Previously all of our bundled Media files lived in the `Samples/Media` subdirectory - including the `RTShaderLib`. However the latter is not a sample, but required to use the RTSS component. Therefore, we now put media files that are required by a component into `Media/*` and install them independent of the Sample Media. This allows you to merely reference these locations instead of having to copy them into your project. Consequently, this allowed us to move various embedded resources to the filesystem for easier editing. **ACTION REQUIRED** you must add the `Media/ShadowVolume` resource location to use the build-in algorithms. ### NEON intrinsics on all ARM platforms We converted our SSE based OptimisedMath using SSE2NEON. While the gains are not as substantial as on x86, you can expect an speedup of about 30% for e.g. CPU skeletal animation. ### Automatic Plugin discovery for Windows Debug builds Ogre now automatically append the `_d` suffix to plugin library names on windows. Consequently it does not need a `plugins_d.cfg` any more. Therefore you can now use the same config files for release and debug with the same content. ### Separate UV skyboxes removed Ogre no longer supports `cubic_texture .. separateUV` textures. Previously it was possible to create a "fake" cubic texture unit which would actually contain 6 individual 2d textures. These could be used to render skyboxes. Only skyboxes that is. For everything else you would need real hardware cubic textures. Ogre will ignore the `separateUV` part now, and create a real cubic texture anyway. The advantage is that ogre renders the skybox with only one draw call. **ACTION REQUIRED** If you use custom shaders on such materials, you will have to update them to cope with real cubic textures. ### RenderSystem - unified API for fixed-function and shaders The `RenderSystem` API was modernized and streamlined for programmable pipeline usage. Consequently most of the legacy fixed function API calls were removed (e.g. `_setProjectionMatrix`, `_setSurfaceParams`). Instead these parameters are now passed through the `GpuProgramParameters` structure to the fixed function unifying the API between fixed and programmable pipeline. RenderSystems supporting `RSC_FIXED_FUNCTION`, now export the respective parameters through `getFixedFunctionParams`. You can query and modify those and then apply them using `applyFixedFunctionParams`. If you bypass the SceneManager and use the RenderSystem directly, e.g. `_setProjectionMatrix` becomes ```cpp auto params = rs->getFixedFunctionParams(TVC_NONE, FOG_NONE); params->setConstant(8, Matrix4()); // the "magic" 8 is defined in getFixedFunctionParams rs->applyFixedFunctionParams(params, GPV_GLOBAL); ``` ### Improved Profiling The instrumentation code inside Ogre was improved to be less costy compared to the measured code. At this we also improved the labels to be more readable (camera name vs. "_renderScene") - see [the updated Profiling tutorial](https://codedocs.xyz/OGRECave/ogre/profiler.html#profRead). Additionally the Profiler class can now use [Remotery](https://github.com/Celtoys/Remotery) as its backend. Again see the tutorial for more details. ### Breaking non-API changes These changes require unit testing on your side as compilation will succeed, but the rendering result may vary compared to 1.11. * `fog_override` semantics changed: previously it would only affect fixed function fog and shader autoparams would still get the global scene fog. Now both autparams and fixed function settings are affected. * `SubMesh::setMaterialName` now immediately queries the `MaterialManager` instead of merely storing the name. This means that if you do not load any `.material` files and do an import/ export cycle of a `.mesh`, the material names will be lost. This is a common use case for offline processing of mesh files. Register a `MeshSerializerListener` to create dummy materials in this case. * `Ogre::any_cast` now throws a `std::bad_cast` exception instead of a `Ogre::InvalidParametersException` for compatibility with `std::any_cast`. Both derive from `std::exception`, in case you want to preserve legacy compatibility. * The `OGRE_BUILD_*` defines moved to a separate `OgreComponents.h` header. As those were typically checked with `#ifdef`, these check will silently fail. Migrate to the `Ogre.h` header instead of including headers form OgreMain directly. * compute shaders are no longer automatically dispatched when the according material is used during rendering. You now have to explicitly reference the respective material in a [*compute* compisitor pass](https://ogrecave.github.io/ogre/api/latest/_compositor-_scripts.html#Compositor-Passes). ## Samples As a side-effect of the stable media files effort, the Sample media files were refactored as well. Now all GL rendersystems share a common GLSL shader codebase - likewise the D3D rendersystems and the Cg plugin use the same Cg shaders (which is just HLSL9 really). Additionally we took advantage of the RTSS improvements and replaced any custom depth shadow code by the unified RTSS solution. ## Bites The `ApplicationContext` class was split into `ApplicationContextBase` and `ApplicationContextSDL`. This allows additional implementations (like Qt) and eases consumption in projects that do not use SDL. ## Real Time Shader System 3.0 The RTSS API was overhauled and is now more flexible and easy to use. You can now directly acquire shaders for an arbitrary Pass using `TargetRenderState` - without having to go through any Viewport Scheme juggling. This means that `TargetRenderState` can now replace any ad-hoc shader generator that you might have in place to leverage the Ogre maintained RTSS shader snippets. The RTSS now defaults to Per-Pixel lighting, consequently making it the default for GL3+/ GLES2 and D3D11. ### Depth Shadowmap Support The PSSM3 shadow stage now supports hardware PCF and automatically uses it if your shadow textures are compatible (i.e. of type `PF_DEPTH`). Furthermore you can now use it generally for depth based textures by not calling `setSplitPoints` - it will use only the first depth shadow texture then. ### Merged Lighting calculations The Fixed Function, Per-Pixel and Normal map sub-render states now all share the same shader code. **ACTION REQUIRED** you must update your `RTShaderLib` for the 1.12 shaders. ## Terrain To allow usage `PF_DEPTH` shadow textures, the "linear" depth code was dropped from the `SM2Profile`. Where previously you were expected to write an interpolated value of `(gl_Position.z - depthRange.x) * depthRange.w` in the fragment shader, it is now enough to just write `gl_FragCoord.z`. This enables early-z optimizations by the hardware and generally eases the workflow. Refer to the Terrain Sample for the updated depth shadow scene setup. Furthermore it is now possible to load legacy 1.7 style Terrains (aka "terrain.cfg") using `TerrainGroup::loadLegacyTerrain`. **ACTION REQUIRED** you have to add the `Media/Terrain` resource location to use the SM2Profile Shader Generator. ## D3D9 RenderSystem Direct3D9 feature level 9.1 is now required. ## GL/ GLES2/ GL3+ `#include` directives in GLSL shaders are now resolved by OGRE. The lookup is performed by filename using the Resource System. (based on the existing code of the Cg plugin) Monolithic shaders are used instead of separable shader objects (SSO) by default again due to better performance and better driver support.
Revision 1.9 / (download) - annotate - [select for diffs], Tue Nov 3 03:27:53 2015 UTC (7 years, 11 months ago) by agc
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base,
pkgsrc-2020Q4,
pkgsrc-2020Q3-base,
pkgsrc-2020Q3,
pkgsrc-2020Q2-base,
pkgsrc-2020Q2,
pkgsrc-2020Q1-base,
pkgsrc-2020Q1,
pkgsrc-2019Q4-base,
pkgsrc-2019Q4,
pkgsrc-2019Q3-base,
pkgsrc-2019Q3,
pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1,
pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3,
pkgsrc-2018Q2-base,
pkgsrc-2018Q2,
pkgsrc-2018Q1-base,
pkgsrc-2018Q1,
pkgsrc-2017Q4-base,
pkgsrc-2017Q4,
pkgsrc-2017Q3-base,
pkgsrc-2017Q3,
pkgsrc-2017Q2-base,
pkgsrc-2017Q2,
pkgsrc-2017Q1-base,
pkgsrc-2017Q1,
pkgsrc-2016Q4-base,
pkgsrc-2016Q4,
pkgsrc-2016Q3-base,
pkgsrc-2016Q3,
pkgsrc-2016Q2-base,
pkgsrc-2016Q2,
pkgsrc-2016Q1-base,
pkgsrc-2016Q1,
pkgsrc-2015Q4-base,
pkgsrc-2015Q4
Changes since 1.8: +2 -1
lines
Diff to previous 1.8 (colored)
Add SHA512 digests for distfiles for devel category Issues found with existing distfiles: distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip distfiles/fortran-utils-1.1.tar.gz distfiles/ivykis-0.39.tar.gz distfiles/enum-1.11.tar.gz distfiles/pvs-3.2-libraries.tgz distfiles/pvs-3.2-linux.tgz distfiles/pvs-3.2-solaris.tgz distfiles/pvs-3.2-system.tgz No changes made to these distinfo files. Otherwise, existing SHA1 digests verified and found to be the same on the machine holding the existing distfiles (morden). All existing SHA1 digests retained for now as an audit trail.
Revision 1.8 / (download) - annotate - [select for diffs], Tue Apr 21 17:04:25 2015 UTC (8 years, 5 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base,
pkgsrc-2015Q3,
pkgsrc-2015Q2-base,
pkgsrc-2015Q2
Changes since 1.7: +3 -1
lines
Diff to previous 1.7 (colored)
Replace size_t overloads with long long overloads to help ILP32 platforms.
Revision 1.7 / (download) - annotate - [select for diffs], Mon Aug 30 20:30:28 2010 UTC (13 years, 1 month ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base,
pkgsrc-2015Q1,
pkgsrc-2014Q4-base,
pkgsrc-2014Q4,
pkgsrc-2014Q3-base,
pkgsrc-2014Q3,
pkgsrc-2014Q2-base,
pkgsrc-2014Q2,
pkgsrc-2014Q1-base,
pkgsrc-2014Q1,
pkgsrc-2013Q4-base,
pkgsrc-2013Q4,
pkgsrc-2013Q3-base,
pkgsrc-2013Q3,
pkgsrc-2013Q2-base,
pkgsrc-2013Q2,
pkgsrc-2013Q1-base,
pkgsrc-2013Q1,
pkgsrc-2012Q4-base,
pkgsrc-2012Q4,
pkgsrc-2012Q3-base,
pkgsrc-2012Q3,
pkgsrc-2012Q2-base,
pkgsrc-2012Q2,
pkgsrc-2012Q1-base,
pkgsrc-2012Q1,
pkgsrc-2011Q4-base,
pkgsrc-2011Q4,
pkgsrc-2011Q3-base,
pkgsrc-2011Q3,
pkgsrc-2011Q2-base,
pkgsrc-2011Q2,
pkgsrc-2011Q1-base,
pkgsrc-2011Q1,
pkgsrc-2010Q4-base,
pkgsrc-2010Q4,
pkgsrc-2010Q3-base,
pkgsrc-2010Q3
Changes since 1.6: +2 -2
lines
Diff to previous 1.6 (colored)
Stop playing with -fvisibility to fix compilation on amd64.
Revision 1.6 / (download) - annotate - [select for diffs], Tue Sep 1 16:53:40 2009 UTC (14 years, 1 month ago) by hasso
Branch: MAIN
CVS Tags: pkgsrc-2010Q2-base,
pkgsrc-2010Q2,
pkgsrc-2010Q1-base,
pkgsrc-2010Q1,
pkgsrc-2009Q4-base,
pkgsrc-2009Q4,
pkgsrc-2009Q3-base,
pkgsrc-2009Q3
Changes since 1.5: +5 -16
lines
Diff to previous 1.5 (colored)
Update to 1.6.3. Not pasting the upstream changelog here, because it's a massive (4 years of development).
Revision 1.5 / (download) - annotate - [select for diffs], Thu Dec 13 10:41:06 2007 UTC (15 years, 9 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2009Q2-base,
pkgsrc-2009Q2,
pkgsrc-2009Q1-base,
pkgsrc-2009Q1,
pkgsrc-2008Q4-base,
pkgsrc-2008Q4,
pkgsrc-2008Q3-base,
pkgsrc-2008Q3,
pkgsrc-2008Q2-base,
pkgsrc-2008Q2,
pkgsrc-2008Q1-base,
pkgsrc-2008Q1,
pkgsrc-2007Q4-base,
pkgsrc-2007Q4,
cwrapper,
cube-native-xorg-base,
cube-native-xorg
Changes since 1.4: +7 -1
lines
Diff to previous 1.4 (colored)
Added fixes for g++4.
Revision 1.4 / (download) - annotate - [select for diffs], Fri May 19 14:32:43 2006 UTC (17 years, 4 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2007Q3-base,
pkgsrc-2007Q3,
pkgsrc-2007Q2-base,
pkgsrc-2007Q2,
pkgsrc-2007Q1-base,
pkgsrc-2007Q1,
pkgsrc-2006Q4-base,
pkgsrc-2006Q4,
pkgsrc-2006Q3-base,
pkgsrc-2006Q3,
pkgsrc-2006Q2-base,
pkgsrc-2006Q2
Changes since 1.3: +4 -1
lines
Diff to previous 1.3 (colored)
Use and fix C++. Fix pthread linkage.
Revision 1.3 / (download) - annotate - [select for diffs], Wed Feb 23 22:24:22 2005 UTC (18 years, 7 months ago) by agc
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base,
pkgsrc-2006Q1,
pkgsrc-2005Q4-base,
pkgsrc-2005Q4,
pkgsrc-2005Q3-base,
pkgsrc-2005Q3,
pkgsrc-2005Q2-base,
pkgsrc-2005Q2,
pkgsrc-2005Q1-base,
pkgsrc-2005Q1
Changes since 1.2: +2 -1
lines
Diff to previous 1.2 (colored)
Add RMD160 digests.
Revision 1.2 / (download) - annotate - [select for diffs], Fri Feb 27 14:50:19 2004 UTC (19 years, 7 months ago) by jmmv
Branch: MAIN
CVS Tags: pkgsrc-2004Q4-base,
pkgsrc-2004Q4,
pkgsrc-2004Q3-base,
pkgsrc-2004Q3,
pkgsrc-2004Q2-base,
pkgsrc-2004Q2,
pkgsrc-2004Q1-base,
pkgsrc-2004Q1
Changes since 1.1: +2 -1
lines
Diff to previous 1.1 (colored)
Fix a typo in the configure script that makes the build fail when using gcc < 3.x, as shown in last kristerw@'s bulk build.
Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Wed Dec 3 19:01:46 2003 UTC (19 years, 10 months ago) by xtraeme
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0
lines
Diff to previous 1.1 (colored)
Initial import of ogre-0.12.1 from pkgsrc-wip. OGRE (Object-Oriented Graphics Rendering Engine) is a scene-oriented, flexible 3D engine written in C++ designed to make it easier and more intuitive for developers to produce games and demos utilising 3D hardware. The class library abstracts all the details of using the underlying system libraries like Direct3D and OpenGL and provides an interface based on world objects and other intuitive classes.
Revision 1.1 / (download) - annotate - [select for diffs], Wed Dec 3 19:01:46 2003 UTC (19 years, 10 months ago) by xtraeme
Branch: MAIN
Initial revision