Up to [cvs.NetBSD.org] / pkgsrc / devel / ogre
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.55 / (download) - annotate - [select for diffs], Thu Nov 16 09:44:03 2023 UTC (2 weeks, 2 days ago) by nia
Branch: MAIN
CVS Tags: HEAD
Changes since 1.54: +4 -2
lines
Diff to previous 1.54 (colored)
ogre: Convert to using FORCE_CXX_STD
Revision 1.54 / (download) - annotate - [select for diffs], Sun Nov 12 13:21:08 2023 UTC (2 weeks, 6 days ago) by wiz
Branch: MAIN
Changes since 1.53: +2 -2
lines
Diff to previous 1.53 (colored)
*: revebump for new brotli option for freetype2 Addresses PR 57693
Revision 1.53 / (download) - annotate - [select for diffs], Mon Aug 14 05:24:13 2023 UTC (3 months, 2 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base,
pkgsrc-2023Q3
Changes since 1.52: +2 -2
lines
Diff to previous 1.52 (colored)
*: recursive bump for Python 3.11 as new default
Revision 1.52 / (download) - annotate - [select for diffs], Fri Aug 11 09:02:05 2023 UTC (3 months, 3 weeks ago) by nia
Branch: MAIN
Changes since 1.51: +7 -1
lines
Diff to previous 1.51 (colored)
ogre: Fix PLIST on systems with GLESv2 support
Revision 1.51 / (download) - annotate - [select for diffs], Fri Jul 21 08:30:48 2023 UTC (4 months, 1 week ago) by nia
Branch: MAIN
Changes since 1.50: +2 -2
lines
Diff to previous 1.50 (colored)
ogre: Require a compiler that supports put_time.
Revision 1.50 / (download) - annotate - [select for diffs], Tue Jul 18 14:11:17 2023 UTC (4 months, 2 weeks ago) by nia
Branch: MAIN
Changes since 1.49: +2 -2
lines
Diff to previous 1.49 (colored)
devel: Adapt packages to use USE_(CC|CXX)_FEATURES
Revision 1.49 / (download) - annotate - [select for diffs], Thu Mar 9 11:17:34 2023 UTC (8 months, 3 weeks ago) by he
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1
Changes since 1.48: +2 -1
lines
Diff to previous 1.48 (colored)
ogre: add gnu++11 to USE_LANGUAGES, due to alloca() usage. Sadly, this doesn't fix the macppc build problems for this package, because the next one is "no -lGLESv2 library found", which is a lot harder to tackle.
Revision 1.48 / (download) - annotate - [select for diffs], Sun Jan 29 21:15:49 2023 UTC (10 months ago) by ryoon
Branch: MAIN
Changes since 1.47: +2 -1
lines
Diff to previous 1.47 (colored)
*: Recursive revbup from graphics/freetype2
Revision 1.47 / (download) - annotate - [select for diffs], Mon Mar 1 12:12:14 2021 UTC (2 years, 9 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1,
pkgsrc-2021Q4-base,
pkgsrc-2021Q4,
pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2,
pkgsrc-2021Q1-base,
pkgsrc-2021Q1
Changes since 1.46: +38 -21
lines
Diff to previous 1.46 (colored)
ogre: Update to 1.12.11 The main change is that it builds again. # New and Noteworthy in OGRE 1.12 This is only a high level overview. For a detailed changes, see the git changelog. ## Core changes ### Component Media files Previously all of our bundled Media files lived in the `Samples/Media` subdirectory - including the `RTShaderLib`. However the latter is not a sample, but required to use the RTSS component. Therefore, we now put media files that are required by a component into `Media/*` and install them independent of the Sample Media. This allows you to merely reference these locations instead of having to copy them into your project. Consequently, this allowed us to move various embedded resources to the filesystem for easier editing. **ACTION REQUIRED** you must add the `Media/ShadowVolume` resource location to use the build-in algorithms. ### NEON intrinsics on all ARM platforms We converted our SSE based OptimisedMath using SSE2NEON. While the gains are not as substantial as on x86, you can expect an speedup of about 30% for e.g. CPU skeletal animation. ### Automatic Plugin discovery for Windows Debug builds Ogre now automatically append the `_d` suffix to plugin library names on windows. Consequently it does not need a `plugins_d.cfg` any more. Therefore you can now use the same config files for release and debug with the same content. ### Separate UV skyboxes removed Ogre no longer supports `cubic_texture .. separateUV` textures. Previously it was possible to create a "fake" cubic texture unit which would actually contain 6 individual 2d textures. These could be used to render skyboxes. Only skyboxes that is. For everything else you would need real hardware cubic textures. Ogre will ignore the `separateUV` part now, and create a real cubic texture anyway. The advantage is that ogre renders the skybox with only one draw call. **ACTION REQUIRED** If you use custom shaders on such materials, you will have to update them to cope with real cubic textures. ### RenderSystem - unified API for fixed-function and shaders The `RenderSystem` API was modernized and streamlined for programmable pipeline usage. Consequently most of the legacy fixed function API calls were removed (e.g. `_setProjectionMatrix`, `_setSurfaceParams`). Instead these parameters are now passed through the `GpuProgramParameters` structure to the fixed function unifying the API between fixed and programmable pipeline. RenderSystems supporting `RSC_FIXED_FUNCTION`, now export the respective parameters through `getFixedFunctionParams`. You can query and modify those and then apply them using `applyFixedFunctionParams`. If you bypass the SceneManager and use the RenderSystem directly, e.g. `_setProjectionMatrix` becomes ```cpp auto params = rs->getFixedFunctionParams(TVC_NONE, FOG_NONE); params->setConstant(8, Matrix4()); // the "magic" 8 is defined in getFixedFunctionParams rs->applyFixedFunctionParams(params, GPV_GLOBAL); ``` ### Improved Profiling The instrumentation code inside Ogre was improved to be less costy compared to the measured code. At this we also improved the labels to be more readable (camera name vs. "_renderScene") - see [the updated Profiling tutorial](https://codedocs.xyz/OGRECave/ogre/profiler.html#profRead). Additionally the Profiler class can now use [Remotery](https://github.com/Celtoys/Remotery) as its backend. Again see the tutorial for more details. ### Breaking non-API changes These changes require unit testing on your side as compilation will succeed, but the rendering result may vary compared to 1.11. * `fog_override` semantics changed: previously it would only affect fixed function fog and shader autoparams would still get the global scene fog. Now both autparams and fixed function settings are affected. * `SubMesh::setMaterialName` now immediately queries the `MaterialManager` instead of merely storing the name. This means that if you do not load any `.material` files and do an import/ export cycle of a `.mesh`, the material names will be lost. This is a common use case for offline processing of mesh files. Register a `MeshSerializerListener` to create dummy materials in this case. * `Ogre::any_cast` now throws a `std::bad_cast` exception instead of a `Ogre::InvalidParametersException` for compatibility with `std::any_cast`. Both derive from `std::exception`, in case you want to preserve legacy compatibility. * The `OGRE_BUILD_*` defines moved to a separate `OgreComponents.h` header. As those were typically checked with `#ifdef`, these check will silently fail. Migrate to the `Ogre.h` header instead of including headers form OgreMain directly. * compute shaders are no longer automatically dispatched when the according material is used during rendering. You now have to explicitly reference the respective material in a [*compute* compisitor pass](https://ogrecave.github.io/ogre/api/latest/_compositor-_scripts.html#Compositor-Passes). ## Samples As a side-effect of the stable media files effort, the Sample media files were refactored as well. Now all GL rendersystems share a common GLSL shader codebase - likewise the D3D rendersystems and the Cg plugin use the same Cg shaders (which is just HLSL9 really). Additionally we took advantage of the RTSS improvements and replaced any custom depth shadow code by the unified RTSS solution. ## Bites The `ApplicationContext` class was split into `ApplicationContextBase` and `ApplicationContextSDL`. This allows additional implementations (like Qt) and eases consumption in projects that do not use SDL. ## Real Time Shader System 3.0 The RTSS API was overhauled and is now more flexible and easy to use. You can now directly acquire shaders for an arbitrary Pass using `TargetRenderState` - without having to go through any Viewport Scheme juggling. This means that `TargetRenderState` can now replace any ad-hoc shader generator that you might have in place to leverage the Ogre maintained RTSS shader snippets. The RTSS now defaults to Per-Pixel lighting, consequently making it the default for GL3+/ GLES2 and D3D11. ### Depth Shadowmap Support The PSSM3 shadow stage now supports hardware PCF and automatically uses it if your shadow textures are compatible (i.e. of type `PF_DEPTH`). Furthermore you can now use it generally for depth based textures by not calling `setSplitPoints` - it will use only the first depth shadow texture then. ### Merged Lighting calculations The Fixed Function, Per-Pixel and Normal map sub-render states now all share the same shader code. **ACTION REQUIRED** you must update your `RTShaderLib` for the 1.12 shaders. ## Terrain To allow usage `PF_DEPTH` shadow textures, the "linear" depth code was dropped from the `SM2Profile`. Where previously you were expected to write an interpolated value of `(gl_Position.z - depthRange.x) * depthRange.w` in the fragment shader, it is now enough to just write `gl_FragCoord.z`. This enables early-z optimizations by the hardware and generally eases the workflow. Refer to the Terrain Sample for the updated depth shadow scene setup. Furthermore it is now possible to load legacy 1.7 style Terrains (aka "terrain.cfg") using `TerrainGroup::loadLegacyTerrain`. **ACTION REQUIRED** you have to add the `Media/Terrain` resource location to use the SM2Profile Shader Generator. ## D3D9 RenderSystem Direct3D9 feature level 9.1 is now required. ## GL/ GLES2/ GL3+ `#include` directives in GLSL shaders are now resolved by OGRE. The lookup is performed by filename using the Resource System. (based on the existing code of the Cg plugin) Monolithic shaders are used instead of separable shader objects (SSO) by default again due to better performance and better driver support.
Revision 1.46 / (download) - annotate - [select for diffs], Fri Jun 5 12:48:59 2020 UTC (3 years, 5 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base,
pkgsrc-2020Q4,
pkgsrc-2020Q3-base,
pkgsrc-2020Q3,
pkgsrc-2020Q2-base,
pkgsrc-2020Q2
Changes since 1.45: +2 -2
lines
Diff to previous 1.45 (colored)
*: Apply revbump for graphics/giflib API change.
Revision 1.45 / (download) - annotate - [select for diffs], Fri Mar 20 11:57:28 2020 UTC (3 years, 8 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base,
pkgsrc-2020Q1
Changes since 1.44: +2 -2
lines
Diff to previous 1.44 (colored)
*: Convert broken sourceforge HOMEPAGEs back to http
Revision 1.44 / (download) - annotate - [select for diffs], Sat Jan 18 23:30:34 2020 UTC (3 years, 10 months ago) by rillig
Branch: MAIN
Changes since 1.43: +2 -2
lines
Diff to previous 1.43 (colored)
all: migrate several HOMEPAGEs to https pkglint --only "https instead of http" -r -F With manual adjustments afterwards since pkglint 19.4.4 fixed a few indentations in unrelated lines. This mainly affects projects hosted at SourceForce, as well as freedesktop.org, CTAN and GNU.
Revision 1.43 / (download) - annotate - [select for diffs], Wed Jul 18 00:06:13 2018 UTC (5 years, 4 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base,
pkgsrc-2019Q4,
pkgsrc-2019Q3-base,
pkgsrc-2019Q3,
pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1,
pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3
Changes since 1.42: +2 -2
lines
Diff to previous 1.42 (colored)
Mark packages that require C++03 (or the GNU variants) if they fail with C++14 default language.
Revision 1.42 / (download) - annotate - [select for diffs], Sat Apr 25 14:20:37 2015 UTC (8 years, 7 months ago) by tnn
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base,
pkgsrc-2018Q2,
pkgsrc-2018Q1-base,
pkgsrc-2018Q1,
pkgsrc-2017Q4-base,
pkgsrc-2017Q4,
pkgsrc-2017Q3-base,
pkgsrc-2017Q3,
pkgsrc-2017Q2-base,
pkgsrc-2017Q2,
pkgsrc-2017Q1-base,
pkgsrc-2017Q1,
pkgsrc-2016Q4-base,
pkgsrc-2016Q4,
pkgsrc-2016Q3-base,
pkgsrc-2016Q3,
pkgsrc-2016Q2-base,
pkgsrc-2016Q2,
pkgsrc-2016Q1-base,
pkgsrc-2016Q1,
pkgsrc-2015Q4-base,
pkgsrc-2015Q4,
pkgsrc-2015Q3-base,
pkgsrc-2015Q3,
pkgsrc-2015Q2-base,
pkgsrc-2015Q2
Changes since 1.41: +2 -2
lines
Diff to previous 1.41 (colored)
Recursive revbump following MesaLib update, categories a through f.
Revision 1.41 / (download) - annotate - [select for diffs], Thu May 15 14:41:47 2014 UTC (9 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base,
pkgsrc-2015Q1,
pkgsrc-2014Q4-base,
pkgsrc-2014Q4,
pkgsrc-2014Q3-base,
pkgsrc-2014Q3,
pkgsrc-2014Q2-base,
pkgsrc-2014Q2
Changes since 1.40: +2 -2
lines
Diff to previous 1.40 (colored)
Revbump after updating graphics/giflib
Revision 1.40 / (download) - annotate - [select for diffs], Wed Oct 9 17:39:04 2013 UTC (10 years, 1 month ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base,
pkgsrc-2014Q1,
pkgsrc-2013Q4-base,
pkgsrc-2013Q4
Changes since 1.39: +2 -2
lines
Diff to previous 1.39 (colored)
recursive bump for libmng-2.0.2 shlib major bump and dependency change
Revision 1.39 / (download) - annotate - [select for diffs], Fri Jul 5 13:29:29 2013 UTC (10 years, 5 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2013Q3-base,
pkgsrc-2013Q3
Changes since 1.38: +2 -2
lines
Diff to previous 1.38 (colored)
Recursive revbump from graphics/giflib update to 5.0.4.
Revision 1.38 / (download) - annotate - [select for diffs], Tue Jun 4 22:15:55 2013 UTC (10 years, 6 months ago) by tron
Branch: MAIN
CVS Tags: pkgsrc-2013Q2-base,
pkgsrc-2013Q2
Changes since 1.37: +2 -2
lines
Diff to previous 1.37 (colored)
Try to fix the fallout caused by the fix for PR pkg/47882. Part 3: Recursively bump package revisions again after the "freetype2" and "fontconfig" handling was fixed.
Revision 1.37 / (download) - annotate - [select for diffs], Mon Jun 3 10:04:48 2013 UTC (10 years, 6 months ago) by wiz
Branch: MAIN
Changes since 1.36: +2 -2
lines
Diff to previous 1.36 (colored)
Bump freetype2 and fontconfig dependencies to current pkgsrc versions, to address issues with NetBSD-6(and earlier)'s fontconfig not being new enough for pango. While doing that, also bump freetype2 dependency to current pkgsrc version. Suggested by tron in PR 47882
Revision 1.36 / (download) - annotate - [select for diffs], Sat Feb 16 11:19:26 2013 UTC (10 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base,
pkgsrc-2013Q1
Changes since 1.35: +2 -2
lines
Diff to previous 1.35 (colored)
Recursive bump for png-1.6.
Revision 1.35 / (download) - annotate - [select for diffs], Sat Jan 26 21:36:22 2013 UTC (10 years, 10 months ago) by adam
Branch: MAIN
Changes since 1.34: +2 -2
lines
Diff to previous 1.34 (colored)
Revbump after graphics/jpeg and textproc/icu
Revision 1.34 / (download) - annotate - [select for diffs], Wed Oct 31 11:17:33 2012 UTC (11 years, 1 month ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base,
pkgsrc-2012Q4
Changes since 1.33: +1 -3
lines
Diff to previous 1.33 (colored)
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.
Revision 1.33 / (download) - annotate - [select for diffs], Mon Feb 6 12:39:55 2012 UTC (11 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base,
pkgsrc-2012Q3,
pkgsrc-2012Q2-base,
pkgsrc-2012Q2,
pkgsrc-2012Q1-base,
pkgsrc-2012Q1
Changes since 1.32: +2 -2
lines
Diff to previous 1.32 (colored)
Revbump for a) tiff update to 4.0 (shlib major change) b) glib2 update 2.30.2 (adds libffi dependency to buildlink3.mk) Enjoy.
Revision 1.32 / (download) - annotate - [select for diffs], Wed Jan 4 15:00:54 2012 UTC (11 years, 11 months ago) by dholland
Branch: MAIN
CVS Tags: pkgsrc-2011Q4-base,
pkgsrc-2011Q4
Changes since 1.31: +3 -2
lines
Diff to previous 1.31 (colored)
missing libXxf86vm, showed up in linux build
Revision 1.31 / (download) - annotate - [select for diffs], Tue Nov 1 06:01:01 2011 UTC (12 years, 1 month ago) by sbd
Branch: MAIN
Changes since 1.30: +2 -2
lines
Diff to previous 1.30 (colored)
Recursive bump for graphics/freetype2 buildlink addition.
Revision 1.30 / (download) - annotate - [select for diffs], Thu Jan 13 13:36:14 2011 UTC (12 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2011Q3-base,
pkgsrc-2011Q3,
pkgsrc-2011Q2-base,
pkgsrc-2011Q2,
pkgsrc-2011Q1-base,
pkgsrc-2011Q1
Changes since 1.29: +2 -2
lines
Diff to previous 1.29 (colored)
png shlib name changed for png>=1.5.0, so bump PKGREVISIONs.
Revision 1.29 / (download) - annotate - [select for diffs], Mon Aug 30 20:42:44 2010 UTC (13 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2010Q4-base,
pkgsrc-2010Q4,
pkgsrc-2010Q3-base,
pkgsrc-2010Q3
Changes since 1.28: +2 -1
lines
Diff to previous 1.28 (colored)
Set LICENSE.
Revision 1.28 / (download) - annotate - [select for diffs], Sun Jun 13 22:44:08 2010 UTC (13 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2010Q2-base,
pkgsrc-2010Q2
Changes since 1.27: +2 -2
lines
Diff to previous 1.27 (colored)
Bump PKGREVISION for libpng shlib name change. Also add some patches to remove use of deprecated symbols and fix other problems when looking for or compiling against libpng-1.4.x.
Revision 1.27 / (download) - annotate - [select for diffs], Mon Jan 18 09:58:46 2010 UTC (13 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2010Q1-base,
pkgsrc-2010Q1
Changes since 1.26: +2 -1
lines
Diff to previous 1.26 (colored)
Second try at jpeg-8 recursive PKGREVISION bump.
Revision 1.26 / (download) - annotate - [select for diffs], Tue Sep 1 16:53:40 2009 UTC (14 years, 3 months ago) by hasso
Branch: MAIN
CVS Tags: pkgsrc-2009Q4-base,
pkgsrc-2009Q4,
pkgsrc-2009Q3-base,
pkgsrc-2009Q3
Changes since 1.25: +14 -8
lines
Diff to previous 1.25 (colored)
Update to 1.6.3. Not pasting the upstream changelog here, because it's a massive (4 years of development).
Revision 1.25 / (download) - annotate - [select for diffs], Wed Aug 26 19:56:44 2009 UTC (14 years, 3 months ago) by sno
Branch: MAIN
Changes since 1.24: +2 -2
lines
Diff to previous 1.24 (colored)
bump revision because of graphics/jpeg update
Revision 1.24 / (download) - annotate - [select for diffs], Thu Feb 22 19:26:22 2007 UTC (16 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2009Q2-base,
pkgsrc-2009Q2,
pkgsrc-2009Q1-base,
pkgsrc-2009Q1,
pkgsrc-2008Q4-base,
pkgsrc-2008Q4,
pkgsrc-2008Q3-base,
pkgsrc-2008Q3,
pkgsrc-2008Q2-base,
pkgsrc-2008Q2,
pkgsrc-2008Q1-base,
pkgsrc-2008Q1,
pkgsrc-2007Q4-base,
pkgsrc-2007Q4,
pkgsrc-2007Q3-base,
pkgsrc-2007Q3,
pkgsrc-2007Q2-base,
pkgsrc-2007Q2,
pkgsrc-2007Q1-base,
pkgsrc-2007Q1,
cwrapper,
cube-native-xorg-base,
cube-native-xorg
Changes since 1.23: +2 -2
lines
Diff to previous 1.23 (colored)
Whitespace cleanup, courtesy of pkglint. Patch provided by Sergey Svishchev in private mail.
Revision 1.23 / (download) - annotate - [select for diffs], Mon Jun 12 16:28:05 2006 UTC (17 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2006Q4-base,
pkgsrc-2006Q4,
pkgsrc-2006Q3-base,
pkgsrc-2006Q3,
pkgsrc-2006Q2-base,
pkgsrc-2006Q2
Changes since 1.22: +2 -2
lines
Diff to previous 1.22 (colored)
Bump PKGREVISION and BUILDLINK_ABI_DEPENDS (where applicable) for SDL shlib changes.
Revision 1.22 / (download) - annotate - [select for diffs], Fri May 19 14:32:43 2006 UTC (17 years, 6 months ago) by joerg
Branch: MAIN
Changes since 1.21: +3 -1
lines
Diff to previous 1.21 (colored)
Use and fix C++. Fix pthread linkage.
Revision 1.21 / (download) - annotate - [select for diffs], Mon Apr 17 13:46:02 2006 UTC (17 years, 7 months ago) by wiz
Branch: MAIN
Changes since 1.20: +2 -2
lines
Diff to previous 1.20 (colored)
Bump BUILDLINK_ABI_DEPENDS.png and PKGREVISION for png-1.2.9nb2 update.
Revision 1.20 / (download) - annotate - [select for diffs], Sat Mar 4 21:29:18 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base,
pkgsrc-2006Q1
Changes since 1.19: +2 -2
lines
Diff to previous 1.19 (colored)
Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no developer is officially maintaining the package. The rationale for changing this from "tech-pkg" to "pkgsrc-users" is that it implies that any user can try to maintain the package (by submitting patches to the mailing list). Since the folks most likely to care about the package are the folks that want to use it or are already using it, this would leverage the energy of users who aren't developers.
Revision 1.19 / (download) - annotate - [select for diffs], Sun Feb 5 23:08:49 2006 UTC (17 years, 10 months ago) by joerg
Branch: MAIN
Changes since 1.18: +2 -2
lines
Diff to previous 1.18 (colored)
Recursive revision bump / recommended bump for gettext ABI change.
Revision 1.18 / (download) - annotate - [select for diffs], Sun Dec 11 09:40:38 2005 UTC (17 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base,
pkgsrc-2005Q4
Changes since 1.17: +2 -2
lines
Diff to previous 1.17 (colored)
Convert aalib to options framework, adding an 'x11' option, and remove aalib-x11 and aview-x11. SDL dependencies change, so bump PKGREVISION (and BUILDLINK_RECOMMENDED) for affected packages. Addresses PR 32046 by Leonard Schmidt.
Revision 1.17 / (download) - annotate - [select for diffs], Wed Aug 10 20:56:15 2005 UTC (18 years, 3 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q3-base,
pkgsrc-2005Q3
Changes since 1.16: +2 -3
lines
Diff to previous 1.16 (colored)
Remove the abuse of buildlink that was pkg-config/buildlink3.mk. That file's sole purpose was to provide a dependency on pkg-config and set some environment variables. Instead, turn pkg-config into a "tool" in the tools framework, where the pkg-config wrapper automatically adds PKG_CONFIG_LIBDIR to the environment before invoking the real pkg-config. For all package Makefiles that included pkg-config/buildlink3.mk, remove that inclusion and replace it with USE_TOOLS+=pkg-config.
Revision 1.16 / (download) - annotate - [select for diffs], Thu Jul 21 16:29:49 2005 UTC (18 years, 4 months ago) by wiz
Branch: MAIN
Changes since 1.15: +2 -2
lines
Diff to previous 1.15 (colored)
Change path from devel/pkgconfig to devel/pkg-config. No PKGREVISION bump since pkg-config is only a BUILD_DEPENDS.
Revision 1.15 / (download) - annotate - [select for diffs], Wed Jun 1 18:02:44 2005 UTC (18 years, 6 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q2-base,
pkgsrc-2005Q2
Changes since 1.14: +1 -2
lines
Diff to previous 1.14 (colored)
Massive cleanup of buildlink3.mk and builtin.mk files in pkgsrc. Several changes are involved since they are all interrelated. These changes affect about 1000 files. The first major change is rewriting bsd.builtin.mk as well as all of the builtin.mk files to follow the new example in bsd.builtin.mk. The loop to include all of the builtin.mk files needed by the package is moved from bsd.builtin.mk and into bsd.buildlink3.mk. bsd.builtin.mk is now included by each of the individual builtin.mk files and provides some common logic for all of the builtin.mk files. Currently, this includes the computation for whether the native or pkgsrc version of the package is preferred. This causes USE_BUILTIN.* to be correctly set when one builtin.mk file includes another. The second major change is teach the builtin.mk files to consider files under ${LOCALBASE} to be from pkgsrc-controlled packages. Most of the builtin.mk files test for the presence of built-in software by checking for the existence of certain files, e.g. <pthread.h>, and we now assume that if that file is under ${LOCALBASE}, then it must be from pkgsrc. This modification is a nod toward LOCALBASE=/usr. The exceptions to this new check are the X11 distribution packages, which are handled specially as noted below. The third major change is providing builtin.mk and version.mk files for each of the X11 distribution packages in pkgsrc. The builtin.mk file can detect whether the native X11 distribution is the same as the one provided by pkgsrc, and the version.mk file computes the version of the X11 distribution package, whether it's built-in or not. The fourth major change is that the buildlink3.mk files for X11 packages that install parts which are part of X11 distribution packages, e.g. Xpm, Xcursor, etc., now use imake to query the X11 distribution for whether the software is already provided by the X11 distribution. This is more accurate than grepping for a symbol name in the imake config files. Using imake required sprinkling various builtin-imake.mk helper files into pkgsrc directories. These files are used as input to imake since imake can't use stdin for that purpose. The fifth major change is in how packages note that they use X11. Instead of setting USE_X11, package Makefiles should now include x11.buildlink3.mk instead. This causes the X11 package buildlink3 and builtin logic to be executed at the correct place for buildlink3.mk and builtin.mk files that previously set USE_X11, and fixes packages that relied on buildlink3.mk files to implicitly note that X11 is needed. Package buildlink3.mk should also include x11.buildlink3.mk when linking against the package libraries requires also linking against the X11 libraries. Where it was obvious, redundant inclusions of x11.buildlink3.mk have been removed.
Revision 1.14 / (download) - annotate - [select for diffs], Sun May 22 20:07:54 2005 UTC (18 years, 6 months ago) by jlam
Branch: MAIN
Changes since 1.13: +2 -2
lines
Diff to previous 1.13 (colored)
Remove USE_GNU_TOOLS and replace with the correct USE_TOOLS definitions: USE_GNU_TOOLS -> USE_TOOLS awk -> gawk m4 -> gm4 make -> gmake sed -> gsed yacc -> bison
Revision 1.13 / (download) - annotate - [select for diffs], Mon Apr 11 21:45:29 2005 UTC (18 years, 7 months ago) by tv
Branch: MAIN
Changes since 1.12: +1 -2
lines
Diff to previous 1.12 (colored)
Remove USE_BUILDLINK3 and NO_BUILDLINK; these are no longer used.
Revision 1.12 / (download) - annotate - [select for diffs], Sun Mar 27 15:43:33 2005 UTC (18 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.11: +2 -2
lines
Diff to previous 1.11 (colored)
PKGREVISION bump for glut dependency removal (SDL/buildlink3.mk).
Revision 1.11 / (download) - annotate - [select for diffs], Tue Dec 28 23:18:17 2004 UTC (18 years, 11 months ago) by reed
Branch: MAIN
CVS Tags: pkgsrc-2005Q1-base,
pkgsrc-2005Q1
Changes since 1.10: +2 -2
lines
Diff to previous 1.10 (colored)
Bump PKGREVISIONs due to libtiff update. Some BUILDLINK_RECOMMENDED bumps done also. (If I missed any, please let me know -- and let me know a good way to automate this.)
Revision 1.10 / (download) - annotate - [select for diffs], Sun Oct 3 00:13:32 2004 UTC (19 years, 2 months ago) by tv
Branch: MAIN
CVS Tags: pkgsrc-2004Q4-base,
pkgsrc-2004Q4
Changes since 1.9: +2 -2
lines
Diff to previous 1.9 (colored)
Libtool fix for PR pkg/26633, and other issues. Update libtool to 1.5.10 in the process. (More information on tech-pkg.) Bump PKGREVISION and BUILDLINK_DEPENDS of all packages using libtool and installing .la files. Bump PKGREVISION (only) of all packages depending directly on the above via a buildlink3 include.
Revision 1.9 / (download) - annotate - [select for diffs], Fri May 7 01:14:47 2004 UTC (19 years, 7 months ago) by xtraeme
Branch: MAIN
CVS Tags: pkgsrc-2004Q3-base,
pkgsrc-2004Q3,
pkgsrc-2004Q2-base,
pkgsrc-2004Q2
Changes since 1.8: +2 -2
lines
Diff to previous 1.8 (colored)
Drop maintainership; I don't have the enough free time to maintain all these packages.
Revision 1.8 / (download) - annotate - [select for diffs], Fri Feb 27 09:02:51 2004 UTC (19 years, 9 months ago) by xtraeme
Branch: MAIN
CVS Tags: pkgsrc-2004Q1-base,
pkgsrc-2004Q1
Changes since 1.7: +8 -8
lines
Diff to previous 1.7 (colored)
bl3ify
Revision 1.7 / (download) - annotate - [select for diffs], Sat Feb 14 18:26:27 2004 UTC (19 years, 9 months ago) by jmmv
Branch: MAIN
Changes since 1.6: +2 -2
lines
Diff to previous 1.6 (colored)
PKGCONFIG_OVERRIDE is relative to WRKSRC.
Revision 1.6 / (download) - annotate - [select for diffs], Sat Feb 14 17:21:39 2004 UTC (19 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.5: +1 -2
lines
Diff to previous 1.5 (colored)
LIBTOOL_OVERRIDE and SHLIBTOOL_OVERRIDE are now lists of shell globs relative to ${WRKSRC}. Remove redundant LIBTOOL_OVERRIDE settings that are automatically handled by the default setting in bsd.pkg.mk.
Revision 1.5 / (download) - annotate - [select for diffs], Thu Jan 22 08:24:30 2004 UTC (19 years, 10 months ago) by grant
Branch: MAIN
Changes since 1.4: +2 -2
lines
Diff to previous 1.4 (colored)
replace deprecated USE_GMAKE with USE_GNU_TOOLS+=make.
Revision 1.4 / (download) - annotate - [select for diffs], Tue Jan 20 12:13:29 2004 UTC (19 years, 10 months ago) by agc
Branch: MAIN
Changes since 1.3: +2 -2
lines
Diff to previous 1.3 (colored)
Move WRKSRC definition away from the first paragraph in a Makefile.
Revision 1.3 / (download) - annotate - [select for diffs], Sat Jan 3 18:49:39 2004 UTC (19 years, 11 months ago) by reed
Branch: MAIN
Changes since 1.2: +2 -1
lines
Diff to previous 1.2 (colored)
Bump package revisions for tiff update. Tiff is backward compatible, but was broken on amd64 platform so this makes sure new tiff is used.
Revision 1.2 / (download) - annotate - [select for diffs], Wed Dec 3 21:18:10 2003 UTC (20 years ago) by xtraeme
Branch: MAIN
Changes since 1.1: +2 -2
lines
Diff to previous 1.1 (colored)
s/wip/devel/
Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Wed Dec 3 19:01:46 2003 UTC (20 years ago) by xtraeme
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0
lines
Diff to previous 1.1 (colored)
Initial import of ogre-0.12.1 from pkgsrc-wip. OGRE (Object-Oriented Graphics Rendering Engine) is a scene-oriented, flexible 3D engine written in C++ designed to make it easier and more intuitive for developers to produce games and demos utilising 3D hardware. The class library abstracts all the details of using the underlying system libraries like Direct3D and OpenGL and provides an interface based on world objects and other intuitive classes.
Revision 1.1 / (download) - annotate - [select for diffs], Wed Dec 3 19:01:46 2003 UTC (20 years ago) by xtraeme
Branch: MAIN
Initial revision