[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / netcdf

File: [cvs.NetBSD.org] / pkgsrc / devel / netcdf / Makefile (download)

Revision 1.12, Sun Mar 2 08:26:09 2003 UTC (21 years, 1 month ago) by jtb
Branch: MAIN
Changes since 1.11: +2 -3 lines

Update to 3.5.0.

Some relevant changes:

 Fixed miswriting of netCDF header when exiting define
 mode.  Because the header was always written correctly
 later, this was only a problem if there was another
 reader of the netCDF file.

 Fixed explicit synchronizing between netCDF writer and
 readers via the nc_sync(), nf_sync(), and ncsync()
 functions.

 Fixed a number of bugs related to attempts to support
 shrinking the header in netCDF files when attributes
 are rewritten or deleted.  Also fixed the problem that
 nc__endef() did not work as intended in reserving
 extra space in the file header, since the extra space
 would be compacted again on calling nc_close().

 Fixed the "redef bug" that occurred when nc_enddef()
 or nf_enddef() is called after nc_redef() or
 nf_redef(), the file is growing such that the new
 beginning of a record variable is in the next "chunk",
 and the size of at least one record variable exceeds
 the chunk size (see netcdf.3 man page for a
 description of this tuning parameter and how to set
 it).  This bug resulted in corruption of some values
 in other variables than the one being added.

 The "__" tuning functions for the Fortran interface,
 nf__create, nf__open, and nf__enddef, are now
 documented in the Fortran interface man pages.

 Changed the extension of C++ files from ".cc" to ".cpp".
 Renamed the C++ interface header file "netcdfcpp.h"
 instead of "netcdf.hh", changing "netcdf.hh" to
 include "netcdfcpp.h" for backward compatibility.

 Fixed bug in ncdump using same CDL header name when
 called with multiple files.

 Added new NULL data type  NC_NAT (Not A Type) to
 facilitate checking whether a variable object has had
 its type defined yet, for example when working with
 packed values.

 Fixed use of compile-time macro NO_NETCDF_2 so it
 really doesn't include old netCDF-2 interfaces, as
 intended.

 Fixed C++ friend declarations to conform to C++ standard.

# $NetBSD: Makefile,v 1.12 2003/03/02 08:26:09 jtb Exp $

DISTNAME=	netcdf-3.5.0
WRKSRC=		${WRKDIR}/${DISTNAME}/src
CATEGORIES=	devel
MASTER_SITES=	ftp://www.gfd-dennou.org/arch/netcdf/unidata-mirror/
EXTRACT_SUFX=	.tar.Z

MAINTAINER=	packages@netbsd.org
HOMEPAGE=	http://www.unidata.ucar.edu/packages/netcdf/index.html
COMMENT=	Library for array-oriented data access

USE_BUILDLINK2=		# defined
USE_FORTRAN=		# defined
USE_CXX=		# defined
USE_LIBTOOL=		# defined
GNU_CONFIGURE=		# defined
CPPFLAGS+=		-Df2cFortran -Dunix

.include "../../mk/bsd.pkg.mk"