[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / ncurses

File: [cvs.NetBSD.org] / pkgsrc / devel / ncurses / Makefile (download)

Revision 1.38, Tue Jun 19 05:06:27 2001 UTC (22 years, 10 months ago) by jlam
Branch: MAIN
CVS Tags: pkgviews-base, pkgviews, netbsd-1-6-RELEASE-base, netbsd-1-6, netbsd-1-5-PATCH003, buildlink2-base
Branch point for: buildlink2
Changes since 1.37: +2 -1 lines

Mark as USE_BUILDLINK_ONLY.

# $NetBSD: Makefile,v 1.38 2001/06/19 05:06:27 jlam Exp $

DISTNAME=		ncurses-${NC_VERS}
NC_VERS=		5.2
CATEGORIES=		devel
MASTER_SITES=		${MASTER_SITE_GNU:=ncurses/} \
			ftp://dickey.his.com/ncurses/ \
			ftp://dickey.his.com/ncurses/${NC_VERS}/

MAINTAINER=		jlam@netbsd.org
HOMEPAGE=		http://dickey.his.com/ncurses/ncurses.html
COMMENT=		CRT screen handling and optimization package

USE_LIBTOOL=		# defined
USE_BUILDLINK_ONLY=	# defined

GNU_CONFIGURE=		# defined
CONFIGURE_ARGS+=	--with-libtool
CONFIGURE_ARGS+=	--enable-bsdpad
CONFIGURE_ARGS+=	--with-cxx-binding
CONFIGURE_ARGS+=	--without-ada
CONFIGURE_ARGS+=	--without-curses-h
CONFIGURE_ARGS+=	--without-gpm
CONFIGURE_ARGS+=	--with-manpage-format=normal
CONFIGURE_ARGS+=	--with-manpage-tbl

# Remove these manpages from the distribution so they won't get installed
CURSES_NO_MAN=		clear.1 tput.1 tset.1

post-configure:
	cd ${WRKSRC}/man;					\
	${RM} -f ${CURSES_NO_MAN};				\
	for file in *.1m; do					\
		${MV} -f $${file} `basename $${file} .1m`.1; 	\
	done;							\
	for file in *.3x; do					\
		${MV} -f $${file} `basename $${file} .3x`.3; 	\
	done

post-install:
	${INSTALL_DATA} ${WRKSRC}/c++/demo.cc \
		${PREFIX}/share/examples/ncurses++demo.cc

.include "../../mk/bsd.pkg.mk"