The NetBSD Project

CVS log for pkgsrc/devel/meson/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / meson

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.50 / (download) - annotate - [select for diffs], Sun Sep 24 18:54:06 2023 UTC (5 days, 19 hours ago) by gutteridge
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, HEAD
Changes since 1.49: +2 -2 lines
Diff to previous 1.49 (colored)

meson: fix non-default Python sandboxed builds with py-cython

Since Meson is not Python versioned, but Cython is, we previously
ended up with a situation where builds of Cython-using packages
would fail. Instead of the Makefile kludge where it would simply
force the default Python version associated with Cython, use a
different hack that will search for all (presently) possible versions.

This is not an ideal solution, but is being committed to fix build
breakage in the lead up to branching pkgsrc 2023Q3. Other solutions
would be to go back to Python versioned Meson, or getting Meson to
handle multi-Python environments more cleanly.

Revision 1.49 / (download) - annotate - [select for diffs], Tue Aug 8 21:34:11 2023 UTC (7 weeks, 3 days ago) by adam
Branch: MAIN
Changes since 1.48: +4 -4 lines
Diff to previous 1.48 (colored)

meson: updated to 1.2.1

1.2.1
Bug fixes

Revision 1.48 / (download) - annotate - [select for diffs], Wed Jul 19 05:36:20 2023 UTC (2 months, 1 week ago) by adam
Branch: MAIN
Changes since 1.47: +4 -4 lines
Diff to previous 1.47 (colored)

meson: updated to 1.2.0

1.2.0

Added Metrowerks C/C++ toolchains
Added str.splitlines method
generator.process(generator.process(...))
Extra files keyword in declare_dependency
Added a new '--genvslite' option for use with 'meson setup ...'
gnome.generate_gir() now supports env kwarg
More data in introspection files
Machine objects get kernel and subsystem properties
default_options and override_options may now be dictionaries
New override of find_program('meson')
Find more specific python version on Windows
Python module can now compile bytecode
rust.bindgen allows passing extra arguments to rustc
Support for defining crate names of Rust dependencies in Rust targets
A machine file may be used to pass extra arguments to clang in a bindgen call
Add a link_with keyword to rust.test()
Rust now supports the b_ndebug option
Wildcards in list of tests to run
New for the generation of Visual Studio vcxproj projects

Revision 1.47 / (download) - annotate - [select for diffs], Thu May 25 19:37:54 2023 UTC (4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2
Changes since 1.46: +4 -4 lines
Diff to previous 1.46 (colored)

meson: updated to 1.1.1

1.1.1
No changelog

Revision 1.46 / (download) - annotate - [select for diffs], Tue Apr 25 19:54:40 2023 UTC (5 months ago) by nikita
Branch: MAIN
Changes since 1.45: +4 -4 lines
Diff to previous 1.45 (colored)

meson: update to version 1.1.0

Changelog (taken from https://mesonbuild.com/Release-notes-for-1-1-0.html):


New features

Meson 1.1.0 was released on 10 April 2023
clang-cl now accepts cpp_std=c++20

Requires clang-cl 13 or later.
coercing values in the option() function is deprecated

Currently code such as:

option('foo', type : 'boolean', value : 'false')

works, because Meson coerces 'false' to false.

This should be avoided, and will now result in a deprecation warning.
New declare_dependency(objects: ) argument

A new argument to declare_dependency makes it possible to add objects directly to executables that use an internal dependency, without going for example through link_whole.
Dump devenv into file and select format

meson devenv --dump [<filename>] command now takes an optional filename argument to write the environment into a file instead of printing to stdout.

A new --dump-format argument has been added to select which shell format should be used. There are currently 3 formats supported:

    sh: Lines are in the format VAR=/prepend:$VAR:/append.
    export: Same as sh but with extra export VAR lines.
    vscode: Same as sh but without $VAR substitution because they do not seems to be properly supported by vscode.

Feature objects now have an enable_auto_if method

This performs the opposite task of the disable_auto_if method, enabling the feature if the condition is true.
Add a FeatureOption.enable_if and .disable_if

These are useful when features need to be constrained to pass to dependency(), as the behavior of an auto and disabled or enabled feature is markedly different. consider the following case:

opt = get_option('feature').disable_auto_if(not foo)
if opt.enabled() and not foo
  error('Cannot enable feat when foo is not also enabled')
endif
dep = dependency('foo', required : opt)

This could be simplified to

opt = get_option('feature').disable_if(not foo, error_message : 'Cannot enable feature when foo is not also enabled')
dep = dependency('foo', required : opt)

For a real life example, here is some code in mesa:

_llvm = get_option('llvm')
dep_llvm = null_dep
with_llvm = false
if _llvm.allowed()
  dep_llvm = dependency(
    'llvm',
    version : _llvm_version,
    modules : llvm_modules,
    optional_modules : llvm_optional_modules,
    required : (
      with_amd_vk or with_gallium_radeonsi or with_gallium_opencl or with_clc
      or _llvm.enabled()
    ),
    static : not _shared_llvm,
    fallback : ['llvm', 'dep_llvm'],
    include_type : 'system',
  )
  with_llvm = dep_llvm.found()
endif
if with_llvm
  ...
elif with_amd_vk and with_aco_tests
  error('ACO tests require LLVM, but LLVM is disabled.')
elif with_gallium_radeonsi or with_swrast_vk
  error('The following drivers require LLVM: RadeonSI, SWR, Lavapipe. One of these is enabled, but LLVM is disabled.')
elif with_gallium_opencl
  error('The OpenCL "Clover" state tracker requires LLVM, but LLVM is disabled.')
elif with_clc
  error('The CLC compiler requires LLVM, but LLVM is disabled.')
else
  draw_with_llvm = false
endif

simplified to:

_llvm = get_option('llvm') \
  .enable_if(with_amd_vk and with_aco_tests, error_message : 'ACO tests requires LLVM') \
  .enable_if(with_gallium_radeonsi, error_message : 'RadeonSI requires LLVM') \
  .enable_if(with_swrast_vk, error_message : 'Vulkan SWRAST requires LLVM') \
  .enable_if(with_gallium_opencl, error_message : 'The OpenCL Clover state trackers requires LLVM') \
  .enable_if(with_clc, error_message : 'CLC library requires LLVM')

dep_llvm = dependency(
  'llvm',
  version : _llvm_version,
  modules : llvm_modules,
  optional_modules : llvm_optional_modules,
  required : _llvm,
  static : not _shared_llvm,
  fallback : ['llvm', 'dep_llvm'],
  include_type : 'system',
)
with_llvm = dep_llvm.found()

Generated objects can be passed in the objects: keyword argument

In previous versions of Meson, generated objects could only be passed as sources of a build target. This was confusing, therefore generated objects can now be passed in the objects: keyword argument as well.
The project function now supports setting the project license files

This goes together with the license name. The license files can be automatically installed via meson.install_dependency_manifest(), or queried via meson.project_license_files().
A new core directory option "licensedir" is available

This will install a dependency manifest to the specified directory, if none is is explicitly set.
sudo meson install now drops privileges when rebuilding targets

It is common to install projects using sudo, which should not affect build outputs but simply install the results. Unfortunately, since the ninja backend updates a state file when run, it's not safe to run ninja as root at all.

It has always been possible to carefully build with:

ninja && sudo meson install --no-rebuild

Meson now tries to be extra safe as a general solution. sudo meson install will attempt to rebuild, but has learned to run ninja as the original (pre-sudo or pre-doas) user, ensuring that build outputs are generated/compiled as non-root.
meson install now supports user-preferred root elevation tools

Previously, when installing a project, if any files could not be installed due to insufficient permissions the install process was automatically re-run using polkit. Now it prompts to ask whether that is desirable, and checks for CLI-based tools such as sudo or opendoas or $MESON_ROOT_CMD, first.

Meson will no longer attempt privilege elevation at all, when not running interactively.
Support for reading options from meson.options

Support has been added for reading options from meson.options instead of meson_options.txt. These are equivalent, but not using the .txt extension for a build file has a few advantages, chief among them many tools and text editors expect a file with the .txt extension to be plain text files, not build scripts.
Redirect introspection outputs to stderr

meson introspect used to disable logging to stdout to not interfere with generated json. It now redirect outputs to stderr to allow printing warnings to the console while keeping stdout clean for json outputs.
New "none" backend

The --backend=none option has been added, to configure a project that has no build rules, only install rules. This avoids depending on ninja.
compiler.preprocess()

Dependencies keyword argument can now be passed to compiler.preprocess() to add include directories or compiler arguments.

Generated sources such as custom targets are now allowed too.
New pybind11 custom dependency

dependency('pybind11') works with pkg-config and cmake without any special support, but did not handle the pybind11-config script.

This is useful because the config-tool will work out of the box when pybind11 is installed, but the pkg-config and cmake files are shoved into python's site-packages, which makes it impossible to use in an out of the box manner.
Allow --reconfigure and --wipe of empty builddir

meson setup --reconfigure builddir and meson setup --wipe builddir are now accepting builddir/ to be empty or containing a previously failed setup attempt. Note that in that case previously passed command line options must be repeated as only a successful build saves configured options.

This is useful for example with scripts that always repeat all options, meson setup builddir --wipe -Dfoo=bar will always work regardless whether it is a first invocation or not.
Allow custom install scripts to run with --dry-run option

An new dry_run keyword is added to meson.add_install_script() to allow a custom install script to run when meson is invoked with meson install --dry-run.

In dry run mode, the MESON_INSTALL_DRY_RUN environment variable is set.

Revision 1.45 / (download) - annotate - [select for diffs], Fri Feb 24 08:19:00 2023 UTC (7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1
Changes since 1.44: +5 -5 lines
Diff to previous 1.44 (colored)

meson: updated to 1.0.1

1.0.1
Bug fixes

Revision 1.44 / (download) - annotate - [select for diffs], Sun Jan 1 21:20:01 2023 UTC (8 months, 4 weeks ago) by adam
Branch: MAIN
Changes since 1.43: +4 -4 lines
Diff to previous 1.43 (colored)

meson: updated to 1.0.0

1.0.0
Compiler check functions prefix kwargs accepts arrays
Flags removed from cpp/objcpp warning level 1
Developer environment improvements
Deprecate java.generate_native_headers, rename to java.native_headers
rust.bindgen accepts a dependency argument
String arguments to the rust.bindgen include_directories argument
The Rust module is stable
in operator for strings
warning-level=everything option

Revision 1.43 / (download) - annotate - [select for diffs], Wed Nov 23 08:18:41 2022 UTC (10 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4
Changes since 1.42: +4 -4 lines
Diff to previous 1.42 (colored)

meson: updated to 0.64.1

0.64.1
Bug fixes

Revision 1.42 / (download) - annotate - [select for diffs], Sun Nov 13 09:57:24 2022 UTC (10 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.41: +5 -5 lines
Diff to previous 1.41 (colored)

meson: updated to 0.64.0

0.64.0
Add optimization plain option
New languages: nasm and masm
Pager and colors for meson configure output
various install_* functions no longer handle the sticky bit
fs.copyfile to replace configure_file(copy : true)
Added update_mime_database to gnome.post_install()
Added preserve_path arg to install_data
BSD support for the jni dependency
Credentials from ~/.netrc for https URLs
Basic support for oneAPI compilers on Linux and Windows
New method to preprocess source files
python.find_installation() now accepts pure argument
Generates rust-project.json when there are Rust targets
summary() accepts disablers
Option to allow meson test to fail fast after the first failing testcase
Incremental ThinLTO with b_thinlto_cache
Update all wraps from WrapDB with meson wrap update command
Added include_core_only arg to wayland.scan_xml.
Automatic fallback using WrapDB

Revision 1.41 / (download) - annotate - [select for diffs], Thu Oct 6 13:32:26 2022 UTC (11 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.40: +4 -4 lines
Diff to previous 1.40 (colored)

meson: updated to 0.63.3

0.63.3
Bug fixes

Revision 1.40 / (download) - annotate - [select for diffs], Mon Sep 5 09:17:07 2022 UTC (12 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3
Changes since 1.39: +4 -4 lines
Diff to previous 1.39 (colored)

meson: updated to 0.63.2

0.63.2
Bug fixes

Revision 1.39 / (download) - annotate - [select for diffs], Mon Aug 15 08:19:39 2022 UTC (13 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.38: +5 -5 lines
Diff to previous 1.38 (colored)

meson: updated to 0.63.1

0.63.1
Bug fixes

Revision 1.38 / (download) - annotate - [select for diffs], Wed Jul 13 03:57:22 2022 UTC (14 months, 2 weeks ago) by triaxx
Branch: MAIN
Changes since 1.37: +9 -9 lines
Diff to previous 1.37 (colored)

commit.msg

Revision 1.37 / (download) - annotate - [select for diffs], Wed Jun 8 08:27:47 2022 UTC (15 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2
Changes since 1.36: +4 -4 lines
Diff to previous 1.36 (colored)

meson: updated to 0.62.2

0.62.2
Bug fixes

Revision 1.36 / (download) - annotate - [select for diffs], Fri May 27 12:26:50 2022 UTC (16 months ago) by adam
Branch: MAIN
Changes since 1.35: +4 -4 lines
Diff to previous 1.35 (colored)

meson: updated to 0.62.1

0.62.1

Bash completion scripts sourced in meson devenv
Setup GDB auto-load for meson devenv
Print modified environment variables with meson devenv --dump
New method and separator kwargs on environment() and meson.add_devenv()
New custom dependency for libdl
pkgconfig.generate will now include variables for builtin directories when referenced
New keyword argument verbose for tests and benchmarks
CMake support for versions <3.17.0 is deprecated
Removal of the RPM module
CMake server API support is removed
Rust proc-macro crates
found programs now have a version method
Minimum required Python version updated to 3.7
Added support for XML translations using itstool
JNI System Dependency Modules
New unstable wayland module
Experimental command to convert environments to cross files
Added optional '--allow-dirty' flag for the 'dist' command
ldconfig is no longer run on install
Added support for Texas Instruments MSP430 and ARM compilers
cmake.configure_package_config_file can now take a dict
Deprecated java.generate_native_header() in favor of the new java.generate_native_headers()
New option to choose python installation environment
JDK System Dependency Renamed from jdk to jni
i18n.merge_file no longer arbitrarily leaves your project half-built
All directory options now support paths outside of prefix
meson install --strip
Support for ARM Ltd. Clang toolchain
structured_sources()
New custom dependency for OpenSSL
D features in declare_dependency
arch_independent kwarg in cmake.write_basic_package_version_file
dataonly Pkgconfig Default Install Path
JAR default install dir

Revision 1.35 / (download) - annotate - [select for diffs], Tue Mar 15 05:43:36 2022 UTC (18 months, 2 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.34: +4 -4 lines
Diff to previous 1.34 (colored)

meson: updated to 0.61.3

0.61.3:
Bug fixes

Revision 1.34 / (download) - annotate - [select for diffs], Tue Feb 22 17:56:53 2022 UTC (19 months ago) by jperkin
Branch: MAIN
Changes since 1.33: +2 -1 lines
Diff to previous 1.33 (colored)

meson: Avoid thin archives on SunOS.

Fixes lots of dependencies.  Bump PKGREVISION.

Revision 1.33 / (download) - annotate - [select for diffs], Tue Feb 15 10:00:05 2022 UTC (19 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.32: +4 -4 lines
Diff to previous 1.32 (colored)

meson: updated to 0.61.2

Meson 0.61

backend_startup_project
Windows.compile_resources CustomTarget
Add a man page backend to refman
extract_objects() supports generated sources
Python 3.6 support will be dropped in the next release
Warning if check kwarg of run_command is missing
meson rewrite can modify extra_files
meson rewrite target <target> info outputs target's extra_files
Visual Studio 2022 backend
Support for CMake <3.14 is now deprecated for CMake subprojects
Added support for sccache
install_symlink function

Revision 1.32 / (download) - annotate - [select for diffs], Wed Dec 29 16:25:01 2021 UTC (21 months ago) by adam
Branch: MAIN
Changes since 1.31: +4 -4 lines
Diff to previous 1.31 (colored)

meson: updated to 0.60.3

0.60.3:
Bug fixes

Revision 1.31 / (download) - annotate - [select for diffs], Sun Nov 28 20:24:25 2021 UTC (22 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.30: +4 -4 lines
Diff to previous 1.30 (colored)

meson: updated to 0.60.2

0.60.2:
Bug fixes

Revision 1.30 / (download) - annotate - [select for diffs], Sun Nov 7 13:23:05 2021 UTC (22 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.29: +5 -5 lines
Diff to previous 1.29 (colored)

meson: updated to 0.60.1

0.60.0:

run_target can now be used as a dependency
The Python Modules dependency method no longer accepts positional arguments
Override python installation paths
New subprojects packagefiles subcommand
Deprecated project options
More efficient static linking of uninstalled libraries
gnome.yelp variadic argument deprecation
static keyword argument to meson.override_dependency()
dependency() sets default_library on fallback subproject
install_emptydir function
Cython can now transpile to C++ as an intermediate language
New custom dependency for iconv
Unknown options are now always fatal
Install DESTDIR relative to build directory
Java Module
Link tests can use sources for a different compiler
Relax restrictions of str.join()
Improvements for the Rustc compiler
The qt modules now accept generated outputs as inputs for qt.compile_*
Waf support in external-project module
Comparing two objects with different types is now an error
Installation tags
Compiler.unittest_args has been removed
Dependencies with multiple names
i18n module now returns gettext targets
Added support for CLA sources when cross-compiling with the C2000 toolchain
Support for clippy-driver as a rustc wrapper
Force Visual Studio environment activation
MSVC compiler now assumes UTF-8 source code by default
Add support for find_library in Emscripten
Optional custom_target() name

Revision 1.29 / (download) - annotate - [select for diffs], Tue Oct 26 10:15:40 2021 UTC (23 months ago) by nia
Branch: MAIN
Changes since 1.28: +2 -2 lines
Diff to previous 1.28 (colored)

archivers: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Could not be committed due to merge conflict:
devel/py-traitlets/distinfo

The following distfiles were unfetchable (note: some may be only fetched
conditionally):

./devel/pvs/distinfo pvs-3.2-solaris.tgz
./devel/eclipse/distinfo eclipse-sourceBuild-srcIncluded-3.0.1.zip

Revision 1.28 / (download) - annotate - [select for diffs], Sun Oct 24 16:20:01 2021 UTC (23 months ago) by adam
Branch: MAIN
Changes since 1.27: +4 -4 lines
Diff to previous 1.27 (colored)

meson: updated to 0.59.3

0.59.3:
Bug fixes

Revision 1.27 / (download) - annotate - [select for diffs], Thu Oct 7 13:40:34 2021 UTC (23 months, 3 weeks ago) by nia
Branch: MAIN
Changes since 1.26: +1 -2 lines
Diff to previous 1.26 (colored)

devel: Remove SHA1 hashes for distfiles

Revision 1.26 / (download) - annotate - [select for diffs], Wed Sep 29 07:29:54 2021 UTC (2 years ago) by adam
Branch: MAIN
Changes since 1.25: +5 -5 lines
Diff to previous 1.25 (colored)

meson: updated to 0.59.2

0.59.2:
Bug fixes

Revision 1.25 / (download) - annotate - [select for diffs], Mon Sep 27 18:50:06 2021 UTC (2 years ago) by adam
Branch: MAIN
Changes since 1.24: +8 -8 lines
Diff to previous 1.24 (colored)

meson: updated to 0.59.1

0.59.0:
Unescaped variables in pkgconfig files
The custom_target() function now accepts a feed argument
Separate functions for qt preprocess
Cython as as first class language
Support for the Wine Resource Compiler
New vs2012 and vs2013 backend options
Developer environment
Fs Module now accepts files objects
Compiler argument checking for get_supported_arguments
New custom dependency for libintl
Parallelized meson subprojects commands
Using Vala no longer requires C in the project languages
The import() function gains required and disabler arguments
Objective C/C++ standard versions
Qt.preprocess source arguments deprecated
New build target methods
Automatically set up Visual Studio environment
gnome.compile_schemas() sets GSETTINGS_SCHEMA_DIR into devenv
update_desktop_database added to gnome.post_install()

Revision 1.24 / (download) - annotate - [select for diffs], Mon Jun 7 18:58:55 2021 UTC (2 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.23: +5 -6 lines
Diff to previous 1.23 (colored)

meson: updated to 0.58.1

0.58.1:
Bug fixes

Revision 1.23 / (download) - annotate - [select for diffs], Tue Jun 1 05:55:46 2021 UTC (2 years, 3 months ago) by cirnatdan
Branch: MAIN
Changes since 1.22: +2 -1 lines
Diff to previous 1.22 (colored)

meson: interpreter: flatten environment() initial values

Import upstream patch for flattening lists. Fixes build of nautilus
https://github.com/mesonbuild/meson/pull/8761/files

Revision 1.22 / (download) - annotate - [select for diffs], Tue May 4 18:54:29 2021 UTC (2 years, 4 months ago) by adam
Branch: MAIN
Changes since 1.21: +5 -5 lines
Diff to previous 1.21 (colored)

meson: updated to 0.58.0

0.58.0:

New meson.global_build_root() and meson.global_source_root() methods
Developer environment
-pipe no longer used by default
meson.add_dist_script() allowd in subprojects
Multiple append() and prepend() in environment() object
dep.get_variable(varname)
clang-format include and ignore lists
Introducing format strings to the Meson language
Skip subprojects installation
String .replace()
meson.get_cross_property() has been deprecated
New range() function
Xcode improvements
Use fallback from wrap file when force fallback
error() with multiple arguments
Specify man page locale during installation
Passing custom_target() output to pkg.generate()
JDK System Dependency
meson subprojects update --reset now re-extract tarballs
Allow using generator with CustomTaget or Index of CustomTarget.
Qt Dependency uses a Factory
Purge subprojects folder
Check if native or cross-file properties exist
summary() accepts features
Address sanitizer support for Visual Studio

Revision 1.21 / (download) - annotate - [select for diffs], Mon Apr 12 10:12:30 2021 UTC (2 years, 5 months ago) by adam
Branch: MAIN
Changes since 1.20: +5 -5 lines
Diff to previous 1.20 (colored)

meson: updated to 0.57.2

0.57.2:
Bug fixes

Revision 1.20 / (download) - annotate - [select for diffs], Sun Feb 21 12:45:22 2021 UTC (2 years, 7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1
Changes since 1.19: +7 -7 lines
Diff to previous 1.19 (colored)

meson: updated to 0.57.1

Release 0.57.0
* Project version can be specified with a file
* Support for reading files at configuration time with the fs module
* meson install --dry-run
* Experimental support for C++ modules in Visual Studio
* Qt6 module
* Unstable Rust module
* Meson test() now accepts protocol : 'rust'
* MSVC/Clang-Cl Argument Changes/Cleanup
* Buildtype remains even if dependent options are changed
* Passing internal dependencies to the compiler object
* unstable_external_project improvements
* gnome.post_install()
* "Edit and continue" (/ZI) is no longer used by default for Visual Studio
* Minimum required Python version updated to 3.6
* Packaging a subproject
* custom_target() and run_target() now accepts an env keyword argument
* summary() accepts external programs or dependencies
* CMake find_package version support
* meson test only rebuilds test dependencies
* The add_*_script methods now accept a File as the first argument
* Unity build with Vala disabled
* New logging format for meson test
* Specify DESTDIR on command line
* Skip install scripts if DESTDIR is set
* Add support for prelinked static libraries
* Rust now has an std option
* Ctrl-C behavior in meson test
* Support added for LLVM's thinLTO
* test() timeout and timeout_multiplier value <= 0
* Knob to control LTO thread
* summary() now uses left alignment for both keys and values
* // is now allowed as a function id for meson rewrite.
* Get keys of configuration data object

Revision 1.19 / (download) - annotate - [select for diffs], Mon Jan 11 07:26:32 2021 UTC (2 years, 8 months ago) by adam
Branch: MAIN
Changes since 1.18: +5 -5 lines
Diff to previous 1.18 (colored)

meson: updated to 0.56.2

0.56.2:
Bugfixes

Revision 1.18 / (download) - annotate - [select for diffs], Thu Jan 7 10:00:52 2021 UTC (2 years, 8 months ago) by adam
Branch: MAIN
Changes since 1.17: +5 -5 lines
Diff to previous 1.17 (colored)

meson: updated to 0.56.1

0.56.1
Bug fixes

Revision 1.17 / (download) - annotate - [select for diffs], Sat Nov 21 11:27:23 2020 UTC (2 years, 10 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.16: +6 -6 lines
Diff to previous 1.16 (colored)

meson: updated to 0.56.0

0.56.0:
* meson test can now filter tests by subproject
* Native (build machine) compilers not always required by project()
* New extra_files key in target introspection
* Preliminary AIX support
* Wraps from subprojects are automatically promoted
* meson.build_root() and meson.source_root() are deprecated
* dep.as_link_whole()
* Add support for all Windows subsystem types
* Added NVidia HPC SDK compilers
* Project and built-in options can be set in native or cross files
* unstable-keyval is now stable keyval
* CMake subproject cross compilation support
* Machine file keys are stored case sensitive
* Consistency between declare_dependency() and pkgconfig.generate() variables
* Qt5 compile_translations now supports qresource preprocessing
* Controlling subproject dependencies with dependency(allow_fallback: ...)
* Custom standard library
* Improvements for the builtin curses dependency
* HDF5 dependency improvements
* External projects
* Per subproject warning_level option
* meson subprojects command
* Added CompCert C compiler
* Dependencies listed in test and benchmark introspection
* include_type support for the CMake subproject object dependency method
* Deprecate Dependency.get_pkgconfig_variable and Dependency.get_configtool_variable

Revision 1.16 / (download) - annotate - [select for diffs], Tue Sep 29 12:19:58 2020 UTC (3 years ago) by adam
Branch: MAIN
Changes since 1.15: +5 -5 lines
Diff to previous 1.15 (colored)

meson: updated to 0.55.3

0.55.3:
Unknown changes

Revision 1.15 / (download) - annotate - [select for diffs], Wed Aug 19 09:20:06 2020 UTC (3 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.14: +5 -5 lines
Diff to previous 1.14 (colored)

meson: updated to 0.55.1

0.55.1:
Bug fixes

Revision 1.14 / (download) - annotate - [select for diffs], Fri Aug 7 13:04:08 2020 UTC (3 years, 1 month ago) by jperkin
Branch: MAIN
Changes since 1.13: +2 -1 lines
Diff to previous 1.13 (colored)

meson: Turn off -z ignore by default on SunOS.

This shouldn't be applied to every single invocation, as it can be too
aggressive and for example remove -lssp when -fstack-protector is being used,
breaking PKGSRC_USE_SSP checks.

Fixes lots of packages.  Bump PKGREVISION.

Revision 1.13 / (download) - annotate - [select for diffs], Tue Jul 28 23:28:23 2020 UTC (3 years, 2 months ago) by tnn
Branch: MAIN
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

only match '++' at the end of the string in previous

Revision 1.12 / (download) - annotate - [select for diffs], Tue Jul 28 22:43:01 2020 UTC (3 years, 2 months ago) by tnn
Branch: MAIN
Changes since 1.11: +2 -1 lines
Diff to previous 1.11 (colored)

meson: fix C++ compiler detection fallout from last update. Bump.

Revision 1.11 / (download) - annotate - [select for diffs], Mon Jul 27 16:08:13 2020 UTC (3 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.10: +6 -6 lines
Diff to previous 1.10 (colored)

meson: updated to 0.55.0

0.55.0:
rpath removal now more careful
Added ability to specify targets in meson compile
Test protocol for gtest
meson.add_*_script methods accept new types
Machine file constants
Configure CMake subprojects with meson.subproject_options
find_program: Fixes when the program has been overridden by executable
Response files enabled on Linux, reined in on Windows
unstable-kconfig module renamed to unstable-keyval
Fatal warnings in gnome.generate_gir()
b_ndebug support for D language compilers
Meson test now produces JUnit xml from results
Config tool based dependencies no longer search PATH for cross compiling
Rename has_exe_wrapper -> can_run_host_binaries
String concatenation in meson_options.txt
Wrap fallback URL
Clang coverage support
Local wrap source and patch files
Local wrap patch directory
Patch on all wrap types
link_language argument added to all targets
meson dist --no-tests
Force fallback for
Implicit dependency fallback
Wrap file provide section
find_program() fallback
Test scripts are given the exe wrapper if needed
Added ability to specify backend arguments in meson compile
Introspection API changes

Revision 1.10 / (download) - annotate - [select for diffs], Tue Jun 30 11:57:50 2020 UTC (3 years, 3 months ago) by adam
Branch: MAIN
Changes since 1.9: +5 -5 lines
Diff to previous 1.9 (colored)

meson: updated to 0.54.3

0.54.3:
Bug fixes

Revision 1.9 / (download) - annotate - [select for diffs], Wed May 20 06:03:58 2020 UTC (3 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2
Changes since 1.8: +5 -5 lines
Diff to previous 1.8 (colored)

meson: updated to 0.54.2

0.54.2:
Bug fixes

Revision 1.8 / (download) - annotate - [select for diffs], Wed Apr 29 13:34:27 2020 UTC (3 years, 5 months ago) by adam
Branch: MAIN
Changes since 1.7: +5 -5 lines
Diff to previous 1.7 (colored)

meson: updated to 0.54.1

0.54.1:
Bug fixes

Revision 1.7 / (download) - annotate - [select for diffs], Thu Apr 23 07:00:08 2020 UTC (3 years, 5 months ago) by triaxx
Branch: MAIN
Changes since 1.6: +2 -1 lines
Diff to previous 1.6 (colored)

meson: disable FreeBSD specific condition

pkgsrc changes:
---------------
  * Add a patch that reverts https://github.com/mesonbuild/meson/commit/aba8792.
    This commit introduced a condition to match FreeBSD path norm for
    pkg-config files. This condition is incompatible with the pkgsrc conventions.
  * Bump revision.

Revision 1.6 / (download) - annotate - [select for diffs], Wed Apr 1 14:51:05 2020 UTC (3 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.5: +6 -6 lines
Diff to previous 1.5 (colored)

meson: update to 0.54.0.

New features

Emscripten (emcc) now supports threads
Introduce dataonly for the pkgconfig module
Consistently report file locations relative to cwd
dependency() consistency
Override dependency()
Simplified dependency() fallback
Backend agnostic compile command
Native (build machine) compilers not always required
Summary improvements
Add a system type dependency for zlib
Added 'name' method
New option --quiet to meson install
Property support emscripten's wasm-ld
Skip sanity tests when cross compiling
Support for overiding the linker with ldc and gdc
Native file properties
Changed the signal used to terminate a test process (group)
Dynamic Linker environment variables actually match docs
Per subproject default_library and werror options
Environment Variables with Cross Builds
Added 'pkg_config_libdir' property
More new sample Meson templates for (Java, Cuda, and more)
Ninja version requirement bumped to 1.7
Added -C argument to meson init command
More than one argument to message() and warning()
Added has_tools method to qt module
The MSI installer is only available in 64 bit version
Uninstalled pkg-config files
CMake find_package COMPONENTS support
Added Microchip XC16 C compiler support
Added Texas Instruments C2000 C/C++ compiler support
Unity file block size is configurable

More details:
https://mesonbuild.com/Release-notes-for-0-54-0.html

Revision 1.5 / (download) - annotate - [select for diffs], Tue Mar 17 10:25:39 2020 UTC (3 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.4: +6 -7 lines
Diff to previous 1.4 (colored)

meson: updated to 0.53.2

0.53.2:
A new module for filesystem operations
meson dist --include-subprojects
Added new Meson templates for Dlang, Rust, Objective-C
Add a new summary() function
Generic Overrider for Dynamic Linker selection
fortran_std option
python.dependency() embed kwarg
Scalapack
Search directories for find_program()
Source tags targets
Dictionary entry using string variable as key
Improved CMake subprojects support
compiler.get_linker_id()
CUDA dependency
Added global option to disable C++ RTTI
Introspection API changes

Revision 1.4 / (download) - annotate - [select for diffs], Wed Dec 11 12:48:07 2019 UTC (3 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.3: +5 -5 lines
Diff to previous 1.3 (colored)

meson: updated to 0.52.1

0.52.1:
Bug fixes (no release notes)

Revision 1.3 / (download) - annotate - [select for diffs], Wed Dec 11 12:45:29 2019 UTC (3 years, 9 months ago) by jperkin
Branch: MAIN
Changes since 1.2: +2 -1 lines
Diff to previous 1.2 (colored)

meson: Backport fix for executable bit tests.

Bump PKGREVISION.

Revision 1.2 / (download) - annotate - [select for diffs], Fri Oct 18 09:59:46 2019 UTC (3 years, 11 months ago) by nia
Branch: MAIN
Changes since 1.1: +6 -10 lines
Diff to previous 1.1 (colored)

meson: Update to 0.52.0

Changes:

* Gettext targets are ignored if gettext is not installed
* Support taking environment values from a dictionary
* alias_target
* Enhancements to the pkg_config_path argument
* The meson test program now accepts an additional "--gdb-path" argument to specify the GDB binary
* Better support for illumos and Solaris
* Splitting of Compiler.get_function_attribute('visibility')
* Clang-tidy target
* Add blocks dependency
* Meson's builtin b_lundef is now supported on macOS
* Compiler and dynamic linker representation split
* Add depth option to wrap-git
* Enhancements to the source_set module
* added --only test(s) option to run_project_tests.py
* Experimental Webassembly support via Emscripten
* Version check in find_program()
* Added vs_module_defs to shared_module()
* Improved support for static libraries
* Enhancements to the kconfig module
* Added include_type kwarg to dependency
* Enhancements to configure_file()
* Projects args can be set separately for build and host machines (potentially breaking change)
* Allow checking if a variable is a disabler
* gtkdoc-check support
* gnome.gtkdoc() returns target object
* Dist is now a top level command

Revision 1.1 / (download) - annotate - [select for diffs], Fri Oct 4 14:06:18 2019 UTC (3 years, 11 months ago) by prlw1
Branch: MAIN

Add meson 0.51.2

The intention is to replace py-meson with meson to allow the possibility
of a python 3 meson to build a python 2 package.

No release notes, but
$ git log --oneline 0.51.1..0.51.2
6857936c (tag: 0.51.2, origin/0.51) Bump versions to 0.51.2 for release
267a69b1 Fix packaging.
0a460903 Fix tests for 0.51.2.
550a03ee gnome: Handle overriden g-ir-scanner
173facd4 cmake: fix missing -lpthread (fixes #5821)
ac2d69bd Pass optimization flags to rustc properly. Closes: #5788.
f2bd0812 Revert "gnome: Use find_program() to get glib-compile-resources"
acdcd736 Put native file before cross file in options list
524280db environment: simplify powerpc conditionals
51d1612d environment: simplify CPU logic via hw.machine_arch on BSDs
6b43e66e Canonicalize 'i86pc' return from platform.machine() for Solaris
bb63fe8e gnome: Use find_program() to get glib-compile-resources
c9524472 Made build. options alias basic ones when native building.
69a01dae Made set_option kwargs named-only.
5c7ff27e Do not print build and host settings when compiling natively.
949accb1 Do not print build compiler info when not cross compiling. It is confusing.
7aadc3aa vs backend: commandrunner.py takes source dir first
46c2a051 Update MSI creator script to newest VS on Win 7. [skip ci]
1a5c121f Fix cross compilation on OSX
c5f99542 coredata: Ignore directories when searching for machine files
85270dce mintro: Fix crash related to the sources kwarg (fixes #5741)
b48e1fcc docs: Add missing closing ` in reference manual
6f18ab18 interpreter: Fix permitted kwargs in dependency.get_variable
7f390e6a docs: correct key in dep.get_variable
58a6ab32 run_unitests: Skip the native_file_is_pipe test on cygwin
2640cd7e unit tests: Check whether pytest-xdist is available
be16f4cf Use pytest parallelisation if available.
5b02f88b ci/cygwin: Install pytest-xdist for unit tests
f7684ec5 ci/cygwin: Don't need a special step to install cmake
6e18169e tests/122 shared module: More verbose logging
87dee156 .travis.yml: Fix cross-mingw test failures
e7990883 cmake: 0.51 backport of #5665
750a7dc0 unit tests: Don't keep builddirs inside source tree on Cygwin
b591f3e7 Keep all build dirs inside the source tree.
bac86f25 meson: handle nested disabler
46d43b29 cmake: added test case for environment variables
e8421b24 meson: Use CMAKE_PREFIX_PATH environment variable
fd3384ca ValaCompiler: only emit '--debug' in debug build.
1e305e60 mintro: Fix section key in buildoptions
81e81209 BUGFIX: Fortran module regex handle more edge cases
d198d50c Fix missing return statements that are seen with -Werror=return-type.
f9211b75 No need to reserve build_ because we use build. instead.
41e9ac35 run_unitests: Add a unit test for native files that are pipes
4e2adb82 coredata: Correctly handle receiving a pipe for native/cross files
0e25505f Do not fail on passing `-Werror=unused-parameter` from environment
3beb2737 Return zero in cross_sizeof
58441054 cmake: Handle disabling subprojects

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>