[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / meld

File: [cvs.NetBSD.org] / pkgsrc / devel / meld / Makefile (download)

Revision 1.123, Wed Nov 23 16:19:51 2022 UTC (2 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.122: +2 -1 lines

massive revision bump after textproc/icu update

# $NetBSD: Makefile,v 1.123 2022/11/23 16:19:51 adam Exp $

DISTNAME=		meld-3.22.0
PKGREVISION=		1
CATEGORIES=		devel
MASTER_SITES=		${MASTER_SITE_GNOME:=sources/meld/${PKGVERSION_NOREV:R}/}
EXTRACT_SUFX=		.tar.xz

MAINTAINER=		wiz@NetBSD.org
HOMEPAGE=		https://meldmerge.org/
COMMENT=		Visual diff and merge tool
LICENSE=		gnu-gpl-v2

BUILD_DEPENDS+=		${PYPKGPREFIX}-distro-[0-9]*:../../devel/py-distro
DEPENDS+=		${PYPKGPREFIX}-gobject3>=3.30:../../devel/py-gobject3
DEPENDS+=		gsettings-desktop-schemas-[0-9]*:../../sysutils/gsettings-desktop-schemas
DEPENDS+=		dconf-[0-9]*:../../devel/dconf

USE_TOOLS+=		msgfmt pkg-config itstool

PYTHON_VERSIONS_INCOMPATIBLE=	27
PY_PATCHPLIST=			yes

REPLACE_PYTHON+=		bin/meld

SUBST_CLASSES+=		python3
SUBST_FILES.python3=	meson.build
SUBST_SED.python3=	-e "s,python.find_installation('python3',python.find_installation('${PYTHONBIN}',"
SUBST_SED.python3+=	-e "s,'python3','python-${PYVERSSUFFIX}',"
SUBST_STAGE.python3=	pre-configure
SUBST_MESSAGE.python3=	Fix python binary name.

# compile step in meson_post_install.py does not support DESTDIR
# https://gitlab.gnome.org/GNOME/meld/-/issues/709
post-install:
	${PYTHONBIN} -m compileall compile_dir ${DESTDIR}${PREFIX}/${PYSITELIB}

.include "../../devel/py-gobject3-common/buildlink3.mk"
.include "../../graphics/adwaita-icon-theme/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
BUILDLINK_API_DEPENDS.py-cairo+=	${PYPKGPREFIX}-cairo>=1.15.0
.include "../../graphics/py-cairo/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../devel/gettext-tools/msgfmt-desktop.mk"
BUILDLINK_API_DEPENDS.glib2+=	glib2>=2.48.0
.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/glib2/schemas.mk"
BUILDLINK_API_DEPENDS.gtk3+=	gtk3+>=3.20
.include "../../lang/python/application.mk"
.include "../../x11/gtk3/buildlink3.mk"
BUILDLINK_API_DEPENDS.gtksourceview4?=	gtksourceview4>=4.6.0nb1
.include "../../x11/gtksourceview4/buildlink3.mk"
.include "../../lang/python/extension.mk"
.include "../../lang/python/tool.mk"
.include "../../devel/meson/build.mk"
.include "../../mk/bsd.pkg.mk"