The NetBSD Project

CVS log for pkgsrc/devel/lua-rocks/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / lua-rocks

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.19 / (download) - annotate - [select for diffs], Wed Jan 4 22:27:08 2023 UTC (14 months, 1 week ago) by nikita
Branch: MAIN
CVS Tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, HEAD
Changes since 1.18: +2 -2 lines
Diff to previous 1.18 (colored)

lua-rocks: update to version 3.9.2

## What's new in LuaRocks 3.9.1

* Fixed error message when Lua library is not found
* Fixed build of Windows binary
* A couple of minor feature additions:
  * API: `loader.which` has a new mode for searching `package.path/cpath`
    * Adds a new second argument, `where`, a string which indicates places
      to search for the module. If `where` contains `"l"`, it will search
      using the LuaRocks loader; if it contains `"p"`, it will look in the
      filesystem using `package.path` and `package.cpath`. You can use both
      at the same time.
  * `--no-project` flag can be used to override `.luarocks` project directory
    detection

## What's new in LuaRocks 3.9.0

* `builtin` build mode now always respects CC, CFLAGS and LDFLAGS
* Check that lua.h version matches the desired Lua version
* Check that the version of the Lua C library matches the desired Lua version
* Fixed deployment of non-wrapped binaries
* Fixed crash when `--lua-version` option is malformed
* Fixed help message for `--pin` option
* Unix: use native methods and don't always rely on $USER to determine user
* Windows: use native CLI tooling more
* macOS: support .tbd extension when checking for libraries
* macOS: add XCode SDK path to search paths
* macOS: add best-effort heuristic for library search using Homebrew paths
* macOS: avoid quoting issues with LIBFLAG
* macOS: deployment target is now 11.0 on macOS 11+
* added DragonFly BSD support
* LuaRocks test suite now runs on Lua 5.4 and LuaJIT
* Internal dependencies of standalone LuaRocks executable were bumped

Revision 1.18 / (download) - annotate - [select for diffs], Thu Dec 9 15:11:07 2021 UTC (2 years, 3 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.17: +2 -2 lines
Diff to previous 1.17 (colored)

lua-rocks: update to 3.8.0

## What's new in LuaRocks 3.8.0

* Support GitHub's protocol security changes transparently.
  * The raw git:// protocol will stop working on GitHub. LuaRocks already
    supports git+https:// as an alternative, but to avoid having to update
    every rockspec in the repository that uses git://github.com, which would
    require a large coordinated effort, LuaRocks now auto-converts github.com
    and www.github.com URLs that use git:// to git+https://
* `luarocks test` has a new flag `--prepare` that checks, downloads and
  installs the tool requirements and rockspec dependencies but does not
  run the test suite for the rockspec being tested.
* Code tweaks so that LuaRocks can run on a Lua interpreter built without
  the `debug` library.
* `luarocks upload` supports uploading pre-packaged `.src.rock` files.
* Configuration fixes for OpenBSD.
* Respect the existing value for the `variables.LUALIB` configuration
  variable if given explicitly by the user in the config file, rather
  than trying to override it with auto-detection.
* Windows fixes for setting file permissions:
  * Revert the use of `Everyone` back to `*S-1-1-0`
  * Quote the use of the `%USERNAME%` variable to support names with spaces

Revision 1.17 / (download) - annotate - [select for diffs], Sun May 2 07:48:22 2021 UTC (2 years, 10 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.16: +2 -2 lines
Diff to previous 1.16 (colored)

lua-rocks: update to 3.7.0

## What's new in LuaRocks 3.7.0

* Improved connectivity resiliency
  * LuaRocks can now use mirrors for downloading rocks even if downloading
    the manifest from the main server succeeds.
    In previous versions, LuaRocks would check whether to use a mirror in the first
    download operation, when it fetches the manifest. Once the server
    (luarocks.org or one of its default mirrors) was chosen, it would stick with
    it for the rest of the command.
    The resulting behavior was that if the manifest fails to load, it switches to
    a mirror and continues from there. But if the manifest fetches ok and the then
    actual rock download fails, it would give up, instead of trying that in a
    mirror as well.
    Now, it retries every download on a mirror whenever the base URL matches one
    configured in cfg.rocks_servers. The original behavior was satisfactory if
    there was complete downtime in the main server, but this new behavior should
    make the CLI much more resilient with regard to any intermittent failures
    happening on the main server.
* On Unix, it now respects environment variables $XDG_CACHE_HOME and $XDG_CONFIG_HOME
  * This means the user's configuration typically resides in ~/.config/luarocks/
    as per the XDG standard
  * The legacy path ~/.luarocks/ continues to be tested first, for backwards
    compatibility
* Fixes check for the default Lua version set in the user's home configuration
* Fixes an issue on Windows where it would incorrectly revoke permissions
  from the current user when installing

## What's new in LuaRocks 3.6.0

* Adds a double-check step to verify that all files from a rock are installed
* Improve resilience of the manifest reader to deal with manifests
  written with older versions of LuaRocks lower than 3.0
* `luarocks pack` now checks that the directory inside the archive being packed
  as a `.src.rock` actually exists, refusing to pack an invalid rock from
  a badly configured rockspec.
* Fixes behavior of `luarocks pack` when the `url` entry of a rockspec
  points to a bare file.
* Remove an entry from the manifest if the rock itself is already missing
* The `configure` script now checks that the version of `lua.h`
  found matches that of the Lua interpreter detected or configured
* Fixes the renaming of scripts when multiple versions are installed
* Fixes availability check for `svn` for rockspecs using Subversion
* Fixes for running with an empty PATH environment variable
* Portability improvements:
  * Windows: vcvarsall.bat output is now properly redirected to NUL
    meaning that the output of `luarocks path` can be used in scripts
  * Fixes autodetection for Cygwin
  * Handles macOS versions greater than 10.10
  * Adds platform specific configurations for NetBSD
  * Respects CC/CFLAGS/LDFLAGS on FreeBSD
* Luacheck now runs on the LuaRocks CI
* Distributed binaries are built using Lua 5.3

Revision 1.16 / (download) - annotate - [select for diffs], Sat Dec 19 11:30:24 2020 UTC (3 years, 2 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.15: +5 -4 lines
Diff to previous 1.15 (colored)

lua-rocks: Update to 3.5.0

## What's new in LuaRocks 3.4.0

### Features

* `luarocks make` now supports `--only-deps`
* `luarocks make` new flag: `--no-install`, which only performs
  the compilation step
* `--deps-only` is now an alias for `--only-deps` (useful in case
  you always kept getting it wrong, like me!)
* `luarocks build` and `luarocks make` now support using
  `--pin` and `--only-deps` at the same time, to produce a lock
  file of dependencies in use without installing the main package.
* `luarocks show` can now accept a substring of the rock's name,
  like `list`.
* `luarocks config`: when running without system-wide permissions,
  try storing the config locally by default.
  Also, if setting both lua_dir and --lua-version explicitly,
  auto-switch the default Lua version.
* `luarocks` with no arguments now prints more info about the
  location of the Lua interpreter which is being used
* `luarocks new_version` now keeps the old URL if the MD5 doesn't
  change.
* `DEPS_DIR` is now accepted as a generic variable for dependency
  directories (e.g. `luarocks install foo DEPS_DIR=/usr/local`)
* Handle quoting of arguments at the application level, for
  improved Windows support
* All-in-one binary bundles `dkjson`, so it runs `luarocks upload`
  without requiring any additional dependencies.
* Tweaks for Terra compatibility

### Fixes

* win32: generate proper temp filename
* No longer assume that Lua 5.3 is built with compat libraries and
  bundles `bit32`
* `luarocks show`: do not crash when rockspec description is empty
* When detecting the location of `lua.h`, check that its version
  matches the version of Lua being used
* Fail gracefully when a third-party tool (wget, etc.) is missing
* Fix logic for disabling mirrors that return network errors
* Fix detection of Lua path based on arg variable
* Fix regression on dependency matching of luarocks.loader

Revision 1.15 / (download) - annotate - [select for diffs], Thu Jul 2 20:53:10 2020 UTC (3 years, 8 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.14: +2 -2 lines
Diff to previous 1.14 (colored)

lua-rocks: mine.

Revision 1.14 / (download) - annotate - [select for diffs], Thu Jul 2 17:24:56 2020 UTC (3 years, 8 months ago) by alnsn
Branch: MAIN
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

Reset maintainership.

Revision 1.13 / (download) - annotate - [select for diffs], Thu Jul 2 12:53:21 2020 UTC (3 years, 8 months ago) by nia
Branch: MAIN
Changes since 1.12: +7 -1 lines
Diff to previous 1.12 (colored)

lua-rocks: Substitute PREFIX properly

Revision 1.12 / (download) - annotate - [select for diffs], Thu Jul 2 12:13:36 2020 UTC (3 years, 8 months ago) by nia
Branch: MAIN
Changes since 1.11: +3 -1 lines
Diff to previous 1.11 (colored)

lua-rocks: Force pkgsrc unzip.

Otherwise it complains:

Error: Failed unpacking rock file: /tmp/luarocks_luarocks-rock-digestif-0.3-1-B5qFAU/digestif-0.3-1.src.rock: 'unzip -n' program not found. Make sure unzip is installed and is available in your PATH (or you may want to edit the 'variables.UNZIP' value in file '/usr/pkg/etc/luarocks/config-5.4.lua')

Revision 1.11 / (download) - annotate - [select for diffs], Thu Jul 2 10:26:18 2020 UTC (3 years, 8 months ago) by nia
Branch: MAIN
Changes since 1.10: +2 -2 lines
Diff to previous 1.10 (colored)

Add 'lua' category to Lua modules.

While here, normalize some packages with strange variable order.

Revision 1.10 / (download) - annotate - [select for diffs], Wed Jul 1 11:06:40 2020 UTC (3 years, 8 months ago) by nia
Branch: MAIN
Changes since 1.9: +8 -11 lines
Diff to previous 1.9 (colored)

lua-rocks: Update to 3.3.1

This adds Lua 5.4 support, among many other features.

Revision 1.9 / (download) - annotate - [select for diffs], Wed Jul 1 10:32:42 2020 UTC (3 years, 8 months ago) by nia
Branch: MAIN
Changes since 1.8: +3 -1 lines
Diff to previous 1.8 (colored)

lua-rocks: Add LUA_VERSIONS_ACCEPTED

Revision 1.8 / (download) - annotate - [select for diffs], Fri Oct 26 12:06:13 2018 UTC (5 years, 4 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4
Changes since 1.7: +2 -1 lines
Diff to previous 1.7 (colored)

lua-rocks: Requires unzip.

Revision 1.7 / (download) - annotate - [select for diffs], Tue Jul 17 22:18:06 2018 UTC (5 years, 8 months ago) by alnsn
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

Update devel/lua-rocks to version 2.4.4.

Changes since version 2.4.3:

* All platfoms: Do not halt a package deletion process when a file
  from the package is missing
* Windows: Updated bundled binaries: Lua 5.1.5, Wget 1.19.4, 7zip 18.01
* Windows: updated installer to better handle gcc toolchains
* Windows: fix detection of directories
* Windows: fixes .def generation

Revision 1.6 / (download) - annotate - [select for diffs], Mon Jan 29 21:18:23 2018 UTC (6 years, 1 month ago) by alnsn
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
Changes since 1.5: +3 -3 lines
Diff to previous 1.5 (colored)

Update luarocks to version 2.4.3.

Version 2.4.3 - 12/Sep/2017
 - Fixed display of pathnames in `luarocks show`
 - Improved check for write permissions when installing
 - Plus assorted bugfixes and improvements

Revision 1.5 / (download) - annotate - [select for diffs], Sat Sep 16 19:53:50 2017 UTC (6 years, 6 months ago) by alnsn
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.4: +2 -2 lines
Diff to previous 1.4 (colored)

Drop maintainership.

Revision 1.4 / (download) - annotate - [select for diffs], Sun Sep 10 14:51:01 2017 UTC (6 years, 6 months ago) by alnsn
Branch: MAIN
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

Update devel/lua-rocks to version 2.4.2.

Version 2.4.2 - 30/Nov/2016
	* Fixed conflict resolution on deploy/delete
	* Improved dependency check messages
	* Performance improvements when removing packages
	* Support user-defined `platforms` array in config file
	* Improvements in Lua interpreter version detection in Unix
	  configure script
	* Relaxed Lua version detection to improve support for
	  alternative implementations (e.g. Ravi)
	* Plus assorted bugfixes and improvements

Revision 1.3 / (download) - annotate - [select for diffs], Wed Aug 16 20:21:08 2017 UTC (6 years, 7 months ago) by wiz
Branch: MAIN
Changes since 1.2: +3 -3 lines
Diff to previous 1.2 (colored)

Follow some http redirects.

Revision 1.2 / (download) - annotate - [select for diffs], Thu Oct 6 20:28:54 2016 UTC (7 years, 5 months ago) by alnsn
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4
Changes since 1.1: +2 -4 lines
Diff to previous 1.1 (colored)

Update devel/lua-rocks to 2.4.1.

What's new since 2.3.0:

* New test suite based on Busted; runs on Linux, OSX and Windows. This
test suite was developed by Robert Karasek as his Google Summer of
Code project for LabLua. You can check out the combined coverage of
all platforms at CodeCov:
https://codecov.io/gh/keplerproject/luarocks/
* git+ssh:// fetch protocol
* Improved behavior preserving permissions
* Improved listing of dependencies on installation
* Improved behavior of argument handling in `pack`
* MSYS and Haiku platform detection
* Feature-based detection of internal bit32 and utf8 modules
* Internal reorganization of luarocks.fs code
* `remove` option --force=fast renamed to --force-fast
* Plus assorted bugfixes and cleanups

What's new since 2.4.0:

* Avoid coroutine use inside luarocks.loader, that apparently affected
OpenResty's require()
* Fix upgrade issues for old versions (e.g. when upgrading from LuaRocks 2.1.0)

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Mon Jun 6 21:31:52 2016 UTC (7 years, 9 months ago) by alnsn
Branch: TNF
CVS Tags: pkgsrc-base, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Initial import of devel/lua-rocks version 2.3.0.

LuaRocks is  a deployment and management system for Lua modules.

It allows you to install Lua modules as self-contained packages
called rocks, which also contain version dependency information.
This information can be used both during installation, so that when
one rock is requested all rocks it depends on are installed as
well, and also optionally at run time, so that when a module is
required, the correct version is loaded.  LuaRocks supports both
local and remote repositories, and multiple local rocks trees.

Revision 1.1 / (download) - annotate - [select for diffs], Mon Jun 6 21:31:52 2016 UTC (7 years, 9 months ago) by alnsn
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>