The NetBSD Project

CVS log for pkgsrc/devel/lua-mode/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / lua-mode

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.10 / (download) - annotate - [select for diffs], Wed Aug 17 12:43:43 2022 UTC (13 months ago) by tnn
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, HEAD
Changes since 1.9: +4 -4 lines
Diff to previous 1.9 (colored)

lua-mode: convert to github.mk

Revision 1.9 / (download) - annotate - [select for diffs], Thu Apr 14 10:21:21 2022 UTC (17 months, 1 week ago) by nikita
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2
Changes since 1.8: +4 -4 lines
Diff to previous 1.8 (colored)

lua-mode: Update to 20210802

Changelog from https://github.com/immerrr/lua-mode/tags

v20210802
 * performance optimizations for automatic indentation
  * lua-skip-ws-and-comments-forward, lua-skip-ws-and-comments-backward: add new
    functions
  * lua-comment-start-pos: make sure point inside comment starter "--" is
    considered inside comment
  * lua-funcname-at-point: refactor to avoid copying syntax table to improve
    performance
  * lua--signum: add backward compat helper
  * code cleanups & minor refactors

Revision 1.8 / (download) - annotate - [select for diffs], Tue Oct 26 10:15:36 2021 UTC (22 months, 3 weeks ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.7: +2 -2 lines
Diff to previous 1.7 (colored)

archivers: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Could not be committed due to merge conflict:
devel/py-traitlets/distinfo

The following distfiles were unfetchable (note: some may be only fetched
conditionally):

./devel/pvs/distinfo pvs-3.2-solaris.tgz
./devel/eclipse/distinfo eclipse-sourceBuild-srcIncluded-3.0.1.zip

Revision 1.7 / (download) - annotate - [select for diffs], Thu Oct 7 13:40:30 2021 UTC (23 months, 2 weeks ago) by nia
Branch: MAIN
Changes since 1.6: +1 -2 lines
Diff to previous 1.6 (colored)

devel: Remove SHA1 hashes for distfiles

Revision 1.6 / (download) - annotate - [select for diffs], Thu Nov 5 22:34:33 2020 UTC (2 years, 10 months ago) by nikita
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.5: +5 -5 lines
Diff to previous 1.5 (colored)

devel/lua-mode: Update to Version 20201010

Changelog, taken from NEWS file and https://github.com/immerrr/lua-mode/releases:

v20201010
* minimum Emacs version requirement is now 24.3

* fix multiline literals propertization not to break subsequent syntax

* lua--fill-paragraph: fix to not move point away

* lua-default-application: ensure it is possible to use (HOST . PORT) to
connect to remote lua process

* lua-kill-process: clean up process-related variables

* lua-indent-nested-block-content-align, lua-indent-close-paren-align: new
variables to control placement of nested blocks and their respective closers.

With lua-indent-nested-block-content-align and lua-indent-close-paren-align set
to nil, it is now possible to auto-indent code like this:

foo = bar(baz, {
      qux,
      quux,
}, {
      xyzzy
})

* lua-rx: fix compatibility with new-style rx macros introduced in Emacs 27

* lua-start-process: ensure comint-prompt-regexp is set locally in inferior
process buffer

* make "git archive" revision format reproduceable by not including the date of
the archiving operation

* imenu: add "require" lines to the index

* lua-backward-up-list: new navigation command that puts point before the
current parenthetic construction/block

* lua-indent-line: improve auto-indentation of implicitly continued statements,
add some performance optimizations

* font-lock: stop highlighting syntax errors in assignment statements

* font-lock: add highlighting of function parameters and "for" loop variables

* font-lock: fix couple of corner cases of highlighting of keywords inside
strings and comments

* Release v20151025
** allow setting lua-indent-level as file local variable (issue #108)

** add luadoc keyword fontification (issue #71)

** fix comments being spilled into the code (issue #25)

** add `run-lua' alias for `lua-start-process' (issue #97)

** skip shebang line when sending to inferior buffer (issue #61)

** add builtin functions and modules for Lua 5.3 (issue #90)

** fix lua-beginning-of-proc matching (issue #85)

** add `lua-documentation-function' to customize the way the documentation is
   shown, rename `lua-search-url-prefix' to `lua-documentation-url',
   auto-detect lua documentation installed in /usr/share/doc/lua (issue #82)

** fix some errors with `lua-kill-process' (issue #69)

** improve `next-error' integration in Lua subprocess buffer: "stdin:N:"
   entries are no longer highlighted and no longer prompt for "stdin" files

* release v20140514

** add support for Lua 5.2 goto statements

** when indenting, don't anchor to block-open tokens
   somefunc({
            ^
            don't indent next line relative to this brace

** fix several `indent-new-comment-line'-related bugs

** add support for local functions in imenu (issue #65)

** fix font lock of functions with underscores (issue #63)

** don't send shebang when sending lua buffer to subprocess (issue #61)

** fix interaction with electric-pair-mode (issue #54)

** rewrite lua-send-region to use "loadstring" rather than "dofile"
   - sending code to processes on remote hosts is now supported
   - stack traces for errors occurred in sent code point to proper lines in files
   - script path is preserved when sending code (issue #55)
   - no more hang ups when waiting for input (issue #48) or after sending code
     with no output (issue #60)

** increase consistency with Emacs ecosystem to improve user experience
   - fix character syntax hacks: '.' is now punctuation and '_' is now symbol
   - remove number highlighting
   - font-lock "nil", "true" and "false" as constants rather than keywords

** make builtin font-locking more stable, enable it after ".." operator

** add missing modulo operator (%) to line-continuation tokens

** fix interaction with electric-pair-mode (issue #54)

** when unindenting block-close tokens consider all of them, not just the first one
     x = foobar('arg1', function ()
                  print('foobar')
     end)
     ^ this line starts with two block-close tokens and is unindented
     accordingly

Revision 1.5 / (download) - annotate - [select for diffs], Tue Nov 3 03:27:48 2015 UTC (7 years, 10 months ago) by agc
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.4: +2 -1 lines
Diff to previous 1.4 (colored)

Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.

Revision 1.4 / (download) - annotate - [select for diffs], Mon Jul 29 20:35:00 2013 UTC (10 years, 1 month ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3
Changes since 1.3: +4 -4 lines
Diff to previous 1.3 (colored)

Update to 20130419:

* highlight hash-bang line as comment

* make lua-mode-hook editable via customize

* fix several indentation bugs & quirks

* fix lua-send-proc not to send previous function when point is at the beginning of a function

* derive lua-mode from prog-mode for Emacs24

* add font-locking for builtins and numeric constants

* fix a bug causing exponential complexity in a keyword matching regexp

* add more unindentation cases for block-closing tokens

* improve multiline highlighting via font-lock-syntactic-keywords
   This should make font-locking of multiline literals more fluent & stable. And
   it becomes customizable via standard font-lock configuration

* properly fontify variable definitions in 'local ...' & 'for ...'
   Also, perform some basic syntax verification in those lines. Multi-line
   constructs not supported yet.

* fix indentation for blocks starting on continued lines
     local foo =
        {
           bar,
           baz
        } ^
           1. these lines should be indented properly now
     ^
     2. the following lines should be unindented properly now

* extend imenu-generic-expression
   Now it matches 'foo = function(...)' function definitions

Revision 1.3 / (download) - annotate - [select for diffs], Fri Feb 11 10:05:30 2011 UTC (12 years, 7 months ago) by jmmv
Branch: MAIN
CVS Tags: pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4, pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1
Changes since 1.2: +4 -4 lines
Diff to previous 1.2 (colored)

Update to 20110121:

* lua-mode now lives in github.
* Small patch to show how to make Emacs automatically use lua-mode for
  files that have a hash-bang line containing "lua", even if they don't
  have a ".lua" suffix.
* Customization of indent level and comments.

Revision 1.2 / (download) - annotate - [select for diffs], Sat Nov 20 21:02:40 2010 UTC (12 years, 10 months ago) by minskim
Branch: MAIN
CVS Tags: pkgsrc-2010Q4-base, pkgsrc-2010Q4
Changes since 1.1: +4 -4 lines
Diff to previous 1.1 (colored)

Update lua-mode to 20100617.

Changes:
- Cleans up the code and attempts to improve long string colouring.
- Adds syntax colouring for variable declarations and long strings,
  and tidies up the source somewhat, while simplifying the
  distribution to a single ELisp file.
- Fixes minor bugs.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Thu May 14 05:52:12 2009 UTC (14 years, 4 months ago) by minskim
Branch: TNF
CVS Tags: pkgsrc-base, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Import lua-mode-20071122 from pkgsrc-wip.  Packaged by Aleksey Cheusov.

Lua-mode is a major Emacs mode for editing source code written in Lua
programming language.

Revision 1.1 / (download) - annotate - [select for diffs], Thu May 14 05:52:12 2009 UTC (14 years, 4 months ago) by minskim
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>