The NetBSD Project

CVS log for pkgsrc/devel/lua-language-server/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / lua-language-server

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.15: download - view: text, markup, annotated - select for diffs
Fri Jan 31 11:22:02 2025 UTC (6 weeks, 3 days ago) by wiz
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +12 -1 lines
lua-language-server: mark BROKEN

Hasn't been building in any builds for over half a year

Revision 1.14: download - view: text, markup, annotated - select for diffs
Sat Jul 6 10:57:00 2024 UTC (8 months, 1 week ago) by riastradh
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +2 -1 lines
devel/lua-language-server: Fix futex timespec misuse on NetBSD.

Revision 1.13: download - view: text, markup, annotated - select for diffs
Mon May 27 09:08:22 2024 UTC (9 months, 2 weeks ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2024Q2-base, pkgsrc-2024Q2
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +7 -1 lines
lua-language-server: Note why this thing can't work on netbsd-9.

Revision 1.12: download - view: text, markup, annotated - select for diffs
Tue Apr 30 22:01:33 2024 UTC (10 months, 2 weeks ago) by nikita
Branches: MAIN
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +11 -12 lines
lua-language-server: update to version 3.8.3

Changelog:

## 3.8.3
`2024-4-23`
* `FIX` server may crash when the workspace is using a non-English path.

## 3.8.2
`2024-4-23`
* This is a fake version only for the new version of VSCode, with a core of 3.8.0.

## 3.8.1
`2024-4-23`
* This is a fake version only for the old version of VSCode, with a core of `3.7.4`. Starting from the next minor version, the version requirement for VSCode will be raised to prevent users still using the old version of VSCode from updating to the new version and experiencing compatibility issues.

## 3.8.0
`2024-4-22`
* `NEW` supports tuple type (@[lizho])
  ```lua
  ---@type [string, number, boolean]
  local t

  local x = t[1] --> x is `string`
  local y = t[2] --> y is `number`
  local z = t[3] --> z is `boolean`
  ```
* `NEW` generic pattern (@[fesily])
  ```lua
  ---@generic T
  ---@param t Cat.`T`
  ---@return T
  local function f(t) end

  local t = f('Smile') --> t is `Cat.Smile`
  ```
* `NEW` alias and enums supports attribute `partial`
  ```lua
  ---@alias Animal Cat

  ---@alias(partial) Animal Dog

  ---@type Animal
  local animal --> animal is `Cat|Dog` here
  ```

  ```lua
  ---@enum(key) ErrorCodes
  local codes1 = {
      OK = 0,
      ERROR = 1,
      FATAL = 2,
  }

  ---@enum(key, partial) ErrorCodes
  local codes2 = {
      WARN = 3,
      INFO = 4,
  }

  ---@type ErrorCodes
  local code

  code = 'ERROR' --> OK
  code = 'WARN'  --> OK

  ```
* `NEW` plugin: add `OnTransFormAst` interface (@[fesily])
* `NEW` plugin: add `OnNodeCompileFunctionParam` interface (@[fesily])
* `NEW` plugin: add `ResolveRequire` interface (@[Artem Dzhemesiuk])
* `NEW` plugin: support multi plugins (@[fesily])
  + setting: `Lua.runtime.plugin` can be `string|string[]`
  + setting: `Lua.runtime.pluginArgs` can be `string[]|table<string, string>`
* `NEW` CLI: `--doc` add option `--doc_out_path <PATH>` (@[Andreas Matthias])
* `NEW` CLI: `--doc_update`, update an existing `doc.json` without using `--doc` again (@[Andreas Matthias])
* `NEW` CLI: `--trust_all_plugins`, this is potentially unsafe for normal use and meant for usage in CI environments only (@[Paul Emmerich])
* `CHG` CLI: `--check` will run plugins (@[Daniel Farrell])
* `FIX` diagnostic: `discard-returns` not works in some blocks (@clay-golem)
* `FIX` rename in library files

## 3.7.4
`2024-1-5`
* `FIX` rename to unicode with `Lua.runtime.unicodeName = true`

## 3.7.3
`2023-11-14`
* `FIX` can not infer arg type in some cases.

## 3.7.2
`2023-11-9`
* `FIX` [#2407]

[#2407]: https://github.com/LuaLS/lua-language-server/issues/2407

## 3.7.1
`2023-11-7`
* `FIX` [#2299]
* `FIX` [#2335]

[#2299]: https://github.com/LuaLS/lua-language-server/issues/2299
[#2335]: https://github.com/LuaLS/lua-language-server/issues/2335

## 3.7.0
`2023-8-24`
* `NEW` support `---@type` and `--[[@as]]` for return statement
* `NEW` commandline parameter `--force-accept-workspace`: allowing the use of the root directory or home directory as the workspace
* `NEW` diagnostic: `inject-field`
* `NEW` `---@enum` supports attribute `key`
  ```lua
  ---@enum (key) AnimalType
  local enum = {
    Cat = 1,
    Dog = 2,
  }

  ---@param animal userdata
  ---@param atp AnimalType
  ---@return boolean
  local function isAnimalType(animal, atp)
    return API.isAnimalType(animal, enum[atp])
  end

  assert(isAnimalType(animal, 'Cat'))
  ```
* `NEW` `---@class` supports attribute `exact`
  ```lua
  ---@class (exact) Point
  ---@field x number
  ---@field y number
  local m = {}
  m.x = 1 -- OK
  m.y = 2 -- OK
  m.z = 3 -- Warning
  ```

* `FIX` wrong hover and signature for method with varargs and overloads
* `FIX` [#2155]
* `FIX` [#2224]
* `FIX` [#2252]
* `FIX` [#2267]

[#2155]: https://github.com/LuaLS/lua-language-server/issues/2155
[#2224]: https://github.com/LuaLS/lua-language-server/issues/2224
[#2252]: https://github.com/LuaLS/lua-language-server/issues/2252
[#2267]: https://github.com/LuaLS/lua-language-server/issues/2267

## 3.6.25
`2023-7-26`
* `FIX` [#2214]

[#2214]: https://github.com/LuaLS/lua-language-server/issues/2214

## 3.6.24
`2023-7-21`
* `NEW` diagnostic: `missing-fields`
* `FIX` shake of `codeLens`
* `FIX` [#2145]

[#2145]: https://github.com/LuaLS/lua-language-server/issues/2145

## 3.6.23
`2023-7-7`
* `CHG` signature: narrow by inputed literal

## 3.6.22
`2023-6-14`
* `FIX` [#2038]
* `FIX` [#2042]
* `FIX` [#2062]
* `FIX` [#2083]
* `FIX` [#2088]
* `FIX` [#2110]
* `FIX` [#2129]

[#2038]: https://github.com/LuaLS/lua-language-server/issues/2038
[#2042]: https://github.com/LuaLS/lua-language-server/issues/2042
[#2062]: https://github.com/LuaLS/lua-language-server/issues/2062
[#2083]: https://github.com/LuaLS/lua-language-server/issues/2083
[#2088]: https://github.com/LuaLS/lua-language-server/issues/2088
[#2110]: https://github.com/LuaLS/lua-language-server/issues/2110
[#2129]: https://github.com/LuaLS/lua-language-server/issues/2129

Revision 1.11: download - view: text, markup, annotated - select for diffs
Fri Sep 22 20:17:21 2023 UTC (17 months, 3 weeks ago) by vins
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +3 -2 lines
lua-language-server: requires FORCE_CXX_STD

Revision 1.10: download - view: text, markup, annotated - select for diffs
Tue Jul 18 14:11:17 2023 UTC (19 months, 4 weeks ago) by nia
Branches: MAIN
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -2 lines
devel: Adapt packages to use USE_(CC|CXX)_FEATURES

Revision 1.9: download - view: text, markup, annotated - select for diffs
Wed May 31 14:32:35 2023 UTC (21 months, 2 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +8 -8 lines
lua54-language-server: update to 3.6.21.

## 3.6.21
`2023-5-24`
* `FIX` disable ffi plugin

## 3.6.20
`2023-5-23`
* `NEW` support connecting by socket with `--socket=PORT`
* `FIX` [#2113]

Revision 1.8: download - view: text, markup, annotated - select for diffs
Wed May 17 22:25:06 2023 UTC (22 months ago) by nikita
Branches: MAIN
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -1 lines
lua-language-server: require gcc 7

Revision 1.7: download - view: text, markup, annotated - select for diffs
Tue May 16 14:35:44 2023 UTC (22 months ago) by nikita
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +3 -1 lines
lua-language-server: maybe fix build on EL Linux.

(which encounters errors with -std=c++17)

Revision 1.6: download - view: text, markup, annotated - select for diffs
Fri May 12 21:37:32 2023 UTC (22 months ago) by nikita
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +13 -3 lines
lua-language-server: patch out randomly failing filewatch test, add clang build dependency.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Fri Apr 28 16:10:41 2023 UTC (22 months, 2 weeks ago) by nikita
Branches: MAIN
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +11 -28 lines
lua-language-server: update to version 3.6.19

Changelog (taken from https://github.com/LuaLS/lua-language-server/releases/tag/3.6.19):

3.6.19 Latest
19906a9
What's Changed

    Readme refresh by @carsakiller in #2028
    Add desc of skynet.task api by @Gowa2017 in #2024
    更新 by @CppCXY in #2043
    Add optional diagnostic warning about any global element by @AndreaWalchshoferSCCH in #2040
    add support for musl version in github actions by @ericwq in #2049
    update for feature_request_102 by @CppCXY in #2052
    fix: add links to too many files warning by @carsakiller in #2080
    update and fix issue by @CppCXY in #2075
    Check for missing @param and @return annotations by @wetzlmaier in #2078

Revision 1.4: download - view: text, markup, annotated - select for diffs
Thu Apr 13 12:28:11 2023 UTC (23 months ago) by wiz
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +3 -1 lines
lua-language-server: no more -Werror

Code not safe enough on all compilers

Revision 1.3: download - view: text, markup, annotated - select for diffs
Fri Mar 31 08:16:41 2023 UTC (23 months, 2 weeks ago) by nikita
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +8 -1 lines
lua-langua-server: patch the hardcoded /usr/pkg in 3rd.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Thu Mar 30 18:41:00 2023 UTC (23 months, 2 weeks ago) by nikita
Branches: MAIN
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +10 -10 lines
lua-language-server: update to version 3.6.18

Import from wip, packaged by wiz/nikita

Changelog:


3.6.18
What's Changed

    更新 by @CppCXY in #1995
    Make functions in string api accept numbers by @C3pa in #2016
    3rd: meta add bee by @fesily in #2021


3.6.17
What's Changed

    fix #1969 by @CppCXY in #1970
    Don't override lm.bindir and lm.EXE_DIR in make.lua by @neeshy in #1977
    fix issues by @CppCXY in #1987
    add: description for config.addonManager.enable by @carsakiller in #1989


3.6.14
What's Changed

    fix #1969 by @CppCXY in #1970
    Don't override lm.bindir and lm.EXE_DIR in make.lua by @neeshy in #1977
    fix issues by @CppCXY in #1987
    add: description for config.addonManager.enable by @carsakiller in #1989


3.6.13


3.6.12
What's Changed

    更新 by @CppCXY in #1918
    fix #1919 by @CppCXY in #1920
    fix #1921 by @CppCXY in #1923
    add: addon manager setting to template by @carsakiller in #1931
    README updates by @carsakiller in #1937
    更新 by @CppCXY in #1939
    更新 by @CppCXY in #1954
    Array of a class type does not get completion #1940 by @jharajeev55 in #1962
    Improve math.abs annotation by @C3pa in #1961
    meta: newproxy can accept a userdata value by @Bilal2453 in #1959


3.6.11
What's Changed

    Small improvements in make.sh by @atk91 in #1890
    更新 by @CppCXY in #1894
    更新修复一些issue by @CppCXY in #1908


3.6.10
What's Changed

    chore: update links to point to organization by @carsakiller in #1874
    更新编译 by @CppCXY in #1877

Revision 1.1: download - view: text, markup, annotated - select for diffs
Wed Mar 29 20:27:09 2023 UTC (23 months, 2 weeks ago) by nikita
Branches: MAIN
Import devel/lua-language-server as lua-language-server version 3.6.9

The Lua Language Server is a comprehensive Lua development
server. It functions as an LSP client, supporting:

* Over 20 supported annotations for documenting your code
* Go to definition
* Dynamic type checking
* Find references
* Diagnostics/Warnings
* Syntax checking
* Element renaming
* Hover to view details on variables, functions, and more
* Autocompletion
* Support for libraries
* Code formatting
* Spell checking
* Custom plugins

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>