[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / libtool-base

Annotation of pkgsrc/devel/libtool-base/Makefile, Revision 1.49

1.49    ! grant       1: # $NetBSD: Makefile,v 1.48 2004/12/17 16:24:23 jlam Exp $
1.1       hubertf     2: #
                      3:
1.44      tv          4: .include "../../devel/libtool/Makefile.common"
                      5:
                      6: PKGNAME=       ${DISTNAME:S/-/-base-/}
1.49    ! grant       7: PKGREVISION=   8
1.8       veego       8: SVR4_PKGNAME=  ltoob
1.2       wiz         9:
                     10: COMMENT=       Generic shared library support script (the script itself)
1.3       hubertf    11:
1.7       wiz        12: CONFLICTS+=    libtool<=1.3.5nb11
1.11      jlam       13:
1.16      dillo      14: TEST_TARGET=   check
1.1       hubertf    15:
                     16: .if ${OPSYS} == "NetBSD"
1.14      jlam       17: .  if !exists(/usr/libexec/ld.so) && !exists(/usr/libexec/ld.elf_so)
1.40      tv         18: CONFIGURE_ARGS+=       --disable-shared
1.15      jlam       19: BUILD_SHLIBTOOL=       NO
1.14      jlam       20: .  endif
1.1       hubertf    21: .endif
1.44      tv         22: CONFIGURE_ARGS+=       --disable-ltdl-install
                     23: BUILD_SHLIBTOOL?=      YES
1.1       hubertf    24:
1.44      tv         25: # We are going to want libtool to find the same versions of the C, C++,
                     26: # and Fortran compilers.
                     27: #
                     28: USE_LANGUAGES=         c c++ fortran
1.40      tv         29: CONFIGURE_ARGS+=       --with-tags=CXX,F77,GCJ
                     30:
1.32      wiz        31: .PHONY: fix-libtool
                     32: fix-libtool:
                     33:        cd ${WRKSRC}; for f in libtool; do                              \
                     34:                ${SED}  -e "s,-L${BUILDLINK_DIR}/lib,," $$f > $$f.new;  \
                     35:                if [ -x $$f ]; then ${CHMOD} +x $$f.new; fi;            \
                     36:                ${MV} -f $$f.new $$f;                                   \
                     37:        done
                     38:
                     39: post-build: fix-libtool
                     40:
1.33      tv         41: .if ${BUILD_SHLIBTOOL} == "NO"
                     42: PLIST_SUBST+=          SHLIBTOOL="@comment "
1.15      jlam       43: .else
1.29      jlam       44: PLIST_SUBST+=          SHLIBTOOL=
1.15      jlam       45:
                     46: post-build:
1.33      tv         47:        cd ${WRKSRC} && \
                     48:                ${SED} -e '/^# Whether or not to build static/{n;s/yes/no/;}' \
                     49:                < libtool > shlibtool
1.15      jlam       50:
                     51: post-install:
1.33      tv         52:        ${INSTALL_SCRIPT} ${WRKSRC}/shlibtool ${PREFIX}/bin/shlibtool
1.13      jlam       53: .endif
                     54:
1.45      tv         55: BUILDLINK_DEPMETHOD.dlcompat=  build
                     56:
1.47      jlam       57: .include "../../mk/dlopen.buildlink3.mk"
1.1       hubertf    58: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>