[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / libsmi

File: [cvs.NetBSD.org] / pkgsrc / devel / libsmi / Makefile (download)

Revision 1.10, Wed Jul 19 19:14:38 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.9: +1 -2 lines

Drop support for LTCONFIG_OVERRIDE.  For quite a long time, pkgsrc
had actually been ignoring LTCONFIG_OVERRIDE anyway and just using
the default LIBTOOL_OVERRIDE to replace libtool scripts in packages.
This just formalizes the fact that LTCONFIG_OVERRIDE is not used
meaningfully by pkgsrc.

# $NetBSD: Makefile,v 1.10 2006/07/19 19:14:38 jlam Exp $
#

DISTNAME=	libsmi-0.1.6
PKGREVISION=	1
CATEGORIES=	devel net
MASTER_SITES=	ftp://ftp.ibr.cs.tu-bs.de/pub/local/libsmi/

MAINTAINER=	sakamoto@NetBSD.org
HOMEPAGE=	http://www.ibr.cs.tu-bs.de/projects/libsmi/
COMMENT=	Library to access SMI MIB information

MIBDIR=		${PREFIX}/share/libsmi/mibs

USE_LIBTOOL=	YES
GNU_CONFIGURE=	YES
CONFIGURE_ARGS+=--with-mibdir=${MIBDIR:Q}
# this might make it easier to use scotty's and ucd-snmp's mibs,
# and local ones too
CONFIGURE_ARGS+=--with-smipath="${MIBDIR}:${PREFIX}/share/snmp/mibs:${PREFIX}/lib/tnm2.1.8/mibs:/usr/local/share/snmp/mibs"

# Only for systems that don't have these:
.include "../../mk/bsd.prefs.mk"
.if ${OS_VERSION:M1.4} || ${OS_VERSION:M1.3} || ${OS_VERSION:M1.2}
CPPFLAGS+=	-Dstrtoll=strtoq -Dstrtoull=strtouq
.endif

.include "../../mk/bsd.pkg.mk"