File:  [cvs.NetBSD.org] / pkgsrc / devel / libffi / Makefile
Revision 1.54: download - view: text, annotated - select for diffs
Sun Feb 9 14:19:04 2025 UTC (2 months, 2 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2025Q1-base, pkgsrc-2025Q1, HEAD
libffi: update to 3.4.7.

3.4.7 Feb-8-2024
      Add static trampoline support for Linux on s390x.
      Fix BTI support for ARM64.
      Support pointer authentication for ARM64.
      Fix ASAN compatibility.
      Fix x86-64 calls with 6 GP registers and some SSE registers.
      Miscellaneous fixes for ARC and Darwin ARM64.
      Fix OpenRISC or1k and Solaris 10 builds.
      Remove nios2 port.

# $NetBSD: Makefile,v 1.54 2025/02/09 14:19:04 wiz Exp $

DISTNAME=	libffi-3.4.7
CATEGORIES=	devel
MASTER_SITES=	${MASTER_SITE_GITHUB:=libffi/}
GITHUB_RELEASE=	v${PKGVERSION_NOREV}

MAINTAINER=	asau@inbox.ru
HOMEPAGE=	https://www.sourceware.org/libffi/
COMMENT=	Foreign function interface
LICENSE=	mit

USE_LANGUAGES=		c c++
USE_LIBTOOL=		yes
USE_TOOLS+=		gmake pkg-config readelf
USE_TOOLS.SunOS+=	perl
GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--disable-multi-os-directory
CONFIGURE_ARGS+=	--includedir=${PREFIX}/include
PKGCONFIG_OVERRIDE+=	libffi.pc.in
INFO_FILES=		yes
TEST_DEPENDS+=		dejagnu-[0-9]*:../../devel/dejagnu
TEST_TARGET=		check

.include "../../mk/compiler.mk"
# The Compaq C frontend groks .s, but not .S. Assemble osf.S directly w/ as(1).
pre-build:
.if !empty(PKGSRC_COMPILER:Mccc)
	cd ${WRKSRC} && ./libtool --mode=compile --tag=CC as -I. -Iinclude -o src/alpha/osf.lo -c src/alpha/osf.S
.endif

.include "../../mk/bsd.prefs.mk"

# patch-src_m68k_ffi.c uses m68k_sync_icache(2)
.if ${MACHINE_PLATFORM:MNetBSD-*-m68k}
LIBS+=		-lm68k
.endif

# fix http://gnats.netbsd.org/42865
.if ${MACHINE_PLATFORM:MSunOS-*-i386} && ${CC_VERSION:Mgcc-[23]*}
CPPFLAGS+=	-D__PIC__
.endif

# On platforms where ld(1) is LLVM ld, relocations against read-only
# segments has to be explicitly allowed.
.if ${MACHINE_PLATFORM:MFreeBSD-1[2-9].*-*}
CFLAGS+=	-Wl,-z,notext
.endif

.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>