The NetBSD Project

CVS log for pkgsrc/devel/libepoll-shim/PLIST

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / libepoll-shim

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.4 / (download) - annotate - [select for diffs], Wed Apr 26 16:12:48 2023 UTC (11 months, 3 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, HEAD
Changes since 1.3: +4 -1 lines
Diff to previous 1.3 (unified)

libepoll-shim: update to 0.0.20230411.

Changes not documented, 2 years of git commits.

Revision 1.3 / (download) - annotate - [select for diffs], Thu Aug 4 14:41:40 2022 UTC (20 months, 2 weeks ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (unified)

libepoll-shim: Fix handling of .pc file - this isn't FreeBSD, so don't
install it to libdata, but rather the standard location for pkgsrc.
Also use PKGCONFIG_OVERRIDE to ensure that the proper RPATH is added.

While here, delint.

Revision 1.2 / (download) - annotate - [select for diffs], Tue Sep 21 14:44:49 2021 UTC (2 years, 6 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3
Changes since 1.1: +3 -3 lines
Diff to previous 1.1 (unified)

libepoll-shim: Support NetBSD with eventfd(2)/timerfd(2)

* Simplify logics in Makefile.
* Exclude eventfd.h for NetBSD with eventfd(2).
* Exclude timerfd.h for NetBSD with timerfd(2).

Revision 1.1 / (download) - annotate - [select for diffs], Mon May 3 17:17:17 2021 UTC (2 years, 11 months ago) by jdolecek
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2

add libepoll-shim 0.0.20210418 small library that implements epoll with kqueue

will be used for net/xfreerdp2

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>