[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / knotifyconfig

File: [cvs.NetBSD.org] / pkgsrc / devel / knotifyconfig / Makefile (download)

Revision 1.29, Mon Nov 11 07:57:10 2019 UTC (4 years, 4 months ago) by markd
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.28: +1 -2 lines

KDE Frameworks update to 5.64.0

5.62.0

KI18n
  Localize long number strings
  Support passing target to ki18n_wrap_ui macro

KIO
  Undoing trashing files on the desktop has been fixed
  kio_trash: split up copyOrMove, for a better error than "should never happen"
  FileUndoManager: clearer assert when forgetting to record
  Fix exit and crash in kio_file when put() fails in readData
  [CopyJob] Fix crash when copying an already existing dir and pressing "Skip"
  [KUrlNavigator] Add MIME types supported by krarc to isCompressedPath
  Added dialog to set execute permission for executable file when trying to
  run it
  [KPropertiesDialog] Always check mount point being null
  [KRun] Check mime type for isExecutableFile first
  Add an icon for the trash root and a proper label
  Add support for handling QNAM SSL errors to KSslErrorUiData
  Making FileJob behave consistently
  [KFilePlacesView] Use asynchronous KIO::FileSystemFreeSpaceJob
  rename internal 'kioslave' helper executable to 'kioslave5'
  [KDirOperator] Middle-elide labels that are too long to fit
  [KDirOperator] Add follow new directories options
  KDirOperator: Only enable "Create New" menu if the selected item is a
  directory
  KIO FTP: Fix file copy hanging when copying to existing file
  KIO: port to non-deprecated KWindowSystem::setMainWindow
  Make file bookmark names consistent
  Add option to build Qt Designer plugin (BUILD_DESIGNERPLUGIN, default ON)
  [KDirOperator] Use more human-readable sort order descriptions
  [Permissions editor] Port icons to use QIcon::fromTheme()

KItemModels
  Add Q_PROPERTIES interface to KDescendantsProxyModel
  Port away from deprecated methods in Qt

KNotification
  Avoid duplicate notifications from showing up on Windows and remove
  whitespaces
  Have 1024x1024 app icon as fallback icon in Snore
  Add `-pid` parameter to Snore backend calls
  Add snoretoast backend for KNotifications on Windows

KPeople
  Make it possible to delete contacts from backends
  Make it possible to modify contacts

KRunner
  Make sure we're checking whether tearing down is due after finishing a job
  Add a done signal to FindMatchesJob instead of using QObjectDecorator wrongly

KTextEditor
  Allow to customize attributes for KSyntaxHighligting themes
  Fix for all themes: allow turn off attributes in XML highlighting files
  simplify isAcceptableInput + allow all stuff for input methods
  simplify typeChars, no need for return code without filtering
  Mimic QInputControl::isAcceptableInput() when filtering typed characters
  try to sanitize line endings on paste
  Fix: allow turn off attributes in XML highlighting files
  improve word completion to use highlighting to detect word boundaries
  More porting from QRegExp to QRegularExpression
  properly check if diff command can be started for swap file diffing
  KTextEditor: Fix left border flicker when switching between documents
  Migrate some more QRegExps to QRegularExpression
  Allow 0 in line ranges in vim mode
  Use CMake find_dependency instead of find_package in CMake config file
  template

KWayland
  [server] Wrap proxyRemoveSurface in smart pointer
  [server] Use cached current mode more and assert validness
  [server] Cache current mode
  Implement zwp_linux_dmabuf_v1

5.63.0

KIO
  [Places panel] Revamp the Recently Saved section
  [DataProtocol] compile without implicit coversion from ascii
  Consider the usage of WebDAV methods sufficient for assuming WebDAV
  REPORT also supports the Depth header
  Make QSslError::SslError <-> KSslError::Error conversion reusable
  Deprecate the KSslError::Error ctor of KSslError
  [Windows] fix listing the parent dir of C:\foo, that's C:\ and not C:
  Fix crash on exit in kio_file (bug 408797)
  Add == and != operators to KIO::UDSEntry
  Replace KSslError::errorString with QSslError::errorString
  Move/copy job: skip stat'ing sources if the destination dir isn't writable
  Fixed interaction with DOS/Windows executables in KRun::runUrl
  [KUrlNavigatorPlacesSelector] Properly identify teardown action
  KCoreDirLister: fix crash when creating new folders from kfilewidget
  [kpropertiesdialog] add icons for the size section
  Add icons for "Open With" and "Actions" menus
  Avoid initializing an unnecessary variable
  Move more functionality from KRun::runCommand/runApplication to
  KProcessRunner
  [Advanced Permissions] Fix icon names
  [KUrlNavigatorButton] Fix QString usage to not use [] out of bounds
  Make KSslError hold a QSslError internally
  Split KSslErrorUiData from KTcpSocket
  Port kpac from QtScript

KPeople
  Claim Android as a supported platform
  Deploy default avatar via qrc
  Bundle plugin files on Android
  Disable DBus pieces on Android
  Fix crash when monitoring a contact that gets removed on PersonData
  Use fully qualified types on signals

KRunner
  Consider UNC paths as NetworkShare context

KService
  Move Amusement to Games directory instead of Games > Toys
  [KService] Add copy constructor
  [KService] add workingDirectory(), deprecate path()

KTextEditor
  try to avoid artifacts in text preview
  Variable expansion: Use std::function internally
  QRectF instead of QRect solves clipping issues
  next rendering artifact goes away if you adjust the clip rect a bit
  avoid the font choosing magic and turn of anti aliasing
  KadeModeMenuList: fix memory leaks and others
  try to scan for usable fonts, works reasonable well if you use no dumb
  scaling factor like 1.1
  Status bar mode menu: Reuse empty QIcon that is implicitly shared
  Expose KTextEditor::MainWindow::showPluginConfigPage()
  Replace QSignalMapper with lambda
  KateModeMenuList: use QString() for empty strings
  KateModeMenuList: add "Best Search Matches" section and fixes for Windows
  Variable expansion: Support QTextEdits
  Add keyboard shortcut for switching Input modes to edit menu
  Variable expansion dialog: properly handle selection changes and item
  activation
  Variable expansion dialog: add filter line edit
  Backup on save: Support time and date string replacements
  Variable expansion: Prefer return value over return argument
  Initial start of variables dialog
  use new format API

KWayland
  Sort files alphabetically in cmake list

5.64.0

KI18n
  Add KLocalizedString::untranslatedText
  Replace all qWarning and related calls with categorised logging

KIO
  Const & signature of new introduced SlaveBase::configValue
  Port to the QSslError variant of KSslInfoDialog
  Port KSSLD internals from KSslError to QSslError
  Make non-ignorable SSL errors explicit
  auto-enable KIO_ASSERT_SLAVE_STATES also for from-git builds
  Port (most of) KSslInfoDialog from KSslError to QSslError
  kio_http: avoid double Content-Type and Depth when used by KDAV
  Port the KSSLD D-Bus interface from KSslError to QSslError
  Replace usage of SlaveBase::config()->readEntry by SlaveBase::configValue
  Remove two unused member variables using KSslError
  Avoid sending KDirNotify::emitFilesAdded when the emptytrashjob finishes
  Deprecate the KTcpSocket-based variant of SslUi::askIgnoreSslErrors
  Treat "application/x-ms-dos-executable" as executable on all platforms
  Replace usage of SlaveBase::config() by SlaveBase::mapConfig()
  ftptest: replace logger-colors with logger
  [SlaveBase] Use QMap instead of KConfig to store ioslave config
  Port KSslErrorUiData to QSslError
  exclude ioslaves directory from api docs
  ftptest: mark overwrite without overwrite flag no longer failing
  ftptest: refactor the daemon startup into its own helper function
  [SslUi] Add api docs for askIgnoreSslErrors()
  consider ftpd not required for the time being
  port ftp slave to new error reporting system
  fix proxy setting loading
  Implement KSslCertificateRule with QSslError instead of KSslError
  Port (most of) the interface of KSslCertificateRule to QSslError
  Port KSslCertificateManager to QSslError
  Update test kfileplacesviewtest following D7446

KNotification
  [KStatusNotifierItem] Allow left click when menu is null
  Remove Growl support
  Add and enable Notification Center support in macOS

KPeople
  Unbreak build: limit DISABLE_DEPRECATED for KService to < 5.0

KService
  Make it compile against qt5.15 without deprecated method

KTextEditor
  KateModeMenuList: improve word wrap
  add hint to copyright header
  clarify license
  add missing s
  KateModeMenuList: force the vertical position above the button
  better: self-contained headers
  group includes for semantics
  sort includes

KWayland
  FakeInput: add support for keyboard key press and release
  Fix non-integer scale copy on creation of OutputChangeSet

ThreadWeaver
  Make it compile against qt5.15

# $NetBSD: Makefile,v 1.29 2019/11/11 07:57:10 markd Exp $

DISTNAME=	knotifyconfig-${KF5VER}
CATEGORIES=	devel

HOMEPAGE=	https://community.kde.org/Frameworks
COMMENT=	Configuration system for KNotify
LICENSE=	gnu-lgpl-v2.1

.include "../../meta-pkgs/kde/kf5.mk"

USE_TOOLS+=	msgmerge

.include "../../devel/kio/buildlink3.mk"
.include "../../x11/qt5-qtbase/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"