File:  [cvs.NetBSD.org] / pkgsrc / devel / kdiff3 / Makefile
Revision 1.113: download - view: text, annotated - select for diffs
Thu Jan 23 23:27:25 2025 UTC (8 weeks ago) by riastradh
Branches: MAIN
CVS tags: HEAD
devel/extra-cmake-modules: Use buildlink3.mk, not TOOL_DEPENDS.

This one is borderline: should it be BUILD_DEPENDS or TOOL_DEPENDS?
It doesn't appear to vary depending on the build environment, so it
doesn't meaningfully describe the cross-builder vs the target system.
It is used only at build-time, but it doesn't have any native
executables -- they're just source code cmake scripts.

For now, it is convenient to use a buildlink3.mk file because this
enables us to explicitly expose only files under share/ECM/ -- and
not other random files installed in the prefix -- via buildlink3 to
keep dependent package builds clean.  Eventually we should have the
same mechanism for TOOL_DEPENDS but that day has not yet come.

This change creates a new use of BUILDLINK_DEPMETHOD build for
extra-cmake-modules, which is a priori risky.  Fortunately,
extra-cmake-modules has no libraries, so this is unlikely to cause
trouble.

# $NetBSD: Makefile,v 1.113 2025/01/23 23:27:25 riastradh Exp $

DISTNAME=	kdiff3-1.10.7
PKGREVISION=	7
CATEGORIES=	devel
MASTER_SITES=	${MASTER_SITE_KDE:=kdiff3/}
EXTRACT_SUFX=	.tar.xz

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://kde.org/applications/development/org.kde.kdiff3
COMMENT=	File and directory diff and merge tool
LICENSE=	gnu-gpl-v2

USE_CMAKE=	yes
USE_LANGUAGES=	c c++

# Upstream states GCC < 8.2 support is "best effort only"; it is presently
# confirmed to work without issue on NetBSD 9.x with GCC 7.5.
USE_CXX_FEATURES+=	c++17

BUILDLINK_TRANSFORM+=	rm:-Wl,--fatal-warnings

TOOLS_DEPENDS.cmake=	cmake>=3.1:../../devel/cmake

.include "../../devel/boost-headers/buildlink3.mk"
BUILDLINK_API_DEPENDS.extra-cmake-modules+=	extra-cmake-modules>=5.10.0
.include "../../devel/extra-cmake-modules/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
BUILDLINK_API_DEPENDS.kcoreaddons+=	kcoreaddons>=5.80.0
.include "../../devel/kcoreaddons/buildlink3.mk"
.include "../../devel/kcrash/buildlink3.mk"
.include "../../devel/kdoctools/buildlink3.mk"
BUILDLINK_API_DEPENDS.ki18n+=	ki18n>=5.80.0
.include "../../devel/ki18n/buildlink3.mk"
.include "../../devel/kio/buildlink3.mk"
.include "../../devel/kparts/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../graphics/kiconthemes/buildlink3.mk"
.include "../../x11/kwidgetsaddons/buildlink3.mk"
.include "../../x11/qt5-qtbase/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>