[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / kcoreaddons

File: [cvs.NetBSD.org] / pkgsrc / devel / kcoreaddons / Makefile (download)

Revision 1.30, Thu Apr 25 20:50:23 2019 UTC (4 years, 11 months ago) by markd
Branch: MAIN
Changes since 1.29: +0 -1 lines

kde: update KDE Frameworks to 5.57.0

KDE Doxygen Tools

  Update URLs to use https

KCMUtils

  [KCModuleLoader] Pass args to created KQuickAddons::ConfigModule
  Pass focus to child searchbar when KPluginSelector is focused
  Improve the KCM error message
  Add runtime guard that pages are KCMs in KCMultiDialog

KConfig

  Add Notify capability to revertToDefault
  point readme to the wiki page
  kconfig_compiler: new kcfgc args HeaderExtension & SourceExtension
  [kconf_update] move from custom logging tech to qCDebug
  Remove reference from const KConfigIniBackend::BufferFragment &
  KCONFIG_ADD_KCFG_FILES macro: ensure a change of File= in kcfg is picked up

KCoreAddons

  Fix "* foo *" we don't want to bold this string
  Fix Bug - clicking contact web url => uncomplete url is selected
  Print strerror when inotify fails (typical reason: "too many open files")

KDeclarative

  [GridViewKCM] Fix implicit width calculation
  move the gridview in a separate file
  Avoid fractionals in GridDelegate sizes and alignments

KDocTools

  Update Ukrainian translation
  Catalan updates
  it entities: update URLs to use https
  Update URLs to use https
  Use Indonesian translation
  Update design to look more similar to kde.org
  Add necessary files to use native Indonesian language for all Indonesian docs

KI18n

  Report human-readable error if Qt5Widgets is required but is not found

KIO

  Replace currentDateTimeUtc().toTime_t() with currentSecsSinceEpoch()
  Replace QDateTime::to_Time_t/from_Time_t with to/fromSecsSinceEpoch
  Improve executable dialog buttons' icons
  [KDirOperator] Show Detailed Tree View by default
  KFileItem: call stat() on demand, add SkipMimeTypeDetermination option
  KIOExec: fix error when the remote URL has no filename
  KFileWidget In saving single file mode an enter/return press on the
  KDirOperator triggers slotOk
  [KDynamicJobTracker] Use generated DBus interface
  [KFileWidget] When saving, highlight filename after clicking existing file
  also when using double-click
  Don't create thumbnails for encrypted Vaults
  Fix WebDAV directory renaming if KeepAlive is off
  Show list of tags in PlacesView
  Delete/Trash confirmation dialogue: Fix misleading title
  Display the correct file/path in "too bit for fat32" error message
  Phrase error message with GiB, not GB
  openwithdialog: use recursive flag in proxy filter
  Remove URLs being fetched when listing job is completed
  [CopyJob] Treat URL as dirty when renaming file as conflict resolution
  Pass local file path to KFileSystemType::fileSystemType()
  Fix upper/lower case rename on case insensitive fs
  Fix "Invalid URL: QUrl("some.txt")" warnings in Save dialog
  Fix crash while moving files
  Fix NTFS hidden check for symlinks to NTFS mountpoints
  Make file overwrite a bit safer

KNotification

  [KStatusNotifierItem] Send desktop-entry hint
  Allow to set custom hints for notifications

KNotifyConfig

  Allow selecting only supported audio files

KPackage Framework

  Fix finding the host tools targets file in the Android docker environment
  Add cross-compilation support for kpackagetool5

KService

  Add X-GNOME-UsesNotifications as recognized key
  Add bison minimum version of 2.4.1 due to %code

KTextEditor

  Fix: apply correctly the text colors of the chosen scheme
  DocumentPrivate: Add option "Auto Reload Document" to View menu
  DocumentPrivate: Support to set dictionary on block selection
  Fix Words & Chars String on katestatusbar
  Fix Minimap with QtCurve style
  KateStatusBar: Show lock icon on modified label when in read-only mode
  DocumentPrivate: Skip auto quotes when these looks already balanced
  Add Variable interface to KTextEditor::Editor
  relax code to only assert in debug build, work in release build
  ensure compatibility with old configs
  more use of generic config interface
  simplify QString KateDocumentConfig::eolString()
  transfer sonnet setting to KTextEditor setting
  ensure now gaps in config keys
  convert more things to generic config interface
  more use of the generic config interface
  generic config interface
  Don't crash on malformed syntax highlighting files
  IconBorder: Accept drag&drop events
  ViewPrivate: Make deselection by arrow keys more handy
  Fix for showing argument hint tree on non-primary screen
  Port some deprecated method
  Restore the search wrapped message to its former type and position
  ViewPrivate: Make 'Apply Word Wrap' more comfortable
  ModeBase::goToPos: Ensure jump target is valid
  ViInputMode: Remove unsupported text attributes from the status bar
  KateStatusBar: Add dictionary button
  add example for line heigh issue

# $NetBSD: Makefile,v 1.30 2019/04/25 20:50:23 markd Exp $

DISTNAME=	kcoreaddons-${KF5VER}
CATEGORIES=	devel

HOMEPAGE=	https://community.kde.org/Frameworks
COMMENT=	Addons to QtCore
LICENSE=	gnu-lgpl-v2 AND gnu-lgpl-v2.1 AND modified-bsd

.include "../../meta-pkgs/kde/kf5.mk"

.if ${OPSYS} != "SunOS"
.include "../../devel/libinotify/buildlink3.mk"
.endif

.include "../../databases/shared-mime-info/buildlink3.mk"
.include "../../mk/fam.buildlink3.mk"
.include "../../x11/qt5-qtbase/buildlink3.mk"
BUILDLINK_DEPMETHOD.qt5-qttools= build
.include "../../x11/qt5-qttools/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"