The NetBSD Project

CVS log for pkgsrc/devel/kbookmarks/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / kbookmarks

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2016Q3


Revision 1.2 / (download) - annotate - [select for diffs], Sun Aug 21 21:17:57 2016 UTC (7 years, 7 months ago) by markd
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.1: +5 -5 lines
Diff to previous 1.1 (colored)

Update KDE Frameworks to 5.25.0

5.22:
KCoreAddons
* Provide a way to disable inotify use in KDirWatch
* Fix KAboutData::applicationData() to init from current
  Q*Application metadata
* Make clear that KRandom is not recommended for cryptography purposes
KDeclarative
* Don't crash if we have no openGL context
KDocTools
* Added entity applications
KI18n
* libgettext: Fix potential use-after-free using non-g++ compilers
KIO
* kurlnavigatortoolbutton.cpp - use buttonWidth in paintEvent()
* New file menu: filter out duplicates (e.g. between .qrc and system files)
* Fix error message on startup of the cookies KCM
* Remove kmailservice5, it can only do harm at this point
* Fix KFileItem::refresh() for symlinks. The wrong size, filetype
  and permissions were being set
* Fix regression in KFileItem: refresh() would lose the file type,
  so a dir became a file
* Set text on QCheckbox widget rather than using a separate label
* Don't enable acl permissions widget if we don't own the file
* Fix double-slash in KUriFilter results when a name filter is set
* KUrlRequester: add signal textEdited (forwarded from QLineEdit)
KItemModels
* Fix template syntax for test case generation
* Fix linking with Qt 5.4 (wrongly placed #endif)
KParts
* Fix the layout of the BrowserOpenOrSaveQuestion dialogue
KPeople
* Add a check for PersonData being valid
KRunner
* Fix metainfo.yaml: KRunner is neither a porting aid nor deprecated
KService
* Remove too-strict maximum string length in KSycoca database
KTextEditor
* Use proper char syntax '"' instead of '\"'
* doxygen.xml: Use default style dsAnnotation for "Custom Tags" as
  well (less hard-coded colors)
* Add option to show the counter of words
* Improved foreground color contrast for search & replace highlightings
* Fix crash when closing Kate through dbus while the print dialog is open
* Cursor::isValid(): add note about isValidTextPosition()
* Add API {Cursor, Range}::{toString, static fromString}

5.23:
KDE Doxygen Tools
* Major rework of the API docs generation
KCMUtils
* Use QQuickWidget for QML KCMs
KConfig
* Avoid skipping KAuthorized check
KCoreAddons
* Print the failing plugin when notifying a cast warning
* [kshareddatacache] Fix invalid use of & to avoid unaligned reads
* Kdelibs4ConfigMigrator: skip reparsing if nothing was migrated
* krandom: Add testcase to catch bug 362161 (failure to auto-seed)
KCrash
* Check size of unix domain socket path before copying to it
KDeclarative
* Support selected state
* KCMShell import can now be used to query for whether opening a KCM
  is actually allowed
KDocTools
* Add commonly used entities for keys to en/user.entities
* Update man-docbook template
* Update book template + man template + add arcticle template
* Call kdoctools_create_handbook only for index.docbook
KIO
* Give clearer error message when KRun(URL) is given a URL without
  scheme
* Add KProtocolInfo::archiveMimetypes()
* use selected icon mode in file open dialog sidebar
* kshorturifilter: fix regression with mailto: not prepended when
* no mailer is installed
KNotification
* use QUrl::fromUserInput to construct sound url
KNotifyConfig
* use QUrl::fromUserInput to construct sound url
KService
* Fix associated applications for mimetypes with uppercase characters
* Lowercase the lookup key for mimetypes, to make it case insensitive
* Fix ksycoca notifications when the DB doesn't exist yet
KTextEditor
* Fix default encoding to UTF-8
* Fix color configurability of default style "Error"
* Search & Replace: Fix replace background color (regression introduced
  in v5.22)
* New color scheme "Breeze Dark", see https://kate-editor.org/?post=3745
* KateUndoManager::setUndoRedoCursorOfLastGroup(): pass Cursor as const
  reference
* sql-postgresql.xml improve syntax highlighting by ignoring multiline
  function bodies
* Add syntax highlighting for Elixir and Kotlin
* VHDL syntax highlighting in ktexteditor: add support for functions
  inside architecture statements
* vimode: Don't crash when given a range for a nonexistent command
* Properly remove composed characters when using Indic locales

5.24:
KBookmarks
* Cleanup KBookmarkManagerList before qApp exits, to avoid deadlocks
  with the DBus thread
KConfig
* Deprecate authorizeKAction() in favor of authorizeAction()
* Fix reproducibility in builds by ensuring utf-8 encoding
KDeclarative
* Make epoxy optional
KDocTools
* Allow KDocTools to always locate at least its own installed stuff
* Use CMAKE_INSTALL_DATAROOTDIR to look for docbook instead of share
* Update qt5options manpage docbook to qt 5.4
* Update kf5options manpage docbook
KI18n
* Also search catalogs for stripped variants of values in env var LANGUAGE
* Fix parsing of env var values WRT modifier and codeset, done in wrong order
KIO
* KIO: add SlaveBase::openPasswordDialogV2 for better error checking,
  please port your kioslaves to it
* Fix KUrlRequester opening file dialog in wrong directory
* Fix unsafe KDirModelDirNode* casts
* Add cmake option KIO_FORK_SLAVES to set default value
* ShortUri filter: fix filtering of mailto:user@host
* Add OpenFileManagerWindowJob to highlight file within a folder
* KRun: add runApplication method
* Add soundcloud search provider
* Fix an alignment issue with the OS X native "macintosh" style
KItemModels
* Add KExtraColumnsProxyModel::removeExtraColumn, will be needed
  by StatisticsProxyModel
KNotifyConfig
* KNotifyConfigWidget: add disableAllSounds() method
KParts
* Add switch to disable KParts' handling of window titles
* Add donate menu item to help menu of our apps
KRunner
* [QueryMatch] Add iconName
KTextEditor
* Show Scrollbar Text Preview after a delay of 250ms
* hide preview and stuff on view content scrolling
* set parent + toolview, I think this is needed to avoid task switcher
  entry in Win10
* Remove "KDE-Standard" from encoding box
* Folding preview on per default
* Avoid dashed underline for preview & avoid poisoning of line layout cache
* Always enable "Show preview of folded text" option
* TextPreview: Adjust the grooveRect-height when scrollPastEnd is enabled
* Scrollbar preview: use groove rect if scrollbar does not use full height
* Add KTE::MovingRange::numberOfLines() just like KTE::Range has
* Code folding preview: set popup height so that all hidden lines fit
* Add option to disable preview of folded text
* Add modeline 'folding-preview' of type bool
* View ConfigInterface: support 'folding-preview' of type bool
* Add bool KateViewConfig::foldingPreview() and setFoldingPreview(bool)
* Feature: Show text preview when hovering over folded code block
* KateTextPreview: add setShowFoldedLines() and showFoldedLines()
* Add modelines 'scrollbar-minimap' [bool], and 'scrollbar-preview' [bool]
* Enable mini-map scrollbar by default
* New feature: Show text preview when hovering over the scrollbar
* KateUndoGroup::editEnd(): pass KTE::Range by const ref
* Fix vim-mode shortcut handling, after behaviour changes in Qt 5.5
* Autobrace: don't insert ' character in text
* ConfigInterface: add scrollbar-minimap config key to enable/disable
  scrollbar mini map
* Fix KTE::View::cursorToCoordinate() when top message widget is visible
* Refactoring of the Emulated Command Bar
* Fix drawing artifacts when scrolling while notifications are visible

5.25:
KBookmarks
* KBookmarkGroup::moveBookmark: fix return value when item is
  already at the right position
KConfig
* Add DeleteFile and RenameFile standard shortcut
KCoreAddons
* Install known licenses and find them at runtime (regression fix)
KDeclarative
* Actually emit valueChanged
KIO
* Fix KIO::linkAs() to work as advertised, i.e. fail if dest already
  exists
* Fix KIO::put("file:///path") to respect the umask
* Fix KIO::pasteActionText for null dest item and for empty URL
* Add support for undoing symlink creation
* GUI option to configure global MarkPartial for KIO slaves
* Fix MaxCacheSize limited to 99 KiB
* Add clipboard buttons to checksums tab
* KNewFileMenu: fix copying template file from embedded resource
* KNewFileMenu: Fix creating link to application
* KNewFileMenu: Fix suggestion of new filename when file already
  exist in desktop
* KNewFileMenu: ensure fileCreated() is emitted for app desktop files too
* KNewFileMenu: fix creating symlinks with a relative target
* KPropertiesDialog: simplify button box usage, fix behavior on Esc
* KProtocolInfo: refill cache to find newly installed protocols
* KIO::CopyJob: port to qCDebug (with its own area, since this can
  be quite verbose)
* KPropertiesDialog: add Checksums tab
* Clean url's path before initializing KUrlNavigator
KItemModels
* KRearrangeColumnsProxyModel: fix assert in index(0, 0) on empty model
* Fix KDescendantsProxyModel::setSourceModel() not clearing internal
  caches
* KRecursiveFilterProxyModel: fix QSFPM corruption due to filtering
  out rowsRemoved signal
* KExtraColumnsProxyModel: implement hasChildren()
KNotification
* Don't set parent of sublayout manually, silences warning
KService
* applications.menu: remove references to unused categories
* Always update the Trader parser from yacc/lex sources
KTextEditor
* Do not ask for overwriting a file twice with native dialogs
* added FASTQ syntax

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>