File:  [cvs.NetBSD.org] / pkgsrc / devel / java-subversion / Makefile
Revision 1.76: download - view: text, annotated - select for diffs
Tue Dec 31 17:33:16 2024 UTC (2 months, 3 weeks ago) by adam
Branches: MAIN
CVS tags: HEAD
subversion: updated to 1.14.5

Apache Subversion 1.14.5. This is a stable bugfix and security release of the
Apache Subversion open source version control system. Among regular bug fixes,
this release fixes CVE-2024-46901: mod_dav_svn denial-of-service via control
characters in paths It has been discovered that the patch for CVE-2013-1968
was incomplete and unintentionally left mod_dav_svn vulnerable to control
characters in filenames. If a path or a revision-property which contains
control characters is committed to a repository then SVN operations served by
mod_dav_svn can be disrupted.

# $NetBSD: Makefile,v 1.76 2024/12/31 17:33:16 adam Exp $

PKGNAME=	java-subversion-${SVNVER}
COMMENT=	Java bindings for Subversion

MAKE_JOBS_SAFE=	no

.include "../../devel/subversion/Makefile.common"

SHLIBTOOL_OVERRIDE=	# empty

USE_TOOLS+=		gmake perl
USE_LANGUAGES+=		c c++
USE_JAVA2=		yes
# We might need PKG_JVM_DEFAULT/PKG_JVMS_ACCEPTED; I'm not much for Java...

CONFIGURE_ARGS+=	--enable-javahl --with-jdk=${PKG_JAVA_HOME}
# To run the tests, uncomment this line if you have junit installed in
# jre/lib/ext .  TODO: If someone packages junit, use that.
#CONFIGURE_ARGS+=	--with-junit

BUILD_TARGET=		javahl
INSTALL_TARGET=		install-javahl
TEST_TARGET=		check-javahl

post-patch:
	${RM} ${WRKSRC}/build-outputs.mk
	${CP} ${FILESDIR}/build-outputs.mk ${WRKSRC}/build-outputs.mk

.include "../../devel/subversion-base/buildlink3.mk"
.include "../../mk/java-vm.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>