The NetBSD Project

CVS log for pkgsrc/devel/java-jna/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / java-jna

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.18: download - view: text, markup, annotated - select for diffs
Mon Dec 2 16:52:51 2024 UTC (3 months, 2 weeks ago) by abs
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, HEAD
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +2 -2 lines
Fix _ULIMIT_CMD -> _ULIMIT_CMD:Q

Note to self: *Always* rebuild after fixing final pkglint

Revision 1.17: download - view: text, markup, annotated - select for diffs
Mon Dec 2 13:44:42 2024 UTC (3 months, 2 weeks ago) by abs
Branches: MAIN
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +9 -15 lines
Switch to dynamic PLIST generation

Comment added to Makefile:

Generated support files in ${PREFIX}/doc vary based on the version of java
used to build, each of 8, 11, 17 and 21 have significant differences. The
documentation is the same, but not the jquery, frame layout and similar files

Approved by nonakap@gmail.com

Revision 1.16: download - view: text, markup, annotated - select for diffs
Thu Nov 28 19:53:23 2024 UTC (3 months, 3 weeks ago) by ryoon
Branches: MAIN
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +2 -3 lines
devel/java-jna: Update to 5.15.0

Changelog:
Release 5.15.0
Features

    #1578: Add support for FreeBSD aarch64 - @alexdupre.
    #1593: Add support for DragonFly BSD x86-64 - @liweitianux.
    #1595: Add IsProcessorFeaturePresent to c.s.j.p.win32.Kernel32 - @dbwiddis.
    #1602: Add XMoveWindow, XResizeWindow, XMoveResizeWindow, XRaiseWindow, XLowerWindow X11 calls to c.s.j.p.unix.X11 - @vinceh121.
    #1613: Added static helper method `Native#getNativeLibrary' for getting the underlying NativeLibrary instance from a Library interface instance or from a "registered" class - @matthiasblaesing.
    #1624: Enable linker build-id for android builds - @mstyura.

Bug Fixes

    #1579: Fix analysis of ELF binary on arm systems running with a java ELF binary without section table headers (java8 on armv7 NAS) - @matthiasblaesing.
    #1586: Fix free_callback JNI weak reference leak - @xiezhaokun.
    6486c90d913a413f247eef84742ce3c474738933: Check CallbackReference#cbstruct for null when checking existing Reference - @matthiasblaesing.
    #1622: Add "linux-riscv64" entry to OSGI Bundle-NativeCode header in MANIFEST.MF - @matthiasblaesing.


Release 5.14.0
Features

    #1556: Add SetJob, SetPrinter to c.s.j.p.w.Winspool - @tresf.
    #1534: Add GetMethod, Put, SpawnInstance to c.s.j.p.win32.COM.WbemCli#IWbemClassObject and ExecMethod to c.s.j.p.win32.COM.WbemCli#IWbemServices - @faddom.
    #1544: Add GetPriorityClass, SetPriorityClass, GetThreadPriority, SetThreadPriority and associated constants to c.s.j.p.win32.Kernel32 - @dEajL3kA.
    #1548: Make interface c.s.j.p.mac.XAttr public - @matthiasblaesing.
    #1551: Add c.s.j.p.bsd.ExtAttr and c.s.j.p.bsd.ExtAttrUtil to wrap BSD <sys/extattr.h> system calls. @rednoah.
    #1517: Add missing O_* (e.g. O_APPEND, O_SYNC, O_DIRECT, ...) to c.s.j.p.linux.Fcntl - @matthiasblaesing.
    #1521: Shutdown CleanerThread once the last cleanable is removed - @matthiasblaesing.
    #1557: Build linux-riscv64 on Ubuntu focal to improve compatibility with older glibc versions - @matthiasblaesing.

Bug Fixes

    #1501: Library.OPTION_STRING_ENCODING is ignore for string arguments function calls - @matthiasblaesing.
    #1504: Increase maximum supported fixed args on varargs calls from 3 to 255 - @andrew-nowak.
    #1545: Fix Java 6 incompatibility in c.s.j.p.win32.Kerne32Util and c.s.j.p.win32.DBT - @matthiasblaesing.

Important Changes

    The interfaces between Java and native code have changed, so libjnidispatch must be rebuilt to be compatible with this release.
    Release drops support for JDKs 6 + 7, so you'll need at least JDK 8 to update to use this version.

Revision 1.15: download - view: text, markup, annotated - select for diffs
Tue Jan 16 03:57:05 2024 UTC (14 months, 1 week ago) by ryoon
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +5 -5 lines
java-jna: Support JDK 21

Revision 1.14: download - view: text, markup, annotated - select for diffs
Tue Jul 18 12:23:48 2023 UTC (20 months ago) by abs
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +2 -2 lines
Update PLIST.java17-javadoc for openjdk17-1.17.0.7.7

This means java-jna will not fail to package for earlier
versions of openjd17, but better to work with what is in the matching tree

Revision 1.13: download - view: text, markup, annotated - select for diffs
Tue Jun 6 12:40:38 2023 UTC (21 months, 2 weeks ago) by riastradh
Branches: MAIN
CVS tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -2 lines
Mass-change BUILD_DEPENDS to TOOL_DEPENDS outside mk/.

Almost all uses, if not all of them, are wrong, according to the
semantics of BUILD_DEPENDS (packages built for target available for
use _by_ tools at build-time) and TOOL_DEPEPNDS (packages built for
host available for use _as_ tools at build-time).

No change to BUILD_DEPENDS as used correctly inside buildlink3.

As proposed on tech-pkg:
https://mail-index.netbsd.org/tech-pkg/2023/06/03/msg027632.html

Revision 1.12: download - view: text, markup, annotated - select for diffs
Thu Mar 2 01:13:38 2023 UTC (2 years ago) by abs
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +8 -6 lines
Support openjdk17 for java-jna

Also fixup PLIST for java8 and java11
Bump PKGREVISION

Revision 1.11: download - view: text, markup, annotated - select for diffs
Sun Feb 19 00:22:58 2023 UTC (2 years, 1 month ago) by abs
Branches: MAIN
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +4 -5 lines
Updated devel/java-jna to 5.13.0

Release (5.13.0)
Features

    #1454: Add c.s.j.p.win32.Psapi.QueryWorkingSetEx and associated Types - @crain-32.
    #1459: Add VirtualLock and VirtualUnlock in c.s.j.p.win32.Kernel32 - @matthiasblaesing.
    #1471: Add c.s.j.p.win32.Advapi32Util#isCurrentProcessElevated and associated Types - @dbwiddis.
    #1474: Add c.s.j.p.win32.WbemCli#IWbemClassObject.IWbemQualifierSet, IWbemServices.GetObject, IWbemContext.SetValue and associated methods - @rchateauneu.
    #1482: Add multilingual support of Kernel32Util.formatMessage - @overpathz.
    #1490: Adds support for a custom SymbolProvider in NativeLibrary & Library - @soywiz.
    #1491: Update libffi to v3.4.4 - @matthiasblaesing.
    #1487: Add 'uses' information to OSGI metadata in MANIFEST.MF to improve stability of package resolution - @sratz.

Bug Fixes

    #1452: Fix memory allocation/handling for error message generation in native library code (dispatch.c) - @matthiasblaesing.
    #1460: Fix win32 variant date conversion in DST offest window and with millisecond values - @eranl.
    #1472: Fix incorrect bitmask in c.s.j.Pointer#createConstant(int) - @dbwiddis.
    #1481: Fix NPE in NativeLibrary when unpacking from classpath is disabled - @trespasserw.
    #1489: Fixes typo in OpenGL32Util#wglGetProcAddress, instead of parameter procName the hardcoded value wglEnumGpusNV was used - @soywiz.

Release 5.12.1
Bug Fixes

    #1447: Null-check cleanable in c.s.j.Memory#close - @dbwiddis.

Release 5.12.0
Features

    #1433: Add CFEqual, CFDictionaryRef.ByReference, CFStringRef.ByReference to c.s.j.p.mac.CoreFoundation - @shalupov
    #978: Remove use of finalizers in JNA and improve concurrency for Memory, CallbackReference and NativeLibrary - @matthiasblaesing.
    #1440: Support for LoongArch64 - @Panxuefeng-loongson.
    #1444: Update embedded libffi to 1f14b3fa92d4442a60233e9596ddec428a985e3c and rebuild native libraries - @matthiasblaesing.

Bug Fixes

    #1438: Handle arrays in structures with differing size - @matthiasblaesing.
    #1442: Handle race condition in c.s.j.p.win32.PdhUtil#PdhEnumObjectItems - @dbwiddis.

Important Changes

    Memory#dispose, CallbackReference#dispose and NativeLibrary#dispose were called by the Object#finalize override. These calls were replaced by the use of a cleaner. It is not guaranteed anymore, that dispose is called on subclasses on finalization.

Release 5.11.0
Features

    #1398: Increase c.s.j.p.win32.Sspi#MAX_TOKEN_SIZE on Windows 8/Server 2012 and later - @dbwiddis.
    #1403: Rebuild AIX binaries with libffi 3.4.2 (other architectures were part of 5.10) - @matthiasblaesing.
    #1404: Added Solaris Kstat2 library - @dbwiddis.
    #1416: Add CFDictionaryGetCount to c.s.j.p.mac.CoreFoundation - @shalupov
    #1418: Add CertOpenStore to c.s.j.p.win32.Crypt32 - @shalupov

Bug Fixes

    #1411: Do not throw Win32Exception on success for empty section in Kernel32Util#getPrivateProfileSection - @mkarg.
    #1414: Fix definition of c.s.j.p.unix.X11.XK_Shift_R - @matthiasblaesing.
    #1323. Fix crashes in direct callbacks on mac OS aarch64 - @matthiasblaesing.
    #1422: Load jawt library relative to sun.boot.library.path system on unix OSes - @matthiasblaesing.
    #1427: Rebuild all binaries with fix from #1422 and #1323 - @matthiasblaesing.

Release 5.10.0
Features

    #1377: Add RegLoadAppKey to c.s.j.p.win32.Advapi32 and registryLoadAppKey to c.s.j.p.win32.Advapi32Util - @mfilippov.
    #1093: Add OpenFileMapping to c.s.j.p.win32.Kernel32 - @lmitusinski.
    #1388: Map the arch zarch_64 as reported by SAPJVM8 to s390x - @MBaesken.
    #1381: Update embedded libffi to 3.4.2 - @matthiasblaesing.
    #1393: Update native encoding detection for JEP400 / JDK 18 (file.encoding now defaults to UTF-8) - @matthiasblaesing.

Bug Fixes

    #1378: Handle failure in ffi_closure_alloc - @davecturner.

Release 5.9.0
Features

    #1336: Add HKEY_CURRENT_USER_LOCAL_SETTINGS to c.s.j.p.win32.WinReg - @Dani-Hub.
    #1337: Add REG_NOTIFY_THREAD_AGNOSTIC to c.s.j.p.win32.WinNet and update REG_LEGAL_CHANGE_FILTER - @Dani-Hub.
    #1338: Add RegNotifyChangeKeyValue to c.s.j.p.win32.Advapi32 - @Dani-Hub.
    #1340: Add CM_Get_DevNode_Registry_Property to c.s.j.p.win32.Cfgmgr32 and corresponding util in c.s.j.p.win32.Cfgmgr32Util - @dbwiddis.
    #1352: Add BringWindowToTop to c.s.j.p.win32.User32 - @kahgoh.
    #1354: Add GetParent to c.s.j.p.win32.User32 - @kahgoh.
    #1360: Add CommandLineToArgvW to c.s.j.p.win32.Shell32 and corresponding util in c.s.j.p.win32.Shell32Util - @dbwiddis.
    #1363: Update NUMA_NODE_RELATIONSHIP in c.s.j.p.win32.WinNT to new version of the structure and improve support for future values of c.s.j.p.win32.WinNT.LOGICAL_PROCESSOR_RELATIONSHIP - @dbwiddis.

Bug Fixes

    #1343: c.s.j.p.mac.CoreFoundation.CFStringRef#stringValue buffer needs space for a null byte - @dbwiddis.
    #1351: Define c.s.j.p.unix.size_t.ByReference and fix macOS sysctl size_t * parameters - @dbwiddis.
    #1362: Clear security sensitive data after usage in c.s.j.p.win32.Crypt32Util#cryptProtectData and #cryptUnprotectData - @dmytro-sheyko.
    #1361: Make c.s.j.p.win32.Crypt32Util#cryptProtectData and #cryptUnprotectData properly handle 0-length array as input - @dmytro-sheyko.

Release 5.8.0
Features

    #1313: Normalize RESOURCE_PREFIX for darwin to darwin-$arch and split jnidispatch library per architecture - @matthiasblaesing.
    #1318: Add support for linux-riscv64 - @thentschel.
    #1327: Add partial support for future values of c.s.j.p.win32.WinNT.LOGICAL_PROCESSOR_RELATIONSHIP enum present in Windows Insider builds - @dbwiddis.

Bug Fixes

    #1317: Change the maven coordinates of the JPMS artifacts from classifier jpms to custom artifact ids jna-jpms and jna-platform-jpms - @matthiasblaesing.
    #1322: Handle 0-length domain names in c.s.j.p.win32.Advapi32Util#getAccountBySid - @dbwiddis.
    #1326: Ensure pointers indirected from Memory and pointing into Memory retain originating object - @matthiasblaesing.

Important Changes

    The maven coordinates of the experimental JPMS (java module system) artifacts were moved from using the classifier jpms to custom artifact ids jna-jpms and jna-platform-jpms, without an classifier. The reason for this is, that the platform artifacts depend on the jna artifacts and need to pull in the right variant. This is not possible if the classifier is used.

    RESOURCE_PREFIX for darwin (mac OS) was changed from darwin to darwin-$arch as the fat binaries on mac OS causes various problems: It was reported, that binaries were rejected from the appstore because x86 binaries were found in the application (jnidispatch for mac OS x86) and that builds needed to be special cased so that the native library can be assembled. The latter is also true for JNA.
    While the prefix is changed, the old prefix is still searched as a fallback location, so if only a fat binary is present, it can still be loaded.

Release 5.7.0
Features

    #1301: Improve bindings of the printer notification functions (FindFirstPrinterChangeNotification, FindNextPrinterChangeNotification) in c.s.j.p.w.Winspool - @ianjoneill.
    #1238: Add macOS aarch64 architecture to universal darwin target. Cherry pick libffi/libffi#577. - @fkistner, @Vzor-, @tresf.
    #1264: Update libffi to v3.3; Add Windows aarch64 target. - @tresf.
    #1293: Bind part of Windows Application Recovery and Restart API: RegisterApplicationRestart, UnregisterApplicationRestart and GetApplicationRestartSettings in c.s.j.p.w.Kernel32 - @matthiasblaesing.
    #1217: Add mappings for AIX Perfstat library to c.s.j.p.unix.aix - @dbwiddis.
    #1231: The test suite can now be executed on Windows using either ANSI or UNICODE win32 API by passing -Dw32.ascii=true/false to ant. Previously, UNICODE was always used. - @T-Svensson
    #1237: Experimental: Add artifacts that make jna and jna-platform named modules (provide module-info.class). The new artifacts are named jna-jpms.jar and jna-platform-jpms.jar - @matthiasblaesing.
    #1242: Add CallWindowProc to User32 - @heldplayer.
    #1239: Improve performance of allocation of c.s.j.Memory objects - @joerg1985.
    #1246: Improve performance of c.s.j.Structure#read and c.s.j.Structure#write - @joerg1985.
    #1260: Add mapping for X11 generic events - @lafoletc.
    #1263: Add LowLevelMouseProc - @nordiakt.
    #1265: Add mapping for XQueryExtension - @lafoletc.
    #1299: Add c.s.j.p.win32.IPHlpApi#GetExtendedTcpTable, c.s.j.p.win32.IPHlpApi#GetExtendedUdpTable, and supporting structures. - @dbwiddis.

Bug Fixes

    #1286: Fix bindings of c.s.j.p.win32.DBT - @matthiasblaesing.
    #326: Fix loading library that re-uses pointers for different callbacks - @fpapai.
    #1244: Fix building on GCC 10 - @matthiasblaesing.
    #1252: - Fix bindings of CTL_ENTRY#getRgAttribute, CTL_INFO#getRgCTLEntry, CTL_INFO#getRgExtension, CERT_EXTENSIONS#getRgExtension, CERT_INFO#getRgExtension, CRL_INFO#getRgCRLEntry, CRL_INFO#getRgExtension, CRL_ENTRY#getRgExtension. Add bindings for CertEnumCertificatesInStore, CertEnumCTLsInStore, CertEnumCRLsInStore and CryptQueryObject in c.s.j.p.win32.Crypt32.
    WARNING: The signatures for CTL_INFO#getRgCTLEntry and CTL_INFO#getRgExtension were changed - as the original signatures were obviously wrong and read the wrong attributes, it is not considered an API break - @matthiasblaesing.
    #1275: Fix CFStringRef#stringValue for empty Strings - @dyorgio.
    #1279: Remove DLLCallback import from CallbackReference - @dyorgio.
    #1278: Improve compatibility of c.s.j.p.WindowUtils#getProcessFilePath and fix unittests for windows 32bit intel - @matthiasblaesing.
    #1284: Fix illegal access exceptions, when retrieving options for private library interfaces with an instance field - @fkistner.
    #1300: Deprecate c.s.j.p.win32.WTypes.BSTR String constructor and setValue method, as BSTR allocation should be managed by COM, Automation, and Interop functions - @dbwiddis.

Breaking Changes

    Prebuild native library for darwin x86 (32bit java on mac OS) was removed

Release 5.6.0
Features

    #1160: Make FileUtils#moveToTrash a varargs method - @matthiasblaesing.
    #1167: Add c.s.j.p.win32.Kernel32#GetProcessAffinityMask - @dbwiddis.
    #1168: Add c.s.j.p.win32.Kernel32#SetProcessAffinityMask - @dbwiddis.
    #1169: Wait for process in getLinuxLdPaths - @rdesgroppes.
    #1178: Add c.s.j.p.win32.IPHlpAPI#GetTcpStatistics, c.s.j.p.win32.IPHlpAPI#GetUdpStatistics, c.s.j.p.win32.IPHlpAPI#GetTcpStatisticsEx and c.s.j.p.win32.IPHlpAPI#GetUdpStatisticsEx - @dbwiddis.
    #1182: Add toString to classes extending c.s.j.ptr.ByReference - @dbwiddis.
    #1191: Add c.s.j.p.win32.Advapi32Util#getTokenPrimaryGroup - @dbwiddis.
    #1194: Add GetConsoleScreenBufferInfo, ReadConsoleInput and WriteConsole with associated structures to c.s.j.p.win32.Wincon - @rednoah.
    #1198: Add NetSessionEnum to c.s.j.p.win32.Netapi32 and WTSEnumerateSessions, WTSQuerySessionInformation, and WTSFreeMemory to c.s.j.p.win32.Wtsapi32 - @dbwiddis.
    #1200: Add mappings for libudev to c.s.j.p.linux.Udev - @dbwiddis.
    #1202: Add mappings supporting shared memory including c.s.j.p.unix.LibCAPI types size_t and ssize_t, c.s.j.p.linux.LibC methods munmap(), msync(), and close(), c.s.j.p.unix.LibCUtil mapping mmap() and ftruncate(), and c.s.j.p.linux.LibRT methods shm_open() and shm_unlink() - @dbwiddis.
    #1209: Add mappings for Thread32First and Thread32Next to c.s.j.p.win32.Kernel32 - @dbwiddis.
    #1214: Add mapping for EnumProcesses to c.s.j.p.win32.Psapi and c.s.j.p.win32.PsapiUtil - @T-Svensson.

Bug Fixes

    #1183: c.s.j.p.win32.WinDef.CHARByReference#getValue should only read one byte - @dbwiddis.
    #1184: c.s.j.p.win32.WinDef.ULONGLONG should always be 8 bytes - @dbwiddis.
    #1196: c.s.j.p.win32.WinNT.LARGE_INTEGER needs to populate both union fields - @dbwiddis.
    #1216: Failure loading frameworks on macOS 11 - @dkocher.

Release 5.5.0
Features

    #1131: Add CoreFoundation, IOKit, and DiskArbitration mappings in c.s.j.p.mac. @dbwiddis.
    #1143: c.s.j.p.mac.SystemB now extends c.s.j.p.unix.LibCAPI. @dbwiddis.
    #1147: Add additional OSGi headers for the JNA bundle to support 32bit ARM (hardfloat) @mattixtech.
    #1148/#1096: Include Win32 COM utils (c.s.j.p.win32.com.util and c.s.j.p.win32.com.annotation) in OSGI bundle @dbwiddis.

Bug Fixes

    #1115: Fix signature for c.s.j.p.win32.Kernel32#CreateRemoteThread and bind VirtualAllocEx, VirtualFreeEx, GetExitCodeThread in c.s.j.p.win32.Kernel32 - @apangin, @matthiasblaesing.
    #1127: Windows needs a wide string in c.s.j.p.win32.COM.IShellFolder#ParseDisplayName - @dbwiddis.
    #1128: KEY_ALL_ACCESS value is incorrect in c.s.j.p.win32.WinNT.java - @trevormaggs.
    #1133: Ensure JARs created from the build system don't contain invalid Info-ZIP Unicode Path extra info - @matthiasblaesing.
    #1134: Read correct member of WinBase.SYSTEM_INFO.processorArchitecture union - @dbwiddis.
    #1118: Fix passing unions containing integer and floating point members as parameters by value - @matthiasblaesing.

Release 5.4.0
Features

    #1105: Deprecate c.s.j.p.win32.Advapi32Util.EventLogRecord#getEventId in favor of #getInstanceId - @dbwiddis.
    #1097: Allow .ocx as extension of native libraries on windows - @dmigowski.
    #1108: Improve performance of c.s.j.Structure#newInstance by iteration available constructors instead of exception handling @bjorndarri.

Bug Fixes

    #1095 Align behaviour of com.sun.jna.platform.macXAttrUtil#setXattr and #getXAttr with CLI tool - @jrobhoward, @matthiasblaesing.
    #1091: Check target number to be greater than zero, before calling Structure#toArray in c.s.j.p.win32.Netapi32Util - @trevormagg, @matthiasblaesing.
    #1103: On big endian architecture IntegerType based values are incorrectly decoded when using direct binding - @matthiasblaesing.

Release 5.3.1
Bug Fixes

    #1089: c.s.j.internal.ReflectionUtils accesses java.lang.invoke.MethodType without reflection, causing java.lang.NoClassDefFoundError on android API level < 26 - @matthiasblaesing.
    #1087: Fix wrong calls to Structure#toArray with zero sized arrays - @matthiasblaesing.

Release 5.3.0
Features

    #1058: Add selectable timeout to stopService() and improve timeout handling - @keithharp.
    #1050: Add c.s.j.p.win32.VersionHelpers and supporting functions - @dbwiddis.
    #1061: replace toArray(new T[size]) with toArray(new T[0]) for better performance - @hc-codersatlas.
    #1064: Add c.s.j.p.win32.Kernel32.GetLogicalProcessorInformationEx function, convenience Util method and supporting structures - @dbwiddis.
    #1065: Add c.s.j.p.win32.PowrProf#CallNTPowerInformation and supporting structures - @dbwiddis.
    #1063: Enhance c.s.j.p.win32.User32 and associated classes to support keyboard related functionality. - @kevemueller.
    #1068: c.s.j.p.win32.Advapi32Util.getAccountBySid(String systemName, PSID sid) ignored parameter instead of passing it to the native function - @nirud.
    #813: Support for default methods on interfaces (experimental) - @matthiasblaesing.
    #1073: Support COM setters with multiple parameters using c.s.j.p.win32.COM.util.ProxyObject - @matthiasblaesing.
    #1083: Prevent access to unsupported values in c.s.j.p.win32.COM.WbemcliUtil#enumerateProperties and bind c.s.j.p.win32.COM.Wbemcli.IWbemClassObject.GetNames - @matthiasblaesing.

Bug Fixes

    #1052, #1053: WinXP compatibility for c.s.j.p.win32.PdhUtil - @dbwiddis.
    #1055: Include c.s.j.p.linux in OSGi bundle. - @dbwiddis.
    #1066: On AIX OpenJDK differs from IBM J9 in the mapping of library names. While J9 maps jnidispatch to libjnidispatch.a, OpenJDK maps to libjnidispatch.so, which causes the native library extractor to fail. AIX is now hard-coded to libjnidispatch.a - @matthiasblaesing.
    #1079: Fix maximum structure alignment for Android i386 - @BugsBeGone.

Revision 1.10: download - view: text, markup, annotated - select for diffs
Mon Jun 6 01:12:56 2022 UTC (2 years, 9 months ago) by gutteridge
Branches: MAIN
CVS tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +9 -7 lines
java-jna: fix default builds

As a workaround for now, don't accept openjdk17, as this version won't
build with it. While here, address some formatting issues noted by
pkglint.

Revision 1.9: download - view: text, markup, annotated - select for diffs
Wed Dec 8 16:03:58 2021 UTC (3 years, 3 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -2 lines
revbump for icu and libffi

Revision 1.8: download - view: text, markup, annotated - select for diffs
Tue Feb 2 01:18:24 2021 UTC (4 years, 1 month ago) by gutteridge
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +5 -4 lines
java-jna: use ANT_ARGS consistently (follow-on build fix)

Fix my previous fix: apparently I misread something that was right in
front of me, whoops.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Sat Jan 23 01:18:48 2021 UTC (4 years, 2 months ago) by gutteridge
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +6 -4 lines
java-jna: non-NetBSD build fixes

This package expects GNU grep, and also makes assumptions about tool
paths that don't always hold (mostly relating to SunOS derivates).
Force use of pkgsrc-supplied tools.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Fri Jan 22 01:22:46 2021 UTC (4 years, 2 months ago) by gutteridge
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +8 -2 lines
java-jna: fix builds with openjdk11 and recent GCC versions

The most recent openjdk11 update resulted in a change to the jquery
version that affects PLIST population of this package. Separately, there
are upstream compiler flags that were causing compilation failures with
recent GCC versions, e.g., 9.3 on NetBSD 9.99.78. (Since different Java
11 packages in pkgsrc aren't aligned with each other release-wise, this
may cause breakage elsewhere, but this at least fixes recent NetBSD on
x86. There's an unrelated problem with this package building on SmartOS
which I'll deal with separately.)

Revision 1.5: download - view: text, markup, annotated - select for diffs
Fri Jun 26 10:26:08 2020 UTC (4 years, 8 months ago) by yyamano
Branches: MAIN
CVS tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +10 -1 lines
Fix PLIST to make this build with JDK 11.
JDK 11 doesn't generate frames.
http://www.ki.nu/pkgsrc/reports/current/NetBSD-9.0/20200531.1505/java-jna-5.2.0nb1/install.log

Revision 1.4: download - view: text, markup, annotated - select for diffs
Thu May 14 19:08:27 2020 UTC (4 years, 10 months ago) by joerg
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2 lines
Honor process limits for build.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sun Mar 8 16:42:25 2020 UTC (5 years ago) by bsiegert
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -1 lines
Revbump packages depending on libffi after .so version change.

Requested by Matthias Ferdinand and Oskar on pkgsrc-users.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Sun Nov 3 10:39:14 2019 UTC (5 years, 4 months ago) by rillig
Branches: MAIN
CVS tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +11 -11 lines
devel: align variable assignments

pkglint -Wall -F --only aligned --only indent -r

No manual corrections.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Fri Apr 5 12:55:15 2019 UTC (5 years, 11 months ago) by nonaka
Branches: MAIN
CVS tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2
PR/54097: Added Java Native Access 5.2.0 as devel/java-jna.

JNA provides Java programs easy access to native shared libraries without
writing anything but Java code - no JNI or native code is required.
This functionality is comparable to Windows' Platform/Invoke and Python's
ctypes.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>