[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / isect

File: [cvs.NetBSD.org] / pkgsrc / devel / isect / Makefile (download)

Revision 1.46, Sat Jan 18 23:30:30 2020 UTC (4 years, 3 months ago) by rillig
Branch: MAIN
Changes since 1.45: +2 -2 lines

all: migrate several HOMEPAGEs to https

pkglint --only "https instead of http" -r -F

With manual adjustments afterwards since pkglint 19.4.4 fixed a few
indentations in unrelated lines.

This mainly affects projects hosted at SourceForce, as well as
freedesktop.org, CTAN and GNU.

# $NetBSD: Makefile,v 1.46 2020/01/18 23:30:30 rillig Exp $
#

DISTNAME=	isect-1.6.2
PKGREVISION=	11
CATEGORIES=	devel
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=isectd/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://isectd.sourceforge.net/
COMMENT=	Open source middleware daemon

GNU_CONFIGURE=	yes
USE_LIBTOOL=	yes
PTHREAD_OPTS+=	require
INFO_FILES=	yes

RCD_SCRIPTS=	isect

DOCDIR=		${PREFIX}/share/doc/isect
EGDIR=		${PREFIX}/share/examples/isect

INSTALLATION_DIRS=	${DOCDIR} ${EGDIR}

post-install:
	for file in ${WRKSRC}/doc/*.html; do \
		${INSTALL_DATA} $${file} ${DESTDIR}${DOCDIR}; \
	done
	${INSTALL_DATA} ${WRKSRC}/COPYING ${DESTDIR}${EGDIR}

.include "../../www/libwww/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"